Re: [PATCH] drm/amd/powerplay: fixed uninitialized value

2018-07-18 Thread Huang Rui
On Thu, Jul 19, 2018 at 01:28:22PM +0800, Evan Quan wrote: > The 'result' is not initialized correctly. It causes the API > return an error code even on success. > > Change-Id: I14aea88b4022b490fb073bc1d4713f4edb96fb46 > Signed-off-by: Evan Quan Acked-by: Huang Rui > --- > drivers/gpu/drm/amd

Re: [PATCH] drm/amdgpu: reduce the number of placements for a BO

2018-07-18 Thread Huang Rui
On Wed, Jul 18, 2018 at 11:17:56AM +0200, Christian König wrote: > Make struct amdgpu_bo a bit smaller. > > Signed-off-by: Christian König Reviewed-by: Huang Rui > --- > drivers/gpu/drm/amd/amdgpu/amdgpu_object.c | 2 ++ > drivers/gpu/drm/amd/amdgpu/amdgpu_object.h | 3 ++- > 2 files changed,

[PATCH] drm/amd/powerplay: fixed uninitialized value

2018-07-18 Thread Evan Quan
The 'result' is not initialized correctly. It causes the API return an error code even on success. Change-Id: I14aea88b4022b490fb073bc1d4713f4edb96fb46 Signed-off-by: Evan Quan --- drivers/gpu/drm/amd/powerplay/hwmgr/vega12_hwmgr.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --gi

Re: [PATCH] drm/amdgpu/powerplay: use irq source defines for smu7 sources

2018-07-18 Thread Zhu, Rex
Reviewed-by: Rex Zhumailto:re...@amd.com>> Best Regards Rex From: amd-gfx on behalf of Alex Deucher Sent: Thursday, July 19, 2018 5:08 AM To: amd-gfx@lists.freedesktop.org Cc: Deucher, Alexander Subject: [PATCH] drm/amdgpu/powerplay: use irq source defines f

RE: [PATCH 1/2] drm/amdgpu: remove superflous UVD encode entity

2018-07-18 Thread Zhou, David(ChunMing)
Acked-by: Chunming Zhou -Original Message- From: amd-gfx [mailto:amd-gfx-boun...@lists.freedesktop.org] On Behalf Of Christian K?nig Sent: Thursday, July 19, 2018 2:45 AM To: amd-gfx@lists.freedesktop.org Subject: [PATCH 1/2] drm/amdgpu: remove superflous UVD encode entity Not sure wha

RE: [PATCH] drm/amdgpu/powerplay: use irq source defines for smu7 sources

2018-07-18 Thread Zhou, David(ChunMing)
Rewiewed-by: Chunming Zhou -Original Message- From: amd-gfx [mailto:amd-gfx-boun...@lists.freedesktop.org] On Behalf Of Alex Deucher Sent: Thursday, July 19, 2018 5:09 AM To: amd-gfx@lists.freedesktop.org Cc: Deucher, Alexander Subject: [PATCH] drm/amdgpu/powerplay: use irq source defin

RE: [PATCH 2/2] drm/amdgpu: clean up UVD instance handling v2

2018-07-18 Thread Zhou, David(ChunMing)
Acked-by: Chunming Zhou -Original Message- From: amd-gfx [mailto:amd-gfx-boun...@lists.freedesktop.org] On Behalf Of Christian K?nig Sent: Thursday, July 19, 2018 2:45 AM To: amd-gfx@lists.freedesktop.org Subject: [PATCH 2/2] drm/amdgpu: clean up UVD instance handling v2 The whole handl

RE: [PATCH] drm/amdgpu: fix job priority handling

2018-07-18 Thread Zhou, David(ChunMing)
Reviewed-by: Chunming Zhou -Original Message- From: amd-gfx [mailto:amd-gfx-boun...@lists.freedesktop.org] On Behalf Of Christian K?nig Sent: Thursday, July 19, 2018 2:15 AM To: amd-gfx@lists.freedesktop.org Subject: [PATCH] drm/amdgpu: fix job priority handling The job might already be

[PATCH] drm/amdgpu/powerplay: use irq source defines for smu7 sources

2018-07-18 Thread Alex Deucher
Use the newly added irq source defines rather than magic numbers for smu7 thermal interrupts. Signed-off-by: Alex Deucher --- drivers/gpu/drm/amd/powerplay/hwmgr/smu_helper.c | 7 --- 1 file changed, 4 insertions(+), 3 deletions(-) diff --git a/drivers/gpu/drm/amd/powerplay/hwmgr/smu_helper

[PATCH 4/5] drm/amdgpu: add emit trap for vcn jpeg

2018-07-18 Thread boyuan.zhang
From: Boyuan Zhang Add emit trap command in jpeg emit fence call. Signed-off-by: Boyuan Zhang --- drivers/gpu/drm/amd/amdgpu/vcn_v1_0.c | 4 1 file changed, 4 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/vcn_v1_0.c b/drivers/gpu/drm/amd/amdgpu/vcn_v1_0.c index 22c1588..745c9ae

[PATCH 3/5] drm/amdgpu: enable system interrupt for jrbc

2018-07-18 Thread boyuan.zhang
From: Boyuan Zhang Enable system interrupt for jrbc during engine starting time. Signed-off-by: Boyuan Zhang --- drivers/gpu/drm/amd/amdgpu/vcn_v1_0.c | 8 +++- 1 file changed, 7 insertions(+), 1 deletion(-) diff --git a/drivers/gpu/drm/amd/amdgpu/vcn_v1_0.c b/drivers/gpu/drm/amd/amdgpu/

[PATCH 5/5] drm/amdgpu: fix emit frame size and comments for jpeg

2018-07-18 Thread boyuan.zhang
From: Boyuan Zhang Fix vcn jpeg ring emit fence size in dword, and fix the naming in comments. Signed-off-by: Boyuan Zhang --- drivers/gpu/drm/amd/amdgpu/vcn_v1_0.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/gpu/drm/amd/amdgpu/vcn_v1_0.c b/drivers/gpu/dr

[PATCH 1/5] drm/amdgpu: add system interrupt register offset header

2018-07-18 Thread boyuan.zhang
From: Boyuan Zhang Add new register offset for enabling system interrupt. Signed-off-by: Boyuan Zhang --- drivers/gpu/drm/amd/include/asic_reg/vcn/vcn_1_0_offset.h | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/gpu/drm/amd/include/asic_reg/vcn/vcn_1_0_offset.h b/drivers/gpu/drm

[PATCH 2/5] drm/amdgpu: add system interrupt mask for jrbc

2018-07-18 Thread boyuan.zhang
From: Boyuan Zhang Add new mask for enabling system interrupt for jrbc. Signed-off-by: Boyuan Zhang --- drivers/gpu/drm/amd/include/asic_reg/vcn/vcn_1_0_sh_mask.h | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/gpu/drm/amd/include/asic_reg/vcn/vcn_1_0_sh_mask.h b/drivers/gpu/drm

[PATCH 2/2] drm/amdgpu: clean up UVD instance handling v2

2018-07-18 Thread Christian König
The whole handle, filp and entity handling is superfluous here. We should have reviewed that more thoughtfully. It looks like somebody just made the code instance aware without knowing the background. v2: fix one more missed case in amdgpu_uvd_suspend Signed-off-by: Christian König --- drivers

[PATCH 1/2] drm/amdgpu: remove superflous UVD encode entity

2018-07-18 Thread Christian König
Not sure what that was every used for, but now it is completely unused. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_uvd.h | 1 - drivers/gpu/drm/amd/amdgpu/uvd_v6_0.c | 12 drivers/gpu/drm/amd/amdgpu/uvd_v7_0.c | 14 -- 3 files changed, 27 d

[PATCH 2/2] drm/amdgpu: clean up UVD instance handling

2018-07-18 Thread Christian König
The whole handle, filp and entity handling is superfluous here. We should have reviewed that more thoughtfully. It looks like somebody just made the code instance aware without knowing the background. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_uvd.c | 103 +

[PATCH 1/2] drm/amdgpu: remove superflous UVD encode entity

2018-07-18 Thread Christian König
Not sure what that was every used for, but now it is completely unused. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_uvd.h | 1 - drivers/gpu/drm/amd/amdgpu/uvd_v6_0.c | 12 drivers/gpu/drm/amd/amdgpu/uvd_v7_0.c | 14 -- 3 files changed, 27 d

Re: [PATCH] drm/amdgpu: fix job priority handling

2018-07-18 Thread Andres Rodriguez
On 2018-07-18 02:14 PM, Christian König wrote: The job might already be released at this point. Signed-off-by: Christian König Reviewed-by: Andres Rodriguez --- drivers/gpu/drm/amd/amdgpu/amdgpu_cs.c | 4 +++- drivers/gpu/drm/amd/amdgpu/amdgpu_job.c | 4 +++- 2 files changed, 6 inser

[PATCH] drm/amdgpu: fix job priority handling

2018-07-18 Thread Christian König
The job might already be released at this point. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_cs.c | 4 +++- drivers/gpu/drm/amd/amdgpu/amdgpu_job.c | 4 +++- 2 files changed, 6 insertions(+), 2 deletions(-) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_cs.c b/drivers

Re: new KASAN running piglit

2018-07-18 Thread Michel Dänzer
On 2018-07-18 06:46 PM, Christian König wrote: > Am 18.07.2018 um 18:44 schrieb Michel Dänzer: >> On 2018-07-18 06:17 PM, Michel Dänzer wrote: >>> On 2018-07-18 06:05 PM, Tom St Denis wrote: Hi Christian, This patch: [root@raven linux]# git bisect bad 90f362bdf0d0d06a1

Re: new KASAN running piglit

2018-07-18 Thread Tom St Denis
[root@raven linux]# file /lib/modules/4.18.0-rc1+/kernel/drivers/gpu/drm/amd/amdgpu/amdgpu.ko /lib/modules/4.18.0-rc1+/kernel/drivers/gpu/drm/amd/amdgpu/amdgpu.ko: ELF 64-bit LSB relocatable, x86-64, version 1 (SYSV), BuildID[sha1]=14495041edc0ecb2d4159e8ee15e87f345ae2ef9, with debug_info, not

Re: new KASAN running piglit

2018-07-18 Thread Christian König
Am 18.07.2018 um 18:44 schrieb Michel Dänzer: On 2018-07-18 06:17 PM, Michel Dänzer wrote: On 2018-07-18 06:05 PM, Tom St Denis wrote: Hi Christian, This patch: [root@raven linux]# git bisect bad 90f362bdf0d0d06a126a5fd35b084436dd8250ad is the first bad commit commit 90f362bdf0d0d06a126a5fd35

Re: new KASAN running piglit

2018-07-18 Thread Michel Dänzer
On 2018-07-18 06:17 PM, Michel Dänzer wrote: > On 2018-07-18 06:05 PM, Tom St Denis wrote: >> Hi Christian, >> >> This patch: >> >> [root@raven linux]# git bisect bad >> 90f362bdf0d0d06a126a5fd35b084436dd8250ad is the first bad commit >> commit 90f362bdf0d0d06a126a5fd35b084436dd8250ad >> Author: Ch

Re: new KASAN running piglit

2018-07-18 Thread Christian König
Going to investigate. But any idea why the backtrace contains only "?" entries? Christian. Am 18.07.2018 um 18:09 schrieb Tom St Denis: Here's the dmesg I should have attached ... Tom On 07/18/2018 12:05 PM, Tom St Denis wrote: Hi Christian, This patch: [root@raven linux]# git bisect bad

Re: [PATCH 2/3] drm/amdgpu: expose only the first UVD instance for now

2018-07-18 Thread Christian König
Am 18.07.2018 um 17:58 schrieb Alex Deucher: On Wed, Jul 18, 2018 at 10:29 AM, Christian König wrote: Am 18.07.2018 um 16:22 schrieb James Zhu: On 2018-07-18 10:11 AM, Christian König wrote: Am 18.07.2018 um 15:40 schrieb James Zhu: On 2018-07-18 08:55 AM, Christian König wrote: Going to

[PATCH xf86-video-amdgpu] Remove drmmode_terminate_leases

2018-07-18 Thread Michel Dänzer
From: Michel Dänzer The RandR screen private is already freed when our CloseScreen runs, so this can't do anything useful. This cleanup has to be done by the X server itself. Signed-off-by: Michel Dänzer --- src/amdgpu_kms.c | 1 - src/drmmode_display.c | 20 src/drm

[pull] amdgpu drm-fixes-4.18

2018-07-18 Thread Alex Deucher
Hi Dave, Fixes for 4.18. The ACP patch is a bit bigger than I would like at this point, but it should have gone in long ago, it just fell through the cracks. The others are pretty small and straight-forward. - ACP fix for boards with 2 I2S instances - DP fix for CZ, vega - Fix for a hybrid graph

Re: new KASAN running piglit

2018-07-18 Thread Michel Dänzer
On 2018-07-18 06:05 PM, Tom St Denis wrote: > Hi Christian, > > This patch: > > [root@raven linux]# git bisect bad > 90f362bdf0d0d06a126a5fd35b084436dd8250ad is the first bad commit > commit 90f362bdf0d0d06a126a5fd35b084436dd8250ad > Author: Christian König > Date:   Mon Jul 16 14:58:48 2018 +02

Re: new KASAN running piglit

2018-07-18 Thread Tom St Denis
Here's the dmesg I should have attached ... Tom On 07/18/2018 12:05 PM, Tom St Denis wrote: Hi Christian, This patch: [root@raven linux]# git bisect bad 90f362bdf0d0d06a126a5fd35b084436dd8250ad is the first bad commit commit 90f362bdf0d0d06a126a5fd35b084436dd8250ad Author: Christian König Da

new KASAN running piglit

2018-07-18 Thread Tom St Denis
Hi Christian, This patch: [root@raven linux]# git bisect bad 90f362bdf0d0d06a126a5fd35b084436dd8250ad is the first bad commit commit 90f362bdf0d0d06a126a5fd35b084436dd8250ad Author: Christian König Date: Mon Jul 16 14:58:48 2018 +0200 drm/amdgpu: change ring priority after pushing the jo

Re: [PATCH 2/3] drm/amdgpu: expose only the first UVD instance for now

2018-07-18 Thread Alex Deucher
On Wed, Jul 18, 2018 at 10:29 AM, Christian König wrote: > Am 18.07.2018 um 16:22 schrieb James Zhu: >> >> >> >> On 2018-07-18 10:11 AM, Christian König wrote: >>> >>> Am 18.07.2018 um 15:40 schrieb James Zhu: On 2018-07-18 08:55 AM, Christian König wrote: > > Going to compl

Re: [PATCH libdrm] amdgpu: add amdgpu_bo_handle_type_kms_noimport

2018-07-18 Thread Michel Dänzer
On 2018-07-17 08:14 PM, Marek Olšák wrote: > Michel, I think you are wasting your time. This change can be misused > as easily as any other API. It's not more dangerous that any other > amdgpu libdrm function. That's trivially false. > You won't achieve anything by optimizing the hash table (= lo

Re: [PATCH 2/2] drm/amdgpu: reduce the number of placements for a BO

2018-07-18 Thread Alex Deucher
On Wed, Jul 18, 2018 at 5:18 AM, Christian König wrote: > Make struct amdgpu_bo a bit smaller. > > Signed-off-by: Christian König Series is: Reviewed-by: Alex Deucher > --- > drivers/gpu/drm/amd/amdgpu/amdgpu_object.c | 2 ++ > drivers/gpu/drm/amd/amdgpu/amdgpu_object.h | 3 ++- > 2 files cha

[PATCH 1/7 v2] drm/amd/display: Remove unnecessary warning

2018-07-18 Thread sunpeng.li
From: Mikita Lipski [why] The warning message floods the dmesg log on Tonga even though it is expected to have a pix_clk set to zero, when the pipe is not active. [how] remove the assert Change-Id: I4ca1e42439369b2305694b403457b5de60fc4ab1 Signed-off-by: Mikita Lipski Reviewed-by: Harry Wentlan

Re: [PATCH 7/7] drm/amd/display: dal 3.1.58

2018-07-18 Thread Paul Menzel
Dear AMDGPU folks, On 07/17/18 15:29, sunpeng...@amd.com wrote: > From: Harry Wentland > > Change-Id: I788210abbb33e0a38267c9bfd3656f51c844d5ac > Signed-off-by: Harry Wentland > Reviewed-by: Aric Cyr > Acked-by: Leo Li > --- > drivers/gpu/drm/amd/display/dc/dc.h | 2 +- > 1 file changed, 1

Re: [PATCH 2/3] drm/amdgpu: expose only the first UVD instance for now

2018-07-18 Thread Christian König
Am 18.07.2018 um 16:22 schrieb James Zhu: On 2018-07-18 10:11 AM, Christian König wrote: Am 18.07.2018 um 15:40 schrieb James Zhu: On 2018-07-18 08:55 AM, Christian König wrote: Going to completely rework the context to ring mapping with Nayan's GSoC work, but for now just stopping to expos

Re: [PATCH 2/3] drm/amdgpu: expose only the first UVD instance for now

2018-07-18 Thread James Zhu
On 2018-07-18 10:11 AM, Christian König wrote: Am 18.07.2018 um 15:40 schrieb James Zhu: On 2018-07-18 08:55 AM, Christian König wrote: Going to completely rework the context to ring mapping with Nayan's GSoC work, but for now just stopping to expose the second UVD instance should do it.

Adjusting fan speed

2018-07-18 Thread Aleksandr Mezin
Is it possible to adjust fan speed without switching to fully manual control (pwm1_enable=1)? I'm looking for something similar to min/max fan speed and target/max temperature settings like in Wattman on Windows. Would be nice to just set them using udev rule. Or is fan control on windows working

Re: [PATCH 2/3] drm/amdgpu: expose only the first UVD instance for now

2018-07-18 Thread Christian König
Am 18.07.2018 um 15:40 schrieb James Zhu: On 2018-07-18 08:55 AM, Christian König wrote: Going to completely rework the context to ring mapping with Nayan's GSoC work, but for now just stopping to expose the second UVD instance should do it. Signed-off-by: Christian König ---   drivers/gpu/dr

Re: [PATCH 2/3] drm/amdgpu: expose only the first UVD instance for now

2018-07-18 Thread James Zhu
On 2018-07-18 08:55 AM, Christian König wrote: Going to completely rework the context to ring mapping with Nayan's GSoC work, but for now just stopping to expose the second UVD instance should do it. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_kms.c | 13 +-

[PATCH 3/3] drm/amdgpu: patch the IBs for the second UVD instance

2018-07-18 Thread Christian König
Patch the IBs for the second UVD instance so that userspace don't need to care about the instance they submit to. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/uvd_v7_0.c | 27 +++ 1 file changed, 27 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/u

[PATCH 2/3] drm/amdgpu: expose only the first UVD instance for now

2018-07-18 Thread Christian König
Going to completely rework the context to ring mapping with Nayan's GSoC work, but for now just stopping to expose the second UVD instance should do it. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_kms.c | 13 + drivers/gpu/drm/amd/amdgpu/amdgpu_queue_mg

[PATCH 1/3] drm/amdgpu: cleanup coding style a bit

2018-07-18 Thread Christian König
No need to bitcast a boolean and even if we should use "!!" instead. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_kms.c | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_kms.c b/drivers/gpu/drm/am

Re: [PATCH] drm/amdgpu/pm: Remove VLA usage

2018-07-18 Thread Zhu, Rex
Patch has been applied to our internal amd-staging-drm-next tree. Thanks. Best Regards Rex From: Christian K?nig Sent: Tuesday, July 17, 2018 2:58:21 PM To: Zhu, Rex; Kees Cook; Deucher, Alexander Cc: Zhou, David(ChunMing); David Airlie; Kuehling, Felix; LKML

[PATCH] drm/amdgpu: lock and unlock console only for amdgpu_fbdev_set_suspend [V2]

2018-07-18 Thread Shirish S
[Why] While the console_lock is held, console output will be buffered, till its unlocked it wont be emitted, hence its ideal to unlock sooner to enable debugging/detecting/fixing of any issue in the remaining sequence of events in resume path. [How] This patch restructures the console_lock, consol

Re: [PATCH] drm/amdgpu: reciprocate amdgpu.._resume sequence to match amdgpu.._suspend

2018-07-18 Thread S, Shirish
On 7/18/2018 3:30 PM, Michel Dänzer wrote: On 2018-07-18 11:40 AM, Shirish S wrote: [Why] 1. To ensure that resume path reciprocates the sequence followed during suspend. 2. While the console_lock is held, console output will be buffered, till its unlocked it wont be emitted, hence its ideal t

Re: [PATCH] drm/amdgpu: reciprocate amdgpu.._resume sequence to match amdgpu.._suspend

2018-07-18 Thread Michel Dänzer
On 2018-07-18 11:40 AM, Shirish S wrote: > [Why] > 1. To ensure that resume path reciprocates the sequence followed during > suspend. > 2. While the console_lock is held, console output will be buffered, till > its unlocked it wont be emitted, hence its ideal to unlock sooner to enable > debugging/

[PATCH] drm/amdgpu: reciprocate amdgpu.._resume sequence to match amdgpu.._suspend

2018-07-18 Thread Shirish S
[Why] 1. To ensure that resume path reciprocates the sequence followed during suspend. 2. While the console_lock is held, console output will be buffered, till its unlocked it wont be emitted, hence its ideal to unlock sooner to enable debugging/detecting/fixing of any issue in the remaining sequen

[PATCH 2/2] drm/amdgpu: reduce the number of placements for a BO

2018-07-18 Thread Christian König
Make struct amdgpu_bo a bit smaller. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_object.c | 2 ++ drivers/gpu/drm/amd/amdgpu/amdgpu_object.h | 3 ++- 2 files changed, 4 insertions(+), 1 deletion(-) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_object.c b/drivers/gpu/d

[PATCH] drm/amdgpu: reduce the number of placements for a BO

2018-07-18 Thread Christian König
Make struct amdgpu_bo a bit smaller. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_object.c | 2 ++ drivers/gpu/drm/amd/amdgpu/amdgpu_object.h | 3 ++- 2 files changed, 4 insertions(+), 1 deletion(-) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_object.c b/drivers/gpu/d

[PATCH 1/2] drm/amdgpu: consistenly name amdgpu_bo_ functions

2018-07-18 Thread Christian König
Just rename functions, no functional change. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu.h | 2 -- drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd_gpuvm.c | 8 +++--- drivers/gpu/drm/amd/amdgpu/amdgpu_cs.c | 10 +++ drivers/gpu/drm/amd/amdgpu/amdgpu