RE: [PATCH 2/2] drm/amdgpu: call ras_debugfs_create_all in debugfs_init

2020-03-09 Thread Chen, Guchun
[AMD Public Use] That's fine. These two patches are: Reviewed-by: Guchun Chen Regards, Guchun -Original Message- From: Zhou1, Tao Sent: Monday, March 9, 2020 6:15 PM To: Chen, Guchun ; Yang, Stanley ; amd-gfx@lists.freedesktop.org Cc: Zhang, Hawking ; Li, Dennis ; Clements, John ;

RE: [PATCH] drm/amdgpu: check for the existence of RAS dir before creating

2020-03-09 Thread Yang, Stanley
[AMD Official Use Only - Internal Distribution Only] centralize all debugfs creation in one place for ras Signed-off-by: Tao Zhou Signed-off-by: Stanley.Yang Change-Id: I7489ccb41dcf7a11ecc45313ad42940474999d81 Patches have been pushed to branch. Regards, Stanley -Original Message- F

RE: [PATCH] drm/amdgpu: check for the existence of RAS dir before creating

2020-03-09 Thread Zhou1, Tao
[AMD Official Use Only - Internal Distribution Only] The issue is fixed by: centralize all debugfs creation in one place for ras Signed-off-by: Tao Zhou Signed-off-by: Stanley.Yang Change-Id: I7489ccb41dcf7a11ecc45313ad42940474999d81 Hi Stanley: Have you pushed the patch? Regards, Tao > --

[PATCH] drm/amdgpu: check for the existence of RAS dir before creating

2020-03-09 Thread Evan Quan
To address the error message below: debugfs: Directory 'ras' with parent '/' already present! Change-Id: I2539e89fdfe4e22055c3be5a48a8c0adad315f91 Signed-off-by: Evan Quan --- drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/drivers/g

RE: [PATCH] drm/amd/powerplay: fix the coverity warning about negative check for an unsigned value

2020-03-09 Thread Quan, Evan
Reviewed-by: Evan Quan -Original Message- From: Liang, Prike Sent: Tuesday, March 10, 2020 8:36 AM To: amd-gfx@lists.freedesktop.org; Quan, Evan ; Deucher, Alexander Cc: Liang, Prike Subject: [PATCH] drm/amd/powerplay: fix the coverity warning about negative check for an unsigned va

[PATCH] drm/amd/powerplay: fix the coverity warning about negative check for an unsigned value

2020-03-09 Thread Prike Liang
There will be a coverity warning because min and max are both unsigned. Signed-off-by: Prike Liang --- drivers/gpu/drm/amd/powerplay/amdgpu_smu.c | 3 --- 1 file changed, 3 deletions(-) diff --git a/drivers/gpu/drm/amd/powerplay/amdgpu_smu.c b/drivers/gpu/drm/amd/powerplay/amdgpu_smu.c index d

RE: [PATCH 1/2] drm/amd/powerplay: fix pre-check condition for setting clock range

2020-03-09 Thread Liang, Prike
> -Original Message- > From: Bjorn Helgaas > Sent: Monday, March 9, 2020 9:11 PM > To: Liang, Prike > Cc: amd-gfx@lists.freedesktop.org; Quan, Evan ; > Huang, Ray ; linux-ker...@vger.org; Deucher, > Alexander > Subject: Re: [PATCH 1/2] drm/amd/powerplay: fix pre-check condition for >

Re: [PATCH] drm/amdkfd: Consolidate duplicated bo alloc flags

2020-03-09 Thread Felix Kuehling
On 2020-03-06 18:30, Yong Zhao wrote: ALLOC_MEM_FLAGS_* used are the same as the KFD_IOC_ALLOC_MEM_FLAGS_*, but they are interweavedly used in kernel driver, resulting in bad readability. For example, KFD_IOC_ALLOC_MEM_FLAGS_COHERENT is not referenced in kernel, and it functions implicitly in ker

Re: [PATCH] drm/amdkfd: Use pr_debug to print the message of reaching event limit

2020-03-09 Thread Felix Kuehling
On 2020-03-09 14:25, Yong Zhao wrote: People are inclined to think of the previous pr_warn message as an error, so use pre_debug instead. Change-Id: I3ac565a2bd3b8d57345812104c872183898d237f Signed-off-by: Yong Zhao Reviewed-by: Felix Kuehling Thanks,   Felix --- drivers/gpu/drm/amd/amd

[PATCH] drm/amdkfd: Use pr_debug to print the message of reaching event limit

2020-03-09 Thread Yong Zhao
People are inclined to think of the previous pr_warn message as an error, so use pre_debug instead. Change-Id: I3ac565a2bd3b8d57345812104c872183898d237f Signed-off-by: Yong Zhao --- drivers/gpu/drm/amd/amdkfd/kfd_events.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/driver

[PATCH v3 2/4] drm/amdgpu/vcn: fix race condition issue for dpg unpause mode switch

2020-03-09 Thread James Zhu
Couldn't only rely on enc fence to decide switching to dpg unpaude mode. Since a enc thread may not schedule a fence in time during multiple threads running situation. v3: 1. Rename enc_submission_cnt to dpg_enc_submission_cnt 2. Add dpg_enc_submission_cnt check in idle_work_handler Signed-of

[PATCH v3 1/4] drm/amdgpu/vcn: fix race condition issue for vcn start

2020-03-09 Thread James Zhu
Fix race condition issue when multiple vcn starts are called. v2: Removed checking the return value of cancel_delayed_work_sync() to prevent possible races here. v3: Add total_submission_cnt to avoid gate power unexpectedly. Signed-off-by: James Zhu --- drivers/gpu/drm/amd/amdgpu/amdgpu_vcn.c

Re: [PATCH 1/2] drm/amdgpu: add function to creat all ras debugfs node

2020-03-09 Thread Alex Deucher
On Mon, Mar 9, 2020 at 5:12 AM Stanley.Yang wrote: > > From: Tao Zhou > > centralize all debugfs creation in one place for ras Might want to note that this is required to fix ras when the driver does not use the drm load and unload callbacks due to ordering issues with the drm device node. With

Re: [PATCH v5 3/4] drm/amdgpu: change hw sched list on ctx priority override

2020-03-09 Thread Christian König
Am 09.03.20 um 14:33 schrieb Nirmoy Das: Switch to appropriate sched list for an entity on priority override. Signed-off-by: Nirmoy Das Reviewed-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_ctx.c | 29 + 1 file changed, 25 insertions(+), 4 deletions(

[PATCH v5 3/4] drm/amdgpu: change hw sched list on ctx priority override

2020-03-09 Thread Nirmoy Das
Switch to appropriate sched list for an entity on priority override. Signed-off-by: Nirmoy Das --- drivers/gpu/drm/amd/amdgpu/amdgpu_ctx.c | 29 + 1 file changed, 25 insertions(+), 4 deletions(-) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ctx.c b/drivers/gpu/drm/amd

[PATCH v8 1/4] drm/amdgpu: set compute queue priority at mqd_init

2020-03-09 Thread Nirmoy Das
We were changing compute ring priority while rings were being used before every job submission which is not recommended. This patch sets compute queue priority at mqd initialization for gfx8, gfx9 and gfx10. Policy: make queue 0 of each pipe as high priority compute queue High/normal priority com

[PATCH 2/4] drm/scheduler: implement a function to modify sched list

2020-03-09 Thread Nirmoy Das
Implement drm_sched_entity_modify_sched() which modifies existing sched_list with a different one. This is going to be helpful when userspace changes priority of a ctx/entity then the driver can switch to the corresponding HW scheduler list for that priority. Signed-off-by: Nirmoy Das Reviewed-by

[PATCH 4/4] drm/amdgpu: remove unused functions

2020-03-09 Thread Nirmoy Das
AMDGPU statically sets priority for compute queues at initialization so remove all the functions responsible for changing compute queue priority dynamically. Signed-off-by: Nirmoy Das Reviewed-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_ring.c | 70 drivers/gpu/d

Re: [PATCH v7 1/4] drm/amdgpu: set compute queue priority at mqd_init

2020-03-09 Thread Christian König
Am 09.03.20 um 13:59 schrieb Nirmoy Das: We were changing compute ring priority while rings were being used before every job submission which is not recommended. This patch sets compute queue priority at mqd initialization for gfx8, gfx9 and gfx10. Policy: make queue 0 of each pipe as high prior

OpenBSD amdgpu RX550 stub messages in dmesg

2020-03-09 Thread Justin Noor
Hello community, I've been experiencing some random and inconsistent crashes related to amdgpu0 on OpenBSD 6.6 current. I noticed the following in my dmesg: amdgpu_irq_add_domain: stub amdgpu_device_resize_fb_bar: stub amdgpu: [powerplay] Failed to retrieve minimum clocks Someone mentioned t

Re: [PATCH 1/2] drm/amd/powerplay: fix pre-check condition for setting clock range

2020-03-09 Thread Bjorn Helgaas
On Wed, Mar 04, 2020 at 10:55:37AM +0800, Prike Liang wrote: > This fix will handle some MP1 FW issue like as mclk dpm table in > renoir has a reverse dpm clock layout and a zero frequency dpm level > as following case. > > cat pp_dpm_mclk > 0: 1200Mhz > 1: 1200Mhz > 2: 800Mhz > 3: 0Mhz > > Signe

[PATCH 2/4] drm/scheduler: implement a function to modify sched list

2020-03-09 Thread Nirmoy Das
Implement drm_sched_entity_modify_sched() which modifies existing sched_list with a different one. This is going to be helpful when userspace changes priority of a ctx/entity then the driver can switch to the corresponding HW scheduler list for that priority. Signed-off-by: Nirmoy Das Reviewed-by

[PATCH 4/4] drm/amdgpu: remove unused functions

2020-03-09 Thread Nirmoy Das
AMDGPU statically sets priority for compute queues at initialization so remove all the functions responsible for changing compute queue priority dynamically. Signed-off-by: Nirmoy Das Reviewed-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_ring.c | 70 drivers/gpu/d

[PATCH v7 1/4] drm/amdgpu: set compute queue priority at mqd_init

2020-03-09 Thread Nirmoy Das
We were changing compute ring priority while rings were being used before every job submission which is not recommended. This patch sets compute queue priority at mqd initialization for gfx8, gfx9 and gfx10. Policy: make queue 0 of each pipe as high priority compute queue High/normal priority com

[PATCH v5 3/4] drm/amdgpu: change hw sched list on ctx priority override

2020-03-09 Thread Nirmoy Das
Switch to appropriate sched list for an entity on priority override. Signed-off-by: Nirmoy Das --- drivers/gpu/drm/amd/amdgpu/amdgpu_ctx.c | 29 + 1 file changed, 25 insertions(+), 4 deletions(-) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ctx.c b/drivers/gpu/drm/amd

AW: [PATCH] drm/amdgpu/display: Fix an error handling path in 'dm_update_crtc_state()'

2020-03-09 Thread Walter Harms
Von: kernel-janitors-ow...@vger.kernel.org im Auftrag von Christophe JAILLET Gesendet: Sonntag, 8. März 2020 10:26 An: harry.wentl...@amd.com; sunpeng...@amd.com; alexander.deuc...@amd.com; christian.koe...@amd.com; david1.z...@amd.com; airl...@linux.

RE: [PATCH 2/2] drm/amdgpu: call ras_debugfs_create_all in debugfs_init

2020-03-09 Thread Zhou1, Tao
[AMD Public Use] We already have amdgpu_ras_debugfs_remove and amdgpu_ras_debugfs_remove_all. In fact, amdgpu_debugfs_fini has been dropped in the patch below, and we are also planning to delete amdgpu_ras_debugfs_remove and amdgpu_ras_debugfs_remove_all. drm/amdgpu: no need to clean debugfs at

RE: [PATCH 2/2] drm/amdgpu: call ras_debugfs_create_all in debugfs_init

2020-03-09 Thread Chen, Guchun
[AMD Public Use] Shall we need other codes to remove ras debugfs in debugfs_fini to avoid leak? Regards, Guchun -Original Message- From: Stanley.Yang Sent: Monday, March 9, 2020 5:12 PM To: amd-gfx@lists.freedesktop.org Cc: Zhang, Hawking ; Chen, Guchun ; Li, Dennis ; Clements, John ;

[PATCH 1/2] drm/amdgpu: add function to creat all ras debugfs node

2020-03-09 Thread Stanley . Yang
From: Tao Zhou centralize all debugfs creation in one place for ras Signed-off-by: Tao Zhou Signed-off-by: Stanley.Yang Change-Id: I7489ccb41dcf7a11ecc45313ad42940474999d81 --- drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c | 29 + drivers/gpu/drm/amd/amdgpu/amdgpu_ras.h | 2

[PATCH 2/2] drm/amdgpu: call ras_debugfs_create_all in debugfs_init

2020-03-09 Thread Stanley . Yang
From: Tao Zhou and remove each ras IP's own debugfs creation Signed-off-by: Tao Zhou Signed-off-by: Stanley.Yang Change-Id: If3d16862afa0d97abad183dd6e60478b34029e95 --- drivers/gpu/drm/amd/amdgpu/amdgpu_debugfs.c | 3 +++ drivers/gpu/drm/amd/amdgpu/amdgpu_gfx.c | 1 - drivers/gpu/drm/amd

[PATCH] drm/amdgpu/display: Fix an error handling path in 'dm_update_crtc_state()'

2020-03-09 Thread Christophe JAILLET
'dc_stream_release()' may be called twice. Once here, and once below in the error handling path if we branch to the 'fail' label. Set 'new_stream' to NULL, once released to avoid the duplicated release function call. Signed-off-by: Christophe JAILLET --- Maybe the 'goto fail' at line 7745 should