Re: Fwd: Barebox 2017.02 works great but no Linux Framebuffer... :-/

2017-06-19 Thread gianluca
Hello Lucas, Sascha and the barebox mailing list guys! I am back with the new boards batch release (now QuadPlus and DualLite iMX6) Now I adapted barebox to fit both processors and it works quite well. From Barebox point-of-view the ldb node of the device-tree is using three timings and they

[PATCH 4/6] mtd: dataflash: Get rid of loop counter in jedec_probe()

2017-06-19 Thread Andrey Smirnov
"For" loop in jedec_probe can be simplified to not need counter 'i'. Convert the code and get rid of the variable. This is a backport of kernel commit a296a1bc3eb54382d2a61d47529e71c9d3bc615e Signed-off-by: Andrey Smirnov --- drivers/mtd/devices/mtd_dataflash.c | 8

[PATCH 3/6] mtd: dataflash: Replace pr_debug, printk with dev_* functions

2017-06-19 Thread Andrey Smirnov
Lion's share of calls to pr_debug in this driver follow the pattern of pr_debug("%s ", dev_name(), ), which should be semantically identical to dev_dbg(, "", ), so replace such occurencies to simplify the code. Convert the small minority of pr_debug that do not follow pattern from above to use

[PATCH 2/6] mtd: dataflash: Improve coding style in jedec_probe()

2017-06-19 Thread Andrey Smirnov
Change the following: - Replace indentation between type and name of local variable from tabs to spaces - Replace magic number 0x1F with CFI_MFR_ATMEL macro - Replace variable 'tmp' with 'ret' and 'i' where appropriate - Reformat multi-line comments and add newlines where

[PATCH 1/6] mtd: dataflash: Replace C99 types with their kernel counterparts

2017-06-19 Thread Andrey Smirnov
No functional change intended. This is a backport of kernel commit c41e43c6faf68a9b70afdb0dfee45d196c27031b Signed-off-by: Andrey Smirnov --- drivers/mtd/devices/mtd_dataflash.c | 40 ++--- 1 file changed, 20 insertions(+), 20

[PATCH 5/6] mtd: dataflash: Make use of "extened device information"

2017-06-19 Thread Andrey Smirnov
In anticipation of supporting chips that need it, extend the size of struct flash_info's 'jedec_id' field to make room 2 byte of extended device information as well as add code to fetch this data during jedec_probe(). This is a backport of kernel commit 1da8869a428317a6d3cd8d47184cf87feb34a98b

[PATCH 0/3] Fix "i.MX: vf610: Ramp CPU clock to maximum frequency"

2017-06-19 Thread Andrey Smirnov
Everyone, It looks like my test setup was somehow contaminated -- possibly by using JTAG to initalize SoC and upload Barebox binary -- so 21921f7f419dfaabcd385595ada24f0352310f1a ("i.MX: vf610: Ramp CPU clock to maximum frequency") didn't actually work as I thought it was and instead it made

[PATCH 6/6] mtd: dataflash: Add flash_info for AT45DB641E

2017-06-19 Thread Andrey Smirnov
This is a backport of kernel commit 67e4145ebf2c161d7404770461b8404f00a6d3bf Signed-off-by: Andrey Smirnov --- drivers/mtd/devices/mtd_dataflash.c | 3 +++ 1 file changed, 3 insertions(+) diff --git a/drivers/mtd/devices/mtd_dataflash.c

[PATCH 0/6] Backport support for "extended device ID" for dataflash

2017-06-19 Thread Andrey Smirnov
Hi everyone, This series is a backport of almost identical patchset that I did for linux kernel: 1. lkml.kernel.org/r/20170421163026.24884-1-andrew.smir...@gmail.com 2. lkml.kernel.org/r/20170421163026.24884-2-andrew.smir...@gmail.com 3.

[PATCH 1/3] clk-vf610: Mark all of CCSR muxes with CLK_OPS_PARENT_ENABLE

2017-06-19 Thread Andrey Smirnov
As per VYBRIDRM.pdf, p. 673: "... When switching clock sources on GL MUX, both active and target clock sources must be active..." So mark all of the clock muxes controlled by CCM_CSSR with CLK_OPS_PARENT_ENABLE to satisfy that requirement. Experiment shows that failing to do so would result in

[PATCH 3/3] i.MX: clk: Remove imx_clk_pllv3_locked()

2017-06-19 Thread Andrey Smirnov
Remove imx_clk_pllv3_locked() which was introduced for the sake of Vybrid platform. The same effect (waiting on 'locked' bit) can be achived with vanilla clk_pllv3_enable/disable, which make said function unnecessary. Signed-off-by: Andrey Smirnov ---

[PATCH 2/3] i.MX: clk-pllv3: Do not touch PLL_BYPASS bit

2017-06-19 Thread Andrey Smirnov
Do not touch PLL_BYPASS bit as a part of clk_pll3_enable/disable execution. For a number of platforms (e.g. Vybrid, i.MX6SL) PLL_BYPASS is specified as a bit controlling a clock MUX represented by a dedicated 'struct clk'. Altering that bit as a part of clk_pll3_enable/disable is equivalent to

[PATCH] ARM: Update zii_vf610_dev_defconfig

2017-06-19 Thread Andrey Smirnov
Update zii_vf610_dev_defconfig to add needed and remove unused features. Signed-off-by: Chris Healy Signed-off-by: Andrey Smirnov --- arch/arm/configs/zii_vf610_dev_defconfig | 39 1 file changed, 9 insertions(+), 30

Re: [PATCH 00/16] RATP logic fixes and improvements

2017-06-19 Thread Sascha Hauer
On Mon, Jun 19, 2017 at 11:07:09AM +0200, Aleksander Morgado wrote: > Hey, > > On 19/06/17 08:46, Sascha Hauer wrote: > >> I went through the RFC916 and ended up preparing a set of fixes and > >> improvements for the RATP logic in barebox. > >> Let me know what you think. > > As far as I can say

Re: [PATCH 00/16] RATP logic fixes and improvements

2017-06-19 Thread Aleksander Morgado
Hey, On 19/06/17 08:46, Sascha Hauer wrote: >> I went through the RFC916 and ended up preparing a set of fixes and >> improvements for the RATP logic in barebox. >> Let me know what you think. > As far as I can say the patches look good. It's quite a while since I > last looked at the RATP code,

Re: [PATCH] defaultenv: bin: init: Add sourcing of config-expansions

2017-06-19 Thread Sascha Hauer
On Tue, Jun 13, 2017 at 03:37:00PM +0200, Daniel Schultz wrote: > This patch adds a further layer to the config hierarchy. It allows a > dynamic configuration of expansions. > > Signed-off-by: Daniel Schultz > --- > defaultenv/defaultenv-2-base/bin/init | 1 + > 1 file

Re: [PATCH v4] arm: boards: phytec-som-am335x: Update boot scripts

2017-06-19 Thread Sascha Hauer
On Tue, Jun 13, 2017 at 03:37:08PM +0200, Daniel Schultz wrote: > Expand the boot scripts with EMMC and add a default file source for > expansions. > > Removed "rw" and "rootwait" bootargs from existing boot scripts. > Added "rootflags='data=journal'" bootarg to SD card boot script. > >

Re: [PATCH 00/16] RATP logic fixes and improvements

2017-06-19 Thread Sascha Hauer
Hi Aleksander, On Thu, Jun 15, 2017 at 01:14:04PM +0200, Aleksander Morgado wrote: > Hey Sascha, > > I went through the RFC916 and ended up preparing a set of fixes and > improvements for the RATP logic in barebox. > Let me know what you think. As far as I can say the patches look good. It's

Re: [PATCH] serial: ns16550: emit an error message if getting the clock fails

2017-06-19 Thread Sascha Hauer
On Wed, Jun 14, 2017 at 12:01:29AM +0200, Uwe Kleine-König wrote: > Signed-off-by: Uwe Kleine-König > --- > drivers/serial/serial_ns16550.c | 1 + > 1 file changed, 1 insertion(+) Applied, thanks Sascha > > diff --git a/drivers/serial/serial_ns16550.c

Re: [PATCH] scripts/kwbimage: support empty binary.0 files

2017-06-19 Thread Sascha Hauer
On Wed, Jun 14, 2017 at 12:02:07AM +0200, Uwe Kleine-König wrote: > While it doesn't make sense to use empty binary headers on a machine for > first stage, it is convenient to support this for build testing. > > Signed-off-by: Uwe Kleine-König > --- >

Re: [PATCH 1/2] of_device_is_stdout_path: simplify

2017-06-19 Thread Sascha Hauer
On Wed, Jun 14, 2017 at 01:31:09PM +0200, Uwe Kleine-König wrote: > Test for dev->device_node being NULL earlier which at the end of the > function allows to simplify the calculation of the return value > > Signed-off-by: Uwe Kleine-König > --- >

Re: [PATCH] mtd: spi-nor: sync definition of Spansion chips from Linux

2017-06-19 Thread Sascha Hauer
On Wed, Jun 14, 2017 at 08:57:05PM +0200, Uwe Kleine-König wrote: > Signed-off-by: Uwe Kleine-König > --- > drivers/mtd/spi-nor/spi-nor.c | 22 -- > 1 file changed, 12 insertions(+), 10 deletions(-) Applied, thanks Sascha > > diff --git

Re: [PATCH 1/3] ARM: mvebu: initial support for Armada 38x

2017-06-19 Thread Sascha Hauer
On Wed, Jun 14, 2017 at 11:50:08PM +0200, Uwe Kleine-König wrote: > This SoC is similar enough to Armada 380/XP to make use of the code > supporting these without further adaption. > > Signed-off-by: Uwe Kleine-König > --- > arch/arm/mach-mvebu/Kconfig | 5 +

Re: [PATCH] clk: let clk_get return errors from of_clk_get_by_name

2017-06-19 Thread Sascha Hauer
On Tue, Jun 13, 2017 at 11:51:28PM +0200, Uwe Kleine-König wrote: > When of_clk_get_by_name fails with -ENODEV it's fine to continue with > clk_get_sys. Other errors (e.g. -EPROBE_DEFER) should be returned however. > > Signed-off-by: Uwe Kleine-König > --- >

Re: [PATCH] pci: mvebu: terminate error message with a newline

2017-06-19 Thread Sascha Hauer
On Tue, Jun 13, 2017 at 07:58:05PM +0200, Uwe Kleine-König wrote: > Signed-off-by: Uwe Kleine-König > --- > drivers/pci/pci-mvebu.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) Applied, thanks Sascha > > diff --git a/drivers/pci/pci-mvebu.c