RE: NXP Layerscape

2021-06-15 Thread Barbier, Renaud
> 09570604 1000 > This is the weird one. The QSPI read data is memory mapped in some SRAM where > it is directly executed. So if I understand you correctly both the PBI and barebox PBL got mapped to the SRAM (which I guess may be the OCRAM1 if i refer to the address above 0x1000)

Re: [PATCH] net/eth: read default mac-address default from dts

2021-06-15 Thread Trent Piepho
Once upon a time, it was common for kernel dts files to be booted with u-boot to include an all zero mac address property, since u-boot could not unpack/pack the fdt. It could only find an existing property and change bytes already present, thus adding a blank mac address to be patched. Barebox

Re: [PATCH 2/2] ARM: i.MX: xload: consider ECC strength when reading page

2021-06-15 Thread Trent Piepho
On Tue, Jun 15, 2021 at 7:35 AM Sascha Hauer wrote: > > > > I do not see any imx nand xloader users at all in mainlinux Barebox > > codebase. Which is annoying, since I'm trying to boot barebox from > > NAND on iMX6ULL and there are no boards in barebox that do this. So I > > have to do it from

[PATCH] net/eth: read default mac-address default from dts

2021-06-15 Thread Michael Grzeschik
Since we have the function of_get_mac_address we can use it to set the default mac address vom the dts. Signed-off-by: Michael Grzeschik --- net/eth.c | 9 + 1 file changed, 9 insertions(+) diff --git a/net/eth.c b/net/eth.c index 84f99d3aa8..baebf89d89 100644 --- a/net/eth.c +++

[PATCH] net/eth: read default mac-address default from dts

2021-06-15 Thread Michael Grzeschik
Since we have the functino of_get_mac_address we can use it to set the default mac address vom the dts. Signed-off-by: Michael Grzeschik --- net/eth.c | 9 + 1 file changed, 9 insertions(+) diff --git a/net/eth.c b/net/eth.c index 84f99d3aa8..baebf89d89 100644 --- a/net/eth.c +++

[PATCH] Add clk_round_rate command

2021-06-15 Thread Sascha Hauer
clk_round_rate returns the rate a clk rate will result to if called clk_set_rate on it with that rate. Add a command for it as it comes in handy sometimes for testing and debugging purposes. Signed-off-by: Sascha Hauer --- commands/clk.c | 32 1 file changed, 32

Re: [PATCH 1/4] common: boot: don't return too early in bootscript dryrun

2021-06-15 Thread Marc Reilly
Hi Ahmad, On Monday, 14 June 2021 6:51:27 PM AEST Ahmad Fatoum wrote: > Hi, > > On 14.06.21 00:26, Marc Reilly wrote: > > A dryrun boot will now run the boot script and a then a > > dryrun of the bootm. > > This would change behavior for boot scripts that directly boot > instead of setting up

Re: [PATCH 1/4] common: boot: don't return too early in bootscript dryrun

2021-06-15 Thread Sascha Hauer
On Mon, Jun 14, 2021 at 10:51:27AM +0200, Ahmad Fatoum wrote: > Hi, > > On 14.06.21 00:26, Marc Reilly wrote: > > A dryrun boot will now run the boot script and a then a > > dryrun of the bootm. > > This would change behavior for boot scripts that directly boot > instead of setting up variables

[PATCH v3 06/10] of: kconfig: of_overlay uses firmwaremgr_load_file

2021-06-15 Thread Steffen Trumtrar
From: Steffen Trumtrar As of_firmware.c uses the firmwaremgr_load_file function, it depends on FIRMWARE. Signed-off-by: Steffen Trumtrar --- drivers/of/Kconfig | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/of/Kconfig b/drivers/of/Kconfig index 23be25d85d09..e58fe50f7090 100644

Re: [PATCH 2/4] ARM: beaglebone: add helper init script for checking if BBBW

2021-06-15 Thread Sascha Hauer
On Mon, Jun 14, 2021 at 08:26:37AM +1000, Marc Reilly wrote: > This adds a check against the eeprom contents to see if the board is a > Beaglebone black wireless. (two bytes at offset 0x12 of eeprom will be > "BW"). > If it is, the global board.variant is updated to "boneblackwireless" > >

Re: [PATCH] Documentation: RISC-V: erizo: fix header level

2021-06-15 Thread Sascha Hauer
On Mon, Jun 14, 2021 at 05:27:53PM +0300, Antony Pavlov wrote: > The "Running on DE0-Nano FPGA board" is a "Erizo" subsection > not independent section. > > Signed-off-by: Antony Pavlov > --- > Documentation/boards/riscv.rst | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) Applied,

Re: [PATCH 3/4] ARM: am33xx: add define for 800Mhz MPU PLL point

2021-06-15 Thread Sascha Hauer
On Mon, Jun 14, 2021 at 08:26:38AM +1000, Marc Reilly wrote: > Signed-off-by: Marc Reilly > --- > arch/arm/mach-omap/include/mach/am33xx-clock.h | 1 + > 1 file changed, 1 insertion(+) Applied this one and 4/4 for now. Sascha -- Pengutronix e.K. |

Re: NXP Layerscape

2021-06-15 Thread Sascha Hauer
On Mon, Jun 14, 2021 at 03:16:27PM +, Barbier, Renaud wrote: > I am a bit confused on how the QSPI image is built. > From images/Makefile.layerscape > $(obj)/barebox-ls1046ardb-qspi.image: $(obj)/start_ls1046ardb.pblb \ > $(board)/ls1046ardb/ls1046ardb_rcw_qspi.cfg \ >

Re: [PATCH 2/2] ARM: i.MX: xload: consider ECC strength when reading page

2021-06-15 Thread Sascha Hauer
On Mon, Jun 14, 2021 at 03:14:22PM -0700, Trent Piepho wrote: > On Tue, Jun 8, 2021 at 11:34 PM Andrej Picej wrote: > > On 8. 06. 21 14:38, Trent Piepho wrote: > > > On Tue, Jun 8, 2021 at 12:23 AM Andrej Picej > > > wrote: > > >> On 7. 06. 21 22:03, Trent Piepho wrote: > > > Ok, so 4 ecc bits

[PATCH 07/11] ARM: Rockchip: Add rk3568 support

2021-06-15 Thread Sascha Hauer
This adds basic support for the Rockchip rk3568 SoC. Signed-off-by: Sascha Hauer --- arch/arm/Kconfig | 3 - arch/arm/mach-rockchip/Kconfig| 12 ++ arch/arm/mach-rockchip/Makefile | 4 +- arch/arm/mach-rockchip/atf.c

[PATCH 10/11] ARM: Rockchip: Add rk3568 evb board support

2021-06-15 Thread Sascha Hauer
This adds support for the rk3568 evb board. Tested features so far are: - 1st stage booting - Network - SD card - eMMC The dts files are based on the ones posted on the mailing lists, they should be rebased on the upstream files once they show up in barebox. Signed-off-by: Sascha Hauer ---

[PATCH 06/11] ARM: Rockchip: Add rk3568 dtsi files

2021-06-15 Thread Sascha Hauer
This adds the rk3568 dtsi files, taken from the mailing list. They should hit upstream soon and can be removed then. Signed-off-by: Sascha Hauer --- arch/arm/dts/rk3568-pinctrl.dtsi | 3111 arch/arm/dts/rk3568.dtsi | 885

[PATCH 11/11] Add rockchip_v8_defconfig

2021-06-15 Thread Sascha Hauer
Add a defconfig for the arm64 based Rockchip SoCs, currently only RK3568 Signed-off-by: Sascha Hauer --- arch/arm/configs/rockchip_v8_defconfig | 120 + 1 file changed, 120 insertions(+) create mode 100644 arch/arm/configs/rockchip_v8_defconfig diff --git

[PATCH 01/11] clk: Add clk_name_* functions

2021-06-15 Thread Sascha Hauer
At some places a clk name may be known without having a struct clk * directly. Add some convenience functions to handle this situation and use them in the clk commands. Signed-off-by: Sascha Hauer --- commands/clk.c | 18 ++ drivers/clk/clk.c | 22 ++

[PATCH 09/11] ARM: rockchip: Add bootm handler for RKNS images

2021-06-15 Thread Sascha Hauer
The rk3568 utilizes boot images starting with the magic 'RKNS'. Add a bootm handler for these to allow them to be chainloaded. Signed-off-by: Sascha Hauer --- arch/arm/mach-rockchip/Makefile | 1 + arch/arm/mach-rockchip/bootm.c | 116 2 files changed, 117

[PATCH 03/11] filetype: Add Rockchip boot image type

2021-06-15 Thread Sascha Hauer
Newer Rockchip SoCs boot images starting with the magic "RKNS". There are older image formats currently not supported, this one is at least supported on the RK3568. Signed-off-by: Sascha Hauer --- common/filetype.c | 3 +++ include/filetype.h | 1 + 2 files changed, 4 insertions(+) diff --git

[PATCH 08/11] ARM: Add atf common support

2021-06-15 Thread Sascha Hauer
ARM trusted firmware has some common data structures passed to bl31. This patch imports the code supporting this taken from U-Boot. The defines and data structures are taken directly from U-Boot, the support code is heavily modified for the sake of readability. Signed-off-by: Sascha Hauer ---

[PATCH 05/11] ARM: Add relocate_to_adr_full()

2021-06-15 Thread Sascha Hauer
relocate_to_adr() currently relocates the PBL code to another address, but doesn't move the piggy data (compressed barebox image). This patch adds relocate_to_adr_full() which moves the full image including the piggy data. This is needed for upcoming Rockchip RK3568 support. Here we are started at

[PATCH 00/11] Rockchip RK3568 support

2021-06-15 Thread Sascha Hauer
After I have posted the drivers for the Rockchip RK3568 separately here comes the SoC support and support for the RK3568 EVB board. With this series the RK3568 EVB board is supported including network support, SD and eMMC, so everything needed to start up with that hardware. The board also needs

[PATCH 04/11] ARM: Rockchip: Add rkimage tool

2021-06-15 Thread Sascha Hauer
This adds a tool for generating "RKNS" type booting image for newer Rockchip SoCs. This image format is supported starting at least with RK3568. Older image types are not (yet) supported. Signed-off-by: Sascha Hauer --- scripts/Makefile | 3 + scripts/rkimage.c | 260

[PATCH 02/11] clk: rockchip rk3568: Initialize clocks

2021-06-15 Thread Sascha Hauer
This initializes the rk3568 clocks in the way U-Boot initializes them as well. Signed-off-by: Sascha Hauer --- drivers/clk/rockchip/clk-rk3568.c | 28 1 file changed, 28 insertions(+) diff --git a/drivers/clk/rockchip/clk-rk3568.c

[PATCH v3 03/10] drivers: fpga: add socfpga bridges

2021-06-15 Thread Steffen Trumtrar
Import the SoCFPGA bridges drivers from linux v4.10-rc2. Description from the original commit: e5f8efa5c8bf86c1fa698551d54db8f6aee221fd ARM: socfpga: fpga bridge driver support Supports Altera SOCFPGA bridges: * fpga2sdram * fpga2hps * hps2fpga * lwhps2fpga

[PATCH v3 05/10] firmware: import fpga-mgr.h from linux

2021-06-15 Thread Steffen Trumtrar
Instead of defining the fpga-mgr structure in the socfpga driver, import the fpga-mgr.h file from linux v4.13. Signed-off-by: Steffen Trumtrar --- drivers/firmware/socfpga.c | 9 +--- include/firmware.h | 1 + include/fpga-mgr.h | 102 + 3

Re: [PATCH] drivers: drop unused usb_gadget_{map,unmap}_request()

2021-06-15 Thread Sascha Hauer
On Mon, Jun 14, 2021 at 05:28:33PM +0300, Antony Pavlov wrote: > There is no code that is dependent on > usb_gadget_{map,unmap}_request(). My first reaction was: But maybe there *should* be code depending on that, but > -#ifdef CONFIG_KERNEL_HAS_DMA > - > -int usb_gadget_map_request(struct

[PATCH v3 04/10] firmware: socfpga: change function prefixes

2021-06-15 Thread Steffen Trumtrar
Since there is now a fpgamgr framework in barebox, the function names are misleading. Change that to be SoCFPGA specific. Signed-off-by: Steffen Trumtrar --- drivers/firmware/socfpga.c | 58 +++--- 1 file changed, 29 insertions(+), 29 deletions(-) diff --git

[PATCH v3 01/10] reset: add of_reset_control_get to header

2021-06-15 Thread Steffen Trumtrar
Signed-off-by: Steffen Trumtrar --- drivers/reset/core.c | 2 +- include/linux/reset.h | 2 ++ 2 files changed, 3 insertions(+), 1 deletion(-) diff --git a/drivers/reset/core.c b/drivers/reset/core.c index 26a54f21dff0..1c9eeaec5491 100644 --- a/drivers/reset/core.c +++ b/drivers/reset/core.c

[PATCH v3 08/10] commands: firmwareload: allow loading firmware from dt

2021-06-15 Thread Steffen Trumtrar
firmwareload can only load a bitstream into an FPGA without any knowledge of possible additional needs (e.g. FPGA bridges). These are defined in the fpga-region nodes in the devicetree. The fpga-region describes the layout of the FPGA and the bridges it needs en/disabled. Add an option to let

[PATCH v3 02/10] drivers: add fpga bridge framework

2021-06-15 Thread Steffen Trumtrar
Import the fpga bridge framework from linux v4.10-rc2. Description from the initial commit adding this to linux: 21aeda950c5f84a8351b862816d832120b217a9b fpga: add fpga bridge framework This framework adds API functions for enabling/ disabling FPGA bridges under kernel control.

[PATCH v3 07/10] of: of_firmware: add support for fpga bridges

2021-06-15 Thread Steffen Trumtrar
Add support for potentially defined FPGA-bridges in the overlay. While at it also add support for loading the firmware directly via a path instead of 'needing' an overlay for that. The direct loading will be done with the existent firmwareload command. Signed-off-by: Steffen Trumtrar ---

[PATCH v3 10/10] firmware: add support for compressed images

2021-06-15 Thread Steffen Trumtrar
At least bitstreams for FPGAs can consist of a lot of zeros depending on device utilization. These bitstreams can be compressed very effectively. Let the firmware code accept these images and decompress them before handing it to the firmware-manager in question. Signed-off-by: Steffen Trumtrar

[PATCH v3 09/10] drivers: firmware: socfpga: remove bridges shutdown

2021-06-15 Thread Steffen Trumtrar
The bridges are now handled via the bridges driver. There is no need to hardcode the memory writes anymore. Signed-off-by: Steffen Trumtrar --- drivers/firmware/socfpga.c | 9 - 1 file changed, 9 deletions(-) diff --git a/drivers/firmware/socfpga.c b/drivers/firmware/socfpga.c index