[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-11-01 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore updated this revision to Diff 172296. stephanemoore added a comment. Updated diff after pulling and merging. Repository: rCTE Clang Tools Extra https://reviews.llvm.org/D51575 Files: clang-tidy/google/CMakeLists.txt clang-tidy/google/FunctionNamingCheck.cpp

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-11-01 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore marked an inline comment as done. stephanemoore added a comment. https://reviews.llvm.org/D51832 is in review to update the objc-property-declaration check to allow arbitrary acronyms and initialisms. Repository: rCTE Clang Tools Extra https://reviews.llvm.org/D51575

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-08 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore added inline comments. Comment at: clang-tidy/google/FunctionNamingCheck.cpp:57 + functionDecl( + isDefinition(), + unless(anyOf(isMain(), matchesName(validFunctionNameRegex(true)), hokein wrote: > stephanemoore wrote: > >

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-08 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore updated this revision to Diff 164570. stephanemoore marked an inline comment as done. stephanemoore added a comment. Cleaned up comment about FunctionNamingCheck not applying to Objective-C method or property declarations. Repository: rCTE Clang Tools Extra

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-08 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore updated this revision to Diff 164569. stephanemoore added a comment. Implemented the following suggested changes: • Added a note that FunctionNamingCheck does not apply to Objective-C method name or property declarations. Repository: rCTE Clang Tools Extra

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-08 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore updated this revision to Diff 164568. stephanemoore marked 3 inline comments as done. stephanemoore edited the summary of this revision. stephanemoore added a comment. Implemented the following suggested changes: • Restricted matching to function declarations that are not in

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-05 Thread Ben Hamilton via Phabricator via cfe-commits
benhamilton added inline comments. Comment at: clang-tidy/google/FunctionNamingCheck.cpp:35 + // non-standard capitalized character sequences including acronyms, + // initialisms, and prefixes of symbols (e.g., UIColorFromNSString). For this + // reason, the regex only

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-05 Thread Ben Hamilton via Phabricator via cfe-commits
benhamilton requested changes to this revision. benhamilton added a comment. This revision now requires changes to proceed. Thanks for this! Let's consolidate this with the property name checker (either simplify the logic there and allow `arBiTRAryCapSAnYWHere` or apply the same registered

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-04 Thread Yan Zhang via Phabricator via cfe-commits
Wizard added inline comments. Comment at: clang-tidy/google/FunctionNamingCheck.cpp:50 + +void FunctionNamingCheck::registerMatchers(MatchFinder *Finder) { + // This check should only be applied to Objective-C sources. Can we do some simple check to see if some

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-04 Thread Haojian Wu via Phabricator via cfe-commits
hokein added inline comments. Comment at: clang-tidy/google/FunctionNamingCheck.cpp:57 + functionDecl( + isDefinition(), + unless(anyOf(isMain(), matchesName(validFunctionNameRegex(true)), stephanemoore wrote: > hokein wrote: > > any

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-03 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore marked an inline comment as done. stephanemoore added inline comments. Comment at: clang-tidy/google/FunctionNamingCheck.cpp:57 + functionDecl( + isDefinition(), + unless(anyOf(isMain(), matchesName(validFunctionNameRegex(true)),

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-03 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore updated this revision to Diff 163656. stephanemoore marked an inline comment as done. stephanemoore added a comment. Updated with changes: - Removed unit tests as other tests have been indicated to provide adequate coverage. - Added a comment explaining why only function

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-03 Thread Haojian Wu via Phabricator via cfe-commits
hokein added a comment. Nice! looks mostly good to me. Comment at: clang-tidy/google/FunctionNamingCheck.cpp:57 + functionDecl( + isDefinition(), + unless(anyOf(isMain(), matchesName(validFunctionNameRegex(true)), any reason why we

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-02 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore marked an inline comment as done. stephanemoore added inline comments. Comment at: docs/ReleaseNotes.rst:60 +- New :doc:`google-objc-function-naming + ` check. Eugene.Zelenko wrote: > Please use alphabetical order. Good catch. Fixed.

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-02 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore updated this revision to Diff 163647. stephanemoore added a comment. Fixed alphabetical ordering of clang-tidy improvements in release notes. Repository: rCTE Clang Tools Extra https://reviews.llvm.org/D51575 Files: clang-tidy/google/CMakeLists.txt

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-02 Thread Eugene Zelenko via Phabricator via cfe-commits
Eugene.Zelenko added inline comments. Comment at: docs/ReleaseNotes.rst:60 +- New :doc:`google-objc-function-naming + ` check. Please use alphabetical order. Repository: rCTE Clang Tools Extra https://reviews.llvm.org/D51575

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-01 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore updated this revision to Diff 163638. stephanemoore added a comment. Minor fixes: - Fixed header guard. - Removed unnecessary imports in header. Repository: rCTE Clang Tools Extra https://reviews.llvm.org/D51575 Files: clang-tidy/google/CMakeLists.txt

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-01 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore created this revision. Herald added subscribers: cfe-commits, xazax.hun, mgorny. §1 Description This check finds function names in function definitions in Objective-C files that do not follow the naming pattern described in the Google Objective-C Style Guide. Function names