On Nov 10, 2011, at 7:07 AM, Preston Sumner wrote:
> On Nov 9, 2011, at 3:34 AM, Andreas Mayer wrote:
>
>>
>> Am 08.11.2011 um 22:40 schrieb Tom Jeffries:
>>
>>> Mac.
>>
>> You will have to use your own subclass of NSButton.
>
> An NSButtonCell subclass is all that's required for a custom ap
Java, running with a byte code verifier and a strict security manager enabled
does a reasonably through job of enforcing private methods at runtime. You can
defeat it, but not typically with remotely loaded code such as applets.
It's a continuum of design choices in languages. You're right that
Hello,
I would like to know best way to determine whether iTunes is
installed or not on mac . I thought of using bundle identifier and that works .
Still , Is there any other way ? Thanks in advance .
Vaibhao Mahore
DISCLAIMER
==
This e-mail may contain privileged and
In my experience, and I'm the author of PhotoRaw, which uses LOTS of memory for
raw image conversion, 128MB is very optimistic. 50-70 on e.g., an iPad 1 is
more like it, and even then there will be occasional situations where you get
terminated.
Sandy
On Nov 9, 2011, at 11:00 PM, David Duncan
On 9 Nov 2011, at 22:44, Andreas Grosam wrote:
>
> On Nov 9, 2011, at 12:11 PM, Karl Goiser wrote:
>
>> Your first option looks better to me!
>> :-)
>>
>> All I’m saying is that Objective C is a very mature language now
> Depending on your perspective, you can say this for many languages. But o
Hello, I just found this example :
abstract Tree which uses NSTreeController and NSOtulineView, so Im checking on
it seems this is what I need :D
I will let you know..
Thanks for the help.
Gustavo
On Nov 9, 2011, at 11:27 PM, Mike Abdullah wrote:
>
> On 9 Nov 2011, at 22:17, Gustavo Pizan
>
> I dunno… XCode… what the hell happened to you? *shakes head*
Man I LOVE the new version. Imo 4* is a huge step forward.
3* was a pita :)
On Wed, Nov 9, 2011 at 2:11 PM, Graham Cox wrote:
> Thanks, that's got it.
>
> I dunno… XCode… what the hell happened to you? *shakes head*
>
> --Gr
On 9 Nov 2011, at 22:17, Gustavo Pizano wrote:
> Hello all.
>
> I have been looking for some guidance or light on this matter,
>
> The closest I was able to find was this page:
>
> http://theocacao.com/document.page/130
>
> but then checking on Apple mail list I read some comments that the a
Hello all.
I have been looking for some guidance or light on this matter,
The closest I was able to find was this page:
http://theocacao.com/document.page/130
but then checking on Apple mail list I read some comments that the above
solution makes uses of undocumented methods.
Im using a NST
Thanks, that's got it.
I dunno… XCode… what the hell happened to you? *shakes head*
--Graham
On 10/11/2011, at 8:52 AM, CoGe - Tamas Nagy wrote:
> No, got the same issue 5 minutes earlier. Just click on the Show Console
> With../Only button on the bottom.
>
>
> On Nov 9, 2011, at 10:48 PM,
On Nov 9, 2011, at 3:34 AM, Andreas Mayer wrote:
>
> Am 08.11.2011 um 22:40 schrieb Tom Jeffries:
>
>> Mac.
>
> You will have to use your own subclass of NSButton.
An NSButtonCell subclass is all that's required for a custom appearance.
Preston
___
No, got the same issue 5 minutes earlier. Just click on the Show Console
With../Only button on the bottom.
<>
On Nov 9, 2011, at 10:48 PM, Graham Cox wrote:
> I upgraded to Xcode 4.2 and NSLog output no longer shows up in the console
> panel of Xcode (it's still viewable in the Console app). Is
I upgraded to Xcode 4.2 and NSLog output no longer shows up in the console
panel of Xcode (it's still viewable in the Console app). Is there a setting
that I need to change, or did this feature get broken?
--Graham
___
Cocoa-dev mailing list (Cocoa-
On Nov 9, 2011, at 9:39 AM, Don Quixote de la Mancha wrote:
> GDB's disassembly is correct for the Thumb code, but when I am in ARM
> mode, it disassembles the ARM instructions as if each one were a pair
> of completely nonsensical Thumb instructions. Is there some way I can
> tell GDB to switch t
On Nov 9, 2011, at 4:24 AM, Don Quixote de la Mancha wrote:
> I know what the separate project and target settings are meant to
> accomplish, but despite having used Xcode since it was called Project
> Builder, I still find these combined settings to be an endless source
> of confusion.
Look for t
On Nov 8, 2011, at 10:51 PM, Don Quixote de la Mancha wrote:
> It's user-configurable. If the user asks for too big a grid, I want to be
> able to tell them that there isn't enough memory, then suggest they try a
> smaller grid.
In a naive implementation using 1 byte per cell and a full dupli
Le 9 nov. 2011 à 19:53, Wim Lewis a écrit :
>
> On 8 Nov 2011, at 11:49 PM, Don Quixote de la Mancha wrote:
>> I can see that Xcode is indeed calling CompileC on my .s source, which
>> ultimately calls clang. Clang is the LLVM compiler's front end for
>> the "C-Like" languages: C, Objective-C a
On 8 Nov 2011, at 11:49 PM, Don Quixote de la Mancha wrote:
> I can see that Xcode is indeed calling CompileC on my .s source, which
> ultimately calls clang. Clang is the LLVM compiler's front end for
> the "C-Like" languages: C, Objective-C and C++.
A quick test on the command-line shows that
On 9 Nov 2011, at 1:49 AM, Don Quixote de la Mancha wrote:
> I need to find a way to associate .s sources with whatever Xcode 4.2
> supplies for an arm assembler. I hunted around in my project's build
> settings but nothing leapt out at me.
Just glancing around; this is a line to pursue, rather
This doesn't have anything to do with Cocoa. You might have better luck taking
it up on the Xcode-users list.
(Sent from my iPad.)
--
Conrad Shultz
On Nov 9, 2011, at 9:39, Don Quixote de la Mancha
wrote:
> My iOS App is build with the Apple LLVM 3.0 compiler in Thumb mode.
> For armv7, I'm
On Wed, Nov 9, 2011 at 9:39 AM, Don Quixote de la Mancha
wrote:
> .globl _IntNoArgs
> .align 2
> .code 16
That should actually be ".align 1". The parameter to .align is the
power to which two is raised to yield the alignment. ".code 16"
generates Thumb code, which wants 2-byte alignment.
> .al
My iOS App is build with the Apple LLVM 3.0 compiler in Thumb mode.
For armv7, I'm pretty sure that's actually Thumb-2.
I'm reimplementing my two most time-consuming functions in ARM
assembly code. The callers of these functions are Thumb, so I use
Thumb to ARM interworking instructions to switch
On Nov 8, 2011, at 10:48 PM, Don Quixote de la Mancha wrote:
> On Tue, Nov 8, 2011 at 10:39 PM, Conrad Shultz
> wrote:
>> And there's a bigger problem. That memory warning notification that you
>> referenced in your first message is there to tell you that you need to
>> free up resources ASAP a
CocoaHeads Lake Forest will be meeting on the second Wednesday of the
month. We will be meeting at the Orange County Public Library (El Toro)
community room, 24672 Raymond Way, Lake Forest, CA 92630
Please join us from 7pm to 9pm on Wednesday, 11/9
We will be discussing iOS 5, iCloud, and other
On Nov 9, 2011, at 9:06 AM, Jeff Kelley wrote:
> Code Red, on the other hand, could infect a
> server running IIS without user interaction.
On the third hand, the remote management bug could be exploited remotely
without user intervention, via a process that was not only always running by
defau
Interesting, thanks.
I think the side of this that typical OS X developers is that their own
internal classes from multiple bundle products are the bulk of the issue, not
for the objC bundle loading mechanism to get a fancy namespace overhaul (which
is understandably a huge undertaking). I s
On Wed, Nov 9, 2011 at 3:08 AM, Don Quixote de la Mancha <
quix...@dulcineatech.com> wrote:
>
> While the iOS and Mac OS X do have a better security track record than
> Windows does, I'm quite certain that's because "The Scene" has been
> focussing on Windows due to its greater numbers. With Appl
>Where did you learn this voodoo?
I had tried it while at BNR (2009) and it worked, so I did not look into other
methods at that point, nor did I ask about it.
Yes I am using NSWindowController, but clearly not 100% correctly.
>I suspect you want to do [aboutWindow setOpaque:NO] instead of this
On Nov 9, 2011, at 3:44 AM, Andreas Grosam wrote:
>
> On Nov 9, 2011, at 12:11 PM, Karl Goiser wrote:
>> without adding this extra layer of complexity, why introduce it for an edge
>> case to address a situation where people are expecting it to act like C++?
> I wouldn't say it is an edge case.
On Nov 8, 2011, at 11:45 PM, Kyle Sluder wrote:
> The kernel only has a certain amount of buffer space dedicated to each
> incoming TCP port. If the port gets flooded, it drops packets.
But this is TCP:
1) Flow control should generally prevent buffers from being overrun;
2) Even if packets are
I had something like the following. I prefer to have instance
variables declared explicitly rather than automatically generated:
// Foo.h
@interface Foo {
Bar *bar;
}
@property bar;
@endif
// Foo.m
@interface Foo () { // ERROR here
Baz *baz;
}
@endif
I spent a couple hours trying to fig
On Nov 9, 2011, at 12:11 PM, Karl Goiser wrote:
> Your first option looks better to me!
> :-)
>
> All I’m saying is that Objective C is a very mature language now
Depending on your perspective, you can say this for many languages. But only
the dead ones do not evolve (Objective-C, does it, thou
Your first option looks better to me!
:-)
All I’m saying is that Objective C is a very mature language now and if it has
been able to get by without adding this extra layer of complexity, why
introduce it for an edge case to address a situation where people are expecting
it to act like C++?
Ap
On 9 Nov 2011, at 08:08, Don Quixote de la Mancha wrote:
> That would be great if I actually received any memory warnings. I don't.
...
> However, I did set a breakpoint at both methods. That breakpoint was never
> hit.
I dont want to wade in to the religious war here (although I'm on the sid
Am 08.11.2011 um 22:40 schrieb Tom Jeffries:
> Mac.
You will have to use your own subclass of NSButton.
> If I need to create a new class, is there some example
> source code available?
http://www.harmless.de/cocoa-code.php#rollover
Andreas
__
On Nov 9, 2011, at 10:11 AM, Karl Goiser wrote:
> .. so if you prefix all your classes with your company name, the only
> conflicts will be with the same class from different bundles, which means
> that only one instance of any class will be loaded, thus saving memory on
> every client’s machi
Le 9 nov. 2011 à 10:11, Karl Goiser a écrit :
> .. so if you prefix all your classes with your company name, the only
> conflicts will be with the same class from different bundles, which means
> that only one instance of any class will be loaded, thus saving memory on
> every client’s machine
On Wed, Nov 9, 2011 at 1:02 AM, Jean-Daniel Dupas
wrote:
> Le 9 nov. 2011 à 07:44, Don Quixote de la Mancha a écrit :
>> While the Space Shuttle exploded twice, I hasten to point out that
>> neither of those failures was due to software bugs.
>>
>
> No, but Ariane 5 first launch failure was ;-)
>
.. so if you prefix all your classes with your company name, the only conflicts
will be with the same class from different bundles, which means that only one
instance of any class will be loaded, thus saving memory on every client’s
machine…
Yes?
On 09/11/2011, at 7:14 PM, Andy O'Meara wrote:
On Nov 8, 2011, at 5:54 PM, Alexander Bokovikov wrote:
> I have a need to read some data from a local socket, which serves for IPC.
> And data may come very quickly, so (AFAIU) inner socket buffer might
> overflow, so a portion of data might be lost.
This has been answered by previous posters
Le 9 nov. 2011 à 07:44, Don Quixote de la Mancha a écrit :
> On Tue, Nov 8, 2011 at 9:48 PM, Wade Tregaskis wrote:
>>> Simple as that, eh? Being able to gracefully handle all out of memory
>>> situations to me seems as "simple" as being required to treat every single
>>> method / function call
Le 9 nov. 2011 à 09:14, Andy O'Meara a écrit :
>
>
> Unfortunately the problem is that when you sell and ship commercial software,
> shipped software can't look into the future. The real aspect of this issue,
> that I raised in my initial post, is that third party developers such as
> ourse
>
>
> ER: Objective-C namespaces
>
> If you're familiar with Radar numbers, you'll recognize that the bug is very
> old. The name is a bit misleading - C++ namespaces or Java packages are
> little better than adding name prefixes by hand. (For example, they don't
> solve the problem of two d
Keep pointers to your packetBuffers in a circular buffer. When a new
packet comes in, add it to the front of the buffer. When you're ready
to process a packet, remove it from the end of the buffer.
Some testing should determine how big your buffer needs to be.
On anything but a real-time operat
Unfortunately the problem is that when you sell and ship commercial software,
shipped software can't look into the future. The real aspect of this issue,
that I raised in my initial post, is that third party developers such as
ourselves internally reuse various support classes for multiple bu
On Tue, Nov 8, 2011 at 11:46 PM, Greg Parker wrote:
> On Nov 8, 2011, at 10:56 PM, Don Quixote de la Mancha wrote:
>> On Tue, Nov 8, 2011 at 10:49 PM, Kyle Sluder wrote:
> No, the reason is that most end-users do not want to pay Space Shuttle prices
> (high) for Space Shuttle capability and flex
46 matches
Mail list logo