Re: RFR: 8004518 8010122 : Default methods on Map

2013-04-15 Thread Peter Levart
Hi Mike, Another thing to note: Some new methods in HashMap need to call inflateTable(), since patch for 8011200 has already been pushed to tl... Regards, Peter On 04/14/2013 08:35 PM, Peter Levart wrote: On 04/14/2013 07:54 PM, Peter Levart wrote: Hi Mike, Just a nit: The order of

Re: JDK-8011653: Upgrade to JAXP 1.5

2013-04-15 Thread Joe Wang
On 4/8/2013 5:24 AM, Alan Bateman wrote: On 08/04/2013 08:39, huizhe wang wrote: Hi Lance, Alan, As I mentioned, I'd like to propose an integration of JAXP 1.5 into JDK8. JAXP 1.5 adds a new feature to control connections. Here's the webrev:

Re: RFR 8010280: jvm.cfg needs updating for non-server builds

2013-04-15 Thread Erik Joelsson
Hello, It looks to me like you are covering the case of both server and client being true twice. How could line 319 ever evaluate to true? Otherwise it looks ok. /Erik On 2013-04-15 02:18, David Holmes wrote: Some background. The jvm.cfg file, for which there is a per-architecture

Re: JDK-8011653: Upgrade to JAXP 1.5

2013-04-15 Thread Alan Bateman
On 15/04/2013 08:48, Joe Wang wrote: : For the new properties then it specifies that a a runtime exception will be thrown. Can this be more specific? They can't be in XMLConstants, but they are in the specific Factories. The properties may be supported by factories that may throw

Re: [OpenJDK 2D-Dev] sun.java2D.Pisces renderer Performance and Memory enhancements

2013-04-15 Thread Laurent Bourgès
Jim, Andrea, I updated MapBench to provide test statistics (avg, median, stddev, rms, med + stddev, min, max) and CSV output (tab separator): http://jmmc.fr/~bourgesl/share/java2d-pisces/MapBench/ Here are the results (OpenJDK8 Ref vs Patched):

Re: RFR 8010280: jvm.cfg needs updating for non-server builds

2013-04-15 Thread David Holmes
On 15/04/2013 7:03 PM, Erik Joelsson wrote: Hello, It looks to me like you are covering the case of both server and client being true twice. How could line 319 ever evaluate to true? Otherwise it looks ok. You are right - that was a leftover from an initial approach that only looked for

RE: Code review request for 8012044: Give more information about self-suppression from Throwable.addSuppressed

2013-04-15 Thread Jason Mehrens
David, The last two paragraphs of Throwable.addSuppressed cover this. The first is your argument bellow and does not forbid anything it claims. The last paragraph explicitly enables this patch. Jason Date: Mon, 15 Apr 2013 12:56:42 +1000 From: david.hol...@oracle.com To:

hg: jdk8/tl/langtools: 6 new changesets

2013-04-15 Thread maurizio . cimadamore
Changeset: b26f36a7ae3b Author:mcimadamore Date: 2013-04-15 14:11 +0100 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/b26f36a7ae3b 8011383: Symbol.getModifiers omits ACC_ABSTRACT from interface with default methods Summary: Fixup for default method modifiers erroneously

hg: jdk8/tl/nashorn: 9 new changesets

2013-04-15 Thread sundararajan . athijegannathan
Changeset: 635a93b61d34 Author:hannesw Date: 2013-04-10 14:00 +0200 URL: http://hg.openjdk.java.net/jdk8/tl/nashorn/rev/635a93b61d34 8011714: Regexp decimal escape handling still not correct Reviewed-by: lagergren, attila !

8012237: CompletableFuture/Basic.java still fails intermittently

2013-04-15 Thread Chris Hegarty
I missed three cases in the previous change [1]. That will teach me for working on the weekend ;-) A full audit of the use of the XxxEitherXxx methods in the test has been done, and there are still three particular checks that are possibly incorrect. The failure is not always seen as this is

RFR: JDK-8008738 - Issue in com.sun.org.apache.xml.internal.serializer.Encodings causes some JCK tests to fail intermittently

2013-04-15 Thread Daniel Fuchs
Hi, This a fix for: JDK-8008738 - Issue in com.sun.org.apache.xml.internal.serializer.Encodings causes some JCK tests to fail intermittently. http://cr.openjdk.java.net/~dfuchs/JDK-8008738/webrev.02/ The issue here is that com.sun.org.apache.xml.internal.serializer.Encodings tries to

Suggestion to improve profile/package in javadoc

2013-04-15 Thread Paul Benedict
I was looking at b85 javadocs, and saw this at the page's top for a class: compact1, compact2, compact3 java.lang I don't think it's clear what is being shown. I understand it -- but I am following the feature closely. I recommend prefixing the data because the package is no longer the sole

Re: 8012237: CompletableFuture/Basic.java still fails intermittently

2013-04-15 Thread Chris Hegarty
On 15/04/2013 17:32, Martin Buchholz wrote: This looks good, in that it fixes the flakiness. Thanks Martin. I don't think we have tests yet that ensure Either completion when only one task completes. Consider writing one normal async supplier and one that waits on a latch; ensure that the

Re: 8012237: CompletableFuture/Basic.java still fails intermittently

2013-04-15 Thread Martin Buchholz
This looks good, in that it fixes the flakiness. I don't think we have tests yet that ensure Either completion when only one task completes. Consider writing one normal async supplier and one that waits on a latch; ensure that the Either future completes with the normal value, then trip the latch

Re: 8012237: CompletableFuture/Basic.java still fails intermittently

2013-04-15 Thread Martin Buchholz
Thanks. This looks good. I might additionally: - rename phaser to something more evocative, like cf3Done - add a checkCompletedXXX for the tardy future after the phaser arrives - check that cf3 result does not change when tardy future completes. On Mon, Apr 15, 2013 at 10:03 AM, Chris Hegarty

Re: 8012237: CompletableFuture/Basic.java still fails intermittently

2013-04-15 Thread Chris Hegarty
On 15/04/2013 18:32, Martin Buchholz wrote: Thanks. This looks good. I might additionally: - rename phaser to something more evocative, like cf3Done - add a checkCompletedXXX for the tardy future after the phaser arrives - check that cf3 result does not change when tardy future completes.

Re: RFR: String.join(), StringJoiner additions

2013-04-15 Thread Alan Bateman
On 12/04/2013 16:02, Alan Bateman wrote: On 11/04/2013 23:33, Jim Gish wrote: Please review http://cr.openjdk.java.net/~jgish/Bugs-5015163-7175206-7172553/ http://cr.openjdk.java.net/%7Ejgish/Bugs-5015163-7175206-7172553/ These are changes that we made in lambda that we're now bringing into

Re: RFR: String.join(), StringJoiner additions

2013-04-15 Thread Martin Buchholz
You are fiddling with the javadoc for getChars, which is an independent change. (I am also fiddling with getChars in another ongoing change). I don't think closing html tags for li are required in javadoc. If you are going to change the exception javadoc, then also change @exception to @throws.

Re: RFR: String.join(), StringJoiner additions

2013-04-15 Thread Martin Buchholz
Is i+1 really preferred to i + 1 ? I thought it was the reverse, and that i+1 was merely tolerated. 1570 if (value[i] == hi value[i+1] == lo) { --- 2425 * @throws NullPointerException If {@code delimiter} is {@code null} you also throw NPE for element null, but you

Re: Review request: 8004260: dynamic proxy class should have same class access as proxy interfaces

2013-04-15 Thread Alan Bateman
On 12/04/2013 19:36, Mandy Chung wrote: Dynamic proxy class is specified to be public, final, and not abstract. For a proxy class that implements a non-public interface, it will be in the same package as the non-public interface but the proxy class is accessible outside of the non-public

Re: RFR: String.join(), StringJoiner additions

2013-04-15 Thread Martin Buchholz
It is natural to compare StringJoiner with guava Joiner. http://docs.guava-libraries.googlecode.com/git/javadoc/com/google/common/base/Joiner.html Joiner is popular and has stood the test of time. Joiner designers chose not to include a prefix and suffix, presumably because that is an independent

Re: RFR: 8004518 8010122 : Default methods on Map

2013-04-15 Thread Mike Duigou
On Apr 15 2013, at 00:39 , Peter Levart wrote: Hi Mike, Another thing to note: Some new methods in HashMap need to call inflateTable(), since patch for 8011200 has already been pushed to tl... Yes. I actually had an off-to-the-side patch which added these and tested with it last week.

Re: Review request: 8004260: dynamic proxy class should have same class access as proxy interfaces

2013-04-15 Thread Mandy Chung
On 4/15/13 11:13 AM, Alan Bateman wrote: I went through the webrev and it looks good to me and good to get this aligned and specified clearly. thanks for the review. A minor comment is that in the save for debugging code in generateProxyClass then you could use Files.write to write the

Re: RFR: String.join(), StringJoiner additions

2013-04-15 Thread Martin Buchholz
On Mon, Apr 15, 2013 at 11:31 AM, Martin Buchholz marti...@google.comwrote: OTOH, I'm guessing you are trying to improve the performance of operations like List.toString. More efficient (single copy char[]) would be to collect all the sub-CharSequences in a CharSequence[], pre-compute the

Use of super in type parameters

2013-04-15 Thread Martin Buchholz
CompletableFuture currently has a method like this: public CompletableFutureVoid acceptEither (CompletableFuture? extends T other, Consumer? super T block) { return doAcceptEither(other, block, null); } But that signature is not quite correct (not as general as

Re: Use of super in type parameters

2013-04-15 Thread Zhong Yu
I have encountered on stackoverflow.com several legit use cases of lower bound. And the other day Ali Lahijani raised the question that Stream.reduce(BinaryOperator) breaks convariance of Stream, and I thought that the root problem is lack of lower bound - the method would have had a better

Re: RFR: String.join(), StringJoiner additions

2013-04-15 Thread Steven Schlansker
On Apr 15, 2013, at 12:21 PM, Martin Buchholz marti...@google.com wrote: On Mon, Apr 15, 2013 at 11:31 AM, Martin Buchholz marti...@google.comwrote: OTOH, I'm guessing you are trying to improve the performance of operations like List.toString. More efficient (single copy char[]) would be

Re: RFR: String.join(), StringJoiner additions

2013-04-15 Thread Martin Buchholz
Thanks for the pointer. Yeah, that's one the pieces I think we should have to do an optimal job of rewriting collection toString methods. On Mon, Apr 15, 2013 at 1:03 PM, Steven Schlansker stevenschlans...@gmail.com wrote: On Apr 15, 2013, at 12:21 PM, Martin Buchholz marti...@google.com

Re: RFR: 8004518 8010122 : Default methods on Map

2013-04-15 Thread Mike Duigou
On Apr 13 2013, at 09:34 , Ulf Zibis wrote: Am 12.04.2013 23:36, schrieb Mike Duigou: On Apr 11 2013, at 15:15 , Ulf Zibis wrote: There is still a yoda style in ConcurrentMap line 72, HashMap line 361 Fixed I still see no change in webrev 5 in HashMap line 361 Now corrected. To

hg: jdk8/tl/jdk: 8008509: 6588413 changed JNIEXPORT visibility for GCC on HSX, jdk's jni_md.h needs similar change

2013-04-15 Thread martinrb
Changeset: 4ed143ddbb8a Author:martin Date: 2013-04-15 14:07 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/4ed143ddbb8a 8008509: 6588413 changed JNIEXPORT visibility for GCC on HSX, jdk's jni_md.h needs similar change Summary: Define JNIEXPORT to use default visibility

Re: RFR: 8004518 8010122 : Default methods on Map

2013-04-15 Thread Mike Duigou
On Apr 14 2013, at 11:35 , Peter Levart wrote: On 04/14/2013 07:54 PM, Peter Levart wrote: Hi Mike, Just a nit: The order of boolean sub-expressions in Map.replace(key, oldValue, newValue): 740 if (!containsKey(key) || !Objects.equals(get(key), oldValue)) ...would be more

Re: RFR: 8004518 8010122 : Default methods on Map

2013-04-15 Thread Mike Duigou
Another updated webrev: http://cr.openjdk.java.net/~mduigou/JDK-8010122/6/webrev/ I've started pre-integration final testing on this patch and plan to push it tomorrow unless something significant comes up. Mike On Apr 15 2013, at 14:31 , Mike Duigou wrote: On Apr 14 2013, at 11:35 ,

Re: RFR: String.join(), StringJoiner additions

2013-04-15 Thread Mike Duigou
On Apr 15 2013, at 13:03 , Steven Schlansker wrote: On Apr 15, 2013, at 12:21 PM, Martin Buchholz marti...@google.com wrote: On Mon, Apr 15, 2013 at 11:31 AM, Martin Buchholz marti...@google.comwrote: OTOH, I'm guessing you are trying to improve the performance of operations like

Re: RFR 8010280: jvm.cfg needs updating for non-server builds

2013-04-15 Thread David Holmes
FYI updated webrev at same location, removing the dead code Erik spotted. http://cr.openjdk.java.net/~dholmes/8010280/webrev/ On 16/04/2013 2:25 AM, Mike Duigou wrote: Hi David; I remember reviewing the jvm.cfg config patch for JDK 7. I had hoped to see the classic and green flags go away

Re: Proxy.isProxyClass scalability

2013-04-15 Thread Mandy Chung
On 4/13/2013 2:59 PM, Peter Levart wrote: I also devised an alternative caching mechanism with scalability in mind which uses WeakReferences for keys (for example ClassLoader) and values (for example Class) that could be used in this situation in case adding a field to ClassLoader is not

RFR : 8010953: Add primitive summary statistics utils

2013-04-15 Thread Mike Duigou
Hello all; Another review in the JSR-335 libraries series. These three classes provide a utility for conveniently finding count, sum, min, max and average of ints, longs or doubles. They can be used with existing code but will most likely be used with the Collectors utilities or directly with

Re: RFR: 8004518 8010122 : Default methods on Map

2013-04-15 Thread Ulf Zibis
Am 15.04.2013 23:06, schrieb Mike Duigou: That's because I'm not the only author. I get to fix it though, the glamourous life of a JDK janitor. :-) ;-) HashTable line 917, 938, 984 etc. HashMap line 588 etc. Collections line 1402 etc. Should be more consistent now. I'm not willing to

hg: jdk8/tl/jdk: 8011800: Add java.util.Objects.requireNonNull(T, SupplierString)

2013-04-15 Thread joe . darcy
Changeset: baaa706d7677 Author:darcy Date: 2013-04-15 18:31 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/baaa706d7677 8011800: Add java.util.Objects.requireNonNull(T, SupplierString) Reviewed-by: alanb, dholmes, mduigou ! src/share/classes/java/util/Objects.java !

Re: RFR JDK-8011426: java.util collection Spliterator implementations

2013-04-15 Thread Mike Duigou
I went back and started again with the 8010096 webrev. Spliterators:: - some implementations are private and some are package private. All package private? List/Set/Iterator/SortedSet:: - Include the same interface level @implSpec warning as Collection? Spliterator:: - pSpliterators also