Re: sun/awt/OSInfo.java

2013-06-24 Thread Alan Bateman
On 24/06/2013 05:57, Weijun Wang wrote: I thought os.name for Solaris is 'Solaris' but it's actually 'SunOS'. There is a helper class at http://hg.openjdk.java.net/jdk8/tl/jdk/file/fd050ba1cf72/src/share/classes/sun/awt/OSInfo.java This file uses if (osName.contains("Solaris") || osName

Re: sun/awt/OSInfo.java

2013-06-24 Thread Weijun Wang
I don't meant to add any API for external users, but even JDK itself needs some helper classes, and looks like sun.misc is the place. In this case, there are too many places inside JDK that checks what the current OS is. Some uses startsWith and some contains, some toLowerCase and some toUppre

hg: jdk8/tl/jdk: 8017453: ReplayCache tests fail on multiple platforms

2013-06-24 Thread weijun . wang
Changeset: 1bf060029a5d Author:weijun Date: 2013-06-24 16:25 +0800 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/1bf060029a5d 8017453: ReplayCache tests fail on multiple platforms Reviewed-by: xuelei ! test/sun/security/krb5/auto/ReplayCacheExpunge.java ! test/sun/security/krb5/a

hg: jdk8/tl/jdk: 8017477: Remove TimeZone.DisplayNames, no longer used

2013-06-24 Thread alan . bateman
Changeset: 5f80b8cee601 Author:alanb Date: 2013-06-24 11:26 +0100 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/5f80b8cee601 8017477: Remove TimeZone.DisplayNames, no longer used Reviewed-by: okutsu ! src/share/classes/java/util/TimeZone.java

Re: sun/awt/OSInfo.java

2013-06-24 Thread Alan Bateman
On 24/06/2013 09:23, Weijun Wang wrote: I don't meant to add any API for external users, but even JDK itself needs some helper classes, and looks like sun.misc is the place. In this case, there are too many places inside JDK that checks what the current OS is. Some uses startsWith and some con

Re: RFR 4641897: Faster string conversion of large integers

2013-06-24 Thread Alan Bateman
On 21/06/2013 16:04, Brian Burkhalter wrote: On Jun 21, 2013, at 2:49 AM, Alan Bateman wrote: One part that might need attention is getRadixConversionCache as I could imagine cases where the synchronization could lead to contention. Have you (or Alan) considered alternatives that would limit

test with a 3rd party jar file?

2013-06-24 Thread huizhe wang
Hi, Does anyone know if it's possible to automate a test with a 3rd party jar file on the bootclasspath or java.endorsed.dirs? I have a test that I run manually with Apache Xerces jar. Thanks, Joe Original Message Subject: [JBS] (JDK-8016773) Regression: diff. behavior wi

Re: RFR 6469160: (fmt) general (%g) formatting of zero (0.0) with precision 0 or 1 throws ArrayOutOfBoundsException

2013-06-24 Thread Brian Burkhalter
Hi Joe, On Jun 21, 2013, at 8:14 PM, Joe Darcy wrote: > Hi Brian, > > What is the expected behavior on signed zero files? I assume you intend "values." > I think they should be added to the test cases. Done starting at line 1180 here: http://cr.openjdk.java.net/~bpb/6469160/test/java/util/Fo

RE: RFR 6469160: (fmt) general (%g) formatting of zero (0.0) with precision 0 or 1 throws ArrayOutOfBoundsException

2013-06-24 Thread Iris Clark
Hi, Brian. Your changes look good to me. Thanks, iris (original code author, not a Reviewer) -Original Message- From: Brian Burkhalter Sent: Friday, June 21, 2013 2:13 PM To: Java Core Libs Subject: RFR 6469160: (fmt) general (%g) formatting of zero (0.0) with precision 0 or 1 throws A

Re: 7122142 : (ann) Race condition between isAnnotationPresent and getAnnotations

2013-06-24 Thread Peter Levart
On 06/19/2013 08:54 PM, Alan Bateman wrote: Thank you for coming back to this. I've looked over the webrev and the approach looks good to me. Joel might want to look at this too. Do you think you could include a test (as we try to include a test with all fixes if we can)? It would be good to

Re: JDK-8016285: Add java.lang.reflect.Parameter.isNamePresent()

2013-06-24 Thread Eric McCorkle
Pinging this RFR. It still needs a capital R reviewer. http://cr.openjdk.java.net/~emc/8016285/ On 06/21/13 19:21, Eric McCorkle wrote: > On 06/21/13 16:15, Aleksey Shipilev wrote: >> On 06/21/2013 11:57 PM, Eric McCorkle wrote: >>> The webrev is here: >>> http://cr.openjdk.java.net/~emc/8016285/

Re: test with a 3rd party jar file?

2013-06-24 Thread Seán Coffey
You should be able to do it with scripts. Mandy designed something similar recently : http://opengrok.ie.oracle.com:8080/opengrok/xref/jdk7u-cpu/jdk/test/closed/java/util/logging/SystemLoggerTest.sh In the recent infrastructure meeting, scripts for tests were frowned upon. I don't see any alte

RFC: 6178739 - Formatter - Zero padding flag with zero width

2013-06-24 Thread Brian Burkhalter
This issue http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6178739 exposes what could be either a minor specification or implementation flaw depending on one's interpretation. The test case is public class TestFormat { public static void main(String argv[]) { System.out.printf("%

Review Request 8007035: Deprecate SecurityManager.checkMemberAccess

2013-06-24 Thread Mandy Chung
I have updated the fix per the discussion in [1]. SecurityManager.checkMemberAccess will be deprecated and will check for AllPermission in a future release. Webrev at: http://cr.openjdk.java.net/~mchung/jdk8/webrevs/8007035/webrev.01/ Specdiff: http://cr.openjdk.java.net/~mchung/jdk8/webrevs/8

Re: RFR 6469160: (fmt) general (%g) formatting of zero (0.0) with precision 0 or 1 throws ArrayOutOfBoundsException

2013-06-24 Thread Joe Darcy
Hi Brian, On 6/24/2013 11:04 AM, Brian Burkhalter wrote: Hi Joe, On Jun 21, 2013, at 8:14 PM, Joe Darcy wrote: Hi Brian, What is the expected behavior on signed zero files? I assume you intend "values." Correct :-) I think they should be added to the test cases. Done starting at line

Re: RFR : 8013712 : (XS) Add Objects.nonNull and Objects.isNull

2013-06-24 Thread Jack Moxley
Really depends about whether you want the method to be bad English, or really bad English. :-). All this double negativity gets me down. What's wrong with exists() ? Sent from my iPhone On 20 Jun 2013, at 08:24, Howard Lovatt wrote: > I would say not needed, !isNull() is sufficient. If includ

Re: RFR : 8013712 : (XS) Add Objects.nonNull and Objects.isNull

2013-06-24 Thread Howard Lovatt
I would say not needed, !isNull() is sufficient. If included isNotNull() is the better name. On 5 May 2013 01:09, Ulf Zibis wrote: > > Am 04.05.2013 04:28, schrieb Mike Duigou: > > I have updated the webrev to include incorporate the feedback I have > received. > > > > http://cr.openjdk.java.ne

Inefficient code of String.indexOf(String)

2013-06-24 Thread Anubhav Chaturvedi
Hello, I have recently started to explore the source code and am new to the open source community. I observed that in String.class within java.lang , the indexOf method, line 1715, uses the bruteforce approach when it comes to string matching. This method is used by the contains(CharSequence) meth

Re: RFR 8009736: Comparator API cleanup

2013-06-24 Thread Per Bothner
You might find interesting this proposal for "big" Scheme. It views a "comparator" as a bundle consisting of an (optional) comparator function, along with optional hash function, equality function, and type-check function. http://trac.sacrideo.us/wg/wiki/ComparatorsCowan Using a more general "co

Re: JDK-8016285: Add java.lang.reflect.Parameter.isNamePresent()

2013-06-24 Thread Aleksey Shipilev
Forgot to reply: I'm ok with webrev.01. -Aleksey (rural r reviewer) On 06/24/2013 11:20 PM, Eric McCorkle wrote: > Pinging this RFR. It still needs a capital R reviewer. > http://cr.openjdk.java.net/~emc/8016285/ > > On 06/21/13 19:21, Eric McCorkle wrote: >> On 06/21/13 16:15, Aleksey Shipilev

Re: test with a 3rd party jar file?

2013-06-24 Thread Rob McKenna
Some interesting conversations were had lately about shell scripts during Joe Darcy's recent infrastructure tech talk. In particular around the idea of a "jdk.testing" package to provide libraries that would help with the types of operations seen in shell scripts. I'm really hoping to spend som

hg: jdk8/tl/jdk: 8017468: typo in javadoc: " ResourceBunlde "

2013-06-24 Thread naoto . sato
Changeset: bb2e67628dc0 Author:naoto Date: 2013-06-24 16:21 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/bb2e67628dc0 8017468: typo in javadoc: " ResourceBunlde " Reviewed-by: okutsu ! src/share/classes/java/util/spi/LocaleServiceProvider.java

Re: RFR 4641897: Faster string conversion of large integers

2013-06-24 Thread Brian Burkhalter
So I am going to try to please everybody (I hope). I agree with Alan Eliasen that the existing patch for 4641897 should be integrated as-is. I also think however that we might as well integrate Aleksey and Dima's patch immediately thereafter, before the large integer division review. To that en

RFR 8017540: Improve multi-threaded contention behavior of BigInteger.toString() radix conversion cache

2013-06-24 Thread Brian Burkhalter
Branching off from this thread http://mail.openjdk.java.net/pipermail/core-libs-dev/2013-June/018244.html I filed this issue (should be public tomorrow) http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8017540 for the getRadixConversionCache() enhancement. The patch is here http://cr.openjdk

RFR JDK-8017212 - File.createTempFile requires unnecessary "read" permission

2013-06-24 Thread Dan Xu
HiAll, The fix of JDK-8013827 added an unnecessary "read" permission requirement in File.createTempFile methods. This change is going to fix this issue. Please help review it. Thanks! webrev: http://cr.openjdk.java.net/~dxu/8017212/webrev.00/ bug: http://bugs.sun.com/view_bug.do?bug_id=80172

Re: test with a 3rd party jar file?

2013-06-24 Thread huizhe wang
Thanks Sean and Rob. Yes, I was told before to avoid shell scripts in tests. I'll wait till after your investigation to see what's the best to do in this case. -Joe On 6/24/2013 3:42 PM, Rob McKenna wrote: Some interesting conversations were had lately about shell scripts during Joe Darcy's

Re: test with a 3rd party jar file?

2013-06-24 Thread Weijun Wang
On 6/25/13 6:42 AM, Rob McKenna wrote: Some interesting conversations were had lately about shell scripts during Joe Darcy's recent infrastructure tech talk. In particular around the idea of a "jdk.testing" package to provide libraries that would help with the types of operations seen in shell sc

hg: jdk8/tl/langtools: 8012722: Single comma in array initializer should parse

2013-06-24 Thread eric . mccorkle
Changeset: bf020de5a6db Author:emc Date: 2013-06-24 22:03 -0400 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/bf020de5a6db 8012722: Single comma in array initializer should parse Summary: Annotations of the form @Foo({,}) should parse Reviewed-by: jjg ! src/share/classes/co

Re: RFC: 6178739 - Formatter - Zero padding flag with zero width

2013-06-24 Thread Joe Darcy
On 6/24/2013 12:56 PM, Brian Burkhalter wrote: This issue http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6178739 exposes what could be either a minor specification or implementation flaw depending on one's interpretation. The test case is public class TestFormat { public static void

hg: jdk8/tl/jdk: 6469160: (fmt) general (%g) formatting of zero (0.0) with precision 0 or 1 throws ArrayOutOfBoundsException

2013-06-24 Thread dan . xu
Changeset: eabcb85fcabc Author:bpb Date: 2013-06-24 14:17 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/eabcb85fcabc 6469160: (fmt) general (%g) formatting of zero (0.0) with precision 0 or 1 throws ArrayOutOfBoundsException Summary: For zero value ensure than an unpadded z

hg: jdk8/tl/jdk: 8017550: Fix doclint issues in java.lang and subpackages

2013-06-24 Thread joe . darcy
Changeset: 82e7682c17e2 Author:darcy Date: 2013-06-24 23:40 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/82e7682c17e2 8017550: Fix doclint issues in java.lang and subpackages Reviewed-by: alanb, chegar ! src/share/classes/java/lang/Boolean.java ! src/share/classes/java/lan