Re: JDK 14 RFR of JDK-8202385: Annotation to mark serial-related fields and methods

2019-07-12 Thread Joe Darcy
Hi Roger, On 7/12/2019 1:31 PM, Roger Riggs wrote: Hi Joe, As an annotation on a field or method, this is a use site annotation. It is an annotation intended for the declarations of fields and methods of Serializable types. From the description, the checks that could be added would only

Re: [OpenJDK 2D-Dev] 8187898: PrintStream should override FilterOutputStream#write(byte[]) with a method that has no throws clause

2019-07-12 Thread Philip Race
In that case just delete the comments and the commented out code ... -phil. On 7/12/19, 3:12 PM, Brian Burkhalter wrote: I think I'd be more inclined to make the code at 970 like that at 1036. Can’t do this exactly as drawImageBGR at 903 does not throw a PrinterException. Have to use Runtime

Re: RFR: 8227642: [TESTBUG] Make docker tests podman compatible

2019-07-12 Thread mikhailo . seledtsov
Hi Severin,   The change looks good to me. Thank you for adding support for Podman container technology. Testing: I ran both HotSpot and JDK container tests with your patch; tests executed on Oracle Linux 7.6 using default container engine (Docker):     test/hotspot/jtreg/containers/   AND

Re: [OpenJDK 2D-Dev] 8187898: PrintStream should override FilterOutputStream#write(byte[]) with a method that has no throws clause

2019-07-12 Thread Brian Burkhalter
> I think I'd be more inclined to make the code at 970 like that at 1036. Can’t do this exactly as drawImageBGR at 903 does not throw a PrinterException. Have to use RuntimeException. Brian > On Jul 12, 2019, at 1:39 PM, Phil Race wrote: > > oh well ... in which I suppose this is the best you

Re: [OpenJDK 2D-Dev] 8187898: PrintStream should override FilterOutputStream#write(byte[]) with a method that has no throws clause

2019-07-12 Thread Phil Race
oh well ... in which I suppose this is the best you can do here. -phil. On 7/12/19 1:10 PM, Brian Burkhalter wrote: (2) I don't know why at 1034 you changed from PrinterIOException to PrinterException. There is no PrinterIOException constructor which accepts a String as its only parameter

Re: JDK 14 RFR of JDK-8202385: Annotation to mark serial-related fields and methods

2019-07-12 Thread Roger Riggs
Hi Joe, As an annotation on a field or method, this is a use site annotation. From the description, the checks that could be added would only be done if the annotation was present and the annotation is a tag for existing fields and methods that are part of the serialization spec. The signatures

Re: [OpenJDK 2D-Dev] 8187898: PrintStream should override FilterOutputStream#write(byte[]) with a method that has no throws clause

2019-07-12 Thread Brian Burkhalter
> On Jul 12, 2019, at 1:02 PM, Phil Race wrote: > >> Not my call, but in PSPrinterJob.java (970-977) it might be cleaner to just >> delete the unused code and comment. > > Dilemma - since at 1036 we are throwing an Exception and the comment at > 970-ish suggests > the author was intending t

Re: [OpenJDK 2D-Dev] 8187898: PrintStream should override FilterOutputStream#write(byte[]) with a method that has no throws clause

2019-07-12 Thread Phil Race
Not my call, but in PSPrinterJob.java (970-977) it might be cleaner to just delete the unused code and comment. Dilemma - since at 1036 we are throwing an Exception and the comment at 970-ish suggests the author was intending to do what s/he did at 1036 but never got around to it. I think I'd

Re: [OpenJDK 2D-Dev] 8187898: PrintStream should override FilterOutputStream#write(byte[]) with a method that has no throws clause

2019-07-12 Thread Brian Burkhalter
Here is new webrev incorporating the two changes below. http://cr.openjdk.java.net/~bpb/8187898/webrev.01/ Thanks, Brian > On Jul 12, 2019, at 12:01 PM, Brian Burkhalter > wrote: > >> On Jul 12, 2019, at 11:17 AM, Roger Riggs > > wrote: >> >> Would it be appro

Re: 8187898: PrintStream should override FilterOutputStream#write(byte[]) with a method that has no throws clause

2019-07-12 Thread Brian Burkhalter
Hi Roger, > On Jul 12, 2019, at 11:17 AM, Roger Riggs wrote: > > Would it be appropriate to add @Override to the new method (and perhaps > existing overridden methods). Yes, I think so. > Previously, calling FilterOutputStream.write(byte[]) would delegate to > write(byte[], 0, length). > The

Re: 8187898: PrintStream should override FilterOutputStream#write(byte[]) with a method that has no throws clause

2019-07-12 Thread Roger Riggs
Hi Brian, Would it be appropriate to add @Override to the new method (and perhaps existing overridden methods). Previously, calling FilterOutputStream.write(byte[]) would delegate to write(byte[], 0, length). The proposed change duplicates the code and changes the ways that overridden classe

RFR: 8227642: [TESTBUG] Make docker tests podman compatible

2019-07-12 Thread Severin Gehwolf
Hi, There is an alternative container engine which is being used by Fedora and RHEL 8, called podman[1]. It's mostly compatible with docker. It looks like OpenJDK docker tests can be made podman compatible with a few little tweaks. One "interesting" one is to not assert "Successfully built" in the

Re: RFR: 8227587: Add internal privileged System.loadLibrary

2019-07-12 Thread Mandy Chung
Just to recap what we discussed offline: We could introduce BootLoader::loadLibrary to load a system native library for boot loader.  sys_path and systemNativeLibraries in ClassLoader implementation are solely for boot loader and it seems cleaner for BootLoader to handle loading of system native

Re: jpackage: spaces in --java-options

2019-07-12 Thread Andy Herrick
I can reproduce this problem and have created JDK-8227641 to address it. /Andy On 7/12/2019 3:53 AM, Serban Iordache wrote: Currently, there is no easy way to pass system properties containing spaces to the Java runtime. For example, if we e

Re: RFR: JDK-8220807: excessive verbose output when running with --win-per-user-install

2019-07-12 Thread Alexey Semenyuk
Andy, The fix suppresses warning for system wide installations too,not just for per user. Is this by intention? - Alexey On 7/12/2019 10:31 AM, Andy Herrick wrote: Please review the jpackage fix for bug [1] at [2]. This is a fix for the JDK-8200758-branch branch of the open sandbox reposit

Re: RFR [14]: 8227438: [TESTLIB] Determine if file exists by Files.exists in function FileUtils.deleteFileIfExistsWithRetry

2019-07-12 Thread Joe Wang
+1 -Joe On 7/11/19 11:32 PM, Frank Yuan wrote: Hi Would you like to review the following patch for Bug: https://bugs.openjdk.java.net/browse/JDK-8227438 --- a/test/lib/jdk/test/lib/util/FileUtils.java Thu Jul 11 15:58:54 2019 + +++ b/test/lib/jdk/test/lib/util/FileUtils

Re: RFR [14]: 8227438: [TESTLIB] Determine if file exists by Files.exists in function FileUtils.deleteFileIfExistsWithRetry

2019-07-12 Thread Lance Andersen
Hi Frank, Took me a while to digest the proposed change, I understand it now and it makes sense to me So I think you are good to go. Best Lance > On Jul 12, 2019, at 2:32 AM, Frank Yuan wrote: > > JDK-8184961

jpackage: spaces in --java-options

2019-07-12 Thread Serban Iordache
Currently, there is no easy way to pass system properties containing spaces to the Java runtime. For example, if we execute jpackage with: --java-options -Dlabel="my great app" The resulting configuration file will contain: [JavaOptions] -Dlabel=my great app instead of the desired: [JavaOptions

Re: RFR: 8227587: Add internal privileged System.loadLibrary

2019-07-12 Thread Mandy Chung
Claes, Thanks for exploring this.  I would like to see if we can avoid introducing an internal @CS method (keep @CSM only for public APIs will help security analysis). There are other alternatives to improve the footprint performance. One idea is java.base and java.desktop each has its own util

Re: RFR: 8227587: Add internal privileged System.loadLibrary

2019-07-12 Thread Claes Redestad
Hi, I'm dropping the java.desktop changes, and Mandy has asked me to explore options that does not add a new @CallerSensitive entry point, even to a strongly encapsulated API like JavaLangAccess Easiest of these is to explicitly provide the class context we're calling from - with proper assertio

RFR: JDK-8220807: excessive verbose output when running with --win-per-user-install

2019-07-12 Thread Andy Herrick
Please review the jpackage fix for bug [1] at [2]. This is a fix for the JDK-8200758-branch branch of the open sandbox repository (jpackage). [1] https://bugs.openjdk.java.net/browse/JDK-8220807 [2] http://cr.openjdk.java.net/~herrick/8220807/ /Andy

Re: RFR: 8227587: Add internal privileged System.loadLibrary

2019-07-12 Thread Philip Race
Hi, Regarding all the touches on the desktop module 1) awt-dev isn't the only list, you should have included swing-dev and 2d-dev at least 2) I am wondering what client testing you propose to do to verify this ? 3) I've spent spare time over a number of months trying to decrease unnecessary co

Re: RFR: 8227587: Add internal privileged System.loadLibrary

2019-07-12 Thread Roger Riggs
Hi Claes, Looks fine. Thanks for the updates, Roger On 7/11/19 10:39 AM, Claes Redestad wrote: Hi Roger, On 2019-07-11 16:10, Roger Riggs wrote: Hi Claes, JavaLangAccess.java: 316: Add @param tag done. System.java:  2282, 2287 Runtime.loadLibrary0 makes a second check for a security m

Re: The final optimized version of Dual-Pivot Quicksort (ver.19.1)

2019-07-12 Thread Laurent Bourgès
Hi, I asked alan to update the webrev, but I can publish it myself... Will do it asap, Stay tuned, Laurent Le mar. 9 juil. 2019 à 22:19, Brent Christian a écrit : > Hi, > > Is the webrev incomplete? It only contains the changes for > DualPivotQuicksort.java, and not for Arrays.java, etc. > > T

Re: RFR [14] JDK-8225763 Inflater and Deflater should implement AutoCloseable

2019-07-12 Thread Jaikiran Pai
Hello Lance, On 12/07/19 5:53 AM, Lance Andersen wrote: > Hi Jaikiran, >> I have now updated the javadoc of end() to be closer to the javadoc >> of close(). >> >> > > Its better but end() should include the wording  > > > This method should be called when the compressor is no longer needed. >