Re: RFR: 8322768: Optimize non-subword vector compress and expand APIs for AVX2 target. [v5]

2024-01-14 Thread Andrey Turbanov
On Tue, 9 Jan 2024 16:48:56 GMT, Jatin Bhateja wrote: >> Hi, >> >> Patch optimizes non-subword vector compress and expand APIs for x86 AVX2 >> only targets. >> Upcoming E-core Xeons (Sierra Forest) and Hybrid CPUs only support AVX2 >> instruction set. >> These are very frequently used APIs in

Re: RFR: 8323183: ClassFile API performance improvements [v6]

2024-01-14 Thread Andrey Turbanov
On Tue, 9 Jan 2024 13:30:58 GMT, Adam Sotona wrote: >> ClassFile API performance related improvements have been separated from >> #17121 into this PR. >> >> These improvements are important to minimize performance regression of >> 8294961: Convert java.base/java.lang.reflect.ProxyGenerator to u

Re: RFR: 8323659: LinkedTransferQueue add and put methods call overridable offer [v3]

2024-01-14 Thread Andrey Turbanov
On Fri, 12 Jan 2024 15:06:01 GMT, Chris Hegarty wrote: >> Update LinkedTransferQueue add and put methods to not call overridable offer. > > Chris Hegarty has updated the pull request incrementally with one additional > commit since the last revision: > > timed offer src/java.base/share/class

Re: RFR: 8323707: Adjust Classfile API's type arg model to better represent the embodied type

2024-01-14 Thread ExE Boss
On Mon, 6 Nov 2023 07:30:41 GMT, Chen Liang wrote: > API changes as discussed on the mailing list: > https://mail.openjdk.org/pipermail/classfile-api-dev/2023-November/000419.html > > Additional questions: > 1. Whether to rename `WildcardIndicator.DEFAULT` to `NONE` src/java.base/share/classes

Re: RFR: 8323659: LinkedTransferQueue add and put methods call overridable offer [v3]

2024-01-14 Thread David Holmes
On Fri, 12 Jan 2024 15:06:01 GMT, Chris Hegarty wrote: >> Update LinkedTransferQueue add and put methods to not call overridable offer. > > Chris Hegarty has updated the pull request incrementally with one additional > commit since the last revision: > > timed offer With my CSR hat on, JDK-8

Re: RFR: 8321620: Optimize JImage decompressors

2024-01-14 Thread Glavo
On Sun, 14 Jan 2024 17:16:37 GMT, Claes Redestad wrote: > Pre-existing issue here is that it seems we don't handle compressed resources > that can't fit in a single byte[], yet we take the overhead of storing > uncompressed/compressed size as longs (4+4 byte overhead per entry). I guess > we s

Re: Is MessageFormat.toPattern() supposed to be reversible?

2024-01-14 Thread Archie Cobbs
Nevermind, I believe now it is and have filed JDK-8323699. Thanks. On Sat, Jan 13, 2024 at 12:45 PM Archie Cobbs wrote: > Clarification question regarding MessageFormat.toPattern() before I file a > bug... > > Is it supposed to be the case that given a MessageFormat object fmt, new > MessageForm

Re: RFR: 8321620: Optimize JImage decompressors

2024-01-14 Thread Claes Redestad
On Fri, 12 Jan 2024 18:45:39 GMT, Glavo wrote: > I generated runtime images using `jlink --compress 2 --add-modules > java.se,jdk.unsupported,jdk.management` and then ran the following JMH > benchmark: > > > @Warmup(iterations = 10, time = 2) > @Measurement(iterations = 5, time = 3) > @Fork(v

RFR: 8323707: Adjust Classfile API's type arg model to better represent the embodied type

2024-01-14 Thread Chen Liang
API changes as discussed on the mailing list: https://mail.openjdk.org/pipermail/classfile-api-dev/2023-November/000419.html Additional questions: 1. Whether to rename `WildcardIndicator.DEFAULT` to `NONE` - Commit messages: - redundant line - Fix a test in langtools, copyright ye

Re: RFR: 8323707: Adjust Classfile API's type arg model to better represent the embodied type

2024-01-14 Thread ExE Boss
On Mon, 6 Nov 2023 07:30:41 GMT, Chen Liang wrote: > API changes as discussed on the mailing list: > https://mail.openjdk.org/pipermail/classfile-api-dev/2023-November/000419.html > > Additional questions: > 1. Whether to rename `WildcardIndicator.DEFAULT` to `NONE` src/java.base/share/classes

RFR: 8323699: MessageFormat.toPattern() generates non-equivalent MessageFormat pattern

2024-01-14 Thread Archie Cobbs
Please consider this fix to ensure that going from `MessageFormat` to pattern string via `toPattern()` and then back via `new MessageFormat()` results in a format that is equivalent to the original. The quoting and escaping rules for `MessageFormat` pattern strings are really tricky. I admit no