Re: 3.2 beta release today?

2005-08-17 Thread Gregory (Grisha) Trubetskoy
On Tue, 16 Aug 2005, Jim Gallacher wrote: What is the correct name for the tarball? mod_python-3.2.0-b.tgz, mod_python-3.2.0-BETA.tgz or something else? I like mod_python-3.2.0b and the tarball would be mod_python-3.2.0b.tgz Grisha

Re: RFC: can I make mod_cache per-dir?

2005-08-17 Thread Colm MacCarthaigh
On Tue, Aug 16, 2005 at 10:44:11PM -0700, Paul Querna wrote: We'd certainly sacrifice some speed under these circumstances; but it'd perhaps be better than nothing and would avoid the possibility where we serve content that is now excluded. -- justin IMO, this is why we should revive

Re: mod_mbox seg faulting on ajax

2005-08-17 Thread Joshua Slive
Paul Querna wrote: Joshua Slive wrote: [What is the active mod_mbox devel list? Trying [EMAIL PROTECTED] [EMAIL PROTECTED] is the best list. As the subject says, mod_mbox has seg faulted about 50 times so far today on ajax. Some core files in ajax:/tmp (after hacking apachectl to adjust

[PATCH] mod_cache. Allow override of some vary headers

2005-08-17 Thread Akins, Brian
This patch allows one to override the values of some headers so that they vary to the same value. Config Example: #all lines that have gzip set one variable SetEnvIf Accept-Encoding gzip gzip=1 #browsers that have problems with gzip BrowserMatch MSIE [1-3] gzip=0 BrowserMatch MSIE [1-5].*Mac

Re: [PATCH] mod_cache. Allow override of some vary headers

2005-08-17 Thread Joshua Slive
Akins, Brian wrote: This patch allows one to override the values of some headers so that they vary to the same value. CacheOverrideHeader Accept-Encoding gzip CacheOverrideHeader User-Agent gzip Very useful looking. I suggest CacheVaryOverride as a much more clear and precise name.

Re: mod_mbox seg faulting on ajax

2005-08-17 Thread Justin Erenkrantz
--On August 17, 2005 1:10:22 PM -0400 Joshua Slive [EMAIL PROTECTED] wrote: Justin... Would it be possible for you to try this out on ajax. I could try to do it myself, but I would need to replicate your setup. I don't think the core dumps are creating any real problem, but I hate to see them

[PATCH] mod_disk_cache deterministic tempfiles

2005-08-17 Thread Akins, Brian
The current 2.1 mod_disk_cache allows any number of workers to be actively trying to cache the same object. This is because of the use of apr_file_mktemp. This patch makes the tempfiles the same per cache object rather than random. I basically added a temp_file() that mimics data_file() and

Re: [PATCH] mod_cache. Allow override of some vary headers

2005-08-17 Thread Justin Erenkrantz
--On August 17, 2005 3:01:03 PM -0400 Akins, Brian [EMAIL PROTECTED] wrote: This patch allows one to override the values of some headers so that they vary to the same value. Config Example: # all lines that have gzip set one variable SetEnvIf Accept-Encoding gzip gzip=1 # browsers that have

Re: [PATCH] mod_cache. Allow override of some vary headers

2005-08-17 Thread Brian Akins
Justin Erenkrantz wrote: The concept is fine. (And as Joshua pointed out 'CacheVaryOverride' would be a better name.) I'm not attatched to the name. So that sounds good to me. A few issues with the implementation (modulo style nits)... This was all done in a few hours today, including

Re: [PATCH] mod_disk_cache deterministic tempfiles

2005-08-17 Thread Graham Leggett
Akins, Brian wrote: The current 2.1 mod_disk_cache allows any number of workers to be actively trying to cache the same object. This is because of the use of apr_file_mktemp. This patch makes the tempfiles the same per cache object rather than random. I basically added a temp_file() that

Re: [PATCH] mod_disk_cache deterministic tempfiles

2005-08-17 Thread Brian Akins
Graham Leggett wrote: This is very cool. On my list of things to do was to handle something similar for serving from the cache as well - again to avoid a thundering herd against backend servers while a file is being cached. I have the thought that we could also serve files that have

Re: [PATCH] mod_disk_cache deterministic tempfiles

2005-08-17 Thread Brian Akins
Graham Leggett wrote: The disk cache might be a bit more involved, but the idea would be the same. Only way I can think of this is to keep trying to seek until file gets renamed. Maybe not very efficient. Or maybe a hash/queue/something that kept track of in-flight objects. But, this

Re: [PATCH] mod_disk_cache deterministic tempfiles

2005-08-17 Thread Graham Leggett
Brian Akins wrote: Only way I can think of this is to keep trying to seek until file gets renamed. Maybe not very efficient. Thing is, compared to the total hits to a server, those hits that were slightly less efficient while serving an in flight object would be a tiny fraction of the

Re: [PATCH] mod_disk_cache deterministic tempfiles

2005-08-17 Thread Colm MacCarthaigh
On Wed, Aug 17, 2005 at 04:13:37PM -0400, Brian Akins wrote: Graham Leggett wrote: The disk cache might be a bit more involved, but the idea would be the same. Only way I can think of this is to keep trying to seek until file gets renamed. Maybe not very efficient. Why bother renaming

Re: [PATCH] mod_disk_cache deterministic tempfiles

2005-08-17 Thread Brian Akins
Colm MacCarthaigh wrote: Why bother renaming the file for such an implementation? If a half-cached file can be served from, and this handled properly, the rename would no longer make any sense :) True. But like Graham said, ultimately, I don't think it's worth it. Not to be biased, but I

Re: [PATCH] mod_disk_cache deterministic tempfiles

2005-08-17 Thread Colm MacCarthaigh
On Wed, Aug 17, 2005 at 04:33:24PM -0400, Brian Akins wrote: True. But like Graham said, ultimately, I don't think it's worth it. I got the opposite from what Graham said, but may have mis-read. Not to be biased, but I think my idea of serving recently expired objects would also avoid the

Re: [PATCH] mod_disk_cache deterministic tempfiles

2005-08-17 Thread Brian Akins
Colm MacCarthaigh wrote: On Wed, Aug 17, 2005 at 04:33:24PM -0400, Brian Akins wrote: True. But like Graham said, ultimately, I don't think it's worth it. I got the opposite from what Graham said, but may have mis-read. Or i did... Depends on the environment. For a proxy, being able

Re: [PATCH] mod_disk_cache deterministic tempfiles

2005-08-17 Thread Colm MacCarthaigh
On Wed, Aug 17, 2005 at 04:11:01PM -0400, Brian Akins wrote: I have the thought that we could also serve files that have recently expired (recent being configurable) if the object was being cached. Psudocode: if(expired (now - recent)) { Content definitely should not be served from the

Re: [PATCH] mod_disk_cache deterministic tempfiles

2005-08-17 Thread Brian Akins
Colm MacCarthaigh wrote: ie revalidate the cache content after N-seconds before it is due to be expired would have the same effect, but avoid serving stale content. Does that make sense? Yes. cool. +1. Thanks! -- Brian Akins Lead Systems Engineer CNN Internet Technologies

Re: [PATCH] mod_disk_cache deterministic tempfiles

2005-08-17 Thread Jim Jagielski
Colm MacCarthaigh wrote: On Wed, Aug 17, 2005 at 04:11:01PM -0400, Brian Akins wrote: I have the thought that we could also serve files that have recently expired (recent being configurable) if the object was being cached. Psudocode: if(expired (now - recent)) { Content

Re: [PATCH] mod_disk_cache deterministic tempfiles

2005-08-17 Thread Justin Erenkrantz
--On August 17, 2005 9:52:32 PM +0100 Colm MacCarthaigh [EMAIL PROTECTED] wrote: Content definitely should not be served from the cache after it has expired imo. However I think an approach like; if((now + interval) expired) { if(!stat(tmpfile)) {

Re: RFC: can I make mod_cache per-dir?

2005-08-17 Thread William A. Rowe, Jr.
At 07:29 AM 8/15/2005, Colm MacCarthaigh wrote: On Mon, Aug 15, 2005 at 01:50:14PM +0200, Graham Leggett wrote: It can't reliably disable caching for a directory. Proxy has a mechanism to do this, cache should have a similar mechanism. Does CacheDisable not do this? That's per-location,

Re: [PATCH] mod_disk_cache deterministic tempfiles

2005-08-17 Thread Justin Erenkrantz
--On August 17, 2005 9:29:05 PM +0100 Colm MacCarthaigh [EMAIL PROTECTED] wrote: Why bother renaming the file for such an implementation? If a half-cached file can be served from, and this handled properly, the rename would no longer make any sense :) For a disk cache it would be tricky to

Re: [PATCH] mod_cache. Allow override of some vary headers

2005-08-17 Thread TOKILEY
In a message dated 8/17/2005 2:01:41 PM Central Daylight Time, [EMAIL PROTECTED] writes: CacheOverrideHeader Accept-Encoding gzip CacheOverrideHeader User-Agent gzip This would allow all browsers that send "Accept-Encoding: gzip" and do not match the BrowserMatches to be mapped to the same

Rolling 2.1.7 On Friday

2005-08-17 Thread Paul Querna
Just a heads up, I am planning to RM and tag 2.1.7 (and re-branch from trunk the 2.2.x branch) on Friday or Saturday this week. I intend to include APR and APR-Util 1.2.1 with this release. As long as 2.1.7 seems good, I would like to do a vote on making it a Beta. Thanks, -Paul