Re: Bookmarking, History and JSF

2006-01-28 Thread Matthias Wessendorf
On 1/27/06, Gary VanMatre [EMAIL PROTECTED] wrote: Hi Gary, The basic idea creates a convention in the url for invoking the method. contextroot/dynamic/remoting$business/cityAndStateForZip.faces?zip=80124 Right it's all about naming conventions :-) I looked a Business.java's

Re: Bookmarking, History and JSF

2006-01-28 Thread Martin Marinschek
Hi Matze, that looks real nice... I think in the end, we'll additionally have some form of url-rewrite in place to be able to specify the stuff without parameters, but just appending one directory after the other. Now, I didn't quite get the story with the bookmarkable URL which is sent by the

Re: Bookmarking, History and JSF

2006-01-28 Thread Mario Ivankovits
Hi Now the phase listener has the convention, that foo and bar are the bean properties and populates the bean with the given values. I tried to follow the thread in full, but sometimes I dont get the point of ones objection. Sorry, if this has already been discussed, but: Why cant we use

Re: Re: Client-ID

2006-01-28 Thread Adam Winer
Yep; BTW, another nastiness with the proxying approach: from a proxy, you have to return a proper proxy around components returned via getChildren() and getFacets(). Blech! We went down this road in UIX (some of which code still survives in the ADF Faces drop); it mostly worked, but only

RE: Re: Re: Client-ID

2006-01-28 Thread jacob
Actually, proxying is pretty straight forward with cglib since we would only need to intercept external invocations upon the instance-- not dealing with proxying within the UIComponent itself-- where member variable state could be difficult. So if you did use cglib to proxy the returned

Re: Re: Client-ID

2006-01-28 Thread Martin Marinschek
We'll try to explore the possibilities further. But if we have either one of (or both) : 1) findPerspective(String scopedId) or a 2) visitComponent(FacesContext f, Visitor c) in the spec, we should probably leave the wrapping approach be. regards, Martin On 1/28/06, Adam Winer [EMAIL

Re: svn commit: r371740 - in /myfaces/core/trunk/impl/src/main/java/org/apache/myfaces: taglib/core/ViewTag.java util/MyFacesJavascriptRendererUtil.java

2006-01-28 Thread Volker Weber
Hi, this checkin breaks tobago and also any other implementation with own ResponseWriter! I get a java.lang.ClassCastException: org.apache.myfaces.tobago.webapp.TobagoResponseWriter at

[jira] Created: (MYFACES-1070) NullPointerException in MyFacesGenericPortlet.facesRender method

2006-01-28 Thread Max Rudman (JIRA)
NullPointerException in MyFacesGenericPortlet.facesRender method Key: MYFACES-1070 URL: http://issues.apache.org/jira/browse/MYFACES-1070 Project: MyFaces Type: Bug Components: Implementation

[jira] Closed: (MYFACES-840) 404 in simple examples using jscookmenu

2006-01-28 Thread Dennis Byrne (JIRA)
[ http://issues.apache.org/jira/browse/MYFACES-840?page=all ] Dennis Byrne closed MYFACES-840: Resolution: Fixed Assign To: Dennis Byrne 404 in simple examples using jscookmenu --- Key:

Re: svn commit: r371740 - in /myfaces/core/trunk/impl/src/main/java/org/apache/myfaces: taglib/core/ViewTag.java util/MyFacesJavascriptRendererUtil.java

2006-01-28 Thread Bruno Aranda
Thanks Volker for reporting that. I've changed the implementation of this stuff in order to not use the HtmlResponseWriterImpl again. It was used to held the information to render the dummyForm. Now this information is held in the request. Can you verify that everything works as expected?

[jira] Closed: (MYFACES-928) Duplicated tag definition selectBooleanCheckboxAjax within the same TLD

2006-01-28 Thread Dennis Byrne (JIRA)
[ http://issues.apache.org/jira/browse/MYFACES-928?page=all ] Dennis Byrne closed MYFACES-928: Resolution: Fixed Assign To: Dennis Byrne Fixed, thanks for reporting this. Duplicated tag definition selectBooleanCheckboxAjax within the same

Re: Bookmarking, History and JSF

2006-01-28 Thread Adam Winer
Craig, Well, I definitely agree that any sort of auto-population is very, very worrisome. But, using value#{param.foo}/value for a managed property still leaves behind some major problems: - If the bean is request-scoped, it forces you to get this parameter into every request - a major

[jira] Closed: (MYFACES-1049) Binary Compatibility w/ the RI

2006-01-28 Thread Dennis Byrne (JIRA)
[ http://issues.apache.org/jira/browse/MYFACES-1049?page=all ] Dennis Byrne closed MYFACES-1049: - Resolution: Fixed Assign To: Dennis Byrne Binary Compatibility w/ the RI -- Key: MYFACES-1049

Re: Bookmarking, History and JSF

2006-01-28 Thread Mario Ivankovits
Hi! - If the bean is request-scoped, it forces you to get this parameter into every request - a major challenge for postback in JSF. Ok, this is really a problem when using param.name - You have to very carefully check incoming parameter values for legitimacy (in a way that JSF