Re: [ovs-dev] [PATCH v05 38/72] include/uapi/linux/openvswitch.h: use __u32 from linux/types.h

2016-08-22 Thread Stephen Hemminger
On Mon, 22 Aug 2016 20:32:55 +0200 Mikko Rapeli wrote: > Fixes userspace compiler error: > > error: unknown type name ‘uint32_t’ > > Signed-off-by: Mikko Rapeli > --- > include/uapi/linux/openvswitch.h | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/include/uapi/

Re: [ovs-dev] [dpdk-dev] OVS-DPDK performance problem on ixgbe vector PMD

2015-08-21 Thread Stephen Hemminger
Use perf top it gives much better data than oprofile On Fri, Aug 21, 2015 at 11:05 AM, Zoltan Kiss wrote: > Hi, > > I've set up a simple packet forwarding perf test on a dual-port 10G > 82599ES: one port receives 64 byte UDP packets, the other sends it out, one > core used. I've used latest OVS

Re: [ovs-dev] [PATCH/RFC] datapath: offload hooks

2014-10-07 Thread Stephen Hemminger
On Wed, 8 Oct 2014 09:40:51 +0900 Simon Horman wrote: > + > +struct ovs_offload_ops { > + /* Flow offload functions */ > + /* Called when a flow entry is added to the flow table */ > + void (*flow_new)(struct sw_flow *); > + /* Called when a flow entry is modified */ > + voi

Re: [ovs-dev] [PATCH/RFC] datapath: offload hooks

2014-10-07 Thread Stephen Hemminger
On Wed, 8 Oct 2014 09:40:51 +0900 Simon Horman wrote: > +struct ovs_offload_ops { > + /* Flow offload functions */ > + /* Called when a flow entry is added to the flow table */ > + void (*flow_new)(struct sw_flow *); > + /* Called when a flow entry is modified */ > + void (*

Re: [ovs-dev] [patch net-next RFC 02/12] net: rename netdev_phys_port_id to more generic name

2014-08-26 Thread Stephen Hemminger
On Tue, 26 Aug 2014 15:23:24 +0300 Or Gerlitz wrote: > just a nit, but if this approach/patch goes in, any reason not to change > IFLA_PHYS_PORT_ID to IFLA_PHYS_ITEM_ID? Userspace API ___ dev mailing list dev@openvswitch.org http://openvswitch.org/mai

[ovs-dev] [PATCH net-next] openvswitch: make generic netlink group const

2014-07-16 Thread Stephen Hemminger
Generic netlink tables can be const. Signed-off-by: Stephen Hemminger --- a/net/openvswitch/datapath.c2014-07-09 03:06:11.400291765 -0700 +++ b/net/openvswitch/datapath.c2014-07-09 03:09:35.688297236 -0700 @@ -66,16 +66,16 @@ static struct genl_family dp_packet_genl static

Re: [ovs-dev] [patch net-next RFC v3 02/10] net: rename netdev_phys_port_id to more generic name

2014-04-17 Thread Stephen Hemminger
On Thu, 17 Apr 2014 14:14:29 +0200 Jiri Pirko wrote: > So this can be reused for identification of other "items" as well. > > Signed-off-by: Jiri Pirko > --- > drivers/net/ethernet/broadcom/bnx2x/bnx2x_main.c | 2 +- > drivers/net/ethernet/mellanox/mlx4/en_netdev.c | 2 +- > drivers/net/et

Re: [ovs-dev] [dpdk-dev] [PATCH RFC] dpif-netdev: Add support Intel DPDK based ports.

2014-01-29 Thread Stephen Hemminger
On Wed, 29 Jan 2014 18:14:01 +0100 Thomas Graf wrote: > On 01/29/2014 05:34 PM, Vincent JARDIN wrote: > > Thomas, > > > > First and easy answer: it is open source, so anyone can recompile. So, > > what's the issue? > > I'm talking from a pure distribution perspective here: Requiring to > recompi

[ovs-dev] [PATCH net-next] ovs: make functions local

2013-12-17 Thread Stephen Hemminger
Several functions and datastructures could be local Found with 'make namespacecheck' Signed-off-by: Stephen Hemminger --- a/net/openvswitch/datapath.c2013-12-05 14:47:26.092495160 -0800 +++ b/net/openvswitch/datapath.c2013-12-17 09:11:42.744892746 -0800 @@ -13

Re: [ovs-dev] [PATCH vxlan v2 1/8] vxlan: Fix module cleanup.

2013-06-26 Thread Stephen Hemminger
When you call unregister_pernet_device last, nothing happens. Since all vxlan device's are unregistered, the per-net vxlan device list would be empty. And since vxlan_stop was never called. The age_timer would never be stopped, and the multicast group would never left, and the forwarding table wi

Re: [ovs-dev] [PATCH net-next 0/8] openvswitch: Add vxlan tunneling support.

2013-06-21 Thread Stephen Hemminger
On Thu, 20 Jun 2013 13:47:11 -0700 Pravin Shelar wrote: > On Thu, Jun 20, 2013 at 10:13 AM, Stephen Hemminger > wrote: > > On Thu, 20 Jun 2013 08:58:42 -0700 > > Stephen Hemminger wrote: > > > >> On Thu, 20 Jun 2013 00:26:15 -0700 > >> Pravin B Sh

Re: [ovs-dev] [PATCH net-next 0/8] openvswitch: Add vxlan tunneling support.

2013-06-20 Thread Stephen Hemminger
On Thu, 20 Jun 2013 00:26:15 -0700 Pravin B Shelar wrote: > First two patches fixes vxlan issues. Next two patches > extends vxlan so that openvswitch can share vxlan udp port > with vxlan module. Rest of patches refactors vxlan data > plane so that ovs can share that code with vxlan module. > L

Re: [ovs-dev] [PATCH net-next 1/8] vxlan: Fix error handling while creating device.

2013-06-20 Thread Stephen Hemminger
On Thu, 20 Jun 2013 00:26:25 -0700 Pravin B Shelar wrote: > Delete vxlan-sock list entry from list before freeing the memory. > > Signed-off-by: Pravin B Shelar > --- > drivers/net/vxlan.c |4 +++- > 1 files changed, 3 insertions(+), 1 deletions(-) > > diff --git a/drivers/net/vxlan.c b/d

Re: [ovs-dev] OVS scaling

2013-04-10 Thread Stephen Hemminger
Try using perf to look at where system is spending it's time. On Wed, Apr 10, 2013 at 3:55 PM, SDN learn wrote: > Hi, > > I'm running OVS-1.4 release on a low frequency x86 machine. I see that > performance doesn't seem to scale linearly from 1 to 2 to 4 cores. > > I have three PC setup: PC1 is g

Re: [ovs-dev] [PATCH v3] Tunnel: Cleanup old tunnel infrastructure.

2013-02-26 Thread Stephen Hemminger
On Tue, 26 Feb 2013 15:55:45 -0800 Jesse Gross wrote: > > + if (!OVS_CB(skb)->tun_key) > > Can you add an unlikely() here? > > > + goto error_free; As far as I know goto's are always considered unlikely by Gcc. ___ dev mailing l

Re: [ovs-dev] [PATCH v4] datapath: Add support for VXLAN tunnels to Open vSwitch

2012-11-27 Thread Stephen Hemminger
On Tue, 27 Nov 2012 15:19:24 -0500 Kyle Mestery wrote: > Note: v4 of this patch removes VXLAN over IPSEC support, > per an offline conversation with Jesse. > > Add support for VXLAN tunnels to Open vSwitch. Add support > for setting the destination UDP port on a per-port basis. > This is done by

Re: [ovs-dev] [PATCH 13/13] Upstream VXLAN: Use UDP Tunnel segmention.

2012-11-26 Thread Stephen Hemminger
Thanks for cleaning up the tunnel infrastructure, it is long over due. Shouldn't this go to the upstream mailing list (net...@vger.kernel.org) instead of being on the OVS mailing list? If you get it submitted right now it could make it in for the 3.8 merge window. There are also the IPv6 tunnels

[ovs-dev] Fw: [Bug 48701] New: Kernel OOPS when transmitting packets using OVS and DSA

2012-10-11 Thread Stephen Hemminger
Begin forwarded message: Date: Thu, 11 Oct 2012 16:13:39 + (UTC) From: bugzilla-dae...@bugzilla.kernel.org To: shemmin...@linux-foundation.org Subject: [Bug 48701] New: Kernel OOPS when transmitting packets using OVS and DSA https://bugzilla.kernel.org/show_bug.cgi?id=48701 Su

Re: [ovs-dev] [RFC upstream PATCH 1/4] GRE: Allow multiple GREPROTO_CISCO protocol handlers.

2012-09-26 Thread Stephen Hemminger
On Wed, 26 Sep 2012 16:34:35 -0700 Pravin B Shelar wrote: > +struct gre_protocol_v0 { > + int (*handler)(struct sk_buff *skb, struct tnl_ptk_info *tpi); > + int (*err_handler)(struct sk_buff *skb, u32 info, > +struct tnl_ptk_info *tpi); > +}; > + It is more conven

Re: [ovs-dev] [RFC upstream PATCH 1/4] GRE: Allow multiple GREPROTO_CISCO protocol handlers.

2012-09-26 Thread Stephen Hemminger
On Wed, 26 Sep 2012 16:34:35 -0700 Pravin B Shelar wrote: > > +int gre_add_protocol_v0(const struct gre_protocol_v0 *proto, u8 priority) > +{ > + if (priority >= GREPROTO_V0_MAX) > + goto err_out; > + > + spin_lock(&gre_proto_lock) You don't need another lock for this. Prot

Re: [ovs-dev] ib0 as a port on a bridge?

2012-09-19 Thread Stephen Hemminger
On Wed, 19 Sep 2012 13:57:39 -0400 christopher barry wrote: > On Tue, 2012-09-18 at 23:49 -0400, christopher barry wrote: > > if this is not the best list for user questions, please send me to > > wherever the best place is for that. > > > > I'm building an opennebula cloud, and I have openvswit

Re: [ovs-dev] [RFC v4] Add TCP encap_rcv hook (repost)

2012-04-24 Thread Stephen Hemminger
On Tue, 24 Apr 2012 16:02:41 + "Kyle Mestery (kmestery)" wrote: > On Apr 23, 2012, at 9:25 PM, Simon Horman wrote: > > On Mon, Apr 23, 2012 at 03:59:24PM -0700, Jesse Gross wrote: > >> On Mon, Apr 23, 2012 at 3:32 PM, Simon Horman wrote: > >>> On Mon, Apr 23, 2012 at 02:38:07PM -0700, Jesse

Re: [ovs-dev] [RFC v4] Add TCP encap_rcv hook (repost)

2012-04-23 Thread Stephen Hemminger
- Original Message - > On Mon, Apr 23, 2012 at 03:59:24PM -0700, Jesse Gross wrote: > > On Mon, Apr 23, 2012 at 3:32 PM, Simon Horman > > wrote: > > > On Mon, Apr 23, 2012 at 02:38:07PM -0700, Jesse Gross wrote: > > >> On Mon, Apr 23, 2012 at 2:08 PM, David Miller > > >> wrote: > > >> >

Re: [ovs-dev] [RFC v4] Add TCP encap_rcv hook (repost)

2012-04-23 Thread Stephen Hemminger
On Mon, 23 Apr 2012 15:15:33 -0400 (EDT) David Miller wrote: > From: Simon Horman > Date: Mon, 23 Apr 2012 17:30:08 +0900 > > > I'm pretty sure the patch I posted added encap_rcv to tcp_sock. > > Am I missing the point? > > It did, my eyes are failing me :-) > > > Currently I am setting up a

Re: [ovs-dev] [RFC v4] Add TCP encap_rcv hook (repost)

2012-04-22 Thread Stephen Hemminger
> This hook is based on a hook of the same name provided by UDP. It > provides > a way for to receive packets that have a TCP header and treat them in > some > alternate way. > > It is intended to be used by an implementation of the STT tunneling > protocol within Open vSwtich's datapath. A pro

Re: [ovs-dev] [RFC v4] Add TCP encap_rcv hook (repost)

2012-04-22 Thread Stephen Hemminger
> From: Simon Horman > Date: Thu, 19 Apr 2012 13:53:35 +0900 > > > This hook is based on a hook of the same name provided by UDP. It > > provides > > a way for to receive packets that have a TCP header and treat them > > in some > > alternate way. > > > > It is intended to be used by an implem

Re: [ovs-dev] Open vSwitch Design

2011-11-25 Thread Stephen Hemminger
Not sure how Openvswitch implementation relates to Openflow specification. There are a few switches supporting Openflow already: http://www.openflow.org/wp/switch-nec/ http://www-03.ibm.com/systems/x/options/networking/bnt8264/index.html The standard(s) are here: http://www.openflow.org/wp/

Re: [ovs-dev] Open vSwitch Design

2011-11-25 Thread Stephen Hemminger
On Fri, 25 Nov 2011 06:24:36 -0500 jamal wrote: > Most hardware bridges out there support all different modes: > You can have learning in the hardware or defer it to user/control plane > by setting some flags. You can have broadcasting done in hardware or > defer to user space. > The mods i was

Re: [ovs-dev] Open vSwitch Design

2011-11-24 Thread Stephen Hemminger
On Thu, 24 Nov 2011 17:30:33 -0500 jamal wrote: > Jesse, > > I am going to try and respond to your comments below. > > On Thu, 2011-11-24 at 12:10 -0800, Jesse Gross wrote: > > > > > * Switching infrastructure: As the name implies, Open vSwitch is > > intended to be a network switch, focuse

Re: [ovs-dev] [GIT PULL v2] Open vSwitch

2011-11-22 Thread Stephen Hemminger
Maybe someone with more insight than me can explain the relationship between Openflow and Open vSwitch. It maybe that the portability of Openflow makes the old qdisc, classifiers to use/implement. ___ dev mailing list dev@openvswitch.org http://openvswitc

Re: [ovs-dev] [PATCH] datapath: Scope global symbols with ovs_ prefix.

2011-11-22 Thread Stephen Hemminger
On Tue, 22 Nov 2011 10:34:04 -0800 Ben Pfaff wrote: > On Tue, Nov 22, 2011 at 10:30:05AM -0800, Jesse Gross wrote: > > OVS has quite a few global symbols that should be scoped with a > > prefix to prevent collisions with other modules in the kernel. > > > > Sugg

Re: [ovs-dev] [PATCH v2 5/5] net: Add Open vSwitch kernel components.

2011-11-21 Thread Stephen Hemminger
One more comment... Shouldn't this device be using netdev_increment_features() like bridging and bonding to have the features of the pseudo device reflect those of the underlying hardware. This would make the device have TSO only if underlying hardware supported it, etc. _

Re: [ovs-dev] [PATCH v2 5/5] net: Add Open vSwitch kernel components.

2011-11-21 Thread Stephen Hemminger
On Mon, 21 Nov 2011 15:18:43 -0800 Jesse Gross wrote: > On Mon, Nov 21, 2011 at 1:59 PM, Stephen Hemminger > wrote: > > On Mon, 21 Nov 2011 13:30:29 -0800 > > Jesse Gross wrote: > > > >> +/** > >> + *   vport_record_error - indicate device error to ge

Re: [ovs-dev] [PATCH v2 5/5] net: Add Open vSwitch kernel components.

2011-11-21 Thread Stephen Hemminger
There are lots of new global symbols created by this module. Since C has no namespaces, a kernel module needs to in general stick to one prefix and naming convention. $ nm openvswitch.ko | grep -v ' U ' | grep -v ' [btrd] ' D __this_module 28c6 T cleanup_module 00

Re: [ovs-dev] [PATCH v2 5/5] net: Add Open vSwitch kernel components.

2011-11-21 Thread Stephen Hemminger
On Mon, 21 Nov 2011 13:30:29 -0800 Jesse Gross wrote: > +/** > + * vport_record_error - indicate device error to generic stats layer > + * > + * @vport: vport that encountered the error > + * @err_type: one of enum vport_err_type types to indicate the error type > + * > + * If using the vport g

Re: [ovs-dev] [PATCH net-next 4/4] net: Add Open vSwitch kernel components.

2011-11-18 Thread Stephen Hemminger
> On Fri, Nov 18, 2011 at 3:23 PM, Stephen Hemminger > wrote: > > On Fri, 18 Nov 2011 15:12:18 -0800 > > Jesse Gross wrote: > > > >> +             write_seqcount_begin(&stats->seqlock); > >> +             stats->tx_p

Re: [ovs-dev] [PATCH net-next 4/4] net: Add Open vSwitch kernel components.

2011-11-18 Thread Stephen Hemminger
On Fri, 18 Nov 2011 15:12:18 -0800 Jesse Gross wrote: > + write_seqcount_begin(&stats->seqlock); > + stats->tx_packets++; > + stats->tx_bytes += sent; > + write_seqcount_end(&stats->seqlock); There is a u64_stats_sync set of macros for this. It has