Re: [osgs] Incremental preloading of gadget metadata and security tokens

2011-08-16 Thread Michael Hermanto
The one-time bulk preloaded of gadget metadata and security tokens are for server-side inlined data, avoiding XHR. We also have incremental (xhr-style) gadget preloading -- osapi.container.preloadGadget() -- and it will cache metadata on top of what has been preloaded (via both one-time/server-side

Re: Review Request: osapi.container.Service.apiPath defaults to the wrong rpc endpoint

2011-08-16 Thread Michael Hermanto
w request for shindig, Stanton Sievers, Michael Hermanto, and Dan Dumont. > > > Summary > --- > > osapi.container.Service.apiPath defaults to the wrong rpc endpoint, it points > to Googles endpoint and not the one in Shindig. If the container does not > pass in an AP

Re: osapi.container.Service.apiPath_

2011-08-16 Thread Michael Hermanto
That's the end-point that we use. Agree on default, since this is in Shindig. Feel free to change it, as long as there is still a way to configure/override it, when we instantiate the osapi.container.Container. On Tue, Aug 16, 2011 at 9:59 AM, Ryan J Baxter wrote: > Hi Mike, > > I was wondering

Re: Review Request: Split deferJs() functionality into its own method

2011-08-02 Thread Michael Hermanto
> > Review request for shindig and Michael Hermanto. > > > Summary > --- > > The previous model of using exportJs() for both deferred and actual symbol > exports turned out to be faulty due to the fact that top-level/global > arguments are not properties. As well

Re: Review Request: Split deferJs() functionality into its own method

2011-08-02 Thread Michael Hermanto
enerated e-mail. To reply, visit: > https://reviews.apache.org/r/1237/ > --- > > (Updated 2011-08-02 00:57:26) > > > Review request for shindig and Michael Hermanto. > > > Summary > --- > > The pr

Re: None of the examples are working in HEAD

2011-08-01 Thread Michael Hermanto
http://codereview.appspot.com/4816065/ On Mon, Aug 1, 2011 at 2:13 PM, daviesd wrote: > If anyone discovers a quick fix to get by in the meantime, please post. I > just recently moved off of 3.0.0-beta2 to pick up some of the recent common > container changes. It'd be nice if maybe we get a bet

Re: Review Request: Improve exportJs() in the face of potentially non-existent symbols.

2011-07-28 Thread Michael Hermanto
is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/1199/ > --- > > (Updated 2011-07-26 21:26:55) > > > Review request for shindig and Michael Hermanto. > > > Summary > ---

Re: Review Request: Improve exportJs() in the face of potentially non-existent symbols.

2011-07-28 Thread Michael Hermanto
: > > --- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/1199/ > --- > > (Updated 2011-07-26 21:26:55) > > > Review request fo

Re: Review Request: Improve exportJs() in the face of potentially non-existent symbols.

2011-07-27 Thread Michael Hermanto
c'. - Michael On 2011-07-26 21:26:55, johnfargo wrote: > > --- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/1199/ > --- > > (Updated 2011-07-26

Re: Enhancing gadgets.log

2011-07-26 Thread Michael Hermanto
Good idea. In fact, I've heard (before) a use case where a gadget wants to log and report back to the container (gadgets.config.init'ed as necessary by container basis), so the parent can do container-specific logging back to the server. Echoing what John says, don't tie gadgets.rpc into gadgets.lo

Re: Review Request: Found typo in gadget_site.js

2011-07-26 Thread Michael Hermanto
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/1200/#review1197 --- Ship it! - Michael On 2011-07-27 03:51:57, Dan Dumont wrote: > > -

Re: Review Request: Don't inject ___jsl.u if there's no non-empty value to inject.

2011-07-26 Thread Michael Hermanto
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/1198/#review1193 --- Ship it! - Michael On 2011-07-26 21:21:42, johnfargo wrote: > > --

Re: Review Request: Don't inject ___jsl.u if there's no non-empty value to inject.

2011-07-26 Thread Michael Hermanto
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/1198/#review1192 --- trunk/java/gadgets/src/main/java/org/apache/shindig/gadgets/js/AddJsl

Re: javascript readability..

2011-07-26 Thread Michael Hermanto
What didn't work for me with -- shindig.foo = function() { return { 'bar': ... }; }(); ... is that methods in the same namespace have to be all defined/implemented in one file. ie: it's fine if all gadgets.rpc.* is implemented in a file rpc.js, but not fine when gadgets.util.* are imple

Re: [VOTE] Ryan Baxter as Apache Shindig Committer

2011-07-22 Thread Michael Hermanto
+1 2011/7/22 ๏̯͡๏ Jasvir Nagra > +1 (binding) > > On Fri, Jul 22, 2011 at 10:06 AM, Henry Saputra >wrote: > > > +1 (binding) > > > > - Henry > > > > On Fri, Jul 22, 2011 at 8:51 AM, Paul Lindner wrote: > > > Hello, > > > > > > I would like to propose that Ryan Baxter be granted committer acces

Re: Setting shindig.gadget-rewrite.externalize-feature-libs=true in shindig.properties by default

2011-07-15 Thread Michael Hermanto
Henry is right. Both inline JS and /gadgets/js-served JS are the output of the same processors in JsServingPipeline. On Wed, Jul 13, 2011 at 7:08 PM, Henry Saputra wrote: > Ok, I was wrong, the RenderingGadgetRewriter DOES call > JsServingPipeline to run the processor. > > - Henry > > On Wed, Jul

Re: Review Request: Adds deferred symbol capability to exportJs.

2011-07-12 Thread Michael Hermanto
Thanks. Synched and saw the changes. LGTM. On Tue, Jul 12, 2011 at 12:06 PM, wrote: >This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/1077/ > > On July 11th, 2011, 10:52 p.m., *Michael Hermanto* wrote: > > > trunk/feature

Re: Review Request: Adds deferred symbol capability to exportJs.

2011-07-11 Thread Michael Hermanto
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/1077/#review1030 --- trunk/features/src/main/javascript/features/exportjs/exportjs.js

Re: Usage or example of preloadTokens

2011-07-06 Thread Michael Hermanto
On Wed, Jul 6, 2011 at 11:38 AM, Jasha Joachimsthal < j.joachimst...@onehippo.com> wrote: > Hi Michael, > > On 6 July 2011 20:03, Michael Hermanto wrote: > > > Sorry for the delay. Had a long 4-day weekend. > > > ah yes, it was a long weekend in the US

Re: Usage or example of preloadTokens

2011-07-06 Thread Michael Hermanto
Sorry for the delay. Had a long 4-day weekend. preloadTokens (and preloadMetadatas) work similarly. In basic, it provides hooks when common container is instantiated to inline a map of gadget URLs to tokens (and metadatas), to warm-up the internal cache, to avoid XHR request when a gadget is navig

Re: Review Request: Common Container precludes synchronous rpc callbacks for handlers registered via Container.rpcRegister

2011-07-06 Thread Michael Hermanto
eview request for shindig, johnfargo and Michael Hermanto. > By Stanton Sievers. > > *Updated 2011-06-30 13:09:14* > Description > > This change is to accommodate synchronous rpc handlers that may be registered > with the common container via > osapi.container.Container.protot

Re: Review Request: gjslint fixes

2011-06-07 Thread Michael Hermanto
request for shindig, johnfargo and Michael Hermanto. > > > Summary > --- > > mostly simple cleanups.. constants.js was heavily modified though... > > > Diffs > - > > /trunk/features/src/main/javascript/features/cloo/cloo.js 1133077 > /trun

Re: svn commit: r1099636 - in /shindig/trunk/java/gadgets/src: main/java/org/apache/shindig/gadgets/uri/DefaultJsUriManager.java main/java/org/apache/shindig/gadgets/uri/UriCommon.java test/java/org/a

2011-05-04 Thread Michael Hermanto
On Wed, May 4, 2011 at 5:02 PM, Henry Saputra wrote: > But will this URL format will be used when getting features from JSServlet? > Yes. What I meant by custom URL is when proxy gadget is trying to generate >

Re: svn commit: r1099636 - in /shindig/trunk/java/gadgets/src: main/java/org/apache/shindig/gadgets/uri/DefaultJsUriManager.java main/java/org/apache/shindig/gadgets/uri/UriCommon.java test/java/org/a

2011-05-04 Thread Michael Hermanto
On Wed, May 4, 2011 at 4:35 PM, Henry Saputra wrote: > Mike, > > This format change could break custom URLs to get external features > for old container and gadgets. > > &loaded= is a new and optional functionality, and only affects JS dynamic compilation. To my knowledge, no-one is using this fun

Re: svn commit: r1095850 - /shindig/trunk/features/src/main/javascript/features/taming/taming.js

2011-04-21 Thread Michael Hermanto
Specifically, this is a rollback of a change made in r1095249. On Thu, Apr 21, 2011 at 6:25 PM, wrote: > Author: mhermanto > Date: Fri Apr 22 01:25:17 2011 > New Revision: 1095850 > > URL: http://svn.apache.org/viewvc?rev=1095850&view=rev > Log: > Rollback removal of taming global var ___. Closu

Re: What happened to the JsHandler?

2011-03-28 Thread Michael Hermanto
Committed in r1085191, in favor for more pipeline-based JS processing. Instead of -- jsHandler.getJsContent(jsUri, servedUri.getAuthority()); do -- jsServingPipiline.execute(ksRequestBuilder.build(jsUri, servedUri.getAuthority())); On Mon, Mar 28, 2011 at 12:09 PM, Han Nguyen wrote: > I just pu

Re: Allow extensions to the common container by allowing other features to provide their own namespace (issue4260049)

2011-03-09 Thread Michael Hermanto
Committed -- http://svn.apache.org/viewvc?rev=1079995&view=rev. Thanks. On Wed, Mar 9, 2011 at 12:39 PM, Michael Hermanto wrote: > LGTM, submit away. :) > > Nit, I still see indentation as more than 2 spaces (perhaps, it's just > codereview). > > > On Wed, M

Re: Allow extensions to the common container by allowing other features to provide their own namespace (issue4260049)

2011-03-09 Thread Michael Hermanto
LGTM, submit away. :) Nit, I still see indentation as more than 2 spaces (perhaps, it's just codereview). On Wed, Mar 9, 2011 at 12:22 PM, wrote: > Updated patch with Mike's suggestion > > > http://codereview.appspot.com/4260049/ >

Re: Allow extensions to the common container by allowing other features to provide their own namespace (issue4260049)

2011-03-08 Thread Michael Hermanto
It looks a little odd: 1) to see internal instance variables directly referred by a utility/helper class. 2) mixins_ used outside of the shindig.container.Container scope. Suggesting a simple change to (statically) add addMixin() on shindig.container.Container, like below -- shindig.container.Con

Re: Hudson build became unstable: Shindig #2215

2011-02-23 Thread Michael Hermanto
Fixed with http://svn.apache.org/viewvc?rev=1074048&view=rev On Wed, Feb 23, 2011 at 9:49 PM, Michael Hermanto wrote: > On it. > > > On Wed, Feb 23, 2011 at 9:14 PM, Apache Hudson Server < > hud...@hudson.apache.org> wrote: > >> See <https://hudson.apache.org/hudson/job/Shindig/2215/changes> >> >> >> >

Re: Hudson build became unstable: Shindig #2215

2011-02-23 Thread Michael Hermanto
On it. On Wed, Feb 23, 2011 at 9:14 PM, Apache Hudson Server < hud...@hudson.apache.org> wrote: > See > > >

Re: Common Container viewParams versus renderParams

2011-02-23 Thread Michael Hermanto
On Wed, Feb 23, 2011 at 5:39 AM, Stanton Sievers wrote: > Hi, > > I've been playing around with the common container and have been wondering > why there are both viewParams and renderParams that can be passed to > shindig.container.Container.prototype.navigateGadget. > shindig.container.ViewParam

Re: [VOTE] Approve Jacobo Tarrio as Shindig Committer

2011-02-07 Thread Michael Hermanto
+1 On Mon, Feb 7, 2011 at 1:57 PM, John Hjelmstad wrote: > Hello, > > I would like to propose that Jacobo Tarrio be granted committer access > to Shindig along with PMC membership. > > Jacobo has contributed substantially to the Java Shindig effort, most > recently in JavaScript serving but also

Re: RES: security token (in the new common container)

2011-02-03 Thread Michael Hermanto
The security token minted in the iframe URL returned via /api/rpc comes DefaultIframeUriManager.generateSecurityToken(). You can supply your own SecurityTokenCodec or override generateSecurityToken() to yield the token that you want. Hope that helps. On Thu, Feb 3, 2011 at 6:09 AM, Han Nguyen wro

Re: Where is property height of the gadget?

2011-01-06 Thread Michael Hermanto
On Thu, Jan 6, 2011 at 10:15 AM, Xandeco, Maxwell wrote: > > Hi, > > When javascript container is redering the gadget in the client, it checks > if has the height property, eg. on the method getMainContent in > shindig.IfrGadget, this method check if has the height and width property to > set the

Re: Constructing the iFrame URL

2011-01-05 Thread Michael Hermanto
d what it can do on the wiki as well. > > Thanks for your help. > > -Ryan > > Email: rjbax...@us.ibm.com > Phone: 978-899-3041 > developerWorks Profile > > > > From: Michael Hermanto > To: dev@shindig.apache.org > Date: 01/04/2011 04:02 PM > Subje

Re: Constructing the iFrame URL

2011-01-04 Thread Michael Hermanto
On Tue, Jan 4, 2011 at 12:54 PM, Ryan J Baxter wrote: > After looking at the code below I was curious about how the common > container was making the metadata request, and sure enough it is doing it > differently than the old container. Looks like at the end of the day the > common container is

Re: Feature shindig.container-1.0

2010-12-20 Thread Michael Hermanto
On Thu, Dec 16, 2010 at 10:54 AM, NikNik wrote: > hi > > I'm using shindig in my application for the year. Version 2.0.0 release. > I'm using 'shindig.container' feature with my small hacks for my needs. > > Few days ago I've found 'shindig.container-1.0' feature which referenced to > 'container'

Re: shindig.BaseIfrGadget Constructor

2010-12-15 Thread Michael Hermanto
I never worked with this API, but chiming in anyway (and hopefully not repeating) ... On Wed, Dec 15, 2010 at 11:03 AM, Ryan J Baxter wrote: > I have a question about the constructor for shindig.BaseIfrGadget in > shindig-container.js which is part of the feature shindig.container. Why > do we

Re: Removing a gadget from container.

2010-12-07 Thread Michael Hermanto
Aside, presumably, this is the old features/shindig.container, and not features/container (common container). In the later, we have closeGadget() in addition to navigateGadget(). On Tue, Dec 7, 2010 at 6:02 PM, Maxwell wrote: > > Is there a way similar to method, shindig.container.addGadget to r

Re: [jira] Created: (SHINDIG-1460) Bug fix and improvement for common container: make gadgets can be rendered successfully with the new common container

2010-11-03 Thread Michael Hermanto
On Tue, Nov 2, 2010 at 7:18 PM, Kai Feng Zhang (JIRA) wrote: > Bug fix and improvement for common container: make gadgets can be rendered > successfully with the new common container > > ---

Re: 404 Error with the container feature

2010-10-21 Thread Michael Hermanto
On Thu, Oct 21, 2010 at 5:34 PM, Andy B Smith wrote: > > > I've just started to look at the container feature that was recently added > per https://issues.apache.org/jira/browse/SHINDIG-1335. I tried to get > this working in a test page but am now hitting a 404 for the /api/rpc/cs. > Is this si

Re: [VOTE] Approve Gagandeep singh as Shindig Committer

2010-08-20 Thread Michael Hermanto
+1 On Fri, Aug 20, 2010 at 6:53 AM, Chirag Shah wrote: > +1 > > On Thu, Aug 19, 2010 at 10:46 PM, Paul Lindner wrote: > > I would like to propose that Gagandeep Singh be granted committer > > access to Shindig > > along with PMC membership if desired. > > > > WIth over 20 accepted patches, nume

Re: [RESULT] Approve Michael Hermanto as Apache Shindig Committer

2010-08-03 Thread Michael Hermanto
Thanks everyone! I looking forward to working with Shindig more. :) On Tue, Aug 3, 2010 at 12:25 AM, Paul Lindner wrote: > The results are in: 5 +1 votes. > > Michael Hermanto is approved as an Apache Shindig committer. > > Congratulations Michael! > > On Wed, Jul 28,

Re: Shindig gadget-and-container framework

2010-05-12 Thread Michael Hermanto
once OAuth 2.0 becomes more widespread. > All noted. Thanks Paul. > > On Wed, May 12, 2010 at 12:31 AM, Michael Hermanto >wrote: > > > Hi all, > > > > In Google, we've been developing a lightweight gadget-and-container > > framework, called "comm

Shindig gadget-and-container framework

2010-05-12 Thread Michael Hermanto
Hi all, In Google, we've been developing a lightweight gadget-and-container framework, called "common container", to 1) simplify container and gadget integration model, and 2) provide near-zero barrier to entry to become a gadget container. The framework is a combination of JS (which container cli