This is an implementation of SerialPortLib using SBI console services.
Tested with:
- Qemu RiscVVirt (non-DBCN case, backed by UART)
- TinyEMU + RiscVVirt (non-DBCN case, HTIF)
- TinyEMU + RiscVVirt (DBCN case, HTIF)
Cc: Daniel Schaefer
Cc: Sunil V L
Signed-off-by: Andrei Warkentin
---
MdePkg
Add a few more definitions and make SbiCall and TranslateError
usable (not static) by library users.
Cc: Daniel Schaefer
Cc: Sunil V L
Signed-off-by: Andrei Warkentin
---
MdePkg/Include/Library/BaseRiscVSbiLib.h | 40 ++--
MdePkg/Library/BaseRiscVSbiLib/BaseRiscVSbiLib.
Hello!
Here are two patches that give a SerialLib backed by
SBI console. Both legacy and DBCN mechanisms are
supported and have been tested (with UART and HTIF).
This is also available at https://github.com/andreiw/edk2-rv-wip/tree/patchset-2
Andrei Warkentin (2):
MdePkg: BaseRiscVSbiLib: make
On Wed, Mar 01, 2023 at 02:09:46PM +0800, Yuanhao Xie wrote:
> The purpose of this patch series is to put the APs in 64-bit mode
> before handing off the boot process to the OS, AMD 64-bit processors
> with SEV-ES follows the original logic.
>
> Ref:https://bugzilla.tianocore.org/show_bug.cgi?id
From: Aryeh Chen
Since AlderLake platform client project align Server project to use
PC00.
Signed-off-by: Aryeh Chen
Cc: Chasel Chiu ,
Cc: Nate DeSimone ,
Cc: Isaac Oram ,
Cc: Liming Gao ,
Cc: Eric Dong
---
Platform/Intel/MinPlatformPkg/Acpi/MinDsdt/MinDsdt.asl | 2 +-
1 file changed, 1 inser
Cc: Guo Dong
Cc: Ray Ni
Cc: Sean Rhodes
Cc: James Lu
Cc: Gua Guo
Signed-off-by: Yuanhao Xie
---
UefiCpuPkg/Library/MpInitLib/X64/AmdSev.nasm | 170
+++
Add the 'AsmRelocateApLoopStartGeneric' for X64 processors except 64-bit
AMD processors with SEV-ES.
Remove the unused arguments of AsmRelocateApLoopStartGeneric, updated
the stack offset.
Create PageTable for the allocated reserved memory.
Only keep 4GB limitation of memory allocation for the
Rename AsmRelocateApLoopStart to AsmRelocateApLoopStartAmdSev
Cc: Guo Dong
Cc: Ray Ni
Cc: Sean Rhodes
Cc: James Lu
Cc: Gua Guo
Signed-off-by: Yuanhao Xie
---
UefiCpuPkg/Library/MpInitLib/DxeMpLib.c | 4 ++--
UefiCpuPkg/Library/MpInitLib/MpEqu.inc| 4 ++--
UefiCpuPkg/Library/
Add CpuPageTableLib required by MpInitLib in UefiPayloadPkg.
Cc: Guo Dong
Cc: Ray Ni
Cc: Sean Rhodes
Cc: James Lu
Cc: Gua Guo
Signed-off-by: Yuanhao Xie
---
UefiPayloadPkg/UefiPayloadPkg.dsc | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/UefiPayloadPkg/UefiPayloadPkg.
Add CpuPageTableLib required by MpInitLib in OvmfPkg.
Cc: Ard Biesheuvel
Cc: Jiewen Yao
Cc: Jordan Justen
Cc: Gerd Hoffmann
Signed-off-by: Yuanhao Xie
---
OvmfPkg/AmdSev/AmdSevX64.dsc | 3 ++-
OvmfPkg/CloudHv/CloudHvX64.dsc | 3 ++-
OvmfPkg/IntelTdx/IntelTdxX64.dsc | 4 +++-
OvmfPkg/Mi
Cc: Guo Dong
Cc: Ray Ni
Cc: Sean Rhodes
Cc: James Lu
Cc: Gua Guo
Signed-off-by: Yuanhao Xie
---
UefiCpuPkg/Library/MpInitLib/DxeMpLib.c | 40
+---
1 file changed, 17 insertions(+), 23 deletions(-)
diff --git a/UefiCpuPkg/Library/MpInitLib/DxeMpLib.c
b/U
Add the union RELOCATE_AP_LOOP_ENTRY, split the path in RelocateApLoop
into two:
1. 64-bit AMD processors with SEV-ES
2. Intel processors (32-bit or 64-bit), 32-bit AMD processors, or
64-bit AMD processors without SEV-ES.
Cc: Guo Dong
Cc: Ray Ni
Cc: Sean Rhodes
Cc: James Lu
Cc: Gua Guo
Si
Check if AP_SAFE_STACK_SIZE is aligned with CPU_STACK_ALIGNMENT
during build time.
No functional or structural changes.
Cc: Guo Dong
Cc: Ray Ni
Cc: Sean Rhodes
Cc: James Lu
Cc: Gua Guo
Signed-off-by: Yuanhao Xie
---
UefiCpuPkg/Library/MpInitLib/MpLib.h | 3 ++-
1 file changed, 2 insertions
The purpose of this patch series is to put the APs in 64-bit mode
before handing off the boot process to the OS, AMD 64-bit processors
with SEV-ES follows the original logic.
Ref:https://bugzilla.tianocore.org/show_bug.cgi?id=4234
Yuanhao Xie (8):
UefiCpuPkg: Check AP_SAFE_STACK_SIZE during b
Acked-by: Ray Ni
> -Original Message-
> From: Desimone, Nathaniel L
> Sent: Wednesday, March 1, 2023 12:55 PM
> To: devel@edk2.groups.io
> Cc: Desimone, Nathaniel L ; Andrew Fish
> ; Ni, Ray ; Kinney, Michael D
> ; Chiu, Chasel
> Subject: [PATCH v1] EmulatorPkg: Remove Duplicate
> gEmuI
Acked-by: Ray Ni
> -Original Message-
> From: Desimone, Nathaniel L
> Sent: Wednesday, March 1, 2023 12:55 PM
> To: devel@edk2.groups.io
> Cc: Desimone, Nathaniel L ; Andrew Fish
> ; Ni, Ray ; Kinney, Michael D
> ; Chiu, Chasel
> Subject: [PATCH v1] EmulatorPkg: Fix misspelling
>
> Fro
Acked-by: Ray Ni
> -Original Message-
> From: Desimone, Nathaniel L
> Sent: Wednesday, March 1, 2023 12:55 PM
> To: devel@edk2.groups.io
> Cc: Desimone, Nathaniel L ; Andrew Fish
> ; Ni, Ray ; Kinney, Michael D
> ; Chiu, Chasel
> Subject: [PATCH v1] EmulatorPkg: Fix SecInterruptEnabled
Nice change😊
Acked-by: Ray Ni
> -Original Message-
> From: Desimone, Nathaniel L
> Sent: Wednesday, March 1, 2023 12:55 PM
> To: devel@edk2.groups.io
> Cc: Desimone, Nathaniel L ; Andrew Fish
> ; Ni, Ray ; Kinney, Michael D
> ; Chiu, Chasel
> Subject: [PATCH v1] EmulatorPkg: Rename Var
Acked-by: Ray Ni
> -Original Message-
> From: Desimone, Nathaniel L
> Sent: Wednesday, March 1, 2023 12:55 PM
> To: devel@edk2.groups.io
> Cc: Desimone, Nathaniel L ; Andrew Fish
> ; Ni, Ray ; Kinney, Michael D
> ; Chiu, Chasel
> Subject: [PATCH v1] EmulatorPkg: Correct Comment
>
> Fro
From: Nate DeSimone
confroms should be conforms.
Signed-off-by: Nate DeSimone
Cc: Jian J Wang
Cc: Liming Gao
Cc: Michael D Kinney
Cc: Dandan Bi
---
MdeModulePkg/Core/DxeIplPeim/Ia32/DxeLoadFunc.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/MdeModulePkg/Core/DxeI
From: Nate DeSimone
Rename PeiCorePe32File to SecCorePe32File, because the variable
actually contains the SEC core... not PEI core.
Cc: Andrew Fish
Cc: Ray Ni
Cc: Michael D Kinney
Cc: Chasel Chiu
Signed-off-by: Nate DeSimone
---
EmulatorPkg/Unix/Host/Host.c | 12 ++--
EmulatorPkg/U
From: Nate DeSimone
Host.inf contains two redundant references to
gEmuIoThunkProtocolGuid. Removing one of them as it is superfluous.
Cc: Andrew Fish
Cc: Ray Ni
Cc: Michael D Kinney
Cc: Chasel Chiu
Signed-off-by: Nate DeSimone
---
EmulatorPkg/Unix/Host/Host.inf | 3 +--
1 file changed, 1 i
From: Nate DeSimone
SecInterruptEanbled should be SecInterruptEnabled
Cc: Andrew Fish
Cc: Ray Ni
Cc: Michael D Kinney
Cc: Chasel Chiu
Signed-off-by: Nate DeSimone
---
EmulatorPkg/Unix/Host/EmuThunk.c | 4 ++--
EmulatorPkg/Unix/Host/Host.h | 4 ++--
EmulatorPkg/Unix/Host/Pthreads.c | 4
From: Nate DeSimone
pased should be passed.
Cc: Andrew Fish
Cc: Ray Ni
Cc: Michael D Kinney
Cc: Chasel Chiu
Signed-off-by: Nate DeSimone
---
EmulatorPkg/Unix/Host/Host.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/EmulatorPkg/Unix/Host/Host.c b/EmulatorPkg/Unix/
From: Nate DeSimone
Delete this macro because:
1. Nothing uses it.
2. It is misspelled.
3. It is a EDK I style GUID definition which is redundant with
an existing EDK II style GUID definition.
Cc: Andrew Fish
Cc: Ray Ni
Cc: Michael D Kinney
Cc: Chasel Chiu
Signed-off-by: Nate DeSimone
-
From: Nate DeSimone
EFI_EMU_UGA_IO_PROTOCOL has been replaced by
EMU_GRAPHICS_WINDOW_PROTOCOL.
Cc: Andrew Fish
Cc: Ray Ni
Cc: Michael D Kinney
Cc: Chasel Chiu
Signed-off-by: Nate DeSimone
---
EmulatorPkg/Unix/Host/Gasket.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --g
It takes same time as original build report to be generated as it constructed
using the same data structures as build report. So I think its OK to not have
it enabled by default.
Patch is ready in the pull request to be reviews.
-Original Message-
From: Ni, Ray
Sent: Tuesday, Februa
Thanks for looking into this more. Given what you found, no additional changes
are required.
I recall there are some other files that have specific requirements.
We can add those when we run into them again.
Mike
> -Original Message-
> From: Rebecca Cran
> Sent: Tuesday, February 28,
Mike,
It looks like the line endings and tab/spaces of .gitmodules doesn't
matter: do we still want to list a preference for it?
"Given the following, I'm not sure line endings matter at all to git?
$ file .gitmodules
.gitmodules: ASCII text, with CRLF, LF line terminators
$ file .gitignor
*Reminder: TianoCore Bug Triage - APAC / NAMO*
*When:*
Tuesday, February 28, 2023
6:30pm to 7:30pm
(UTC-08:00) America/Los Angeles
*Where:*
https://teams.microsoft.com/l/meetup-join/19%3ameeting_OTk1YzJhN2UtOGQwNi00NjY4LWEwMTktY2JiODRlYTY1NmY0%40thread.v2/0?context=%7b%22Tid%22%3a%2246c98d88-e344
What's the status of this patch?
Does report generation take time? If no, why not generate them by default
without individual flag control.
I really like the feature to generate "compile_commands.json"
> -Original Message-
> From: Palomino Sosa, Guillermo A
> Sent: Tuesday, February 28,
What about .gitmodules?
Mike
> -Original Message-
> From: Rebecca Cran
> Sent: Tuesday, February 28, 2023 10:21 AM
> To: Kinney, Michael D ; Ard Biesheuvel
> ; devel@edk2.groups.io
> Cc: Andrew Fish ; Leif Lindholm
> Subject: Re: [edk2-devel] [PATCH 1/1] Add a .editorconfig file to tel
On Tue, 28 Feb 2023 at 19:20, Rebecca Cran wrote:
>
> Before I sent out an official v2 patch, does the following look good?
>
Looks fine to me, thanks.
>
> diff --git a/.editorconfig b/.editorconfig
> new file mode 100644
> index ..587d5bbaa884
> --- /dev/null
> +++ b/.editorconfig
>
Before I sent out an official v2 patch, does the following look good?
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index ..587d5bbaa884
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,31 @@
+# EditorConfig file: https://EditorConfig.org
+
+root = true
+
+[*]
+charset
From: "Chevron Li (WH)"
1.Implement override function for EdkiiSdMmcInitHostPre case to
configure bayhub host.
2.Implement override function for EdkiiSdMmcInitHostPost case to
configure bayhub host.
Cc: Hao A Wu
Cc: Ray Ni
Cc: Jian J Wang
Cc: Liming Gao
Signed-off-by: Chevron Li
---
.../Bu
Looks good to me.
Reviewed-by Samer El-Haj-Mahmoud
> -Original Message-
> From: devel@edk2.groups.io On Behalf Of Gao,
> Zhichao via groups.io
> Sent: Thursday, February 16, 2023 4:18 AM
> To: Sunny Wang ; devel@edk2.groups.io; Sam
> Kaynor
> Cc: Ni, Ray
> Subject: Re: [edk2-devel] [P
Reviewed-by: G Edhaya Chandran
-=-=-=-=-=-=-=-=-=-=-=-
Groups.io Links: You receive all messages sent to this group.
View/Reply Online (#100546): https://edk2.groups.io/g/devel/message/100546
Mute This Topic: https://groups.io/mt/95662763/21656
Group Owner: devel+ow...@edk2.groups.io
Unsubscribe
Reviewed-by: G Edhaya Chandran
-=-=-=-=-=-=-=-=-=-=-=-
Groups.io Links: You receive all messages sent to this group.
View/Reply Online (#100545): https://edk2.groups.io/g/devel/message/100545
Mute This Topic: https://groups.io/mt/95662761/21656
Group Owner: devel+ow...@edk2.groups.io
Unsubscribe
Hi everyone,
I have this bmp file which I defined in the FV.FVMAIN_COMPACT section of
the OvmfPkgX64.fdf file. when I get the a hexdump on the built firmware
(OVMF.fd) I can see the file inside it. but whenever I call the
the GetSectionFromAnyFv() function from a Application it fails to find the
fi
> On 28. Feb 2023, at 07:12, Gerd Hoffmann wrote:
>
>  Hi,
>
>>> (a) the SecureBoot variable is not present (EFI_NOT_FOUND) according to
>>>the return value, or
>>
>> @Maintainers Would there be any objection to drop this and skip the SB
>> checks only when explicitly disabled?
>> Pleas
For this series:
Reviewed-by: Heng Luo
> -Original Message-
> From: Li, Yi1
> Sent: Friday, February 24, 2023 2:49 PM
> To: devel@edk2.groups.io
> Cc: Li, Yi1 ; Gao, Zhichao ; Tan,
> Ming ; Luo, Heng
> Subject: [edk2-staging][PATCH 0/2] CryptoPkg: openssl submodule update
>
> Patch 1:
Reviewed-by: Heng Luo
> -Original Message-
> From: Li, Yi1
> Sent: Friday, February 24, 2023 2:49 PM
> To: devel@edk2.groups.io
> Cc: Li, Yi1 ; Gao, Zhichao ; Tan,
> Ming ; Luo, Heng
> Subject: [edk2-staging][PATCH 2/2] CryptoPkg: fix wrong name in tls 1.2
> cipher suite
>
> Keep ciphe
Reviewed-by: Heng Luo
> -Original Message-
> From: Li, Yi1
> Sent: Friday, February 24, 2023 2:49 PM
> To: devel@edk2.groups.io
> Cc: Li, Yi1 ; Gao, Zhichao ; Tan,
> Ming ; Luo, Heng
> Subject: [edk2-staging][PATCH 1/2] CryptoPkg: update openssl to 1.1.1t
>
> Pick up bugfixes from the
43 matches
Mail list logo