Re: [PATCH v4 3/6] Make testutils use utilfdt

2011-09-22 Thread David Gibson
On Wed, Sep 21, 2011 at 01:32:46PM -0700, Simon Glass wrote: The load_blob() and save_blob() functions are very similar to the utilfdt versions. This removes the duplicated code. Signed-off-by: Simon Glass s...@chromium.org Acked-by: David Gibson da...@gibson.dropbear.id.au -- David Gibson

Re: [PATCH v4 4/6] ftdump: use utilfdt to read blob

2011-09-22 Thread David Gibson
On Wed, Sep 21, 2011 at 01:32:47PM -0700, Simon Glass wrote: Now that we have utilfdt_read(), ftdump should use it too. Signed-off-by: Simon Glass s...@chromium.org Acked-by: David Gibson da...@gibson.dropbear.id.au -- David Gibson| I'll have my music baroque, and my

[PATCH] serial/imx: add of_alias_get_id() reference back

2011-09-22 Thread Shawn Guo
As of_alias_get_id() gets fixed and ready for use, the patch adds the of_alias_get_id() reference back to imx serial driver. Signed-off-by: Shawn Guo shawn@linaro.org --- drivers/tty/serial/imx.c | 13 + 1 files changed, 9 insertions(+), 4 deletions(-) diff --git

Re: [PATCH] dt: add of_alias_scan and of_alias_get_id

2011-09-22 Thread Shawn Guo
On Wed, Sep 21, 2011 at 02:46:54PM -0600, Grant Likely wrote: From: Shawn Guo shawn@linaro.org The patch adds function of_alias_scan to populate a global lookup table with the properties of 'aliases' node and function of_alias_get_id for drivers to find alias id from the lookup table.

Re: [PATCH] devicetree: Add a registry of vendor prefixes

2011-09-22 Thread Nicolas Ferre
Hi Grant, Le 21/09/2011 17:23, Grant Likely : There is no centralized listing for the in-use vendor prefixes used in compatible strings and property names. This patch adds one. New prefixes should get added to this list to reduce the likelyhood of namespace collisions. Signed-off-by:

Re: [PATCH] ARM: vexpress: initial device tree support

2011-09-22 Thread Dave Martin
On Wed, Sep 21, 2011 at 07:47:32AM -1000, Mitch Bradley wrote: On 9/21/2011 7:15 AM, Dave Martin wrote: On Wed, Sep 21, 2011 at 11:37:54AM -0500, Rob Herring wrote: On 09/21/2011 09:57 AM, Grant Likely wrote: On Wed, Sep 21, 2011 at 7:24 AM, Rob Herringrobherri...@gmail.com wrote: On

Re: [PATCH v4 2/3] dtc: Support character literals in cell lists

2011-09-22 Thread Jon Loeliger
I'm in favour of applying the char literals in cell lists patch immediately. Jon? Done. jdl ___ devicetree-discuss mailing list devicetree-discuss@lists.ozlabs.org https://lists.ozlabs.org/listinfo/devicetree-discuss

Re: [PATCH v4 2/6] Add fdt read/write utility functions

2011-09-22 Thread Jon Loeliger
This adds higher-level libfdt operations for reading/writing an fdt blob from/to a file, as well s a function to decode a data type string as will be used by fdtget, fdtput. Add utilfdt tests This adds a few tests for the simple type argument supported by utilfdt_decode_type. I assume

Re: DT vs ARM static mappings

2011-09-22 Thread Pawel Moll
- map the entire I/O area in map_io(), depending on the board - have an __iomem pointer for the sysreg - populate that pointer using of_iomap from the device tree address before you first access it. Ok, so what I came with is below... It's based more-or-less on top of Dave's patch (it's

Re: [PATCH] dt: add of_alias_scan and of_alias_get_id

2011-09-22 Thread Grant Likely
On Thu, Sep 22, 2011 at 02:53:08PM +0800, Shawn Guo wrote: On Wed, Sep 21, 2011 at 02:46:54PM -0600, Grant Likely wrote: From: Shawn Guo shawn@linaro.org The patch adds function of_alias_scan to populate a global lookup table with the properties of 'aliases' node and function

[PATCH v5 0/5] Add fdtget and fdtput for access to fdt from build system

2011-09-22 Thread Simon Glass
This patch set adds two new utilities: fdtget for reading properties from a device tree binary file fdtput for updating the device tree binary file These are useful in scripts where configuration or other information must be passed to the running system from the build system or vice versa.

[PATCH v5 5/5] Add fdtput utility to write property values to a device tree

2011-09-22 Thread Simon Glass
This simple utility allows writing of values into a device tree from the command line. It aimes to be the opposite of fdtget. What is it for: - Updating fdt values when a binary blob already exists (even though source may be available it might be easier to use this utility rather than sed,

[PATCH v5 2/5] Make testutils use utilfdt

2011-09-22 Thread Simon Glass
The load_blob() and save_blob() functions are very similar to the utilfdt versions. This removes the duplicated code. Signed-off-by: Simon Glass s...@chromium.org Acked-by: David Gibson da...@gibson.dropbear.id.au --- Changes in v3: - Make testutils.c use utilfdt for load/save blobs

[PATCH v5 1/5] Add fdt read/write utility functions

2011-09-22 Thread Simon Glass
This adds higher-level libfdt operations for reading/writing an fdt blob from/to a file, as well as a function to decode a data type string as will be used by fdtget, fdtput. This also adds a few tests for the simple type argument supported by utilfdt_decode_type. Signed-off-by: Simon Glass

[PATCH v5 4/5] Add fdtget utility to read property values from a device tree

2011-09-22 Thread Simon Glass
This simply utility makes it easy for scripts to read values from the device tree. It is written in C and uses the same libfdt as the rest of the dtc package. What is it for: - Reading fdt values from scripts - Extracting fdt information within build systems - Looking at particular values without

Re: [PATCH] serial/imx: add of_alias_get_id() reference back

2011-09-22 Thread Grant Likely
On Thu, Sep 22, 2011 at 02:48:13PM +0800, Shawn Guo wrote: As of_alias_get_id() gets fixed and ready for use, the patch adds the of_alias_get_id() reference back to imx serial driver. Signed-off-by: Shawn Guo shawn@linaro.org --- drivers/tty/serial/imx.c | 13 + 1 files

Re: [PATCH] dt: add empty for_each_child_of_node, of_find_property

2011-09-22 Thread Grant Likely
On Wed, Sep 21, 2011 at 01:23:10PM -0600, Stephen Warren wrote: The patch adds a couple empty functions for non-dt build, so that drivers migrating to dt can save some '#ifdef CONFIG_OF'. Signed-off-by: Stephen Warren swar...@nvidia.com --- Applied, thanks. g. Unfortunately, I screwed up

Re: [PATCH v3 1/2] input: samsung-keypad: Add HAVE_SAMSUNG_KEYPAD config option

2011-09-22 Thread Grant Likely
On Mon, Sep 19, 2011 at 03:49:12PM +0530, Thomas Abraham wrote: For platforms using device tree, the static keypad device instances are not required and SAMSUNG_DEV_KEYPAD is not selected. Since, samsung keypad driver has dependency on SAMSUNG_DEV_KEYPAD config option, the driver is left out

Re: [PATCH v3 2/2] input: samsung-keypad: Add device tree support

2011-09-22 Thread Grant Likely
On Mon, Sep 19, 2011 at 03:49:13PM +0530, Thomas Abraham wrote: Add device tree based discovery support for Samsung's keypad controller. Cc: Joonyoung Shim jy0922.s...@samsung.com Cc: Donghwa Lee dh09@samsung.com Signed-off-by: Thomas Abraham thomas.abra...@linaro.org A few things to

Re: [PATCH v2 RESEND 2] gpio-vx855: add device tree binding

2011-09-22 Thread Grant Likely
On Mon, Sep 19, 2011 at 10:27:07AM +0100, Daniel Drake wrote: Hi Grant, Thanks for looking at this. On Sat, Sep 17, 2011 at 4:56 PM, Grant Likely grant.lik...@secretlab.ca wrote: drivers/mfd/vx855.c should be modified to assign pdev-of_node, which can be used here for setting up

Re: [PATCH 0/3] Variable sized cell support

2011-09-22 Thread Anton Staaf
On Wed, Sep 21, 2011 at 7:26 PM, David Gibson da...@gibson.dropbear.id.au wrote: On Wed, Sep 21, 2011 at 01:42:08PM -0700, Anton Staaf wrote: This patch set adds, tests, and documents support for variable sized cells in cell arrays.  The new syntax is:     property = /size/ [8|16|32|64] 0x00

Re: [PATCH 2/3] dtc: Add data_append_literal function

2011-09-22 Thread Anton Staaf
On Wed, Sep 21, 2011 at 7:33 PM, David Gibson da...@gibson.dropbear.id.au wrote: On Wed, Sep 21, 2011 at 01:42:10PM -0700, Anton Staaf wrote: This function deals with appending literals of various sizes (8, 16 32, and 64 bit currently).  It handles endianess conversions and verifies that the

Re: [PATCH 3/3] dtc: Add support for variable sized cells

2011-09-22 Thread Anton Staaf
On Wed, Sep 21, 2011 at 7:42 PM, David Gibson da...@gibson.dropbear.id.au wrote: On Wed, Sep 21, 2011 at 01:42:11PM -0700, Anton Staaf wrote: Cells of size 8, 16, 32, and 64 bits are supported.  The new /size/ syntax was selected so as to not pollute the reserved keyword space with

[PATCH v2 0/3] Variable sized cell support

2011-09-22 Thread Anton Staaf
This patch set adds, tests, and documents support for variable sized cells in cell arrays. The new syntax is: property = /size/ [8|16|32|64] 0x00 0x12; So cell arrays of 8, 16, 32, or 64-bits can now be created. No padding is done on the resulting cell array. So if three 8-bit cells

[PATCH v2 1/3] libfdt: Add fdt16_to_cpu utility function

2011-09-22 Thread Anton Staaf
This utility routine will be used in the variable size cell literal append code. It is a straightforward adaptation of the fdt32_to_cpu function. Signed-off-by: Anton Staaf robot...@chromium.org Cc: Jon Loeliger j...@jdl.com Cc: David Gibson da...@gibson.dropbear.id.au Cc: Grant Likely

[PATCH v2 2/3] dtc: Add data_append_integer function

2011-09-22 Thread Anton Staaf
This function deals with appending integers of various sizes (8, 16 32, and 64 bit currently). It handles endianess conversions and verifies that the given integer is not larger than the specified size. Signed-off-by: Anton Staaf robot...@chromium.org Cc: David Gibson da...@gibson.dropbear.id.au

Re: [PATCH v5 1/5] Add fdt read/write utility functions

2011-09-22 Thread Jon Loeliger
This adds higher-level libfdt operations for reading/writing an fdt blob from/to a file, as well as a function to decode a data type string as will be used by fdtget, fdtput. This also adds a few tests for the simple type argument supported by utilfdt_decode_type. Signed-off-by: Simon

Re: [PATCH v5 2/5] Make testutils use utilfdt

2011-09-22 Thread Jon Loeliger
The load_blob() and save_blob() functions are very similar to the utilfdt versions. This removes the duplicated code. Signed-off-by: Simon Glass s...@chromium.org Acked-by: David Gibson da...@gibson.dropbear.id.au Applied. Thanks, jdl ___

Re: [PATCH v5 3/5] ftdump: use utilfdt to read blob

2011-09-22 Thread Jon Loeliger
Now that we have utilfdt_read(), ftdump should use it too. Signed-off-by: Simon Glass s...@chromium.org Acked-by: David Gibson da...@gibson.dropbear.id.au Applied. Thanks, jdl ___ devicetree-discuss mailing list devicetree-discuss@lists.ozlabs.org

Re: [PATCH v5 1/5] Add fdt read/write utility functions

2011-09-22 Thread Simon Glass
Hi Jon, On Thu, Sep 22, 2011 at 11:54 AM, Jon Loeliger j...@jdl.com wrote: This adds higher-level libfdt operations for reading/writing an fdt blob from/to a file, as well as a function to decode a data type string as will be used by fdtget, fdtput. This also adds a few tests for the simple

[PATCH 2/4] arm/dt: Tegra: Add pinmux node to tegra20.dtsi

2011-09-22 Thread Stephen Warren
Add a pinmux node to tegra20.dtsi in order to instantiate the future pinmux device. Signed-off-by: Stephen Warren swar...@nvidia.com --- See patch for details on dependencies. .../devicetree/bindings/pinmux/pinmux_nvidia.txt |5 + arch/arm/boot/dts/tegra20.dtsi

[PATCH 0/4] arm/tegra: Convert gpio pinmux to platform devices

2011-09-22 Thread Stephen Warren
in Russell's gpio branch, since it edits a file renamed there. I imagine the series will be merged into that branch. * The whole series is based off next-20110922 plus a couple patches in the ARM patch system (7094, 7095). * This series affects both the GPIO and pinmux drivers. Potentially

[PATCH 1/4] arm/tegra: Prep boards for gpio/pinmux conversion to pdevs

2011-09-22 Thread Stephen Warren
The Tegra GPIO driver will be converted from static registration via postcore_initcall() to be a platform device later in this patch series. A new Tegra pinmux platform device will also be added. Prepare for this by modifying all boards to register the appropriate platform devices before-hand, so

[PATCH 3/4] gpio/tegra: Convert to a platform device

2011-09-22 Thread Stephen Warren
Signed-off-by: Stephen Warren swar...@nvidia.com --- See patch for details on dependencies. drivers/gpio/gpio-tegra.c | 31 --- 1 files changed, 20 insertions(+), 11 deletions(-) diff --git a/drivers/gpio/gpio-tegra.c b/drivers/gpio/gpio-tegra.c index

[PATCH 4/4] arm/tegra: Convert pinmux driver to a platform device

2011-09-22 Thread Stephen Warren
Signed-off-by: Stephen Warren swar...@nvidia.com --- See patch for details on dependencies. arch/arm/mach-tegra/pinmux.c | 26 ++ 1 files changed, 26 insertions(+), 0 deletions(-) diff --git a/arch/arm/mach-tegra/pinmux.c b/arch/arm/mach-tegra/pinmux.c index

Re: [PATCH v2 2/3] dtc: Add data_append_integer function

2011-09-22 Thread David Gibson
On Thu, Sep 22, 2011 at 11:25:26AM -0700, Anton Staaf wrote: This function deals with appending integers of various sizes (8, 16 32, and 64 bit currently). It handles endianess conversions and verifies that the given integer is not larger than the specified size. Signed-off-by: Anton Staaf

Re: [PATCH 3/3] dtc: Add support for variable sized cells

2011-09-22 Thread David Gibson
On Thu, Sep 22, 2011 at 11:02:59AM -0700, Anton Staaf wrote: On Wed, Sep 21, 2011 at 7:42 PM, David Gibson da...@gibson.dropbear.id.au wrote: On Wed, Sep 21, 2011 at 01:42:11PM -0700, Anton Staaf wrote: Cells of size 8, 16, 32, and 64 bits are supported.  The new /size/ syntax was selected

Re: [PATCH 2/3] dtc: Add data_append_literal function

2011-09-22 Thread David Gibson
On Thu, Sep 22, 2011 at 10:57:58AM -0700, Anton Staaf wrote: On Wed, Sep 21, 2011 at 7:33 PM, David Gibson da...@gibson.dropbear.id.au wrote: On Wed, Sep 21, 2011 at 01:42:10PM -0700, Anton Staaf wrote: [snip] + +     if ((len 64) (value = (1ULL len))) +             die(Literal value

Re: [PATCH v5 4/5] Add fdtget utility to read property values from a device tree

2011-09-22 Thread David Gibson
On Thu, Sep 22, 2011 at 10:11:05AM -0700, Simon Glass wrote: This simply utility makes it easy for scripts to read values from the device tree. It is written in C and uses the same libfdt as the rest of the dtc package. What is it for: - Reading fdt values from scripts - Extracting fdt

Re: [PATCH v5 5/5] Add fdtput utility to write property values to a device tree

2011-09-22 Thread David Gibson
On Thu, Sep 22, 2011 at 10:11:06AM -0700, Simon Glass wrote: This simple utility allows writing of values into a device tree from the command line. It aimes to be the opposite of fdtget. What is it for: - Updating fdt values when a binary blob already exists (even though source may be

[PATCH v3] of/irq: introduce of_irq_init

2011-09-22 Thread Rob Herring
From: Rob Herring rob.herr...@calxeda.com of_irq_init will scan the devicetree for matching interrupt controller nodes. Then it calls an initialization function for each found controller in the proper order with parent nodes initialized before child nodes. Based on initial pseudo code from Grant

Re: [PATCHv2 3/3] picoxcell: add the DTS for the PC7302 board

2011-09-22 Thread Barry Song
2011/9/15 Jamie Iles ja...@jamieiles.com: On Thu, Sep 15, 2011 at 08:32:02AM -0300, Benjamin Herrenschmidt wrote: On Wed, 2011-08-24 at 15:41 +0100, Jamie Iles wrote: +   chosen { +           bootargs = console=ttyS0,115200 earlyprintk loglevel=9 root=ubi0:rootfs rw rootfstype=ubifs

Re: [PATCHv2 3/3] picoxcell: add the DTS for the PC7302 board

2011-09-22 Thread Benjamin Herrenschmidt
On Fri, 2011-09-23 at 10:31 +0800, Barry Song wrote: 2011/9/15 Jamie Iles ja...@jamieiles.com: On Thu, Sep 15, 2011 at 08:32:02AM -0300, Benjamin Herrenschmidt wrote: On Wed, 2011-08-24 at 15:41 +0100, Jamie Iles wrote: + chosen { + bootargs = console=ttyS0,115200

Re: [PATCH v2 2/3] dtc: Add data_append_integer function

2011-09-22 Thread Anton Staaf
On Thu, Sep 22, 2011 at 5:19 PM, David Gibson da...@gibson.dropbear.id.au wrote: On Thu, Sep 22, 2011 at 11:25:26AM -0700, Anton Staaf wrote: This function deals with appending integers of various sizes (8, 16 32, and 64 bit currently).  It handles endianess conversions and verifies that the

Re: [PATCH 2/3] dtc: Add data_append_literal function

2011-09-22 Thread Anton Staaf
On Thu, Sep 22, 2011 at 5:13 PM, David Gibson da...@gibson.dropbear.id.au wrote: On Thu, Sep 22, 2011 at 10:57:58AM -0700, Anton Staaf wrote: On Wed, Sep 21, 2011 at 7:33 PM, David Gibson da...@gibson.dropbear.id.au wrote: On Wed, Sep 21, 2011 at 01:42:10PM -0700, Anton Staaf wrote: [snip]