[PATCH] of/base: fix typos

2013-05-07 Thread Prabhakar Lad
From: Lad, Prabhakar prabhakar.cse...@gmail.com the function of_property_read_u8/16/32_array() has a parameter out_values, but the description mentioned it as out_value. This patch fixes this typo. Signed-off-by: Lad, Prabhakar prabhakar.cse...@gmail.com --- drivers/of/base.c | 12

Re: [PATCH v4] extcon: Palmas Extcon Driver

2013-05-07 Thread Chanwoo Choi
Hi Kishon, I add some opinion about this patch. On 05/06/2013 10:17 PM, Kishon Vijay Abraham I wrote: From: Graeme Gregory g...@slimlogic.co.uk This is the driver for the USB comparator built into the palmas chip. It handles the various USB OTG events that can be generated by cable

[PATCH] ARM: samsung: use #include for all device trees

2013-05-07 Thread Padmavathi Venna
Replace /include/ (dtc) with #include (C pre-processor) for all Samsung DT files Signed-off-by: Padmavathi Venna padm...@samsung.com --- This patch is dependent on below patches by Stephen Warren http://www.spinics.net/lists/linux-kbuild/msg07616.html arch/arm/boot/dts/exynos4.dtsi

Re: [PATCH v4] extcon: Palmas Extcon Driver

2013-05-07 Thread Kishon Vijay Abraham I
Hi, On Tuesday 07 May 2013 11:40 AM, Chanwoo Choi wrote: Hi Kishon, I add some opinion about this patch. On 05/06/2013 10:17 PM, Kishon Vijay Abraham I wrote: From: Graeme Gregory g...@slimlogic.co.uk This is the driver for the USB comparator built into the palmas chip. It handles the

[PATCH V2 0/3] clk: Samsung: audss: Register audio subsytem clocks using common clk framework

2013-05-07 Thread Padmavathi Venna
Samsung S5PV210 and Exynos SoC has a separate subsystem for audio. This subsystem has a internal clock controller which controls i2s0 and pcm0 clocks. This patch series adds the Samsung audio subsytem clock to the common clock framework and provides the I2S controllers clock information in the

[PATCH V2 2/3] ARM: dts: add Exynos audio subsystem clock controller node

2013-05-07 Thread Padmavathi Venna
Audio subsystem introduced in s5pv210 and exynos platforms which has a internal clock controller. This patch adds a node for the same on exynos5250. Signed-off-by: Padmavathi Venna padm...@samsung.com --- arch/arm/boot/dts/exynos5250.dtsi |6 ++ 1 files changed, 6 insertions(+), 0

Re: [PATCH v4] extcon: Palmas Extcon Driver

2013-05-07 Thread Chanwoo Choi
On 05/07/2013 03:25 PM, Kishon Vijay Abraham I wrote: Hi, On Tuesday 07 May 2013 11:40 AM, Chanwoo Choi wrote: Hi Kishon, I add some opinion about this patch. On 05/06/2013 10:17 PM, Kishon Vijay Abraham I wrote: From: Graeme Gregory g...@slimlogic.co.uk This is the driver for the USB

Re: [PATCH v4] extcon: Palmas Extcon Driver

2013-05-07 Thread Chanwoo Choi
On 05/07/2013 03:57 PM, Chanwoo Choi wrote: diff --git a/include/linux/extcon/extcon_palmas.h b/include/linux/extcon/extcon_palmas.h new file mode 100644 index 000..a5119c9 --- /dev/null +++ b/include/linux/extcon/extcon_palmas.h @@ -0,0 +1,26 @@ +/* + * extcon_palmas.h - palmas

Re: [PATCH v4] extcon: Palmas Extcon Driver

2013-05-07 Thread Mark Brown
On Tue, May 07, 2013 at 10:42:53AM +0530, Kishon Vijay Abraham I wrote: On Monday 06 May 2013 08:10 PM, Mark Brown wrote: On Mon, May 06, 2013 at 06:47:04PM +0530, Kishon Vijay Abraham I wrote: + if (palmas_usb-linkstat != PALMAS_USB_STATE_VBUS) { + if

Re: [PATCH v8 1/3] of/pci: Unify pci_process_bridge_OF_ranges from Microblaze and PowerPC

2013-05-07 Thread Andrew Murray
On Sun, May 05, 2013 at 03:41:49AM +0100, Benjamin Herrenschmidt wrote: On Mon, 2013-04-22 at 11:41 +0100, Andrew Murray wrote: The pci_process_bridge_OF_ranges function, used to parse the ranges property of a PCI host device, is found in both Microblaze and PowerPC architectures. These

Re: [PATCH v4] extcon: Palmas Extcon Driver

2013-05-07 Thread Kishon Vijay Abraham I
On Tuesday 07 May 2013 12:35 PM, Chanwoo Choi wrote: On 05/07/2013 03:57 PM, Chanwoo Choi wrote: diff --git a/include/linux/extcon/extcon_palmas.h b/include/linux/extcon/extcon_palmas.h new file mode 100644 index 000..a5119c9 --- /dev/null +++ b/include/linux/extcon/extcon_palmas.h @@ -0,0

Re: [PATCH RFC v3] media: i2c: mt9p031: add OF support

2013-05-07 Thread Prabhakar Lad
Hi Arnd, On Mon, May 6, 2013 at 8:29 PM, Prabhakar Lad prabhakar.cse...@gmail.com wrote: Hi Arnd, On Fri, May 3, 2013 at 8:04 PM, Arnd Bergmann a...@arndb.de wrote: On Friday 03 May 2013, Prabhakar Lad wrote: [snip] +} Ok, good. @@ -955,7 +998,17 @@ static int mt9p031_probe(struct

Re: [PATCH v4] extcon: Palmas Extcon Driver

2013-05-07 Thread Kishon Vijay Abraham I
Hi, On Tuesday 07 May 2013 01:28 PM, Mark Brown wrote: On Tue, May 07, 2013 at 10:42:53AM +0530, Kishon Vijay Abraham I wrote: On Monday 06 May 2013 08:10 PM, Mark Brown wrote: On Mon, May 06, 2013 at 06:47:04PM +0530, Kishon Vijay Abraham I wrote: + if (palmas_usb-linkstat !=

[PATCH] net: of_mdio: fix behavior on missing phy device

2013-05-07 Thread Sebastian Hesselbarth
of_mdiobus_register creates a phy_device even if get_phy_device failed to create it previously. This causes indefinite polling on non-existent PHYs. This fix makes of_mdio_register rely on get_phy_device to properly create the device or fail otherwise. Signed-off-by: Sebastian Hesselbarth

Re: [PATCH V2 2/3] ARM: dts: add Exynos audio subsystem clock controller node

2013-05-07 Thread Tomasz Figa
Hi Padmavathi, On Tuesday 07 of May 2013 12:13:35 Padmavathi Venna wrote: Audio subsystem introduced in s5pv210 and exynos platforms which has a internal clock controller. This patch adds a node for the same on exynos5250. Signed-off-by: Padmavathi Venna padm...@samsung.com ---

Re: [PATCH v8 1/3] of/pci: Unify pci_process_bridge_OF_ranges from Microblaze and PowerPC

2013-05-07 Thread Benjamin Herrenschmidt
On Tue, 2013-05-07 at 09:01 +0100, Andrew Murray wrote: There were no objections to this latest revision until now and it is currently sitting with Jason Cooper (mvebu-next/pcie). [1] Ok, well I've just sent Linus a pull request for my changes so at least drop the powerpc changes from your

Re: [PATCH v4] extcon: Palmas Extcon Driver

2013-05-07 Thread Mark Brown
On Tue, May 07, 2013 at 03:17:08PM +0530, Kishon Vijay Abraham I wrote: On Tuesday 07 May 2013 01:28 PM, Mark Brown wrote: The platform can provide it's own vbus control in which case this is not needed. So why is there no interaction with this external VBUS control and how does the driver

Re: [RFC PATCH v2] drivers: bus: add ARM CCI support

2013-05-07 Thread Lorenzo Pieralisi
On Fri, May 03, 2013 at 04:17:07PM +0100, Javi Merino wrote: Hi Lorenzo, On Wed, May 01, 2013 at 05:18:28PM +0100, Lorenzo Pieralisi wrote: On ARM multi-cluster systems coherency between cores running on different clusters is managed by the cache-coherent interconnect (CCI). It allows

Re: [PATCH V2 2/3] ARM: dts: add Exynos audio subsystem clock controller node

2013-05-07 Thread Padma Venkat
Hi Tomasz, On Tue, May 7, 2013 at 3:24 PM, Tomasz Figa t.f...@samsung.com wrote: Hi Padmavathi, On Tuesday 07 of May 2013 12:13:35 Padmavathi Venna wrote: Audio subsystem introduced in s5pv210 and exynos platforms which has a internal clock controller. This patch adds a node for the same on

[PATCH] pinctrl: single: fix error return code in pcs_parse_one_pinctrl_entry()

2013-05-07 Thread Wei Yongjun
From: Wei Yongjun yongjun_...@trendmicro.com.cn Fix to return a negative error code from the error handling case instead of 0, as done elsewhere in this function. Introduced by commit 9dddb4df90d136429b6d6ddefceb49a9b93f6cd1 (pinctrl: single: support generic pinconf) Signed-off-by: Wei Yongjun

Re: [PATCH v8] i2c: exynos5: add High Speed I2C controller driver

2013-05-07 Thread Sachin Kamat
On 7 May 2013 08:20, Naveen Krishna Chatradhi naveenkrishna...@gmail.com wrote: From: Naveen Krishna Chatradhi ch.nav...@samsung.com Adds support for High Speed I2C driver found in Exynos5 and later SoCs from Samsung. Driver only supports Device Tree method. Changes since v1: 1. Added

Re: [PATCH] pinctrl: single: fix error return code in pcs_parse_one_pinctrl_entry()

2013-05-07 Thread Haojian Zhuang
On 7 May 2013 20:06, Wei Yongjun weiyj...@gmail.com wrote: From: Wei Yongjun yongjun_...@trendmicro.com.cn Fix to return a negative error code from the error handling case instead of 0, as done elsewhere in this function. Introduced by commit 9dddb4df90d136429b6d6ddefceb49a9b93f6cd1

[PATCH] net/spider_net: fix error return code in spider_net_open()

2013-05-07 Thread Wei Yongjun
From: Wei Yongjun yongjun_...@trendmicro.com.cn Fix to return a negative error code from the error handling case instead of 0, as done elsewhere in this function. Signed-off-by: Wei Yongjun yongjun_...@trendmicro.com.cn --- drivers/net/ethernet/toshiba/spider_net.c | 3 ++- 1 file changed, 2

Re: [PATCH] pinctrl: single: fix error return code in pcs_parse_one_pinctrl_entry()

2013-05-07 Thread Wei Yongjun
On 05/07/2013 08:11 PM, Haojian Zhuang wrote: On 7 May 2013 20:06, Wei Yongjun weiyj...@gmail.com wrote: From: Wei Yongjun yongjun_...@trendmicro.com.cn Fix to return a negative error code from the error handling case instead of 0, as done elsewhere in this function. Introduced by commit

Re: [PATCH] pinctrl: single: fix error return code in pcs_parse_one_pinctrl_entry()

2013-05-07 Thread Haojian Zhuang
On 7 May 2013 20:57, Wei Yongjun weiyj...@gmail.com wrote: On 05/07/2013 08:11 PM, Haojian Zhuang wrote: On 7 May 2013 20:06, Wei Yongjun weiyj...@gmail.com wrote: From: Wei Yongjun yongjun_...@trendmicro.com.cn Fix to return a negative error code from the error handling case instead of 0,

[PATCH] powerpc/fsl_msi: fix error return code in fsl_of_msi_probe()

2013-05-07 Thread Wei Yongjun
From: Wei Yongjun yongjun_...@trendmicro.com.cn Fix to return a negative error code in the MSI bitmap alloc error handling case instead of 0, as done elsewhere in this function. Signed-off-by: Wei Yongjun yongjun_...@trendmicro.com.cn --- arch/powerpc/sysdev/fsl_msi.c | 5 ++--- 1 file changed,

Re: [RFC PATCH v2] drivers: bus: add ARM CCI support

2013-05-07 Thread Lorenzo Pieralisi
On Mon, May 06, 2013 at 04:05:28PM +0100, Nicolas Pitre wrote: Review comments below. Thanks Nico. On Wed, 1 May 2013, Lorenzo Pieralisi wrote: index 000..fb9e8e0 --- /dev/null +++ b/drivers/bus/arm-cci.c @@ -0,0 +1,372 @@ +/* + * CCI cache coherent interconnect driver + *

Re: [RFC 0/2] V4L2 API for exposing flash subdevs as LED class device

2013-05-07 Thread Laurent Pinchart
On Tuesday 07 May 2013 02:11:27 Kim, Milo wrote: On Monday, May 06, 2013 6:34 PM Andrzej Hajda wrote: This RFC proposes generic API for exposing flash subdevices via LED framework. Rationale Currently there are two frameworks which are used for exposing LED flash to user space:

Re: [RFC PATCH v2] drivers: bus: add ARM CCI support

2013-05-07 Thread Nicolas Pitre
On Tue, 7 May 2013, Lorenzo Pieralisi wrote: On Mon, May 06, 2013 at 04:05:28PM +0100, Nicolas Pitre wrote: When compiled in, module_init() is translated into device_initcall(). This is way too late for bringing up secondary CPUs during boot via the MCPM layer. That is not an issue as far

[PATCH v9 2/3] of/pci: mips: convert to common of_pci_range_parser

2013-05-07 Thread Andrew Murray
This patch converts the pci_load_of_ranges function to use the new common of_pci_range_parser. Signed-off-by: Andrew Murray andrew.mur...@arm.com Signed-off-by: Liviu Dudau liviu.du...@arm.com Signed-off-by: Gabor Juhos juh...@openwrt.org Reviewed-by: Rob Herring rob.herr...@calxeda.com

[PATCH v9 0/3] of/pci: Provide common support for PCI DT parsing

2013-05-07 Thread Andrew Murray
This patchset factors out duplicated code associated with parsing PCI DT ranges properties across the architectures and introduces a ranges parser. This parser of_pci_range_parser can be used directly by ARM host bridge drivers enabling them to obtain ranges from device trees. I've included the

[PATCH v9 1/3] of/pci: Provide support for parsing PCI DT ranges property

2013-05-07 Thread Andrew Murray
This patch factors out common implementation patterns to reduce overall kernel code and provide a means for host bridge drivers to directly obtain struct resources from the DT's ranges property without relying on architecture specific DT handling. This will make it easier to write archiecture

[PATCH v9 3/3] of/pci: microblaze: convert to common of_pci_range_parser

2013-05-07 Thread Andrew Murray
This patch converts the pci_load_of_ranges function to use the new common of_pci_range_parser. Signed-off-by: Andrew Murray andrew.mur...@arm.com Signed-off-by: Liviu Dudau liviu.du...@arm.com --- arch/microblaze/pci/pci-common.c | 106 ++ 1 files changed, 38

Re: [PATCH 3/3] ARM: kirkwood: remove clock gating disabling for km_kirkwood

2013-05-07 Thread Jason Cooper
Valentin, Nice series! I thought once the mv643xx_eth DT bindings take hold that this was going to be one of the holdovers with a custom board init file. Looks like that won't be the case ;-) On Tue, May 07, 2013 at 05:52:21PM +0200, Valentin Longchamp wrote: A new clock gating controller is

Re: [PATCH 1/3] clk: mvebu: add gate ctrl for Prestera kirkwood variants

2013-05-07 Thread Gregory CLEMENT
On 05/07/2013 05:52 PM, Valentin Longchamp wrote: The kirkwood device found in the Prestera SoCs does not have all the peripherals of its the usual kirkwood SoCs. There are hence missing clocks in the SoCs. This patch registers another gate controller for the kirkwood that registers only

[PATCH v4 0/19] Allow images to work on sandbox

2013-05-07 Thread Simon Glass
This series adjusts the image code to work with sandbox and prepares it for verified boot to come later. The primary goal here is to get image loading to work on sandbox, which is mostly a set of fairly minor changes such as using map_sysmem() instead of just a cast when converting from a U-Boot

[PATCH v4 06/19] libfdt: Add fdt_next_subnode() to permit easy subnode iteration

2013-05-07 Thread Simon Glass
Iterating through subnodes with libfdt is a little painful to write as we need something like this: for (depth = 0, count = 0, offset = fdt_next_node(fdt, parent_offset, depth); (offset = 0) (depth 0); offset = fdt_next_node(fdt, offset, depth)) { if (depth == 1) {

Re: [PATCH 1/3] clk: mvebu: add gate ctrl for Prestera kirkwood variants

2013-05-07 Thread Andrew Lunn
On Tue, May 07, 2013 at 06:11:44PM +0200, Gregory CLEMENT wrote: On 05/07/2013 05:52 PM, Valentin Longchamp wrote: The kirkwood device found in the Prestera SoCs does not have all the peripherals of its the usual kirkwood SoCs. There are hence missing clocks in the SoCs. This patch

Re: [PATCH 1/3] clk: mvebu: add gate ctrl for Prestera kirkwood variants

2013-05-07 Thread Sebastian Hesselbarth
On 05/07/2013 06:11 PM, Gregory CLEMENT wrote: On 05/07/2013 05:52 PM, Valentin Longchamp wrote: The kirkwood device found in the Prestera SoCs does not have all the peripherals of its the usual kirkwood SoCs. There are hence missing clocks in the SoCs. This patch registers another gate

[PATCH RESEND] genirq: add function to get IRQ edge/level flags

2013-05-07 Thread Javier Martinez Canillas
According to Documentation/devicetree/bindings/interrupt-controller/interrupts.txt the #interrupt-cells property of an interrupt-controller is used to define the number of cells needed to specify a single interrupt. A commonly used variant is two cell on which #interrupt-cells = 2 and the first

Re: [PATCH V2] video: implement a simple framebuffer driver

2013-05-07 Thread Andrew Morton
We don't seem to have a well-defined path to travel here, and I don't get the feeling that anyone has signed up to walk it? So I'm inclined to merge Stephen's patch as-is into 3.10. It's pretty simple and standalone. Any strenuous objections? BTW, Olof told me off-list that this patch is a

Re: [U-Boot] [PATCH v4 06/19] libfdt: Add fdt_next_subnode() to permit easy subnode iteration

2013-05-07 Thread Jerry Van Baren
Hi Simon, On 05/07/2013 12:11 PM, Simon Glass wrote: Iterating through subnodes with libfdt is a little painful to write as we need something like this: [snip] Signed-off-by: Simon Glass s...@chromium.org (Cherry-picked from dtc commit 4e76ec79) Acked-by: Gerald Van Baren

Re: [PATCH RFC v3] media: i2c: mt9p031: add OF support

2013-05-07 Thread Laurent Pinchart
Hi Prabhakar, Thank you for the patch. On Friday 03 May 2013 12:21:59 Prabhakar Lad wrote: From: Lad, Prabhakar prabhakar.cse...@gmail.com add OF support for the mt9p031 sensor driver. Alongside this patch sorts the header inclusion alphabetically. Signed-off-by: Lad, Prabhakar

Re: [PATCH RFC v3] media: i2c: mt9p031: add OF support

2013-05-07 Thread Laurent Pinchart
Hi Prabhakar, On Tuesday 07 May 2013 15:10:36 Prabhakar Lad wrote: On Mon, May 6, 2013 at 8:29 PM, Prabhakar Lad wrote: On Fri, May 3, 2013 at 8:04 PM, Arnd Bergmann a...@arndb.de wrote: On Friday 03 May 2013, Prabhakar Lad wrote: [snip] +} Ok, good. @@ -955,7 +998,17 @@

Re: [PATCH V2] video: implement a simple framebuffer driver

2013-05-07 Thread Stephen Warren
On 05/07/2013 03:33 PM, Andrew Morton wrote: We don't seem to have a well-defined path to travel here, and I don't get the feeling that anyone has signed up to walk it? So I'm inclined to merge Stephen's patch as-is into 3.10. It's pretty simple and standalone. Any strenuous objections?

Re: [PATCH RFC v3] media: i2c: mt9p031: add OF support

2013-05-07 Thread Prabhakar Lad
HI Laurent, On Wed, May 8, 2013 at 7:31 AM, Laurent Pinchart laurent.pinch...@ideasonboard.com wrote: Hi Prabhakar, Thank you for the patch. On Friday 03 May 2013 12:21:59 Prabhakar Lad wrote: From: Lad, Prabhakar prabhakar.cse...@gmail.com add OF support for the mt9p031 sensor driver.

Re: [PATCH RFC v3] media: i2c: mt9p031: add OF support

2013-05-07 Thread Prabhakar Lad
Hi Laurent, On Wed, May 8, 2013 at 7:32 AM, Laurent Pinchart laurent.pinch...@ideasonboard.com wrote: Hi Prabhakar, On Tuesday 07 May 2013 15:10:36 Prabhakar Lad wrote: On Mon, May 6, 2013 at 8:29 PM, Prabhakar Lad wrote: On Fri, May 3, 2013 at 8:04 PM, Arnd Bergmann a...@arndb.de wrote: