Re: Questions about windows support

2012-02-23 Thread Christopher Nicholson-Sauls
h cool # just to put a file in there $ ls -l cool $ ls * # the lol file is interpreted as an option! -rw-r--r-- 1 me users 0 2012-02-20 22:18 cool $ imagine the poor newb trying to understand that! +1, LOL. T rsync -aAHX src dest && rm -fr src -- Christopher Nicholson-Sauls

Re: Proposal for std.path replacement

2011-03-06 Thread Christopher Nicholson-Sauls
On 03/07/11 00:24, Jonathan M Davis wrote: > On Sunday 06 March 2011 22:09:22 Nick Sabalausky wrote: >> "Jonathan M Davis" wrote in message >> news:mailman.2280.1299459971.4748.digitalmar...@puremagic.com... >> >>> This reminds me. I should look into mime types one of these days to see >>> what th

Re: Proposal for std.path replacement

2011-03-06 Thread Christopher Nicholson-Sauls
On 03/07/11 00:09, Nick Sabalausky wrote: > "Jonathan M Davis" wrote in message > news:mailman.2280.1299459971.4748.digitalmar...@puremagic.com... >> >> This reminds me. I should look into mime types one of these days to see >> what the >> appropriate way (if any) would be to put support for the

Re: alias this question

2011-02-16 Thread Christopher Nicholson-Sauls
On 02/13/11 10:30, Olli Aalto wrote: > I encountered a problem with alias this, when the aliased member is > private. I'm using the latest dmd2. It reports the follwing: > src\main.d(14): Error: struct K.K member s is not accessible > > If I change the private modifier on the s member to public it

Re: Stupid little iota of an idea

2011-02-12 Thread Christopher Nicholson-Sauls
On 02/12/11 04:08, Olivier Pisano wrote: > Le 12/02/11 10:36, Olivier Pisano a écrit : >> 4) I believe a function name should tell what it does. An alphabet >> letter (greek or not) is a poor indication and should be avoided. "sum" >> is a more reasonable choice than "epsilon", even if that what we

Re: Stupid little iota of an idea

2011-02-12 Thread Christopher Nicholson-Sauls
On 02/11/11 19:36, Daniel Gibson wrote: > Am 12.02.2011 02:25, schrieb bearophile: >> Michel Fortin: >> >>> No one noticed yet that the a..b:c syntax causes ambiguity? Tell me, >>> how do you rewrite this using the new proposed syntax: >>> >>> auto aa = [iota(a, b, c): 1, iota(d, e): 2]; >> >>

Re: Stupid little iota of an idea

2011-02-12 Thread Christopher Nicholson-Sauls
On 02/11/11 18:46, so wrote: >> atob(1, 6) // easy to mix things like atoi >> ptoq(1, 6) // rocks imo! > > walk(1, 6) // now you have admit this is the best. I dunno. When I see 'walk' I think of collections, not ranges. But... I don't think it'd be terribly ambiguous, at least. For the record

Re: inlining or not inlining...

2011-02-12 Thread Christopher Nicholson-Sauls
> > All of this is hardly related to the simple feature I initially asked for: > > string escString (string s) @tellmeifnotinlined { > s2 = s.replace("\n","\\n"); > s2 = s.replace("\t","\\t"); > return s2; > } > void show (X x) { > // ... use es

Re: inlining or not inlining...

2011-02-11 Thread Christopher Nicholson-Sauls
On 02/11/11 14:26, Jim wrote: > Jim Wrote: > >> bearophile Wrote: >>> The LLVM back-end of LDC is able to inline much more, but even here a list >>> of inlined/not inlined functions helps. D is almost a system language, so >>> sometimes you need to go lower level (or you just need a program that

Re: More on Rust

2011-02-11 Thread Christopher Nicholson-Sauls
On 02/10/11 13:49, Andrej Mitrovic wrote: > On 2/10/11, Walter Bright wrote: >> auto x = (localtime().hours >= 8) ? "awake!" : "asleep, go away."; > > Aye, a one liner! > > I hate seeing things like this: > if (funcall()) > { > var = "foo"; > } > else > { > var = "bar"; > } > > So much

Re: More on the necessity and difficulty of a package management system

2011-02-08 Thread Christopher Nicholson-Sauls
On 01/26/11 16:45, Andrei Alexandrescu wrote: > Seems to be unduly difficult in Python: > > http://www.google.com/buzz/michael.bruntonspall/AcMtiMEUgZ2/Packaging-and-deploying-python-web-apps > > > We need to have a good solution for D. > > > Andrei This seems related to a project I've been p

Re: Writing XML

2011-02-08 Thread Christopher Nicholson-Sauls
On 02/06/11 18:18, Tomek Sowiński wrote: > Rainer Schuetze napisał: > >> This looks nice and compact Using opDispatch to specify the tag (I guess >> that is what you are using to create a tag "book" by calling xml.book()) >> feels like misusing opDispatch, though. Does it add readability in >>

Re: Filtering even numbers in various languages

2011-02-08 Thread Christopher Nicholson-Sauls
On 02/08/11 19:02, Andrei Alexandrescu wrote: > https://gist.github.com/817504 > > I added a D version. > > Andrei I would argue that (a & 1 == 0) is a cheaper simple test for evenness... Good show. Not really sure what the point of the list was... but sometimes these things are just (for) f

Re: Python's partition

2011-01-22 Thread Christopher Nicholson-Sauls
On 01/22/11 15:38, Andrei Alexandrescu wrote: > On 1/22/11 3:33 PM, Christopher Nicholson-Sauls wrote: >> On 01/22/11 11:44, Andrei Alexandrescu wrote: >>> Looking through Python's string functions >>> (http://docs.python.org/release/2.5.2/lib/string-metho

Re: Python's partition

2011-01-22 Thread Christopher Nicholson-Sauls
On 01/22/11 11:44, Andrei Alexandrescu wrote: > Looking through Python's string functions > (http://docs.python.org/release/2.5.2/lib/string-methods.html) I noticed > partition(): > > partition(sep) > Split the string at the first occurrence of sep, and return a > 3-tuple containing the part b

Re: Why is the "in" storage class missing from the ParameterStorageClass enum?

2011-01-22 Thread Christopher Nicholson-Sauls
On 01/20/11 21:57, Andrej Mitrovic wrote: > On 1/21/11, Jonathan M Davis wrote: >> Umm. in is never the default. in is essentially an alias for const scope. >> The >> default is non-shared and mutable. >> >> - Jonathan M Davis >> > > That's what I thought. But I did saw it mentioned in this NG a

Re: easy to upgrade OS (was Re: DVCS)

2011-01-22 Thread Christopher Nicholson-Sauls
On 01/22/11 03:57, spir wrote: > On 01/22/2011 09:58 AM, Walter Bright wrote: >> Gour wrote: >>> I'm very seriously considering to put PC-BSD on my desktop and of >>> several others in order to reduce my admin-time required to maint. all >>> those machines. >> >> OSX is the only OS (besides DOS) I'

Re: What Makes A Programming Language Good

2011-01-18 Thread Christopher Nicholson-Sauls
On 01/18/11 03:11, Vladimir Panteleev wrote: > On Tue, 18 Jan 2011 11:05:34 +0200, Walter Bright > wrote: > >> Vladimir Panteleev wrote: >>> On Tue, 18 Jan 2011 07:20:56 +0200, Walter Bright >>> wrote: >>> http://urbanhonking.com/ideasfordozens/2011/01/18/what-makes-a-programming-language-g

Re: repeat

2011-01-18 Thread Christopher Nicholson-Sauls
On 01/18/11 03:07, Walter Bright wrote: > Andrei Alexandrescu wrote: >> I want to generalize the functionality in string's repeat and move it >> outside std.string. There is an obvious semantic clash here. If you >> say repeat("abc", 3) did you mean one string "abcabcabc" or three >> strings "abc",

Re: DVCS (was Re: Moving to D)

2011-01-12 Thread Christopher Nicholson-Sauls
On 01/11/11 15:36, Walter Bright wrote: > Andrej Mitrovic wrote: >> That's my biggest problem with Linux. Having technical problems is not >> the issue, finding the right solution in the sea of forum posts is the >> problem. > > The worst ones begin with "you might try this..." or "I think this mi

Re: DVCS (was Re: Moving to D)

2011-01-12 Thread Christopher Nicholson-Sauls
On 01/10/11 21:14, retard wrote: > Sun, 09 Jan 2011 06:00:21 -0600, Christopher Nicholson-Sauls wrote: > >> On 01/08/11 20:18, Walter Bright wrote: >>> Vladimir Panteleev wrote: >>>> On Sun, 09 Jan 2011 00:34:19 +0200, Walter Bright >>>> wrote: >

Re: Is this a bug?

2011-01-09 Thread Christopher Nicholson-Sauls
On 01/09/11 16:28, Sean Eskapp wrote: > This code works fine: > > int[] arr = [ 1, 2, 3, 4, 5 ]; > auto myMax = function int(int a, int b) { return (a > b) ? a : b; }; > auto biggest = reduce!(myMax)(arr); > > But passing the function literal directly to reduce causes an error.

Re: DVCS (was Re: Moving to D)

2011-01-09 Thread Christopher Nicholson-Sauls
On 01/08/11 20:18, Walter Bright wrote: > Vladimir Panteleev wrote: >> On Sun, 09 Jan 2011 00:34:19 +0200, Walter Bright >> wrote: >> >>> Yeah, I could spend an afternoon doing that. >> >> sudo apt-get build-dep meld >> wget http://ftp.gnome.org/pub/gnome/sources/meld/1.5/meld-1.5.0.tar.bz2 >> tar

Re: D vs C++

2010-12-29 Thread Christopher Nicholson-Sauls
On 12/28/10 12:04, Caligo wrote: > > I just read the section on mixins in chapter 3 and my jaw hit the floor. > Yeah, I had that reaction as well. Combined with CTFE, mixins and string mixins can do some pretty amazing things. Sometimes the addition of Tuples can make it even better. For exam

Re: Game development is worthless? WTF? (Was: Why Ruby?)

2010-12-20 Thread Christopher Nicholson-Sauls
On 12/19/10 14:52, Nick Sabalausky wrote: > "Daniel Gibson" wrote in message > news:mailman.37.1292790264.4748.digitalmar...@puremagic.com... >> On Sun, Dec 19, 2010 at 5:41 PM, Caligo wrote: >>> You are absolutely right; life sucks for many people, and that's why some >>> of >>> them choose to

Re: Game development is worthless? WTF? (Was: Why Ruby?)

2010-12-20 Thread Christopher Nicholson-Sauls
On 12/19/10 14:00, Nick Sabalausky wrote: > "Caligo" wrote in message > news:mailman.30.1292776925.4748.digitalmar...@puremagic.com... >> You are absolutely right; life sucks for many people, and that's why some >> of >> them choose to play video games. It gives them a chance to escape >> real

Re: Game development is worthless? WTF? (Was: Why Ruby?)

2010-12-20 Thread Christopher Nicholson-Sauls
On 12/20/10 04:25, Max Samukha wrote: > On 12/19/2010 09:48 PM, Nick Sabalausky wrote: > >>> >> >> Assuming you meant that as a sarcastic counter-example: There may be >> ways in >> which they make life suck less, but *overall*, they're generally >> considered >> to make life suck *more*. So the "

Re: Game development is worthless? WTF? (Was: Why Ruby?)

2010-12-19 Thread Christopher Nicholson-Sauls
On 12/19/10 04:19, bearophile wrote: > Christopher Nicholson-Sauls: > >> So no, games in and of themselves don't contribute anything -- if you >> don't count fun, and honestly, I do count it -- but they have been a >> driving force behind a lot of innovation. >

Re: Why Ruby?

2010-12-19 Thread Christopher Nicholson-Sauls
On 12/19/10 01:29, spir wrote: > On Sat, 18 Dec 2010 18:13:50 -0800 > Walter Bright wrote: > >>> you could write: >>> sort!(@1>@2)(x); >> [...] >>> I think this idea (or something similar) is worth consideration. It is >>> simply a small extension to an already existing feature that would g

Re: Game development is worthless? WTF? (Was: Why Ruby?)

2010-12-19 Thread Christopher Nicholson-Sauls
On 12/18/10 14:12, Nick Sabalausky wrote: > "Nick Sabalausky" wrote in message > news:iej46p$42...@digitalmars.com... >> "Caligo" wrote in message >> news:mailman.5.1292651710.4588.digitalmar...@puremagic.com... >>> >>> IMO there is no honor in game development as it contributes nothing to >>>

Re: [OT] Mozilla Thunderbird

2010-12-17 Thread Christopher Nicholson-Sauls
On 12/16/10 07:39, Justin Johansson wrote: > Just wondering how others rate Thunderbird as a decent newsreader. > > My experience with Thunderbird is that it is not of a standard of > distinction that one would hope for in 2010 coming 2011. > > For one thing, and perhaps this is a newsgroup serve

Re: ByToken Range

2010-12-11 Thread Christopher Nicholson-Sauls
On 12/11/10 22:41, Matthias Walter wrote: > Hi all, > > I wrote a ByToken tokenizer that models Range, i.e. it can be used in a > foreach loop to read from a std.stdio.File. For it to work one has to > supply it with a delegate, taking a current buffer and a controller > class instance. It is call

Re: Why Ruby?

2010-12-10 Thread Christopher Nicholson-Sauls
On 12/10/10 19:26, Ary Borenszweig wrote: > http://vimeo.com/17420638 > > A very interesting talk. > > I used to like D. To write code in a high level while at the same > time being very close to the machine, with class invariants, unit > tests and many other features seemed very appealing. But I

Re: Please vote on std.datetime

2010-12-10 Thread Christopher Nicholson-Sauls
On 12/10/10 18:17, Jonathan M Davis wrote: > On Friday, December 10, 2010 15:29:40 Fawzi Mohamed wrote: >> On 10-dic-10, at 20:07, Jonathan M Davis wrote: >>> On Friday, December 10, 2010 09:55:02 Fawzi Mohamed wrote: On 10-dic-10, at 18:02, Jonathan M Davis wrote: thanks for the ans

Re: DMD2 .deb fails to install on Ubuntu 10.10 – just remove »shell« ?

2010-12-08 Thread Christopher Nicholson-Sauls
On 12/08/10 19:50, Ellery Newcomer wrote: > Quick - which gets executed first - /usr/bin/* or /usr/local/bin/* ? > > Either way, someone or something is going to be surprised. > > It would probably be a better idea to either remove or rename the less > used ones. 'shell' is uncomfortably generic