Array slice assign syntax

2011-11-15 Thread bearophile
The Bugzilla issues that I really care about is a not an useless long list, it's about fifteen items long, and this post is about one of them. I think current array slice assign syntax is a bit messy, and I think this should be addressed. Kenji Hara has recently written a very nice pr

Re: Array slice assign syntax

2011-11-16 Thread Manu
The Bugzilla issues that I really care about is a not an useless long > list, it's about fifteen items long, and this post is about one of them. > > I think current array slice assign syntax is a bit messy, and I think this > should be addressed. > > Kenji Hara has recently w

Re: Array slice assign syntax

2011-11-16 Thread Marco Leise
a = b for two static arrays of the same type and size is ok for me, especially when the size is small. I get your point though and like a strict syntax, too. The notion of a vector operation always using [] seems natural.

Re: Array slice assign syntax

2011-11-16 Thread Simen Kjærås
On Wed, 16 Nov 2011 04:24:25 +0100, bearophile wrote: [Good stuff] Votes++

Re: Array slice assign syntax

2011-11-16 Thread Regan Heath
On Wed, 16 Nov 2011 03:24:25 -, bearophile wrote: +1 vote toward looking into this more. I like the idea of a more consistent syntax, and the [] requirement for vector operations vs single/simple assignment. Lot of time ago I have opened bug issue 3971 on this topic, but that Bugz

Re: Array slice assign syntax

2011-11-16 Thread Timon Gehr
On 11/16/2011 04:24 AM, bearophile wrote: The Bugzilla issues that I really care about is a not an useless long list, it's about fifteen items long, and this post is about one of them. I think current array slice assign syntax is a bit messy, and I think this should be addressed. Kenji

Re: Array slice assign syntax

2011-11-17 Thread Martin Nowak
On Wed, 16 Nov 2011 19:47:47 +0100, Timon Gehr wrote: On 11/16/2011 04:24 AM, bearophile wrote: The Bugzilla issues that I really care about is a not an useless long list, it's about fifteen items long, and this post is about one of them. I think current array slice assign syntax is

Re: Array slice assign syntax

2011-11-17 Thread Timon Gehr
think current array slice assign syntax is a bit messy, and I think this should be addressed. Kenji Hara has recently written a very nice program (that here I have modified a bit for clarity) that shows the current array assign situation: import std.stdio, std.typetuple; void main() { writeln(&q