https://issues.dlang.org/show_bug.cgi?id=8755
Jack Stouffer changed:
What|Removed |Added
Status|NEW |RESOLVED
CC|
https://d.puremagic.com/issues/show_bug.cgi?id=8755
--- Comment #21 from bearophile_h...@eml.cc 2014-03-21 05:32:04 PDT ---
(In reply to comment #20)
> I'm not sure it's a fair reference, because Phobos doesn't "do" anything, it
> just provides function. I'd be willing to bet there is a fair am
https://d.puremagic.com/issues/show_bug.cgi?id=8755
--- Comment #20 from monarchdo...@gmail.com 2014-03-21 05:07:58 PDT ---
(In reply to comment #18)
> What I don't like is to give only 1 single scalar argument if you have N
> functions and then implicitly multiply the single seed N times. Simil
https://d.puremagic.com/issues/show_bug.cgi?id=8755
--- Comment #19 from bearophile_h...@eml.cc 2014-03-21 04:03:46 PDT ---
See also Issue 10670
--
Configure issuemail: https://d.puremagic.com/issues/userprefs.cgi?tab=email
--- You are receiving this mail because: ---
https://d.puremagic.com/issues/show_bug.cgi?id=8755
--- Comment #18 from bearophile_h...@eml.cc 2014-03-21 03:46:15 PDT ---
(In reply to comment #17)
> it would be possible to make `Tuple` and
> `args...` co-exist as input argument style. EG:
>
> r = a.fold!("a + b", "a + b * b")(0.0, 0.0); //
https://d.puremagic.com/issues/show_bug.cgi?id=8755
--- Comment #17 from monarchdo...@gmail.com 2014-03-21 01:51:41 PDT ---
(In reply to comment #14)
> >Furthermore, it also improves usability by making the seeds passed by
> >parameter pack, instead of forcing the use of a tuple.<
>
> OK. (Des
https://d.puremagic.com/issues/show_bug.cgi?id=8755
--- Comment #16 from monarchdo...@gmail.com 2014-03-21 01:44:56 PDT ---
(In reply to comment #15)
> Why is reduce (sorry, fold) allowing multiple function arguments in the first
> place?
>
> If you want to compose functions to avoid another O(
https://d.puremagic.com/issues/show_bug.cgi?id=8755
--- Comment #15 from wihkman 2014-03-20 20:02:07 PDT ---
Why is reduce (sorry, fold) allowing multiple function arguments in the first
place?
If you want to compose functions to avoid another O(n) iteration, then you
should compose the reduce
https://d.puremagic.com/issues/show_bug.cgi?id=8755
--- Comment #14 from bearophile_h...@eml.cc 2014-03-20 18:28:41 PDT ---
>Furthermore, it also improves usability by making the seeds passed by
>parameter pack, instead of forcing the use of a tuple.<
OK. (Despite in a modern language tuples s
https://d.puremagic.com/issues/show_bug.cgi?id=8755
--- Comment #13 from monarchdo...@gmail.com 2014-03-20 12:32:49 PDT ---
(In reply to comment #12)
> (In reply to comment #10)
> > How about "fold" instead, that's the classical functional programming name
> > for
> > that. Also there is foldl
https://d.puremagic.com/issues/show_bug.cgi?id=8755
--- Comment #12 from monarchdo...@gmail.com 2014-02-21 13:56:43 PST ---
(In reply to comment #10)
> How about "fold" instead, that's the classical functional programming name for
> that. Also there is foldl and foldr in Haskell.
"Introduce fol
https://d.puremagic.com/issues/show_bug.cgi?id=8755
--- Comment #11 from monarchdo...@gmail.com 2014-02-19 14:53:47 PST ---
(In reply to comment #10)
> How about "fold" instead, that's the classical functional programming name for
> that. Also there is foldl and foldr in Haskell.
Took a quick l
https://d.puremagic.com/issues/show_bug.cgi?id=8755
--- Comment #10 from Martin Nowak 2014-02-19 14:05:12 PST ---
How about "fold" instead, that's the classical functional programming name for
that. Also there is foldl and foldr in Haskell.
--
Configure issuemail: https://d.puremagic.com/issu
https://d.puremagic.com/issues/show_bug.cgi?id=8755
--- Comment #9 from monarchdo...@gmail.com 2014-02-19 14:00:05 PST ---
(In reply to comment #7)
> Haskell has a function call flip for this.
> http://hackage.haskell.org/package/base-4.6.0.1/docs/Prelude.html#v:flip
>
> It turns a function tak
https://d.puremagic.com/issues/show_bug.cgi?id=8755
--- Comment #8 from bearophile_h...@eml.cc 2014-01-25 02:20:53 PST ---
(In reply to comment #7)
> Maybe we could rename it to flipArgs to make it useable?
Beside changing the order of reduce arguments you can also shorten the name of
that fli
https://d.puremagic.com/issues/show_bug.cgi?id=8755
Martin Nowak changed:
What|Removed |Added
CC||c...@dawg.eu
--- Comment #7 from Marti
http://d.puremagic.com/issues/show_bug.cgi?id=8755
Peter Alexander changed:
What|Removed |Added
CC||daniel...@bigpond.com
--- Comment #6
http://d.puremagic.com/issues/show_bug.cgi?id=8755
monarchdo...@gmail.com changed:
What|Removed |Added
CC||monarchdo...@gmail.com
--- Com
http://d.puremagic.com/issues/show_bug.cgi?id=8755
Denis Shelomovskij changed:
What|Removed |Added
CC||verylonglogin@gmail.com
--- C
http://d.puremagic.com/issues/show_bug.cgi?id=8755
--- Comment #3 from bearophile_h...@eml.cc 2012-10-04 12:26:41 PDT ---
(In reply to comment #2)
> Why is it any different to sort being "a < b" by default? Should we require
> that sort is always sort!"a < b"?
It's different because it's widel
http://d.puremagic.com/issues/show_bug.cgi?id=8755
--- Comment #2 from adamsib...@hotmail.com 2012-10-04 10:03:04 PDT ---
> This is not a good idea. Invisible defaults are magic, and magic is bad.
Why is it any different to sort being "a < b" by default? Should we require
that sort is always so
http://d.puremagic.com/issues/show_bug.cgi?id=8755
bearophile_h...@eml.cc changed:
What|Removed |Added
CC||bearophile_h...@eml.cc
--- Com
22 matches
Mail list logo