Re: [git pull] drm fixes for 5.16-rc3

2022-01-09 Thread Geert Uytterhoeven
On Sat, Nov 27, 2021 at 8:29 PM wrote: > The pull request you sent on Fri, 26 Nov 2021 10:52:04 +1000: > > > git://anongit.freedesktop.org/drm/drm tags/drm-fixes-2021-11-26 > > has been merged into torvalds/linux.git: > https://git.kernel.org/torvalds/c/a4849f6000e29235a2707f22e39da6b897bb9543

Re: [PATCH] dma-buf: Move sysfs work out of DMA-BUF export/release path

2022-01-09 Thread Christian König
Am 07.01.22 um 22:25 schrieb Hridya Valsaraju: On Fri, Jan 7, 2022 at 10:17 AM Hridya Valsaraju wrote: On Fri, Jan 7, 2022 at 2:22 AM Christian König wrote: Am 06.01.22 um 20:04 schrieb Hridya Valsaraju: On Thu, Jan 6, 2022 at 12:59 AM Christian König wrote: Am 05.01.22 um 00:51 schrieb

[PATCH] drm/tegra: Fix reference leak in tegra_dsi_ganged_probe

2022-01-09 Thread Miaoqian Lin
The reference taken by 'of_find_device_by_node()' must be released when not needed anymore. Add put_device() call to fix this. Fixes: e94236cde4d5 ("drm/tegra: dsi: Add ganged mode support") Signed-off-by: Miaoqian Lin --- drivers/gpu/drm/tegra/dsi.c | 4 +++- 1 file changed, 3 insertions(+), 1

Re: [PATCH v2] drm/v3d: Fix PM disable depth imbalance in v3d_platform_drm_probe

2022-01-09 Thread Miaoqian Lin
Hi Melissa, On Sun, Jan 09, 2022 at 04:48:17PM -0100, Melissa Wen wrote: > On 01/06, Miaoqian Lin wrote: > > The pm_runtime_enable will increase power disable depth. > > If the probe fails, we should use pm_runtime_disable() to balance > > pm_runtime_enable(). > > > > if (ret) > > -

[PATCH v2] drm/v3d/v3d_drv: Check for error num after setting mask

2022-01-09 Thread Jiasheng Jiang
Because of the possible failure of the dma_supported(), the dma_set_mask_and_coherent() may return error num. Therefore, it should be better to check it and return the error if fails. Also, we can create a variable for the mask to solve the alignment issue. Fixes: 334dd38a3878 ("drm/v3d: Set

Re: [PATCH] drm/bridge: adv7533: make array clock_div_by_lanes static const

2022-01-09 Thread Laurent Pinchart
Hi Colin, Thank you for the patch. On Sun, Jan 09, 2022 at 08:41:05PM +, Colin Ian King wrote: > Don't populate the read-only array clock_div_by_lanes on the stack but > instead it static const. Also makes the object code a little smaller. > > Signed-off-by: Colin Ian King > --- >

[PATCH] drm/msm/dpu: invalid parameter check in dpu_setup_dspp_pcc

2022-01-09 Thread José Expósito
The function performs a check on the "ctx" input parameter, however, it is used before the check. Initialize the "base" variable after the sanity check to avoid a possible NULL pointer dereference. Fixes: 4259ff7ae509e ("drm/msm/dpu: add support for pcc color block in dpu driver")

Re: [PATCH 1/2] drm/i2c/tda998x: Switch to atomic operations

2022-01-09 Thread Fabio Estevam
Hi Tommaso, On Sat, Jan 8, 2022 at 4:17 PM Tommaso Merciai wrote: > Hi Fabio, > If you need some test let me know. Whitch filesystem are you using? I am using a rootfs generated by Buildroot. The issue I see seems to be hotplug-related. cat /sys/class/drm/card1-HDMI-A-1/status not always

[PATCH] drm/amd/display: invalid parameter check in dmub_hpd_callback

2022-01-09 Thread José Expósito
The function performs a check on the "adev" input parameter, however, it is used before the check. Initialize the "dev" variable after the sanity check to avoid a possible NULL pointer dereference. Fixes: e27c41d5b0681 ("drm/amd/display: Support for DMUB HPD interrupt handling")

[Bug 201957] amdgpu: ring gfx timeout

2022-01-09 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=201957 James (james.a.el...@gmail.com) changed: What|Removed |Added CC||james.a.el...@gmail.com

Re: [PATCH RESEND v2 2/3] drm/vkms: add support for multiple overlay planes

2022-01-09 Thread José Expósito
Hi Melissa, Thanks for reviewing and applying the series :) Now [1] should apply cleanly on drm-misc-next. Do you want me to resend it with the appropriate prefix? On Sun, Jan 09, 2022 at 03:59:55PM -0100, Melissa Wen wrote: > I checked that several testcases from kms_cursor_crc are failing

Re: [PATCH v2] drm/v3d: Fix PM disable depth imbalance in v3d_platform_drm_probe

2022-01-09 Thread Melissa Wen
On 01/06, Miaoqian Lin wrote: > The pm_runtime_enable will increase power disable depth. > If the probe fails, we should use pm_runtime_disable() to balance > pm_runtime_enable(). > > Fixes: 57692c9 ("drm/v3d: Introduce a new DRM driver for Broadcom V3D V3.x+") > Signed-off-by: Miaoqian Lin >

Re: [PATCH] drm/v3d/v3d_drv: Check for error num after setting mask

2022-01-09 Thread Melissa Wen
On 01/06, Melissa Wen wrote: > On 01/06, Jiasheng Jiang wrote: > > Because of the possible failure of the dma_supported(), the > > dma_set_mask_and_coherent() may return error num. > > Therefore, it should be better to check it and return the error if > > fails. > > > > Fixes: 334dd38a3878

[PATCH] drm: bridge: adv7511: Fix ADV7535 HPD enablement

2022-01-09 Thread Jagan Teki
Existing HPD enablement logic is not compatible with ADV7535 bridge, thus any runtime plug-in of HDMI cable is not working on these bridge designs. Unlike other ADV7511 family of bridges, the ADV7535 require HPD_OVERRIDE bit to set and reset for proper handling of HPD functionality. Fix it.

Re: [RFC PATCH] drm/panfrost: Handle IDVS_GROUP_SIZE feature

2022-01-09 Thread Alyssa Rosenzweig
kbase dt-bindings say that tasks are sent to cores in groups of N + 1, where N is the value here. So our old behaviour sends tasks in groups of 1; the new behaviour sends tasks in groups of 16. I assume this has performance implications but no conformance implications. Searching GitHub, I can't

[PATCH] dt-bindings: msm/mdp4: convert to yaml format

2022-01-09 Thread David Heidelberg
Convert mdp4 binding into yaml format. Signed-off-by: David Heidelberg --- .../devicetree/bindings/display/msm/mdp4.txt | 114 .../devicetree/bindings/display/msm/mdp4.yaml | 124 ++ 2 files changed, 124 insertions(+), 114 deletions(-) delete mode 100644

[RFC PATCH] drm/panfrost: Handle IDVS_GROUP_SIZE feature

2022-01-09 Thread Alyssa Rosenzweig
The IDVS group size feature was missing. It is used on some Bifrost and Valhall GPUs, and is the last kernel-relevant Bifrost feature we're missing. This feature adds an extra IDVS group size field to the JM_CONFIG register. In kbase, the value is configurable via the device tree; kbase uses 0xF

[PATCH 2/2] drm/panfrost: Merge some feature lists

2022-01-09 Thread Alyssa Rosenzweig
Now that we only list features of interest to kernel space, lots of GPUs have the same feature bits. To cut down on the repetition in the file, merge feature lists that are identical between similar GPUs. Note that this leaves some unmerged identical Bifrost feature lists, as there are more

[PATCH 1/2] drm/panfrost: Remove features meant for userspace

2022-01-09 Thread Alyssa Rosenzweig
Early versions of the legacy kernel driver included comprehensive feature lists for every GPU, even though most of the enumerated features only matter to userspace. For example, HW_FEATURE_INTERPIPE_REG_ALIASING was a feature bit indicating that a GPU had "interpipe register aliasing": arithmetic,

[PATCH 0/2] drm/panfrost: Clean up our feature lists

2022-01-09 Thread Alyssa Rosenzweig
We've cargo culted a large number of useless feature bits from kbase. We're about to add support for a number of new Mali GPUs into mainline. Let's cut down on the copy-paste required and clean up the feature lists first. Alyssa Rosenzweig (2): drm/panfrost: Remove features meant for userspace

Re: [PATCH RESEND v2 3/3] drm/vkms: drop "Multiple overlay planes" TODO

2022-01-09 Thread Melissa Wen
On 01/07, José Expósito wrote: > Remove the task from the TODO list. > > Signed-off-by: José Expósito > --- > Documentation/gpu/vkms.rst | 2 -- > 1 file changed, 2 deletions(-) > > diff --git a/Documentation/gpu/vkms.rst b/Documentation/gpu/vkms.rst > index 941f0e7e5eef..9c873c3912cc 100644 >

Re: [PATCH RESEND v2 2/3] drm/vkms: add support for multiple overlay planes

2022-01-09 Thread Melissa Wen
On 01/07, José Expósito wrote: > Create 8 overlay planes instead of 1 when the "enable_overlay" module > parameter is set. > > The following igt-gpu-tools tests were executed without finding > regressions. Notice than the numbers are identical: > > | master branch |

Re: [PATCH RESEND v2 1/3] drm/vkms: refactor overlay plane creation

2022-01-09 Thread Melissa Wen
On 01/07, José Expósito wrote: > Move the logic to create an overlay plane to its own function. > Refactor, no functional changes. > > Signed-off-by: José Expósito > --- > drivers/gpu/drm/vkms/vkms_output.c | 26 +++--- > 1 file changed, 19 insertions(+), 7 deletions(-) > >

[PATCH] drm/panfrost: Update create_bo flags comment

2022-01-09 Thread Alyssa Rosenzweig
Update a comment stating create_bo took no flags, since it now takes a bit mask of optional flags NOEXEC and HEAP. Signed-off-by: Alyssa Rosenzweig --- include/uapi/drm/panfrost_drm.h | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/include/uapi/drm/panfrost_drm.h

Re: [PATCH] drm/etnaviv: relax submit size limits

2022-01-09 Thread Christian Gmeiner
Am Do., 6. Jan. 2022 um 19:10 Uhr schrieb Lucas Stach : > > While all userspace tried to limit commandstreams to 64K in size, > a bug in the Mesa driver lead to command streams of up to 128K > being submitted. Allow those to avoid breaking existing userspace. > > Fixes: 6dfa2fab8ddd ("drm/etnaviv:

[PATCH v7 6/6] drm/amdgpu: add drm buddy support to amdgpu

2022-01-09 Thread Arunpravin
- Remove drm_mm references and replace with drm buddy functionalities - Add res cursor support for drm buddy v2(Matthew Auld): - replace spinlock with mutex as we call kmem_cache_zalloc (..., GFP_KERNEL) in drm_buddy_alloc() function - lock drm_buddy_block_trim() function as it calls

[PATCH v7 3/6] drm: implement top-down allocation method

2022-01-09 Thread Arunpravin
Implemented a function which walk through the order list, compares the offset and returns the maximum offset block, this method is unpredictable in obtaining the high range address blocks which depends on allocation and deallocation. for instance, if driver requests address at a low specific

[PATCH v7 4/6] drm: implement a method to free unused pages

2022-01-09 Thread Arunpravin
On contiguous allocation, we round up the size to the *next* power of 2, implement a function to free the unused pages after the newly allocate block. v2(Matthew Auld): - replace function name 'drm_buddy_free_unused_pages' with drm_buddy_block_trim - replace input argument name

[PATCH v7 5/6] drm/amdgpu: move vram inline functions into a header

2022-01-09 Thread Arunpravin
Move shared vram inline functions and structs into a header file Signed-off-by: Arunpravin --- drivers/gpu/drm/amd/amdgpu/amdgpu_vram_mgr.h | 51 1 file changed, 51 insertions(+) create mode 100644 drivers/gpu/drm/amd/amdgpu/amdgpu_vram_mgr.h diff --git

[PATCH v7 2/6] drm: improve drm_buddy_alloc function

2022-01-09 Thread Arunpravin
- Make drm_buddy_alloc a single function to handle range allocation and non-range allocation demands - Implemented a new function alloc_range() which allocates the requested power-of-two block comply with range limitations - Moved order computation and memory alignment logic from i915

[PATCH v7 1/6] drm: move the buddy allocator from i915 into common drm

2022-01-09 Thread Arunpravin
Move the base i915 buddy allocator code into drm - Move i915_buddy.h to include/drm - Move i915_buddy.c to drm root folder - Rename "i915" string with "drm" string wherever applicable - Rename "I915" string with "DRM" string wherever applicable - Fix header file dependencies - Fix alignment issues

Re: [PATCH v6 1/6] drm: move the buddy allocator from i915 into common drm

2022-01-09 Thread Arunpravin
On 07/01/22 9:27 pm, Christian König wrote: > Am 07.01.22 um 16:49 schrieb Matthew Auld: >> On 26/12/2021 22:24, Arunpravin wrote: >>> Move the base i915 buddy allocator code into drm >>> - Move i915_buddy.h to include/drm >>> - Move i915_buddy.c to drm root folder >>> - Rename "i915" string

Re: [PATCH 1/2] video: vga16fb: Fix logic that checks for the display standard

2022-01-09 Thread Geert Uytterhoeven
Hi Javier, On Fri, Jan 7, 2022 at 9:00 PM Javier Martinez Canillas wrote: > The vga16fb framebuffer driver supports both Enhanced Graphics Adapter > (EGA) and Video Graphics Array (VGA) 16 color graphic cards. > > But the logic to check whether the EGA or VGA standard are used is not > correct.

Re: [PATCH 2/2] video: vga16fb: Only probe for EGA and VGA 16 color graphic cards

2022-01-09 Thread Geert Uytterhoeven
Hi Javier, On Fri, Jan 7, 2022 at 9:00 PM Javier Martinez Canillas wrote: > The vga16fb framebuffer driver only supports Enhanced Graphics Adapter > (EGA) and Video Graphics Array (VGA) 16 color graphic cards. > > But it doesn't check if the adapter is one of those or if a VGA16 mode > is used.