[PATCH] staging: lustre: cleanup align switch and case

2014-12-22 Thread samuel kihahu
From: samuel kihahu Align switch and case to be at the same indent. Signed-off-by: samuel kihahu --- drivers/staging/lustre/lnet/selftest/module.c | 50 +-- 1 file changed, 25 insertions(+), 25 deletions(-) diff --git a/drivers/staging/lustre/lnet/selftest/module.c b/

Re: [PATCH] staging: lustre: cleanup align switch and case

2014-12-22 Thread Greg KH
On Tue, Dec 23, 2014 at 07:38:04AM +0300, samuel kihahu wrote: > On Mon, Dec 22, 2014 at 01:18:01PM -0800, Greg KH wrote: > > On Mon, Dec 22, 2014 at 11:48:57PM +0300, samuel kihahu wrote: > > > From: skihahu > > > > > > Align switch and case to be at the same indent. > > > > > > Signed-off-by:

Re: [PATCH] Fix a white space coding style problem

2014-12-22 Thread Greg KH
On Tue, Dec 23, 2014 at 05:10:28AM +, Kroderia wrote: > Signed-off-by: Kroderia I doubt that is the name you sign legal documents with, right? Please fix that up, and give a much better subject: and body of the changelog for what you are doing. Look at the archives for how to properly do th

[PATCH] Fix a white space coding style problem

2014-12-22 Thread Kroderia
Signed-off-by: Kroderia --- drivers/staging/skein/skein_generic.c |1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/skein/skein_generic.c b/drivers/staging/skein/skein_generic.c index 85bd7d0..899078f 100644 --- a/drivers/staging/skein/skein_generic.c +++ b/drivers/staging/sk

Re: [PATCH] staging: lustre: cleanup align switch and case

2014-12-22 Thread samuel kihahu
On Mon, Dec 22, 2014 at 01:18:01PM -0800, Greg KH wrote: > On Mon, Dec 22, 2014 at 11:48:57PM +0300, samuel kihahu wrote: > > From: skihahu > > > > Align switch and case to be at the same indent. > > > > Signed-off-by: samuel kihahu > > The "From:" and "Signed-off-by:" names don't match, which

[PATCH v5 5/6] mmc: rtsx: add support for sdio card

2014-12-22 Thread micky_ching
From: Micky Ching Modify transfer mode for support sdio card, send cmd and data at the same time for read data transfer, but send data after cmd for write data transfer. Signed-off-by: Micky Ching --- drivers/mmc/host/rtsx_pci_sdmmc.c | 234 ++ 1 file change

[PATCH v5 4/6] mmc: rtsx: add helper function to simplify code

2014-12-22 Thread micky_ching
From: Micky Ching To support sdio card, transfer mode need make a change, this need to split code and use it in different place, Add new function to simplify repeat operation. Signed-off-by: Micky Ching --- drivers/mmc/host/rtsx_pci_sdmmc.c | 95 +-- 1 file

[PATCH v5 6/6] mmc: rtsx: swap function position to avoid pre declaration

2014-12-22 Thread micky_ching
From: Micky Ching move function sd_read_data()/sd_write_data() behind sd_send_cmd_get_rsp() to avoid pre-declaration. Signed-off-by: Micky Ching --- drivers/mmc/host/rtsx_pci_sdmmc.c | 203 +++--- 1 file changed, 100 insertions(+), 103 deletions(-) diff --git a

[PATCH v5 3/6] mmc: rtsx: init cookie at probe/card_event

2014-12-22 Thread micky_ching
From: Micky Ching host->cookie is used for handle async request, we should init it to negative value when new card inserted, make cookie value invalid. Signed-off-by: Micky Ching --- drivers/mmc/host/rtsx_pci_sdmmc.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/mmc/host/rtsx_p

[PATCH v5 2/6] mmc: rtsx: add dump_reg_range to simplify dump register

2014-12-22 Thread micky_ching
From: Micky Ching Add a new function to dump register within a range. We print 1 register a line before this patch, this may make debug info too long when we add more register to dump. The new dump_reg_range() dump to 8 register a line, and it is easy to use. Signed-off-by: Micky Ching --- dr

[PATCH v5 0/6] mmc: rtsx: add support for sdio card

2014-12-22 Thread micky_ching
From: Micky Ching v5: fix patch(5) building error, no code change diff v4. v4: split patch in more detailed patches. no code changes diff v3. v3: rtsx_pci_sdmmc.c: - dump_reg_range - remove unused pointer check - fix start index v2: rtsx_pci.h: - remove unused rtsx_p

[PATCH v5 1/6] mfd: rtsx: add func to split u32 into register

2014-12-22 Thread micky_ching
From: Micky Ching Add helper function to write u32 to registers, if we want to put u32 value to 4 continuous register, this can help us reduce tedious work. Signed-off-by: Micky Ching Acked-by: Lee Jones --- include/linux/mfd/rtsx_pci.h | 9 + 1 file changed, 9 insertions(+) diff --g

Re: [PATCH] dgnc/digi.h: checkpatch: Changend complex macros (enclosed parantheses)

2014-12-22 Thread Greg KH
On Mon, Dec 22, 2014 at 08:04:02PM +0100, Simone Weiss wrote: > The patch previous in this thread (dgnc/dpacompat.h) defines partly the same > macros as dgnc/digi.h and so it is neccessary tochange the macros in this > file as well, so no macros get redefined > Please wrap your changelog body

[PATCH 2/2] staging: media: bcm2048: Remove obsolete cleanup for clientdata

2014-12-22 Thread Wolfram Sang
A few new i2c-drivers came into the kernel which clear the clientdata-pointer on exit or error. This is obsolete meanwhile, the core will do it. Signed-off-by: Wolfram Sang --- drivers/staging/media/bcm2048/radio-bcm2048.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/medi

Re: [PATCH] staging: lustre: cleanup align switch and case

2014-12-22 Thread Greg KH
On Mon, Dec 22, 2014 at 11:48:57PM +0300, samuel kihahu wrote: > From: skihahu > > Align switch and case to be at the same indent. > > Signed-off-by: samuel kihahu The "From:" and "Signed-off-by:" names don't match, which doesn't make much sense, right? Please fix and resend. ___

Re: [PATCH net-next] hyperv: Fix some variable name typos in send-buffer init/revoke

2014-12-22 Thread David Miller
From: Haiyang Zhang Date: Fri, 19 Dec 2014 18:25:18 -0800 > The changed names are union fields with the same size, so the existing code > still works. But, we now update these variables to the correct names. > > Signed-off-by: Haiyang Zhang > Reviewed-by: K. Y. Srinivasan Applied. ___

[PATCH] staging: lustre: cleanup align switch and case

2014-12-22 Thread samuel kihahu
From: skihahu Align switch and case to be at the same indent. Signed-off-by: samuel kihahu --- drivers/staging/lustre/lnet/selftest/module.c | 50 +-- 1 file changed, 25 insertions(+), 25 deletions(-) diff --git a/drivers/staging/lustre/lnet/selftest/module.c b/driver

[PATCH] Staging: line6: fix coding style issue in pcm.h

2014-12-22 Thread Dmitriy Polyanskiy
This is a patch to pcm.h file that fixes up some space warnings found by checkpatch.pl Signed-off-by: Dmitriy Polyanskiy --- drivers/staging/line6/pcm.h |6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/line6/pcm.h b/drivers/staging/line6/pcm.h index 6a

[PATCH] media: tlg2300: disable building the driver

2014-12-22 Thread Jim Davis
This driver doesn't build with the current kernel, as reported in linux-next (https://lkml.org/lkml/2014/12/18/483) and by the 0-day build system (https://www.mail-archive.com/linux-media@vger.kernel.org/msg83501.html). Since it's scheduled for removal, disable building it for now. Signed-off-by:

Re: [PATCH] [PATCH v2 2/6] dgnc/dgnc_sysfs.c: checkpatch: Use of dev_err ? instead of printk

2014-12-22 Thread Greg KH
On Mon, Dec 22, 2014 at 07:43:56PM +0100, Simone Weiss wrote: > I originally wanted to replace both of the printk cals in this file with > dev_err(). > But in the function dgnc_create_driver_sysfiles only the struct pci_driver > was given, > sadly I coudn't figure out a way to get a struct devi

[PATCH] staging: rtl8723au: fix sparse warning

2014-12-22 Thread Alexey Tulia
drivers/staging/rtl8723au/core/rtw_xmit.c:2375 warning: symbol 'rtl8723a_EfusePgPacketRead' was not declared. Should it be static? Function 'rtw_ack_tx_done23a' seems to be unused in current staging code. Signed-off-by: Alexey Tulia --- drivers/staging/rtl8723au/core/rtw_xmit.c | 9 - 1

[PATCH] staging: vt6656: Use ether_addr_copy() on vnt_private members.

2014-12-22 Thread Krzysztof Adamski
This patch fixes checkpatch.pl warning: WARNING: Prefer ether_addr_copy() over memcpy() if the Ethernet addresses are __aligned(2) current_net_addr and permanent_net_addr members of vnt_private alignment is changed to at last 16 bits so that ether_addr_copy can be safely used on them. buf->data

[PATCH] staging: vt6656: whitespace checkpatch warning fix.

2014-12-22 Thread Krzysztof Adamski
This fixes following checkpatch.pl error: ERROR: space prohibited before that ',' (ctx:WxW) Signed-off-by: Krzysztof Adamski --- drivers/staging/vt6656/rxtx.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/vt6656/rxtx.c b/drivers/staging/vt6656/rxtx.c index

[PATCH v2 2/2] staging: skein: Fixing single statement macro checkpatch warning

2014-12-22 Thread mathieu . poirier
From: Mathieu Poirier WARNING: Single statement macros should not use a do {} while (0) loop Signed-off-by: Mathieu Poirier --- drivers/staging/skein/skein_block.c | 17 - 1 file changed, 4 insertions(+), 13 deletions(-) diff --git a/drivers/staging/skein/skein_block.c b/driv

[PATCH v2 1/2] staging: skein: Fixing trailing whitespace error

2014-12-22 Thread mathieu . poirier
From: Mathieu Poirier Signed-off-by: Mathieu Poirier --- drivers/staging/skein/skein_generic.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/skein/skein_generic.c b/drivers/staging/skein/skein_generic.c index 85bd7d0168b0..899078f1b8bc 100644 --- a/drivers/staging/skein/sk

[PATCH v2 0/2] staging: skein: Fixing various coding style problems

2014-12-22 Thread mathieu . poirier
From: Mathieu Poirier This patchset is fixing miscellaneous coding style problems as reported by checkpatch. More interesting is the removal of 'do {} while (0) loop' statements for single line macros. The following provides a guarantee the semantic of the object code hasn't been altered by the

Re: [PATCH] staging/iio/accel: checkpatch: fixed long lines by moving comments

2014-12-22 Thread Sudip Mukherjee
On Mon, Dec 22, 2014 at 02:23:42AM +0100, Helene Gsaenger wrote: > Signed-off-by: Helene Gsaenger > Signed-off-by: Simone Weiss > --- > drivers/staging/iio/accel/adis16203.h | 41 > ++- > 1 file changed, 31 insertions(+), 10 deletions(-) > > diff --git a/drivers