[PATCH net 0/1] fix bug in netvsc driver

2017-07-24 Thread Stephen Hemminger
Internal testing found a problem under some load tests and the problem was bisected down to one commit. This needs to go to current (4.13) and stable (4.12). Stephen Hemminger (1): Revert "netvsc: optimize calculation of number of slots" drivers/net/hyperv/netvsc_drv.c | 43

[PATCH net 1/1] Revert "netvsc: optimize calculation of number of slots"

2017-07-24 Thread Stephen Hemminger
The logic for computing page buffer scatter does not take into account the impact of compound pages. Therefore the optimization to compute number of slots was incorrect and could cause stack corruption a skb was sent with lots of fragments from huge pages. This reverts commit

Re: [PATCH net-next 0/6] netvsc: minor fixes

2017-07-24 Thread David Miller
From: Stephen Hemminger Date: Mon, 24 Jul 2017 10:57:24 -0700 > This fixes fallout from previous patch related to RTNL and RCU > annotaiton. Also one patch sent to wrong list. Series applied, thanks. ___ devel mailing list

Re: [PATCH] netvsc: fix ptr_ret.cocci warnings

2017-07-24 Thread David Miller
From: Stephen Hemminger Date: Mon, 24 Jul 2017 16:21:57 -0700 > On Mon, 24 Jul 2017 16:20:28 -0700 (PDT) > David Miller wrote: > >> From: kbuild test robot >> Date: Sat, 22 Jul 2017 02:54:43 +0800 >> >> >

Re: [PATCH] netvsc: fix ptr_ret.cocci warnings

2017-07-24 Thread Stephen Hemminger
On Mon, 24 Jul 2017 16:20:28 -0700 (PDT) David Miller wrote: > From: kbuild test robot > Date: Sat, 22 Jul 2017 02:54:43 +0800 > > > drivers/net/hyperv/netvsc_drv.c:737:8-14: WARNING: PTR_ERR_OR_ZERO can be > > used > > > > > > Use

Re: [PATCH] netvsc: fix ptr_ret.cocci warnings

2017-07-24 Thread David Miller
From: kbuild test robot Date: Sat, 22 Jul 2017 02:54:43 +0800 > drivers/net/hyperv/netvsc_drv.c:737:8-14: WARNING: PTR_ERR_OR_ZERO can be used > > > Use PTR_ERR_OR_ZERO rather than if(IS_ERR(...)) + PTR_ERR > > Generated by: scripts/coccinelle/api/ptr_ret.cocci > >

Re: [PATCH 02/37] binder: use group leader instead of open thread

2017-07-24 Thread John Stultz
On Mon, Jul 24, 2017 at 2:23 PM, Greg Kroah-Hartman wrote: > On Mon, Jul 24, 2017 at 02:00:45PM -0700, John Stultz wrote: >> On Thu, Jun 29, 2017 at 12:01 PM, Todd Kjos wrote: >> > The binder allocator assumes that the thread that >> > called

[PATCH] staging: rtl8192u: fix spelling mistake: "Senondary" -> "Secondary"

2017-07-24 Thread Colin King
From: Colin Ian King Trivial fix to spelling mistake in IEEE80211_DEBUG message Signed-off-by: Colin Ian King --- drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

Re: [PATCH 02/37] binder: use group leader instead of open thread

2017-07-24 Thread Greg Kroah-Hartman
On Mon, Jul 24, 2017 at 02:00:45PM -0700, John Stultz wrote: > On Thu, Jun 29, 2017 at 12:01 PM, Todd Kjos wrote: > > The binder allocator assumes that the thread that > > called binder_open will never die for the lifetime of > > that proc. That thread is normally the

Re: [PATCH 02/37] binder: use group leader instead of open thread

2017-07-24 Thread John Stultz
On Mon, Jul 24, 2017 at 2:00 PM, John Stultz wrote: > On Thu, Jun 29, 2017 at 12:01 PM, Todd Kjos wrote: >> The binder allocator assumes that the thread that >> called binder_open will never die for the lifetime of >> that proc. That thread is normally

Re: [PATCH 02/37] binder: use group leader instead of open thread

2017-07-24 Thread John Stultz
On Thu, Jun 29, 2017 at 12:01 PM, Todd Kjos wrote: > The binder allocator assumes that the thread that > called binder_open will never die for the lifetime of > that proc. That thread is normally the group_leader, > however it may not be. Use the group_leader instead > of

[PATCH net-next 4/6] netvsc: fix netvsc_set_channels

2017-07-24 Thread Stephen Hemminger
The number of channels returned by rndis_filter_device_add maybe less than the number requested. Therefore set correct real number of queues. Signed-off-by: Stephen Hemminger --- drivers/net/hyperv/netvsc_drv.c | 51 +++-- 1 file

[PATCH net-next 6/6] netvsc: remove no longer used max_num_rss queues

2017-07-24 Thread Stephen Hemminger
This value has been calculated in rndis_device_attach since 4.11. Signed-off-by: Stephen Hemminger --- drivers/net/hyperv/hyperv_net.h | 1 - drivers/net/hyperv/netvsc_drv.c | 2 -- 2 files changed, 3 deletions(-) diff --git a/drivers/net/hyperv/hyperv_net.h

[PATCH net-next 5/6] netvsc: include rtnetlink.h

2017-07-24 Thread Stephen Hemminger
Since these files use rtnl_derefernce make sure and include rtnetlink.h Signed-off-by: Stephen Hemminger --- drivers/net/hyperv/netvsc_drv.c | 2 ++ drivers/net/hyperv/rndis_filter.c | 1 + 2 files changed, 3 insertions(+) diff --git a/drivers/net/hyperv/netvsc_drv.c

[PATCH net-next 1/6] netvsc: remove bogus rtnl_unlock

2017-07-24 Thread Stephen Hemminger
Remove accidental rtnl_unlock from earlier testing. Fixes: 3962981f4822 ("netvsc: add rtnl annotations in rndis") Signed-off-by: Stephen Hemminger --- drivers/net/hyperv/netvsc_drv.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/net/hyperv/netvsc_drv.c

[PATCH net-next 2/6] netvsc: Remove redundant use of ipv6_hdr()

2017-07-24 Thread Stephen Hemminger
From: Mohammed Gamal This condition already uses an object of type ipv6hdr in the line above. Use the object directly instead of calling ipv6_hdr Signed-off-by: Mohammed Gamal --- drivers/net/hyperv/netvsc_drv.c | 2 +- 1 file changed, 1 insertion(+), 1

[PATCH net-next 3/6] netvsc: prefetch the first incoming ring element

2017-07-24 Thread Stephen Hemminger
In interrupt handler, prefetch the first incoming ring element so that it is in cache by the time NAPI poll gets to it. Signed-off-by: Stephen Hemminger --- drivers/net/hyperv/netvsc.c | 8 +++- 1 file changed, 7 insertions(+), 1 deletion(-) diff --git

[PATCH net-next 0/6] netvsc: minor fixes

2017-07-24 Thread Stephen Hemminger
This fixes fallout from previous patch related to RTNL and RCU annotaiton. Also one patch sent to wrong list. Mohammed Gamal (1): netvsc: Remove redundant use of ipv6_hdr() Stephen Hemminger (5): netvsc: remove bogus rtnl_unlock netvsc: prefetch the first incoming ring element netvsc:

Re: [PATCH v1 5/6] uuid: Kill uapi/uuid.h

2017-07-24 Thread Christoph Hellwig
> diff --git a/scripts/mod/file2alias.c b/scripts/mod/file2alias.c > index 29d6699d5a06..1c68709123aa 100644 > --- a/scripts/mod/file2alias.c > +++ b/scripts/mod/file2alias.c > @@ -36,7 +36,7 @@ typedef uint16_t__u16; > typedef unsigned char__u8; > typedef struct { > __u8

Re: [PATCH v1 4/6] vmbus: Switch to use new generic UUID API

2017-07-24 Thread Christoph Hellwig
On Wed, Jul 19, 2017 at 09:28:55PM +0300, Andy Shevchenko wrote: > There are new types and helpers that are supposed to be used in new code. > > As a preparation to get rid of legacy types and API functions do > the conversion here. Can you split the uapi changes into a separate patch? I'd love

Re: [PATCH v3] staging: vboxvideo: Kconfig: Fix typos in help text

2017-07-24 Thread Dan Carpenter
Looks good. Thanks. regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

[PATCH v3] staging: vboxvideo: Kconfig: Fix typos in help text

2017-07-24 Thread Martin Kepplinger
This fixes typos in vboxvideo's help text. Most notably, "to builtin this module" becomes "to build this driver built-in to the kernel". Signed-off-by: Martin Kepplinger --- revision history v3: Avoid a repetition of "this driver". v2: Say "to build this

[PATCH v2] staging: vboxvideo: Kconfig: Fix typos in help text

2017-07-24 Thread Martin Kepplinger
This fixes typos in vboxvideo's help text. Most notably, "to builtin this module" becomes "to build this driver built-in to the kernel". Signed-off-by: Martin Kepplinger --- Thanks Dan. I actually also had the feeling that even though it's better, it's not as clear as it

Re: [PATCH] staging: vboxvideo: Kconfig: Fix typos in help text

2017-07-24 Thread Dan Carpenter
On Mon, Jul 24, 2017 at 08:45:16AM +0200, Martin Kepplinger wrote: > This fixes typos in vboxvideo's help text. > > Signed-off-by: Martin Kepplinger > --- > drivers/staging/vboxvideo/Kconfig | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git

Re: [PATCH 1/3] staging: pi433: Style fix - align block comments

2017-07-24 Thread Marcus Wolf
Hi Dan, when I started with the RFM69CW about two years ago (at the beginning not as a driver, but everything within the applicaton) I kind of automatically produced a list of all registers of the chip (most probably by importing and reorganizing the datasheet in Excel). Everytime I need to

Re: [PATCH 3/3] staging: pi433: - style fix, space at start of line

2017-07-24 Thread Dan Carpenter
On Sat, Jul 22, 2017 at 03:51:21PM +1200, Derek Robson wrote: > Fixed checkpatch errors of "please, no spaces at the start of a line" > > Signed-off-by: Derek Robson > --- > drivers/staging/pi433/rf69.c | 4 +- > drivers/staging/pi433/rf69_enum.h | 206 >

Re: [PATCH 2/3] staging: pi433: - style fix, space before tabs

2017-07-24 Thread Dan Carpenter
On Sat, Jul 22, 2017 at 10:48:24AM +0200, Marcus Wolf wrote: > Reviewed-by: Marcus Wolf > > >From my point of view, the rearrangement of the block of SET_CHECKED reduces > >the > readability a lot. I like same stuff to be aligned (all brakets below each > other >

Re: [PATCH 1/3] staging: pi433: Style fix - align block comments

2017-07-24 Thread Dan Carpenter
On Sat, Jul 22, 2017 at 03:50:50PM +1200, Derek Robson wrote: > + * // RegOsc1 > + * #define OSC1_RCCAL_START 0x80 > + * #define OSC1_RCCAL_DONE 0x40 > + * Why do we have all these commented out defines? regards, dan carpenter

Re: [PATCH] staging: vboxvideo: Kconfig: Fix typos in help text

2017-07-24 Thread Hans de Goede
Hi, On 24-07-17 08:45, Martin Kepplinger wrote: This fixes typos in vboxvideo's help text. Signed-off-by: Martin Kepplinger Looks good to me: Acked-by: Hans de Goede Regards, Hans --- drivers/staging/vboxvideo/Kconfig | 4 ++-- 1 file

Re: [PATCH] media: imx: prpencvf: enable double write reduction

2017-07-24 Thread Philipp Zabel
On Sat, 2017-07-22 at 14:21 -0700, Steve Longerbeam wrote: > For the write channels with 4:2:0 subsampled YUV formats, avoid chroma > overdraw by only writing chroma for even lines. Reduces necessary write > memory bandwidth by at least 25% (more with rotation enabled). > > Signed-off-by: Steve

Re: [PATCH] media: imx: prpencvf: enable double write reduction

2017-07-24 Thread Philipp Zabel
Hi Steve, On Sat, 2017-07-22 at 15:04 -0700, Steve Longerbeam wrote: > Hi Philipp, > > This is the same as your patch to CSI, applied to ic-prpencvf. > > I'm not really sure what this cpmem bit is doing. The U/V planes > in memory are already subsampled by 2 in both width and height. > This

Re: [PATCH] Staging: greybus: Match alignment with open parenthesis.

2017-07-24 Thread Dan Carpenter
I don't understand why greybus has to be special instead of the same as everything else. Who cares about this stuff really? Just do whatever is easiest and most common. regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org

[PATCH] staging: vboxvideo: Kconfig: Fix typos in help text

2017-07-24 Thread Martin Kepplinger
This fixes typos in vboxvideo's help text. Signed-off-by: Martin Kepplinger --- drivers/staging/vboxvideo/Kconfig | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/vboxvideo/Kconfig b/drivers/staging/vboxvideo/Kconfig index