Re: [PATCH] hv_netvsc: Add per-cpu ethtool stats for netvsc

2018-06-07 Thread David Miller
From: Yidong Ren Date: Wed, 6 Jun 2018 15:27:00 -0700 > From: Yidong Ren > > This patch implements following ethtool stats fields for netvsc: > cpu_tx/rx_packets/bytes > cpu_vf_tx/rx_packets/bytes > > Corresponding per-cpu counters exist in current code. Exposing these > counters will help

Re: [PATCH v2] hv_netvsc: Fix a network regression after ifdown/ifup

2018-06-07 Thread David Miller
From: Dexuan Cui Date: Wed, 6 Jun 2018 21:32:51 + > > Recently people reported the NIC stops working after > "ifdown eth0; ifup eth0". It turns out in this case the TX queues are not > enabled, after the refactoring of the common detach logic: when the NIC > has sub-channels, usually we

[PATCH 4/4] Staging:rtl8192e Cleanup comparison to NULL

2018-06-07 Thread Janani Sankara Babu
This patch replaces the comparison of var to NULL with !var Signed-off-by: Janani Sankara Babu --- drivers/staging/rtl8192e/rtl819x_BAProc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8192e/rtl819x_BAProc.c b/drivers/staging/rtl8192e/rtl819x_BAProc.c

[PATCH 3/4] Staging:rtl8192e Fix Comparison to true is error prone

2018-06-07 Thread Janani Sankara Babu
This patch removes the comaprison to bool value in the code Signed-off-by: Janani Sankara Babu --- drivers/staging/rtl8192e/rtl819x_BAProc.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8192e/rtl819x_BAProc.c

[PATCH 2/4] Staging:rtl8192e Fix Comparison to False is error prone

2018-06-07 Thread Janani Sankara Babu
This patch removes comparison to False(ie. bool) in the code Signed-off-by: Janani Sankara Babu --- drivers/staging/rtl8192e/rtl819x_BAProc.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/staging/rtl8192e/rtl819x_BAProc.c

[PATCH 1/4] Staging:rtl8192e Replace function names by using __func__ identifier

2018-06-07 Thread Janani Sankara Babu
This patch is created to solve the warning shown by checkpatch script Prefer using '"%s...", __func__' to using ', this function's name, in a string Signed-off-by: Janani Sankara Babu --- drivers/staging/rtl8192e/rtl819x_BAProc.c | 8 1 file changed, 4 insertions(+), 4 deletions(-)

RE: [PATCH v4] Drivers: HV: Send one page worth of kmsg dump over Hyper-V during panic

2018-06-07 Thread Sunil Muthuswamy
Thanks. > -Original Message- > From: Dexuan Cui > Sent: Wednesday, June 6, 2018 5:31 PM > To: Sunil Muthuswamy > Cc: de...@linuxdriverproject.org; KY Srinivasan ; > Stephen Hemminger > Subject: RE: [PATCH v4] Drivers: HV: Send one page worth of kmsg dump > over Hyper-V during panic > >

Re: [PATCH] Staging:rtl8192e Replace function names by using __func__

2018-06-07 Thread Joe Perches
On Thu, 2018-06-07 at 23:29 -0400, Janani Sankara Babu wrote: > This patch is created to solve the warning shown by checkpatch script > Prefer using '"%s...", __func__' to using ', this function's name, > in a string [] > diff --git a/drivers/staging/rtl8192e/rtl819x_BAProc.c >

Re: Do Qualcomm drivers use DMA buffers for request_firmware_into_buf()?

2018-06-07 Thread Ard Biesheuvel
On 7 June 2018 at 20:21, Bjorn Andersson wrote: > On Thu 07 Jun 09:33 PDT 2018, Greg Kroah-Hartman wrote: > >> On Thu, Jun 07, 2018 at 06:23:01PM +0200, Ard Biesheuvel wrote: >> > On 7 June 2018 at 18:18, Bjorn Andersson >> > wrote: >> > > On Wed 06 Jun 13:32 PDT 2018, Luis R. Rodriguez wrote:

Re: [PATCH v3 2/5] efi: Add embedded peripheral firmware support

2018-06-07 Thread Luis R. Rodriguez
On Thu, Jun 07, 2018 at 09:49:50AM -0700, Bjorn Andersson wrote: > On Tue 08 May 09:10 PDT 2018, Luis R. Rodriguez wrote: > > > On Tue, May 08, 2018 at 03:38:05PM +, Luis R. Rodriguez wrote: > > > On Fri, May 04, 2018 at 12:44:37PM -0700, Martijn Coenen wrote: > > > > On Wed, Apr 25, 2018 at

Re: Do Qualcomm drivers use DMA buffers for request_firmware_into_buf()?

2018-06-07 Thread Bjorn Andersson
On Thu 07 Jun 09:33 PDT 2018, Greg Kroah-Hartman wrote: > On Thu, Jun 07, 2018 at 06:23:01PM +0200, Ard Biesheuvel wrote: > > On 7 June 2018 at 18:18, Bjorn Andersson wrote: > > > On Wed 06 Jun 13:32 PDT 2018, Luis R. Rodriguez wrote: > > > > > >> On Fri, Jun 01, 2018 at 09:23:46PM +0200, Luis

Re: Do Qualcomm drivers use DMA buffers for request_firmware_into_buf()?

2018-06-07 Thread Bjorn Andersson
On Thu 07 Jun 09:23 PDT 2018, Ard Biesheuvel wrote: > On 7 June 2018 at 18:18, Bjorn Andersson wrote: > > On Wed 06 Jun 13:32 PDT 2018, Luis R. Rodriguez wrote: > > > >> On Fri, Jun 01, 2018 at 09:23:46PM +0200, Luis R. Rodriguez wrote: > >> > On Tue, May 08, 2018 at 03:38:05PM +, Luis R.

[PATCH] Staging:rtl8192e Replace function names by using __func__

2018-06-07 Thread Janani Sankara Babu
This patch is created to solve the warning shown by checkpatch script Prefer using '"%s...", __func__' to using ', this function's name, in a string Signed-off-by: Janani Sankara Babu --- drivers/staging/rtl8192e/rtl819x_BAProc.c | 8 1 file changed, 4 insertions(+), 4 deletions(-)

Re: Do Qualcomm drivers use DMA buffers for request_firmware_into_buf()?

2018-06-07 Thread Ard Biesheuvel
On 7 June 2018 at 18:49, Greg Kroah-Hartman wrote: > On Thu, Jun 07, 2018 at 06:43:05PM +0200, Ard Biesheuvel wrote: >> On 7 June 2018 at 18:33, Greg Kroah-Hartman >> wrote: >> > On Thu, Jun 07, 2018 at 06:23:01PM +0200, Ard Biesheuvel wrote: >> >> On 7 June 2018 at 18:18, Bjorn Andersson >>

Re: [PATCH v3 2/5] efi: Add embedded peripheral firmware support

2018-06-07 Thread Bjorn Andersson
On Tue 08 May 09:10 PDT 2018, Luis R. Rodriguez wrote: > On Tue, May 08, 2018 at 03:38:05PM +, Luis R. Rodriguez wrote: > > On Fri, May 04, 2018 at 12:44:37PM -0700, Martijn Coenen wrote: > > > On Wed, Apr 25, 2018 at 10:55 AM, Luis R. Rodriguez > > > wrote: [..] > > > 2) Most of those

Re: Do Qualcomm drivers use DMA buffers for request_firmware_into_buf()?

2018-06-07 Thread Greg Kroah-Hartman
On Thu, Jun 07, 2018 at 06:43:05PM +0200, Ard Biesheuvel wrote: > On 7 June 2018 at 18:33, Greg Kroah-Hartman > wrote: > > On Thu, Jun 07, 2018 at 06:23:01PM +0200, Ard Biesheuvel wrote: > >> On 7 June 2018 at 18:18, Bjorn Andersson > >> wrote: > >> > On Wed 06 Jun 13:32 PDT 2018, Luis R.

Re: Do Qualcomm drivers use DMA buffers for request_firmware_into_buf()?

2018-06-07 Thread Ard Biesheuvel
On 7 June 2018 at 18:33, Greg Kroah-Hartman wrote: > On Thu, Jun 07, 2018 at 06:23:01PM +0200, Ard Biesheuvel wrote: >> On 7 June 2018 at 18:18, Bjorn Andersson wrote: >> > On Wed 06 Jun 13:32 PDT 2018, Luis R. Rodriguez wrote: >> > >> >> On Fri, Jun 01, 2018 at 09:23:46PM +0200, Luis R.

Re: Do Qualcomm drivers use DMA buffers for request_firmware_into_buf()?

2018-06-07 Thread Greg Kroah-Hartman
On Thu, Jun 07, 2018 at 06:23:01PM +0200, Ard Biesheuvel wrote: > On 7 June 2018 at 18:18, Bjorn Andersson wrote: > > On Wed 06 Jun 13:32 PDT 2018, Luis R. Rodriguez wrote: > > > >> On Fri, Jun 01, 2018 at 09:23:46PM +0200, Luis R. Rodriguez wrote: > >> > On Tue, May 08, 2018 at 03:38:05PM +,

Re: Do Qualcomm drivers use DMA buffers for request_firmware_into_buf()?

2018-06-07 Thread Bjorn Andersson
On Wed 06 Jun 13:32 PDT 2018, Luis R. Rodriguez wrote: > On Fri, Jun 01, 2018 at 09:23:46PM +0200, Luis R. Rodriguez wrote: > > On Tue, May 08, 2018 at 03:38:05PM +, Luis R. Rodriguez wrote: > > > On Fri, May 04, 2018 at 12:44:37PM -0700, Martijn Coenen wrote: > > > > > > > > I think the

Re: Do Qualcomm drivers use DMA buffers for request_firmware_into_buf()?

2018-06-07 Thread Ard Biesheuvel
On 7 June 2018 at 18:18, Bjorn Andersson wrote: > On Wed 06 Jun 13:32 PDT 2018, Luis R. Rodriguez wrote: > >> On Fri, Jun 01, 2018 at 09:23:46PM +0200, Luis R. Rodriguez wrote: >> > On Tue, May 08, 2018 at 03:38:05PM +, Luis R. Rodriguez wrote: >> > > On Fri, May 04, 2018 at 12:44:37PM -0700,

Re: [PATCH v2] staging: pi433: add mutex fixing concurrency issues.

2018-06-07 Thread Hugo Lefeuvre
> Add a mutex fixing a potential NULL pointer dereference in the pi433 > driver. > > If pi433_release and pi433_ioctl are concurrently called, > pi433_release might set filp->private_data to NULL while pi433_ioctl > is still accessing it, leading to NULL pointer dereference. This issue > might

[PATCH 16/18] staging: mt7621-pinctrl: use ternary operator return in rt2880_get_group_name

2018-06-07 Thread Sergio Paracuellos
Trivial change to have only one return in 'rt2880_get_group_name' function using a ternary operator instead of an if statement and two returns. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 5 + 1 file changed, 1 insertion(+), 4 deletions(-) diff

[PATCH 09/18] staging: mt7621-pinctrl: align function parameters in some functions

2018-06-07 Thread Sergio Paracuellos
Function parameters along the code has different alignment styles. Just unify all of them making style consistent. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 29 - 1 file changed, 14 insertions(+), 15 deletions(-) diff --git

[PATCH 13/18] staging: mt7621-pinctrl: make use of pinctrl_utils_reserve_map

2018-06-07 Thread Sergio Paracuellos
Function rt2880_pinctrl_dt_node_to_map was using 'kzalloc' to reserve map memory. There is a 'pinctrl_utils_reserve_map' to do this function. Just use it. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 12 +--- 1 file changed, 9 insertions(+), 3

[PATCH 15/18] staging: mt7621-pinctrl: refactor rt2880_pinctrl_dt_node_to_map function

2018-06-07 Thread Sergio Paracuellos
Using 'function' and 'groups' bindings in the device tree give the posibility of refactor 'rt2880_pinctrl_dt_node_to_map' and simplify it a lot. Make use of the 'of_property_count_strings' function to get number of groups for the node and iterate over the groups using 'of_property_for_each_string'

[PATCH 18/18] staging: mt7621-pinctrl: replace core_initcall_sync with module_platform_driver

2018-06-07 Thread Sergio Paracuellos
We don't really need initialization of this at such an early stage. Just use module_platform_driver to initialize this driver. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 7 +-- 1 file changed, 1 insertion(+), 6 deletions(-) diff --git

[PATCH 10/18] staging: mt7621-pinctrl: use tabs instead of spaces in some indentations

2018-06-07 Thread Sergio Paracuellos
Kernel coding style use tabs for indent code instead of spaces. Fix some places where spaces were being used silencing also checkpatch script complains. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 6 +++--- 1 file changed, 3 insertions(+), 3

[PATCH 11/18] staging: mt7621-pinctrl: make use of pinctrl_utils_free_map

2018-06-07 Thread Sergio Paracuellos
There was a custom 'rt2880_pinctrl_dt_free_map' function which it was doing the same as pinctrl_utils_free_map defined in 'pinctrl-utils.h' header file. Use it instead avoiding code duplications. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 16

[PATCH 17/18] staging: mt7621-pinctrl: remove 'rt2880_pinctrl_pin_dbg_show' callback

2018-06-07 Thread Sergio Paracuellos
The debug information provided by this function does not make sense at all, so just remove it. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 8 1 file changed, 8 deletions(-) diff --git a/drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c

[PATCH 02/18] staging: mt7621-pinctrl: replace 'unsigned' types with 'unsigned int'

2018-06-07 Thread Sergio Paracuellos
This commit replaces all 'unsigned' type declarations along the driver code in favour of the preferred one 'unsigned int'. This also silence checkpatch script warnings about this issue. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 27

[PATCH 05/18] staging: mt7621-pinctrl: avoid space after if condition

2018-06-07 Thread Sergio Paracuellos
Adding spaces between if condition and parenthesis are not needed at all and checkpatch script complains about them. Fix one in driver code. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[PATCH 03/18] staging: mt7621-pinctrl: remove unnecessary 'out of memory' message

2018-06-07 Thread Sergio Paracuellos
Messages when memory allocation fails are not needed at all and checkpatch script complains about them. Remove one in this driver code. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git

[PATCH 12/18] staging: mt7621-pinctrl: replace uint8_t type with u8 for 'gpio' field

2018-06-07 Thread Sergio Paracuellos
Struct 'rt2880_priv' contains a field 'gpio' which is defined as uint8_t and should be defined with 'u8' which is preferred. Update some cast along the code related with this new change. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 6 +++--- 1 file

[PATCH 00/18] staging: mt7621-pinctrl: some cleanups

2018-06-07 Thread Sergio Paracuellos
This patch series make some cleanups for this driver: - different checkpatch issues - Avoid code duplication using some stuff from pinctrl utils - Some trivial refactors Neil, I will send bindings documentation for this, but appart of that it would be nice if you could point me out other

[PATCH 07/18] staging: mt7621-pinctrl: avoid lines over 80 chars

2018-06-07 Thread Sergio Paracuellos
This commit silence checkpatch warnings about lines which exceeds 80 chars. In some cases to improve code redability temporal 'size' variable has been included and assigned before allocations. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 36

[PATCH 08/18] staging: mt7621-pinctrl: replace seq_printf with seq_puts

2018-06-07 Thread Sergio Paracuellos
For a constant format without additional arguments, use seq_puts() instead of seq_printf() fixing also the following checkpatch.pl warning: 'Prefer seq_puts to seq_printf' Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 2 +- 1 file changed, 1

[PATCH 14/18] staging: mt7621-dts: use 'function' and 'groups' for pinctrl bindings

2018-06-07 Thread Sergio Paracuellos
According to documentation 'pinctrl-bindings.txt' bindings 'groups' and 'function' can be used directly. So replace all of them. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-dts/mt7621.dtsi | 48 +- 1 file changed, 24 insertions(+), 24

[PATCH 06/18] staging: mt7621-pinctrl: add space in function call parameter list

2018-06-07 Thread Sergio Paracuellos
Call to kernel function 'devm_kzalloc' has no space between one of its parameters and checkpatch script complains about. Fix it. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[PATCH 04/18] staging: mt7621-pinctrl: replace ENOSYS with better fitting error code

2018-06-07 Thread Sergio Paracuellos
This commit replaces ENOSYS return with ENOTSUPP silencing the following checkpatch warning: WARNING: ENOSYS means 'invalid syscall nr' and nothing else Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)

[PATCH 01/18] staging: mt7621-pinctrl: add SPDX identifier

2018-06-07 Thread Sergio Paracuellos
It's good to have SPDX identifiers in driver files to make it easier to audit the kernel tree for correct licenses. Fix up the one of staging mt7621-pinctrl file to have a proper SPDX identifier, based on the license text in the file itself. The SPDX identifier is a legally binding shorthand,

[PATCH] staging: media: bcm2048: match alignment with open parenthesis

2018-06-07 Thread Gabriel Fanelli
This patch fixes the checkpatch.pl issue: CHECK: Alignment should match open parenthesis Signed-off-by: Gabriel Fanelli --- drivers/staging/media/bcm2048/radio-bcm2048.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/media/bcm2048/radio-bcm2048.c