RE: [PATCH 1/1] Drivers: HV: Send one page worth of kmsg dump over Hyper-V during panic

2018-07-10 Thread Michael Kelley (EOSG)
>From k...@linuxonhyperv.com Sent: Saturday, July 7, >2018 7:57 PM > > From: Sunil Muthuswamy > > In the VM mode on Hyper-V, currently, when the kernel panics, an error > code and few register values are populated in an MSR and the Hypervisor > notified. This information is collected on the

Re: [bug report] netvsc: use ERR_PTR to avoid dereference issues

2018-07-10 Thread Stephen Hemminger
On Tue, 3 Jul 2018 15:01:42 +0300 Dan Carpenter wrote: > Hello stephen hemminger, > > The patch 9749fed5d43d: "netvsc: use ERR_PTR to avoid dereference > issues" from Jul 19, 2017, leads to the following static checker > warning: > > drivers/net/hyperv/rndis_filter.c:1344

RE: [PATCH V2 1/5] X86/Hyper-V: Add flush HvFlushGuestPhysicalAddressSpace hypercall support

2018-07-10 Thread Michael Kelley (EOSG)
From: Tianyu Lan Monday, July 9, 2018 2:03 AM > Hyper-V supports a pv hypercall HvFlushGuestPhysicalAddressSpace to > flush nested VM address space mapping in l1 hypervisor and it's to > reduce overhead of flushing ept tlb among vcpus. This patch is to > implement it. > > Signed-off-by: Lan

RE: [PATCH 5/5] staging: fsl-dpaa2/eth: Remove Rx frame size check

2018-07-10 Thread Ioana Ciocoi Radulescu
> -Original Message- > From: Dan Carpenter [mailto:dan.carpen...@oracle.com] > Sent: Monday, July 9, 2018 10:28 PM > To: Ioana Ciocoi Radulescu > Cc: gre...@linuxfoundation.org; de...@driverdev.osuosl.org; linux- > ker...@vger.kernel.org; Ioana Ciornei > Subject: Re: [PATCH 5/5] staging:

RE: [PATCH 2/2] x86/hyper-v: check for VP_INVAL in hyperv_flush_tlb_others()

2018-07-10 Thread Michael Kelley (EOSG)
From: Vitaly Kuznetsov Monday, July 9, 2018 10:40 AM > Commit 1268ed0c474a ("x86/hyper-v: Fix the circular dependency in IPI > enlightenment") pre-filled hv_vp_index with VP_INVAL so it is now > (theoretically) possible to observe hv_cpu_number_to_vp_number() > returning VP_INVAL. We need to

RE: [PATCH 1/2] x86/hyper-v: check cpumask_to_vpset() return value in hyperv_flush_tlb_others_ex()

2018-07-10 Thread Michael Kelley (EOSG)
From: Vitaly Kuznetsov Monday, July 9, 2018 10:40 AM > Commit 1268ed0c474a ("x86/hyper-v: Fix the circular dependency in IPI > enlightenment") made cpumask_to_vpset() return '-1' when there is a CPU > with unknown VP index in the supplied set. This needs to be checked before > we pass 'nr_bank'

[PATCH 2/3] staging: mt7621-pci: use generic kernel pci subsystem read and write

2018-07-10 Thread Sergio Paracuellos
map_bus callback is called before every .read/.write operation. Implement it and change custom read write operations for the pci subsystem generics. Make the probe function to assign data for controller data and get pci register base from device tree. Signed-off-by: Sergio Paracuellos ---

[PATCH 3/3] staging: mt7621-pci: remove dead code derived to not use custom reads and writes

2018-07-10 Thread Sergio Paracuellos
Driver is using now pci subsystem generics reads and writes. Because of this there is a lot of dead code that can be removed. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pci/pci-mt7621.c | 128 1 file changed, 128 deletions(-) diff --git

[PATCH 0/3] staging: mt7621-pci: avoid custom pci config read and writes

2018-07-10 Thread Sergio Paracuellos
This patch series include an attempt to avoid the use of custom read and writes in driver code and use PCI subsystem common ones. In order to do this map_bus callback is implemented and also a data structure for driver is included. registers base address is being readed from device tree and the

[PATCH 1/3] staging: mt7621-pci: add data struct for mt7621 pci controller

2018-07-10 Thread Sergio Paracuellos
Add new 'mt7621_pcie_port' struct as data for the pci controller. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pci/pci-mt7621.c | 10 ++ 1 file changed, 10 insertions(+) diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c b/drivers/staging/mt7621-pci/pci-mt7621.c

Re: [PATCH 5/5] staging: fsl-dpaa2/eth: Remove Rx frame size check

2018-07-10 Thread Dan Carpenter
On Tue, Jul 10, 2018 at 03:55:32PM +, Ioana Ciocoi Radulescu wrote: > > -Original Message- > > From: Dan Carpenter [mailto:dan.carpen...@oracle.com] > > Sent: Monday, July 9, 2018 10:28 PM > > To: Ioana Ciocoi Radulescu > > Cc: gre...@linuxfoundation.org; de...@driverdev.osuosl.org;

Re: [PATCH 2/2] staging: mt7621-gpio: remove driver

2018-07-10 Thread Greg Kroah-Hartman
On Tue, Jul 10, 2018 at 05:18:48PM +0200, Arnd Bergmann wrote: > The gpio-mt7621 driver has graduated out of staging and got accepted > into the gpio tree. Since they both use the same Kconfig symbol, > we could run into conflicts, e.g. I got this failure when the staging > driver got enabled with

[PATCH 2/2] staging: mt7621-gpio: remove driver

2018-07-10 Thread Arnd Bergmann
The gpio-mt7621 driver has graduated out of staging and got accepted into the gpio tree. Since they both use the same Kconfig symbol, we could run into conflicts, e.g. I got this failure when the staging driver got enabled with the other one being unavailable but using the same Kconfig symbol:

[PATCH v2 8/8] staging:rtl8192u: Correction of indentation issues - Coding Style

2018-07-10 Thread John Whitmore
Simple changes to correct indentation issues. Signed-off-by: John Whitmore --- .../rtl8192u/ieee80211/ieee80211_softmac.c| 76 +-- 1 file changed, 37 insertions(+), 39 deletions(-) diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c

[PATCH v2 7/8] staging:rtl8192u: Correct indentation of ieee80211_softmac_new_net()

2018-07-10 Thread John Whitmore
Coding style change to correct the indentation of the function ieee80211_softmac_new_net(). A large proportion of the function's if statements were incorrectly indented. Signed-off-by: John Whitmore --- .../rtl8192u/ieee80211/ieee80211_softmac.c| 101 +- 1 file changed, 50

[PATCH v2 5/8] staging:rtl8192u: Move trailing conditional statement to the following line

2018-07-10 Thread John Whitmore
Coding standard requires that the conditional statement is not on the same line as the 'if' or 'else' but on the following line. Statements moved accordingly. Signed-off-by: John Whitmore --- .../rtl8192u/ieee80211/ieee80211_softmac.c| 25 +-- 1 file changed, 17

[PATCH v2 2/8] staging:rtl8192u: Correct indentation and spacing for braces of code blocks

2018-07-10 Thread John Whitmore
Simple style change to fix the indentaiton and spacing of the braces around multiline code blocks. Braces removed from code block with a single line. Signed-off-by: John Whitmore --- .../rtl8192u/ieee80211/ieee80211_softmac.c| 254 -- 1 file changed, 107 insertions(+), 147

[PATCH v2 4/8] staging:rtl8192u: Remove prohibited spaces - Coding Style

2018-07-10 Thread John Whitmore
Simple removal of spaces prohibited by the coding standard. Signed-off-by: John Whitmore --- .../staging/rtl8192u/ieee80211/ieee80211_softmac.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c

[PATCH v2 6/8] staging:rtl8192u: Remove unnecessary parentheses - Coding Style

2018-07-10 Thread John Whitmore
checkpatch.pl flags unnecessary parentheses, so removed from code. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c

[PATCH v2 3/8] staging:rtl8192u: Correct spacing before and after parenthesis - Style

2018-07-10 Thread John Whitmore
Corrected coding style issues aroung opening and closed parenthesis. Spaces, or blank line, removed from after '(' or before ')' Signed-off-by: John Whitmore --- .../rtl8192u/ieee80211/ieee80211_softmac.c| 78 +-- 1 file changed, 36 insertions(+), 42 deletions(-) diff

[PATCH v2 1/8] staging:rtl8192u: Remove blank lines before '}' and after '{' characters

2018-07-10 Thread John Whitmore
Coding style change to simply remove the unrequired blanks lines before a closing brace or after an opening brace. Signed-off-by: John Whitmore --- .../rtl8192u/ieee80211/ieee80211_softmac.c | 18 -- 1 file changed, 18 deletions(-) diff --git

[PATCH v2 0/8] staging:rtl8192u Coding style changes

2018-07-10 Thread John Whitmore
My last attempt saw some patches applied but a bad commit message resulted in a rejection and subsequent patches not applying. These patches are more or less the same but the numbers have changed from 3, 5, 7, 8, 9, 10, 11 & 12 to 1-8. ___ devel

Re: [PATCH v3 00/23] staging: mt7621-pci: Some cleanups

2018-07-10 Thread Sergio Paracuellos
On Tue, Jul 10, 2018 at 12:58:18PM +0200, Greg KH wrote: > On Tue, Jul 10, 2018 at 12:55:10PM +0200, Greg KH wrote: > > On Mon, Jul 09, 2018 at 10:21:02PM +0200, Sergio Paracuellos wrote: > > > This patch series clean up a bit mt7621-pci driver. > > > > > > Chnages in v3: > > > - PATCH 1 has

Re: [PATCH] ANDROID: binder: Latelimit binder_debug().

2018-07-10 Thread Martijn Coenen
On Tue, Jul 10, 2018 at 2:09 PM, Tetsuo Handa wrote: > I don't have benchmark data (I'm not an Android user). But an example log at > https://syzkaller.appspot.com/text?tag=CrashLog=12f316fc40 got > about 13214 messages in 124 seconds (over 100 messages per a second). I meant data for the

Re: [PATCH] ANDROID: binder: Latelimit binder_debug().

2018-07-10 Thread Tetsuo Handa
On 2018/07/09 23:29, Tetsuo Handa wrote: > On 2018/07/09 23:02, Martijn Coenen wrote: >> On Mon, Jul 9, 2018 at 3:27 PM, Dmitry Vyukov wrote: >>> I know almost nothing about binder. How these debug messages are >>> enabled? I don't see anything like CONFIG_BINDER_VERBOSE_DEBUG in the >>> config:

Re: [PATCH v3 00/23] staging: mt7621-pci: Some cleanups

2018-07-10 Thread Greg KH
On Tue, Jul 10, 2018 at 12:55:10PM +0200, Greg KH wrote: > On Mon, Jul 09, 2018 at 10:21:02PM +0200, Sergio Paracuellos wrote: > > This patch series clean up a bit mt7621-pci driver. > > > > Chnages in v3: > > - PATCH 1 has been splited in several patches for better review > > - PATCH

Re: [PATCH v3 00/23] staging: mt7621-pci: Some cleanups

2018-07-10 Thread Greg KH
On Mon, Jul 09, 2018 at 10:21:02PM +0200, Sergio Paracuellos wrote: > This patch series clean up a bit mt7621-pci driver. > > Chnages in v3: > - PATCH 1 has been splited in several patches for better review > - PATCH "avoid pointer arithmetics in some macros" gets back > a needed

Re: [PATCH v3 03/23] staging: mt7621-pci: add new variable to be set to PCI base address

2018-07-10 Thread Greg KH
On Mon, Jul 09, 2018 at 10:21:05PM +0200, Sergio Paracuellos wrote: > Add new 'mt7621_pci_base' variable as a pointer to definition > RALINK_PCI_BASE to use it along the code. > > Signed-off-by: Sergio Paracuellos > --- > drivers/staging/mt7621-pci/pci-mt7621.c | 3 +++ > 1 file changed, 3

Re: [PATCH v3 04/23] staging: mt7621-pci: reimplement pci_config_[read|write] functions

2018-07-10 Thread Greg KH
On Mon, Jul 09, 2018 at 10:21:06PM +0200, Sergio Paracuellos wrote: > The logic for this functions is kind of mess calling to other > functions which ends up in using very ugly macros. Reimplement > this two using kernel write[b,w,l] and read[b,w,l] and the variable > 'mt7621_pci_base'. Function

Re: [PATCH 1/4] staging: pi433: Add SPDX-License-Identifier tag

2018-07-10 Thread Greg KH
On Tue, Jul 10, 2018 at 12:03:16PM +0200, Sophie Matter wrote: > The missing SPDX tag was added to the top of the files of this > driver, according to the comments on top of each file (GPL license > or higher). > > Signed-off-by: Sophie Matter > Signed-off-by: Rico Schrage What tree are you

Re: [PATCH 2/4] staging: pi433: Comply with 80 character column limit

2018-07-10 Thread Greg KH
On Tue, Jul 10, 2018 at 12:03:17PM +0200, Sophie Matter wrote: > Lines have been split where it makes sense to shorten them in order > to comply with the coding standards and fix checkpatch.pl warnings. > There are still lines left that are too long, however breaking > those would impair

Re: [PATCH] staging: mt7621-gpio: remove driver from staging

2018-07-10 Thread Greg KH
On Mon, Jul 09, 2018 at 06:05:48PM +0200, Sergio Paracuellos wrote: > Remove driver from staging. It has been accepted in > the linux-gpio tree. > > Signed-off-by: Sergio Paracuellos > --- > > Refer to commits in linux-gpio: > - >

[PATCH 3/4] staging: pi433: Use preferred commenting style

2018-07-10 Thread Sophie Matter
For multi-line comments, the preferred commenting style from the coding style Documentation was applied to the comments, meaning almost blank lines at the beginning and end of the comment. One changed comment includes a line over 80 characters, causing checkpatch.pl to complain, however breaking

[PATCH 2/4] staging: pi433: Comply with 80 character column limit

2018-07-10 Thread Sophie Matter
Lines have been split where it makes sense to shorten them in order to comply with the coding standards and fix checkpatch.pl warnings. There are still lines left that are too long, however breaking those would impair readability. Signed-off-by: Sophie Matter Signed-off-by: Rico Schrage ---

[PATCH 1/4] staging: pi433: Add SPDX-License-Identifier tag

2018-07-10 Thread Sophie Matter
The missing SPDX tag was added to the top of the files of this driver, according to the comments on top of each file (GPL license or higher). Signed-off-by: Sophie Matter Signed-off-by: Rico Schrage --- drivers/staging/pi433/pi433_if.c | 1 + drivers/staging/pi433/pi433_if.h | 1 +

[PATCH 4/4] staging: pi433: Make only one statement per line

2018-07-10 Thread Sophie Matter
Lines containing multiple statements were broken into multiple lines, increasing readability and complying with the coding standard. This also fixes several checkpatch.pl errors complaining about the lines being too long. Signed-off-by: Sophie Matter Signed-off-by: Rico Schrage ---