[PATCH 2/4] staging: rtl8188eu: remove unnecessary parentheses

2018-08-04 Thread Michael Straube
Remove unnecessary parentheses from if conditions. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_iol.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_iol.c b/drivers/staging/rtl8188eu/core/rtw_iol.c index

[PATCH 1/4] staging: rtl8188eu: rename rtw_IOL_applied

2018-08-04 Thread Michael Straube
Rename rtw_IOL_applied to be all lowercase. rtw_IOL_applied -> rtw_iol_applied Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_efuse.c| 2 +- drivers/staging/rtl8188eu/core/rtw_iol.c | 2 +- drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c | 4 ++--

[PATCH 3/4] staging: rtl8188eu: remove redundant include

2018-08-04 Thread Michael Straube
The header osdep_service.h is included from drv_types.h, so remove the redundant include. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/include/rtw_iol.h | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/rtl8188eu/include/rtw_iol.h

[PATCH 4/4] staging: rtl8188eu: remove unnecessary includes

2018-08-04 Thread Michael Straube
In the header rtw_iol.h there is only one function declared. Remove the include of rtw_iol.h from files that do not use this function. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/mac_cfg.c| 1 - drivers/staging/rtl8188eu/hal/phy.c| 1 -

Re: [PATCH v6 1/8] media: v4l: Add definitions for MPEG2 slice format and metadata

2018-08-04 Thread Hans Verkuil
On 07/25/2018 12:02 PM, Paul Kocialkowski wrote: > Stateless video decoding engines require both the MPEG slices and > associated metadata from the video stream in order to decode frames. > > This introduces definitions for a new pixel format, describing buffers > with MPEG2 slice data, as well

Re: [PATCH v6 0/8] Cedrus driver for the Allwinner Video Engine, using media requests

2018-08-04 Thread Hans Verkuil
On 07/25/2018 12:02 PM, Paul Kocialkowski wrote: > This is the sixth iteration of the updated Cedrus driver, > that supports the Video Engine found in most Allwinner SoCs, starting > with the A10. It was tested on the A13, A20, A33 and H3. > > The initial version of this driver[0] was originally

Re: [PATCH v6 4/8] media: platform: Add Cedrus VPU decoder driver

2018-08-04 Thread Hans Verkuil
Hi Paul, See below for my review comments. Mostly small fry, the main issue I found is that there is no support for VIDIOC_DECODER_CMD. That's the proper way of stopping a decoder. Don't rely on the deprecated allow_zero_bytesused field. On 07/25/2018 12:02 PM, Paul Kocialkowski wrote: > This

Re: [PATCH v6 2/8] media: v4l: Add definition for Allwinner's MB32-tiled NV12 format

2018-08-04 Thread Hans Verkuil
On 07/25/2018 12:02 PM, Paul Kocialkowski wrote: > This introduces support for Allwinner's MB32-tiled NV12 format, where > each plane is divided into macroblocks of 32x32 pixels. Hence, the size > of each plane has to be aligned to 32 bytes. The pixels inside each > macroblock are coded as they

Re: [PATCH v6 1/8] media: v4l: Add definitions for MPEG2 slice format and metadata

2018-08-04 Thread Hans Verkuil
Hi Paul, Some comments below. It looks pretty good, it's mostly small things that I commented upon. On 07/25/2018 12:02 PM, Paul Kocialkowski wrote: > Stateless video decoding engines require both the MPEG slices and > associated metadata from the video stream in order to decode frames. > >

[PATCH 1/7] staging:rtl8192u: Remove typedef and rename QOS_TCLAS - Style

2018-08-04 Thread John Whitmore
Remove the typedef from the union QOS_TCLAS, which causes a checkpatch issue with defining new types. In addition, as a type, the name should be in lowercase so has been changed. These are coding style changes and should have no impact on runtime code execution. Signed-off-by: John Whitmore ---

[PATCH 3/7] staging:rtl8192u: Rename multiple variables - Style

2018-08-04 Thread John Whitmore
All of the variables used within the structures of the union qos_tclas cause checkpatch issue due to CamelCase naming. As none the member variables are used in code all have been changed on one patch. These changes are coding style in nature and should not impact runtime code execution.

[PATCH 5/7] staging:rtl8192u: Remove comments - Style

2018-08-04 Thread John Whitmore
Removal of three comments. The comments in question do not add anything to the understanding of the code, and if they are necessary it would imply that the structure and its member variables are badly named. This is a simple style change and should have no impact on runtime code execution.

[PATCH 6/7] staging:rtl8192u: Remove unused member variable - Style

2018-08-04 Thread John Whitmore
Remove name of 'reserved' bitfield member which is simply used to pad the bitfield to a byte boundary. The actual bit has been left in place so alignment should not change. The name, which is not required has been removed. This is a coding style change which should have no impact on runtime code

[PATCH 7/7] staging:rtl8192u: Replace magic number with defined constant - Style

2018-08-04 Thread John Whitmore
Replace the magic number '8' with defined constant which is normally used 'MAX_DEV_ADDR_SIZE'. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c | 2 +- 1 file changed, 1

[PATCH 2/7] staging:rtl8192u: Rename types in QOS_TCLAS union - Style

2018-08-04 Thread John Whitmore
Whilst none of the structures inside the qos_tclas union are used, their names conflict with the coding standard being named in uppercase. The names of all five have been changed to lowercase. This is a style change, and since none of the structures are referenced, these changes should have no

[PATCH 0/7] staging:rtl8192u: Coding style changes

2018-08-04 Thread John Whitmore
Cleanup of the drivers/staging/rtl8192u/ieee80211/rtl819x_TS.h file as the QOS_TCLAS union was moved into this file, in a previous patch. The type contained a number of naming issues. John Whitmore (7): staging:rtl8192u: Remove typedef and rename QOS_TCLAS - Style staging:rtl8192u: Rename

[PATCH 4/7] staging:rtl8192u: Remove blank line - Style

2018-08-04 Thread John Whitmore
Removal of a blank like which causes a checkpatch issue. This is a simple coding style change and should have no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/rtl819x_TS.h | 1 - 1 file changed, 1 deletion(-) diff --git

Re: [PATCH] Staging: rtlwifi: base: Fixed line ending with parentheses

2018-08-04 Thread Julia Lawall
On Sat, 4 Aug 2018, Sohil Ladhani wrote: > This patch fixes the "Lines should not end with a '('" problem reported by > checkpatch There is still no v2 in the subject line, or explanation of what has changed under the --- (I assume this is still the same place and the same code; I didn't keep

[PATCH] Staging: rtlwifi: base: Fixed line ending with parentheses

2018-08-04 Thread Sohil Ladhani
This patch fixes the "Lines should not end with a '('" problem reported by checkpatch Signed-off-by: Sohil Ladhani --- drivers/staging/rtlwifi/base.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/staging/rtlwifi/base.c b/drivers/staging/rtlwifi/base.c index

Re: [PATCH] Staging: rtlwifi: base: fixed a brace coding style issue

2018-08-04 Thread Julia Lawall
On Sat, 4 Aug 2018, Sohil Ladhani wrote: > Fixed a coding style issue This seems to fix the header problem. But it is a patch on the same code at the same place doing the same thing as the previous message. So you should say [PATCH v2] in the subject line, and then below the --- explain

Re: [PATCH] Staging: rtlwifi: base: fixed a brace coding style issue

2018-08-04 Thread Julia Lawall
On Sat, 4 Aug 2018, Sohil Ladhani wrote: > linux-ker...@vger.kernel.org, Sohil Ladhani > Bcc: > Subject: [PATCH] Staging: rtlwifi: base: fixed a brace coding style issue > Reply-To: It doesn't look right that the above text is in the message body when I respond to it. Send the patch to

[PATCH] Staging: rtlwifi: base: fixed a brace coding style issue

2018-08-04 Thread Sohil Ladhani
Fixed a coding style issue Signed-off-by: Sohil Ladhani --- drivers/staging/rtlwifi/base.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/staging/rtlwifi/base.c b/drivers/staging/rtlwifi/base.c index 094827c1879a..654aa4e068ba 100644 ---

[PATCH] Staging: rtlwifi: base: fixed a brace coding style issue

2018-08-04 Thread Sohil Ladhani
linux-ker...@vger.kernel.org, Sohil Ladhani Bcc: Subject: [PATCH] Staging: rtlwifi: base: fixed a brace coding style issue Reply-To: Fixed a coding style issue Signed-off-by: Sohil Ladhani --- drivers/staging/rtlwifi/base.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff