Re: [PATCH v6 4/5] drm/bridge: anx7625: add HDCP support

2021-03-29 Thread Sean Paul
On Mon, Mar 29, 2021 at 6:27 AM Xin Ji wrote: > > On Thu, Mar 25, 2021 at 02:19:23PM -0400, Sean Paul wrote: > > On Fri, Mar 19, 2021 at 2:35 AM Xin Ji wrote: > > > > > > Add HDCP feature, enable HDCP function through chip internal key > > > and downstream&

Re: [PATCH v6 4/5] drm/bridge: anx7625: add HDCP support

2021-03-25 Thread Sean Paul
; + DRM_DEV_DEBUG_DRIVER(dev, "enable HDCP 1.4\n"); > + > + ret = anx7625_write_or(ctx, ctx->i2c.rx_p1_client, 0xee, 0x20); > + > + /* Try auth flag */ > + ret |= anx7625_write_or(ctx, ctx->i2c.rx_p1_client, 0xec, 0x10); > + /* Interrupt for DRM */ > + re

[PATCH] staging: emxx_udc: remove unused variable driver_desc

2021-02-18 Thread Sean Behan
Signed-off-by: Sean Behan --- drivers/staging/emxx_udc/emxx_udc.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/emxx_udc/emxx_udc.c b/drivers/staging/emxx_udc/emxx_udc.c index 3536c03ff523..741147a4f0fe 100644 --- a/drivers/staging/emxx_udc/emxx_udc.c +++ b/drivers/staging

[PATCH] staging: emxx_udc: remove unused variable driver_desc

2021-02-17 Thread Sean Behan
When building with W=1, there is a warning that this variable is unused. It is not used so remove it to fix the warning. Thanks to nat...@kernel.org for helping me submit my first patch. Signed-off-by: Sean Behan --- drivers/staging/emxx_udc/emxx_udc.c | 1 - 1 file changed, 1 deletion

[PATCH] staging: emxx_udc: remove unused variable driver_desc

2021-02-17 Thread Sean Behan
When building with W=1 (or however you found it), there is a warning that this variable is unused. It is not used so remove it to fix the warning. Signed-off-by: Sean Behan --- drivers/staging/emxx_udc/emxx_udc.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/emxx_udc

[PATCH] remove unused variable driver_desc

2021-02-16 Thread Sean Behan
--- drivers/staging/emxx_udc/emxx_udc.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/emxx_udc/emxx_udc.c b/drivers/staging/emxx_udc/emxx_udc.c index 3536c03ff523..741147a4f0fe 100644 --- a/drivers/staging/emxx_udc/emxx_udc.c +++ b/drivers/staging/emxx_udc/emxx_udc.c @@ -38,7

Re: [PATCH v1 03/10] KVM: Prepare kvm_is_reserved_pfn() for PG_reserved changes

2019-11-06 Thread Sean Christopherson
On Wed, Nov 06, 2019 at 07:56:34AM +0100, David Hildenbrand wrote: > On 06.11.19 01:08, Dan Williams wrote: > >On Tue, Nov 5, 2019 at 4:03 PM Sean Christopherson > >>But David's proposed fix for the above refcount bug is to omit the patch > >>so that KVM no lo

Re: [PATCH v1 03/10] KVM: Prepare kvm_is_reserved_pfn() for PG_reserved changes

2019-11-05 Thread Sean Christopherson
On Tue, Nov 05, 2019 at 03:43:29PM -0800, Dan Williams wrote: > On Tue, Nov 5, 2019 at 3:30 PM Dan Williams wrote: > > > > On Tue, Nov 5, 2019 at 3:13 PM Sean Christopherson > > wrote: > > > > > > On Tue, Nov 05, 2019 at 03:02:40PM -0800, Dan Williams wrot

Re: [PATCH v1 03/10] KVM: Prepare kvm_is_reserved_pfn() for PG_reserved changes

2019-11-05 Thread Sean Christopherson
On Tue, Nov 05, 2019 at 03:30:00PM -0800, Dan Williams wrote: > On Tue, Nov 5, 2019 at 3:13 PM Sean Christopherson > wrote: > > > > On Tue, Nov 05, 2019 at 03:02:40PM -0800, Dan Williams wrote: > > > On Tue, Nov 5, 2019 at 12:31 PM David Hildenbrand > > > wr

Re: [PATCH v1 03/10] KVM: Prepare kvm_is_reserved_pfn() for PG_reserved changes

2019-11-05 Thread Sean Christopherson
On Tue, Nov 05, 2019 at 03:02:40PM -0800, Dan Williams wrote: > On Tue, Nov 5, 2019 at 12:31 PM David Hildenbrand wrote: > > > The scarier code (for me) is transparent_hugepage_adjust() and > > > kvm_mmu_zap_collapsible_spte(), as I don't at all understand the > > > interaction between THP and _PA

Re: [PATCH v1 03/10] KVM: Prepare kvm_is_reserved_pfn() for PG_reserved changes

2019-11-05 Thread Sean Christopherson
On Tue, Nov 05, 2019 at 09:30:53PM +0100, David Hildenbrand wrote: > >>>I think I know what's going wrong: > >>> > >>>Pages that are pinned via gfn_to_pfn() and friends take a references, > >>>however are often released via > >>>kvm_release_pfn_clean()/kvm_release_pfn_dirty()/kvm_release_page_clean

Re: [PATCH v1 03/10] KVM: Prepare kvm_is_reserved_pfn() for PG_reserved changes

2019-11-05 Thread Sean Christopherson
On Tue, Nov 05, 2019 at 11:02:46AM +0100, David Hildenbrand wrote: > On 05.11.19 10:49, David Hildenbrand wrote: > >On 05.11.19 10:17, David Hildenbrand wrote: > >>On 05.11.19 05:38, Dan Williams wrote: > >>>On Thu, Oct 24, 2019 at 5:11 AM David Hildenbrand wrote: > > Right now, ZONE_DEVI

Re: [PATCH] dma: mediatek: addres minor style issues flagged by clang-format.

2019-03-17 Thread Sean Wang
ndle irq status %08x\n", > - status); > + dev_dbg(hsdma->ddev.dev, "unhandle irq status %08x\n", > status); > /* clean intr bits */ > mtk_hsdma_write(hsdma, HSDMA_REG_INT_STATUS, status); > Acked-by: Sean Wang

URGENT RESPONSE NEEDED

2018-10-12 Thread Sean Kim.
Hello my dear. Did you receive my email message to you? Please, get back to me ASAP as the matter is becoming late. Expecting your urgent response. Sean. ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org

Re: [PATCH 1/13] KVM: Add tlb_remote_flush_with_range callback in kvm_x86_ops

2018-09-10 Thread Sean Christopherson
On Mon, 2018-09-10 at 08:38 +, Tianyu Lan wrote: > Add flush range call back in the kvm_x86_ops and platform can use it > to register its associated function. The parameter "kvm_tlb_range" > accepts a single range and flush list which contains a list of ranges. > > Signed-off-by: Lan Tianyu >

Re: [PATCH 1/2] gpio: mediatek: add driver for MT7621

2018-06-10 Thread Sean Wang
put from the Mediatek > maintainers (especially Sean Wang) on this, especially: > > - Is MT7621 a non-pincontrol GPIO controller, or can it > eventually use pin control as a back-end? Will a separate > pin control driver appear later for this SoC? > MT7621 also have the circuit for pad

Re: [PATCH v2] staging: mt7621-eth: Fix sparse warning in ethtool.c

2018-04-01 Thread Sean Wang
mmc, pci, ethernet, gsw and hsdma all could probably reuse the current mainline code. Sean > > > --- > > Changes in v2: > > - Per GregKH's feedback (thanks!), don't add unnecessary new .h file > > dependencies. This patch version reverts those change

Re: [PATCH Resend] staging: media: lirc: style fix - replace hard-coded function names

2017-11-29 Thread Sean Young
re-written. https://patchwork.linuxtv.org/patch/45189/ It hasn't been merged yet, but I suspect that is imminent. Sean > @@ -888,9 +888,9 @@ static ssize_t read(struct file *filep, char __user > *outbuf, size_t n, > unsigned int m; > DECLARE_WAITQUEUE(wait, curren

Re: [Outreachy kernel] [PATCH v2] Staging: ccree: Remove unused variable monitor_lock

2017-09-11 Thread Sean Paul
On Mon, Sep 11, 2017 at 12:28 PM, Srishti Sharma wrote: > Remove the variable monitor_lock as it is not used anywhere. > > Signed-off-by: Srishti Sharma Reviewed-by: Sean Paul > --- > Changes in v2: > -The variable that was not to be declared as volatile can be > el

Re: [Outreachy kernel] Re: [PATCH] Staging: ccree: Don't use volatile for monitor_lock

2017-09-11 Thread Sean Paul
I tried to find where is this variable being used in the code, but I > didn't find any usage of it . It might be an important attribute of > this structure definition but, I don't see it's value being set to > anything or being used somewhere . > AFAICT, it's not use

Re: [Outreachy kernel] [PATCH] Staging: media: imx: Prefer using BIT macro

2017-09-08 Thread Sean Paul
VF BIT(16) Hi Srishti, Thanks for your patch. Perhaps this is just personal preference, but I find the previous version more readable. Since IMX_MEDIA_GRP_ID_CSI and IMX_MEDIA_GRP_ID_CSI1 are multi-bit fields, you can't fully eliminate the bit shift operations, so you end up with a mix

Re: [PATCH v3 28/28] drm: vboxvideo: switch to drm_*_get(), drm_*_put() helpers

2017-08-11 Thread Sean Paul
On Fri, Aug 11, 2017 at 12:11 PM, Hans de Goede wrote: > Hi, > > On 11-08-17 18:04, Sean Paul wrote: >> >> On Fri, Aug 11, 2017 at 03:26:45PM +0200, Hans de Goede wrote: >>> >>> Hi, >>> >>> On 11-08-17 14:33, Cihangir Akturk wrote: >>

Re: [PATCH v3 28/28] drm: vboxvideo: switch to drm_*_get(), drm_*_put() helpers

2017-08-11 Thread Sean Paul
t; > > > Signed-off-by: Cihangir Akturk > > Thank you for doing this, looks good to me: > > Reviewed-by: Hans de Goede > Applied to drm-misc-next, thank you for the review! Sean > Regards, > > Hans > > > > > --- > > drivers/stagi

Re: [PATCH v2] staging: vboxvideo: Add vboxvideo to drivers/staging

2017-06-14 Thread Sean Paul
On Wed, Jun 14, 2017 at 11:34:10AM +0200, Michael Thayer wrote: > Hello Sean, > > 13.06.2017 20:03, Sean Paul wrote: > [Discussion of vboxvideo driver clean-up.] > > > First, thank you for your submission. > > Thank you for your feedback. > > [Discussion

Re: [PATCH v2] staging: vboxvideo: Add vboxvideo to drivers/staging

2017-06-13 Thread Sean Paul
our life somewhat if it is in the upstream kernel, > in whatever form, rather than in multiple forks. > > > Remember, this code needs us, we don't need this code at all :) > > I assume that that was not meant that way, but that came over as > slightly unfriendly to me.

[PATCH] [media] sir_ir: infinite loop in interrupt handler

2017-05-16 Thread Sean Young
Since this driver does no detection of hardware, it might be used with a non-sir port. Escape out if we are spinning. Signed-off-by: Sean Young --- drivers/media/rc/sir_ir.c | 6 ++ 1 file changed, 6 insertions(+) diff --git a/drivers/media/rc/sir_ir.c b/drivers/media/rc/sir_ir.c index

Re: [[media] rc] e662671619: BUG: kernel hang in test stage

2017-05-16 Thread Sean Young
756b4e17f2f2f82b9f842 > Author: Sean Young > AuthorDate: Tue Mar 7 17:07:59 2017 -0300 > Commit: Mauro Carvalho Chehab > CommitDate: Wed Apr 5 14:50:57 2017 -0300 > > [media] rc: promote lirc_sir out of staging > > Rename lirc_sir to sir_ir in the pr

Re: [PATCH RESEND] staging: media: lirc: use new parport device model

2017-01-30 Thread Sean Young
Prevoius patch is at https://patchwork.kernel.org/patch/7883591/ Since noone ported lirc_parallel to rc-core, the lirc_parallel staging driver has been droppped from the current media tree. I have ported a few other lirc drivers to rc-core but I never found anyone using lirc_parallel or

Re: [PATCH] Staging: media: lirc: style fix, using octal file permissions

2017-01-30 Thread Sean Young
ot;); > > static void free_imon_context(struct imon_context *context) In the current media tree, drivers/staging/media/lirc/lirc_imon.c has been merged with drivers/media/rc/imon.c already, I'm afraid. This patch no longer applies. Sean ___ deve

[PATCH] staging: dgnc: Let line have less 80 char

2016-09-01 Thread Sean
This patch fix a minor checkpath warming: "WARNING: line over 80 characters" Signed-off-by: Sean Wei --- drivers/staging/dgnc/dgnc_neo.c | 116 1 file changed, 82 insertions(+), 34 deletions(-) diff --git a/drivers/staging/dgnc/dgnc_neo.c

[PATCH] staging: dgnc: Let line have less 80 char

2016-09-01 Thread Sean
This patch fix a minor checkpath warming: "WARNING: line over 80 characters" Signed-off-by: Sean --- drivers/staging/dgnc/dgnc_neo.c | 116 1 file changed, 82 insertions(+), 34 deletions(-) diff --git a/drivers/staging/dgnc/dgnc_neo.c b/drive

[PATCH] staging: dgnc: Let line have less 80 char

2016-08-26 Thread Sean
This patch fix a minor checkpath warming: "WARNING: line over 80 characters" Signed-off-by: Sean --- drivers/staging/dgnc/dgnc_neo.c | 116 1 file changed, 82 insertions(+), 34 deletions(-) diff --git a/drivers/staging/dgnc/dgnc_neo.c b/drive

[PATCH] staging:rtl8192e: Usage count off by one

2015-11-15 Thread Sean MacLennan
The rtllib driver is not calling try_module_get() when loading the encryption modules. Because of this, you can never remove the module once you have used it one (i.e. bring up the wireless interface). Signed-off-by: Sean MacLennan --- drivers/staging/rtl8192e/rtllib_softmac.c | 2 +- drivers

[PATCH] Staging: Octeon USB: Fix space prohibited between function name and open parenthesis

2015-02-28 Thread Sean Darcy
This patch fixes the following checkpatch.pl warning in drivers/staging/octeon-usb/octeon-hcd.c WARNING: space prohibited between function name and open parenthesis '(' Signed-off-by: Sean Darcy --- drivers/staging/octeon-usb/octeon-hcd.c | 2 +- 1 file changed, 1 insertion(+),

[PATCH v2] Staging: dgnc: Fix long line coding style issues in dgnc_cls.h

2014-12-03 Thread Sean Cleator
A patch to fix the rest of the long line warnings in the dgnc_cls.h file found by the checkpatch.pl tool Signed-off-by: Sean Cleator --- drivers/staging/dgnc/dgnc_cls.h | 18 -- 1 file changed, 12 insertions(+), 6 deletions(-) diff --git a/drivers/staging/dgnc/dgnc_cls.h b

[PATCH] Staging: dgnc: Fix long line coding style issues in dgnc_cls.h

2014-12-03 Thread Sean Cleator
A patch to fix the rest of the long line warnings in the dgnc_cls.h file found by the checkpatch.pl tool Signed-off-by: Sean Cleator --- drivers/staging/dgnc/dgnc_cls.h | 22 +- 1 file changed, 17 insertions(+), 5 deletions(-) diff --git a/drivers/staging/dgnc/dgnc_cls.h b

[PATCH] Staging: slicoss: Fix long line issues in slicoss.c

2014-12-03 Thread Sean Cleator
A patch to the slicoss.c file to fix some of the long line issues found by the checkpath.pl tool Signed-off-by: Sean Cleator --- drivers/staging/slicoss/slicoss.c | 39 ++- 1 file changed, 26 insertions(+), 13 deletions(-) diff --git a/drivers/staging

[PATCH] Staging: slicoss: Fix long line issues in slicoss.c

2014-12-02 Thread Sean Cleator
A patch to the slicoss.c file to fix some of the long line issues found by the checkpath.pl tool Signed-off-by: Sean Cleator --- drivers/staging/slicoss/slicoss.c | 39 ++- 1 file changed, 26 insertions(+), 13 deletions(-) diff --git a/drivers/staging

Re: [V2 PATCH 01/10] added media agnostic (MA) USB HCD driver

2014-11-14 Thread Sean O. Stalley
On Wed, Nov 12, 2014 at 05:03:18PM -0500, Alan Stern wrote: > On Wed, 12 Nov 2014, Sean O. Stalley wrote: > > Our plan to support multiple MA devices is to have them all connected > > to the same virtual host controller, so only 1 would be needed. > > > > Woul

Re: [V2 PATCH 01/10] added media agnostic (MA) USB HCD driver

2014-11-12 Thread Sean O. Stalley
Sorry, for got to respond to a couple comments. See responses below. On Wed, Nov 12, 2014 at 01:40:21PM -0800, Sean O. Stalley wrote: > Thanks for reviewing. My responses are inline. > > Greg has asked that we clean up this code internally before we > send out another patchset to

Re: [V2 PATCH 01/10] added media agnostic (MA) USB HCD driver

2014-11-12 Thread Sean O. Stalley
Thanks for reviewing. My responses are inline. Greg has asked that we clean up this code internally before we send out another patchset to the mailing list. I will address the issues you pointed out, but it may be a while before you see another patchset. Thanks Again, Sean On Tue, Nov 11, 2014

Re: [PATCH 05/10] added media specific (MS) TCP drivers

2014-11-12 Thread Sean O. Stalley
the mailing list. I will make sure we fix the problems you pointed out, but it may be a while before you see another patchset. Thanks, Sean On Tue, Nov 04, 2014 at 09:48:33AM +0100, Tobias Klauser wrote: > On 2014-11-03 at 21:42:52 +0100, Stephanie Wallick > wrote: > > This is whe

Re: [V2 PATCH 02/10] added media agnostic (MA) USB HCD roothubs

2014-11-12 Thread Sean O. Stalley
. Thanks, Sean O. Stalley On Wed, Nov 12, 2014 at 09:35:42AM +0100, Oliver Neukum wrote: > On Mon, 2014-11-10 at 18:09 -0800, Stephanie Wallick wrote: > > diff --git a/drivers/staging/mausb/drivers/mausb_hub.c > > b/drivers/staging/mausb/drivers/mausb_hub.c > > new file mode 100

Re: [V2 PATCH 03/10] added media agnostic (MA) data structures and handling

2014-11-11 Thread Sean O. Stalley
s. We won't resubmit the driver until a senior kernel developer has signed off on it. Sincerely, Sean O. Stalley Stephanie S. Wallick ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

[PATCH] r8192e_pci driver broken 3.14+

2014-05-28 Thread Sean MacLennan
A sparse error fixup removed a htons() which is required for the driver to function. This patch puts the htons() back and fixes the sparse warning correctly by changing the left side cast. Signed-off-by: Sean MacLennan --- diff --git a/drivers/staging/rtl8192e/rtllib_tx.c b/drivers/staging

Re: r8192e_pci driver broken 3.14+

2014-05-21 Thread Sean MacLennan
On Sat, 19 Apr 2014 16:57:45 -0400 Sean MacLennan wrote: > A sparse error fixup removed a htons() which is required for the > driver to function. This patch puts the htons() back and fixes the > sparse warning correctly by changing the left side cast. > > Signed-off-by:

[PATCH] r8192e_pci driver broken 3.14+

2014-04-19 Thread Sean MacLennan
A sparse error fixup removed a htons() which is required for the driver to function. This patch puts the htons() back and fixes the sparse warning correctly by changing the left side cast. Signed-off-by: Sean MacLennan --- diff --git a/drivers/staging/rtl8192e/rtllib_tx.c b/drivers/staging

Re: r8192e_pci driver broken 3.14+

2014-04-19 Thread Sean MacLennan
On Sat, 19 Apr 2014 11:17:23 -0700 Greg KH wrote: > On Sat, Apr 19, 2014 at 02:12:34PM -0400, Sean MacLennan wrote: > > Fix a sparse error in the htons() call. htons() returns a __be16 > > not a u16. > > > > Signed-off-by: Sean MacLennan > > --- > > Y

Re: r8192e_pci driver broken 3.14+

2014-04-19 Thread Sean MacLennan
Fix a sparse error in the htons() call. htons() returns a __be16 not a u16. Signed-off-by: Sean MacLennan --- diff --git a/drivers/staging/rtl8192e/rtllib_tx.c b/drivers/staging/rtl8192e/rtllib_tx.c index 3e79bff..b7dd153 100644 --- a/drivers/staging/rtl8192e/rtllib_tx.c +++ b/drivers/staging

Re: r8192e_pci driver broken 3.14+

2014-04-19 Thread Sean MacLennan
A sparse error fixup removed a htons() which is required for the driver to function. Put the htons() back. Signed-off-by: Sean MacLennan --- diff --git a/drivers/staging/rtl8192e/rtllib_tx.c b/drivers/staging/rtl8192e/rtllib_tx.c index 11d0a9d..3e79bff 100644 --- a/drivers/staging/rtl8192e

r8192e_pci driver broken 3.14+

2014-04-18 Thread Sean MacLennan
report, I don't really use the wireless in the winter. Cheers, Sean ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Re: [PATCH RFC 26/46] drivers/base: provide an infrastructure for componentised subsystems

2014-01-08 Thread Sean Paul
On Wed, Jan 8, 2014 at 4:36 PM, Russell King - ARM Linux wrote: > On Tue, Jan 07, 2014 at 03:18:21PM -0500, Sean Paul wrote: >> On Thu, Jan 2, 2014 at 4:27 PM, Russell King >> wrote: >> > Subsystems such as ALSA, DRM and others require a single card-level >> >

Re: [PATCH RFC 26/46] drivers/base: provide an infrastructure for componentised subsystems

2014-01-07 Thread Sean Paul
ll in any attached bridges that are specified in the device tree. Along those lines, it might be worthwhile to pull some of the master bind functionality in your next patch into drm helpers so other drivers can use them, and so we have concrete bindings across drm. Make sense? Sean > The supe

[PATCH] Staging: Remove a few superfluous braces

2013-09-10 Thread Sean Williams
Please don't flame me :) I'm getting my feet wet with kernel contribution. One example I saw in a video by GKH suggested cleaning up coding style as a good first commit. Signed-off-by: Sean Williams --- drivers/staging/comedi/drivers/ni_at_a2150.c | 7 +++ 1 file changed, 3