[Emc-developers] [patch] improve task debug and readahead code cleanup

2009-06-03 Thread micges
regards, Michael Index: task/emctask.cc === RCS file: /cvs/emc2/src/emc/task/emctask.cc,v retrieving revision 1.36 diff -U3 -r1.36 emctask.cc --- task/emctask.cc 1 Mar 2009 00:50:33 - 1.36 +++ task/emctask.cc 3 Jun 2009 13:22:37

Re: [Emc-developers] [patch] improve task debug and readahead code cleanup

2009-06-03 Thread Jeff Epler
I have a few comments thrown in below.. On Wed, Jun 03, 2009 at 07:27:46PM +0200, micges wrote: > - if (readRetval > INTERP_MIN_ERROR || readRetval == 3 > /* INTERP_ENDFILE > - > */ || > -

Re: [Emc-developers] [patch] improve task debug and readahead code cleanup

2009-06-03 Thread micges
Jeff Epler napisał(a): > I have a few comments thrown in below.. > > On Wed, Jun 03, 2009 at 07:27:46PM +0200, micges wrote: > >> -if (readRetval > INTERP_MIN_ERROR || readRetval == 3 >> /* INTERP_ENDFILE >> -

Re: [Emc-developers] [patch] improve task debug and readahead code cleanup

2009-06-03 Thread Jeff Epler
> > On Wed, Jun 03, 2009 at 07:27:46PM +0200, micges wrote: > >>if (execRetval == 2 /* INTERP_ENDFILE */ ) { > >> > > Jeff Epler napisał(a): > > Why not change this one as long as you're in here? (of course, > > INTERP_ENDFILE is not 2 in my copy of emc!) > > > > Jeff > > > > On We

Re: [Emc-developers] [patch] improve task debug and readahead code cleanup

2009-06-03 Thread Chris Lesiak
Michael, You might also consider eliminating the goto interpret_again loop in emcTaskPlan() by changing it to a do loop. This would cause a need to re-indent a large block, leading to a large diff, but if the body of the loop were placed in a function it would be a win in readability. The varia

Re: [Emc-developers] [patch] improve task debug and readahead code cleanup

2009-06-03 Thread micges
Chris Lesiak napisał(a): > Michael, > > You might also consider eliminating the goto interpret_again loop in > emcTaskPlan() by changing it to a do loop. > This would cause a need to re-indent a large block, leading to a large > diff, but if the body of the loop were placed in a function it would