Re: Alternative syntax for |

2011-11-16 Thread Dmitry Soshnikov
On 16.11.2011 10:27, Russell Leggett wrote: Given the recent conversation about class as operator and its likely composition with |, I propose turning the syntax: /MemberExpression/ | /ProtoLiteral/ into extends /MemberExpression ProtoLiteral/ In the common case of using the class

Re: migrating `let' and `const'

2011-11-16 Thread Andy Wingo
Hi again, Please excuse my ignorance, but: On Tue, 2011-11-15 at 07:41 -0800, Brendan Eich wrote: To quote Waldemar from https://mail.mozilla.org/pipermail/es-discuss/2010-October/011972.html It's a judgment call, and I'd take these on a case-by-case basis. For const and let, I see

Re: Alternative syntax for |

2011-11-16 Thread Andreas Rossberg
On 16 November 2011 20:45, Erik Arvidsson erik.arvids...@gmail.com wrote: Sorry for being too brief. Today the following works. f(); ... function f() { ... } but the following does not: f(); ... let f = function f() {}; I think it is important that we keep the forward reference

Re: Alternative syntax for |

2011-11-16 Thread Brendan Eich
On Nov 16, 2011, at 8:19 AM, Russell Leggett wrote: On Wed, Nov 16, 2011 at 11:07 AM, Jake Verbaten rayn...@gmail.com wrote: It's simply that var x = someProto beget { ... } reads nicer then var x = someProto extends { ... } I'd prefer to have readability on the non class related

Re: migrating `let' and `const'

2011-11-16 Thread Brendan Eich
On Nov 16, 2011, at 4:18 AM, Erik Corry wrote: In script type=harmony mode we plan to support the new non-hoisted semantics. Block-hoisted -- temporal dead zone. Requires a sentinel value still in general. Hope this is not bad news! /be ___

Re: Alternative syntax for |

2011-11-16 Thread Brendan Eich
On Nov 16, 2011, at 11:12 AM, Erik Arvidsson wrote: One thing that all of these discussions are missing is the hoisting property of function and any possible future classes. If we use let Point = ... we lose all hoisting and the order of your declarations starts to matter and we will end up

Re: migrating `let' and `const'

2011-11-16 Thread Andreas Rossberg
On 16 November 2011 20:03, Brendan Eich bren...@mozilla.com wrote: On Nov 16, 2011, at 4:18 AM, Erik Corry wrote: In script type=harmony mode we plan to support the new non-hoisted semantics. Block-hoisted -- temporal dead zone. Requires a sentinel value still in general. Hope this is not

Re: Alternative syntax for |

2011-11-16 Thread David Herman
On Nov 16, 2011, at 12:11 PM, Dmitry Soshnikov wrote: Yes, I understand, but it doesn't answer the question -- why do we need _additional_ keyword Infix operators can be conditional keywords. That's the current plan for is, IINM. Dave ___

Re: Globalization API working draft

2011-11-16 Thread Norbert Lindenberg
And now we also have a bugzilla product into which you can report issues found in the specification: https://bugs.ecmascript.org/enter_bug.cgi?product=ECMAScript%20Globalization%20API Items that may need discussion among a larger audience should still go to es-discuss@mozilla.org. Thanks,

Re: Alternative syntax for |

2011-11-16 Thread Brendan Eich
On Nov 16, 2011, at 9:31 PM, David Herman wrote: On Nov 16, 2011, at 12:11 PM, Dmitry Soshnikov wrote: Yes, I understand, but it doesn't answer the question -- why do we need _additional_ keyword Infix operators can be conditional keywords. That's the current plan for is, IINM. and

Re: with

2011-11-16 Thread Mark S. Miller
On Wed, Nov 16, 2011 at 11:24 PM, David Herman dher...@mozilla.com wrote: Someone who shall remain nameless shot this down when I floated it privately. But I just have to throw this out there, because I kind of can't stop myself falling in love with it... We used to have this (mis-)feature

Re: with

2011-11-16 Thread Dmitry Soshnikov
On 17.11.2011 11:24, David Herman wrote: Someone who shall remain nameless shot this down when I floated it privately. But I just have to throw this out there, because I kind of can't stop myself falling in love with it... We used to have this (mis-)feature for dynamically extending scope

Re: with

2011-11-16 Thread David Herman
| On Nov 16, 2011, at 11:27 PM, Mark S. Miller wrote: On Wed, Nov 16, 2011 at 11:24 PM, David Herman dher...@mozilla.com wrote: Someone who shall remain nameless shot this down when I floated it privately. But I just have to throw this out there, because I kind of can't stop myself

Re: with

2011-11-16 Thread David Herman
On Nov 16, 2011, at 11:28 PM, Dmitry Soshnikov wrote: However, we nevertheless had/have the semantics for `with', and it may cause confusion. Right, that's the natural objection. But... with-statements are dead, long live with-expressions! Moreover, you need to specify that [noNewLineHere]

Re: with

2011-11-16 Thread David Flanagan
On 11/16/11 11:30 PM, David Herman wrote: | On Nov 16, 2011, at 11:27 PM, Mark S. Miller wrote: On Wed, Nov 16, 2011 at 11:24 PM, David Herman dher...@mozilla.com mailto:dher...@mozilla.com wrote: Someone who shall remain nameless shot this down when I floated it privately. But I

Re: with

2011-11-16 Thread David Herman
On Nov 16, 2011, at 11:27 PM, Mark S. Miller wrote: On Wed, Nov 16, 2011 at 11:24 PM, David Herman dher...@mozilla.com wrote: obj with { foo: 12 } with { bar: 13 } with { baz: 17 } I don't get it yet. What do you mean by dynamically extending prototype chains? What does the above