Re: revive let blocks

2015-06-29 Thread Andreas Rossberg
On 26 June 2015 at 04:08, Kevin Smith zenpars...@gmail.com wrote: I think do expressions are go for ES7 but they need re-championing, and implementation. I'll stir the pot. I think Andreas was interested at some point? Yes, I'm planning to prepare a proper spec for the September meeting.

Re: When macros will get in, will the core get slimmed in favour of macro-definitions?

2015-06-29 Thread Andreas Rossberg
I doubt this will be possible in a backwards compatible manner. With ES6, we missed the opportunity to take more of a desugaring approach for new features. As a consequence, there now is a fair amount of micro variation between seemingly related features that is only describable in terms of

Re: Move es-discuss to discuss.webplatform.org?

2015-06-29 Thread Andreas Rossberg
On 19 June 2015 at 23:04, Axel Rauschmayer a...@rauschma.de wrote: http://discourse.specifiction.org/t/upcoming-migration/805 Would it make sense to move es-discuss to that upcoming site? I’m not particularly fond of mailing lists and much prefer forums, especially discourse-based ones.

Re: function.sent beta equivalence?

2015-06-29 Thread Andreas Rossberg
On 24 June 2015 at 22:56, Jason Orendorff jason.orendo...@gmail.com wrote: Quick question about function.sent: As of ES6, there's this parallel between functions and generators: // how to wrap a function // f2 is equivalent to f, if f doesn't use `this`. function f(...) { ... }

Re: RegExp.escape()

2015-06-29 Thread Benjamin Gruenbaum
Why? What advantage would it offer? On Mon, Jun 29, 2015 at 9:49 PM, C. Scott Ananian ecmascr...@cscott.net wrote: And I'm suggesting that `RegExp.escape(str, /[image: ☺]/ug)` is a much better idea.​ --scott ___ es-discuss mailing list

Re: Will any new features be tied to constructors?

2015-06-29 Thread Anne van Kesteren
On Sat, Jun 27, 2015 at 2:21 AM, Anne van Kesteren ann...@annevk.nl wrote: For custom elements in DOM there's a proposal to have the constructor be controlled by the user agent and have some kind of callback that actually initiates the element. This has some advantage in that it allows the

Re: RegExp.escape()

2015-06-29 Thread Allen Wirfs-Brock
On Jun 27, 2015, at 9:17 AM, Mark S. Miller wrote: Safety over readability please. If there is a single fully escaped form that is safe to use in all the expected contexts, let's choose that. The results of RegExp.escape are not very readable anyway, and rarely read. So compromising

Re: function.sent beta equivalence?

2015-06-29 Thread Brendan Eich
Andreas Rossberg wrote: But it's a good question. Maybe it's an indication that we should not add function.sent? We talked about this at the last meeting, though maybe you weren't there (meeting notes header with people present and their 2 or 3LAs gets copied forward a lot!). It doesn't seem

Re: RegExp.escape()

2015-06-29 Thread C. Scott Ananian
And I'm suggesting that `RegExp.escape(str, /[image: ☺]/ug)` is a much better idea.​ --scott ___ es-discuss mailing list es-discuss@mozilla.org https://mail.mozilla.org/listinfo/es-discuss

Re: RegExp.escape()

2015-06-29 Thread Benjamin Gruenbaum
This is currently discussed at https://github.com/benjamingr/RegExp.escape/issues/29#issuecomment-116789780 . Adding my comment from there to here too: Some languages (PHP for example) do this (optional parameter with additional parameters) so it's not unprecedented. The question we should ask

Re: RegExp.escape()

2015-06-29 Thread C. Scott Ananian
Please, not an iterable over characters. (Or at least, not only.) Use a RegExp. Imagine trying to ensure that any characters over \u007f were escaped. You don't want an iterable over ~64k characters. In addition, a RegExp would allow you to concisely specify hex digits, but only at the start

Re: RegExp.escape()

2015-06-29 Thread Benjamin Gruenbaum
I meant something like `RegExp.escape(str, ☺)` (also escapes `☺`). Since strings are iterable by code points via the new iteration protocol this sounds like the natural choice. I'm not sure such a second argument would be a good idea. On Mon, Jun 29, 2015 at 9:42 PM, C. Scott Ananian