Re: ES4 draft: Object

2008-03-10 Thread Mark S. Miller
On Mon, Mar 10, 2008 at 11:14 PM, Maciej Stachowiak <[EMAIL PROTECTED]> wrote: > [...] I'd like to propose the following three alternatives to the > current proposal: > > 1) Remove the feature entirely from ES4 (as part of the "judicious > feature cuts" process) until a more appropriate syntax i

Re: ES4 draft: Object

2008-03-10 Thread Maciej Stachowiak
On Mar 10, 2008, at 11:14 PM, Maciej Stachowiak wrote: > The optional second argument to make propertyIsEnumerable a setter has > some practical problems: > > 1) It violates the very strong norm that getter and setter functions > are separate and have their own different arguments. It will make t

Re: Insurrection (was: ES4 draft: Object)

2008-03-10 Thread Geoffrey Garen
>> ES3 has several abstraction mechanisms: >> * lambda abstraction, which it gets approximately as right as Scheme! >> * objects as a generalization of records, which has some pros and >> cons >> * prototype-based sharing of common behavior, which is used almost >> exclusively by JavaScript progr

Re: Insurrection (was: ES4 draft: Object)

2008-03-10 Thread Maciej Stachowiak
On Mar 10, 2008, at 9:54 PM, Mark Miller wrote: > ES3 has several abstraction mechanisms: > * lambda abstraction, which it gets approximately as right as Scheme! > * objects as a generalization of records, which has some pros and cons > * prototype-based sharing of common behavior, which is used

Re: ES4 draft: Object

2008-03-10 Thread Maciej Stachowiak
On Mar 10, 2008, at 7:01 PM, Lars Hansen wrote: >> We are the WG. Are you saying that substantive discussions >> of your proposals are not welcome? Not sure what the point >> of participating is if that's the case. > > Sorry, I didn't realize that "I find it abhorrent" qualified as > substantiv

Re: ES4 draft: Object

2008-03-10 Thread Ian Hickson
On Mon, 10 Mar 2008, Waldemar Horwat wrote: > > > intrinsic function propertyIsEnumerable(name: EnumerableId, flag: > > (boolean|undefined) = undefined): boolean > > I too find the second parameter here abhorrent. Please find another way > to solve it (Brendan's namespace idea maybe) or remove

Insurrection (was: ES4 draft: Object)

2008-03-10 Thread Mark Miller
On Mon, Mar 10, 2008 at 8:11 PM, Jeff Dyer <[EMAIL PROTECTED]> wrote: > On 3/10/08 5:40 PM, Waldemar Horwat wrote: > > I'm dealing with a serious insurrection of folks who believe that the ES4 > > working group has a bad attitude, based on Brendan's public comments and > > responses to issues l

Re: ES4 draft: Function

2008-03-10 Thread Jon Zeppieri
On 3/10/08, Erik Arvidsson <[EMAIL PROTECTED]> wrote: > There are valid use cases for new Function (...) and Function(...). > One that comes to mind is getting an attribute in DOM and make it into > an event handler. Yes, the Function constructor and meta::invoke can > be replaced by eval but F

Re: ES4 draft: Function

2008-03-10 Thread Erik Arvidsson
There are valid use cases for new Function (...) and Function(...). One that comes to mind is getting an attribute in DOM and make it into an event handler. Yes, the Function constructor and meta::invoke can be replaced by eval but Function needs to be there for ES3 compatibility. On Mon, Mar 10,

Re: ES4 draft: Function

2008-03-10 Thread Jon Zeppieri
On 3/10/08, Lars Hansen <[EMAIL PROTECTED]> wrote: > First draft of the spec for the Function class. Please comment. > Suggestion: deprecate the Function constructor and static invoke(). Almost all of its uses are better handled by function expressions and, in those cases where eval() in require

Re: ES4 draft: Object

2008-03-10 Thread Robert Sayre
On Mon, Mar 10, 2008 at 11:11 PM, Jeff Dyer <[EMAIL PROTECTED]> wrote: > > it would > be helpful to follow up with possible solutions or at least insight into > what makes it abhorrent (your word). FWIW, I also did not grasp the force of the objection, and would like to understand better. > >

RE: ES4 draft: Name

2008-03-10 Thread Lars Hansen
Draft 2, changelog near the beginning. Please note the OPEN ISSUES section, which names two fairly arbitrary designs in this proposal. Comments welcome. --lars > -Original Message- > From: [EMAIL PROTECTED] > [mailto:[EMAIL PROTECTED] On Behalf Of Lars Hansen > Sent: 5. mars 2008 17:32

Re: ES4 draft: Object

2008-03-10 Thread Jeff Dyer
On 3/10/08 5:40 PM, Waldemar Horwat wrote: > Lars Hansen wrote: >> The feature was approved by the WG and solves a practical problem. >> If another way to solve this practical problem is proposed (in a >> more structured form than in the ongoing discussion) and finds favor >> with the WG, then

RE: ES4 draft: Object

2008-03-10 Thread Lars Hansen
> -Original Message- > From: Waldemar Horwat [mailto:[EMAIL PROTECTED] > Sent: 10. mars 2008 19:40 > To: Lars Hansen > Cc: es4-discuss@mozilla.org > Subject: Re: ES4 draft: Object > > Lars Hansen wrote: > > The feature was approved by the WG and solves a practical problem. > > If another

RE: ES4 draft: Function

2008-03-10 Thread Lars Hansen
> -Original Message- > From: [EMAIL PROTECTED] > [mailto:[EMAIL PROTECTED] On Behalf Of Lars Hansen > Sent: 10. mars 2008 18:46 > To: Erik Arvidsson > Cc: es4-discuss Discuss > Subject: RE: ES4 draft: Function > > > -Original Message- > > From: Erik Arvidsson [mailto:[EMAIL PROTEC

Re: ES4 draft: Object

2008-03-10 Thread Waldemar Horwat
Lars Hansen wrote: > The feature was approved by the WG and solves a practical problem. > If another way to solve this practical problem is proposed (in a > more structured form than in the ongoing discussion) and finds favor > with the WG, then fine -- of course we can replace it. Until then, > t

Re: ES4 draft: Object

2008-03-10 Thread liorean
On 11/03/2008, Lars Hansen <[EMAIL PROTECTED]> wrote: > As far as I can see this is not a problem in the file I sent out, nor in > the one I received from the reflector. > > What mailer are you using? Gmail's web interface. And checking, it appears only using the View link, not the Download link

RE: ES4 draft last call: line continuation in string and regexliterals

2008-03-10 Thread Jeff Dyer
> -Original Message- > From: [EMAIL PROTECTED] [mailto:es4-discuss- > [EMAIL PROTECTED] On Behalf Of Waldemar Horwat > Sent: Monday, March 10, 2008 6:29 PM > To: Lars Hansen > Cc: es4-discuss Discuss > Subject: Re: ES4 draft last call: line continuation in string and > regexliterals > >

Re: ES4 draft last call: line continuation in string and regex literals

2008-03-10 Thread Waldemar Horwat
Lars Hansen wrote: >>> The character sequence BACKSLASH (where >>> will be one of the characters LF, LS, or PS) is >>> removed from string literals delimited by either single or triple >>> SINGLEQUOTE or DOUBLEQUOTE characters. (Triple-quoting is >> defined in >>> [5].) >> This states that:

No ES4-WG phone call (RE: ES4 process tweaks)

2008-03-10 Thread Jeff Dyer
> Waldemar Horwat wrote: > > Jeff Dyer wrote: > > - Phone calls as needed > > Is there one tomorrow? There's a blank agenda page for it. Hearing no objection, the ES4-WG weekly phone calls are suspended until sufficient need for one arises. Enjoy your free hour! Jd ___

RE: ES4 draft: Object

2008-03-10 Thread Lars Hansen
As far as I can see this is not a problem in the file I sent out, nor in the one I received from the reflector. What mailer are you using? Anyone else see this? --lars > -Original Message- > From: [EMAIL PROTECTED] > [mailto:[EMAIL PROTECTED] On Behalf Of liorean > Sent: 10. mars 2008

RE: ES4 draft last call: line continuation in string and regex literals

2008-03-10 Thread Lars Hansen
> -Original Message- > From: Waldemar Horwat [mailto:[EMAIL PROTECTED] > Sent: 10. mars 2008 18:59 > To: Lars Hansen > Cc: es4-discuss Discuss > Subject: Re: ES4 draft last call: line continuation in string > and regex literals > > > The character sequence BACKSLASH (where > > will be

RE: ES4 draft: Object

2008-03-10 Thread Lars Hansen
> -Original Message- > From: Waldemar Horwat [mailto:[EMAIL PROTECTED] > Sent: 10. mars 2008 18:50 > To: Lars Hansen > Cc: es4-discuss@mozilla.org > Subject: Re: ES4 draft: Object > > > intrinsic function propertyIsEnumerable(name: EnumerableId, flag: > > (boolean|undefined) = undefined)

Re: ES4 process tweaks

2008-03-10 Thread Waldemar Horwat
Jeff Dyer wrote: > - Phone calls as needed Is there one tomorrow? There's a blank agenda page for it. Waldemar ___ Es4-discuss mailing list Es4-discuss@mozilla.org https://mail.mozilla.org/listinfo/es4-discuss

Re: ES4 draft last call: line continuation in string and regex literals

2008-03-10 Thread Waldemar Horwat
> The character sequence BACKSLASH (where > will be one of the characters LF, LS, or PS) is removed from string literals > delimited by either single or triple SINGLEQUOTE or DOUBLEQUOTE characters. > (Triple-quoting is defined in [5].) This states that: "abc\\ tde" evaluates to the string

RE: ES4 draft: Object

2008-03-10 Thread Lars Hansen
> -Original Message- > From: [EMAIL PROTECTED] > [mailto:[EMAIL PROTECTED] On Behalf Of liorean > Sent: 10. mars 2008 17:52 > To: es4-discuss@mozilla.org > Subject: Re: ES4 draft: Object > > On 10/03/2008, Lars Hansen <[EMAIL PROTECTED]> wrote: > > Draft 2 of the spec for the Object class

Re: ES4 draft: Object

2008-03-10 Thread Waldemar Horwat
> intrinsic function propertyIsEnumerable(name: EnumerableId, flag: > (boolean|undefined) = undefined): boolean I too find the second parameter here abhorrent. Please find another way to solve it (Brendan's namespace idea maybe) or remove this feature altogether. How does property lookup deal

RE: ES4 draft: Function

2008-03-10 Thread Lars Hansen
> -Original Message- > From: Erik Arvidsson [mailto:[EMAIL PROTECTED] > Sent: 10. mars 2008 17:31 > To: Lars Hansen > Cc: es4-discuss Discuss > Subject: Re: ES4 draft: Function > > What is the reason to make the thisObj param to bind optional? Symmetry with call and apply and a consequen

Re: ES4 draft: Vector

2008-03-10 Thread Waldemar Horwat
> new Vector. ( length=..., fixed=... ) It would be helpful for readability to have the types here. > The |Vector| constructor is implementation-defined. This is misleading. Usually when a standard states that something is implementation-defined, it means that its semantics are not specified i

Re: ES4 draft: Object

2008-03-10 Thread liorean
On 10/03/2008, Lars Hansen <[EMAIL PROTECTED]> wrote: > Draft 2 of the spec for the Object class. Changelog near the beginning. The intrinsic toString method returns the concatenation of "[", "object", the class name of the object, and "]". There should probably be a whitepace between

Re: ES4 draft: Object

2008-03-10 Thread Yuh-Ruey Chen
Brendan Eich wrote: > On Mar 9, 2008, at 3:01 PM, Yuh-Ruey Chen wrote: > > > Brendan Eich wrote: > >> ES3 code can't detect namespaces, so arguably shouldn't care if we > >> were to implement DontEnum using an open namespace. But this could be > >> a problem for mixed ES3 and ES4 scenarios where th

Re: ES4 draft: Function

2008-03-10 Thread Erik Arvidsson
What is the reason to make the thisObj param to bind optional? 2008/3/10 Lars Hansen <[EMAIL PROTECTED]>: > First draft of the spec for the Function class. Please comment. > > --lars > > ___ > Es4-discuss mailing list > Es4-discuss@mozilla.org > htt

Re: ES4 draft: Object

2008-03-10 Thread liorean
On 10/03/2008, Lars Hansen <[EMAIL PROTECTED]> wrote: > Draft 2 of the spec for the Object class. Changelog near the beginning. The draft HTML seems a little broken. There's … in it early on, later these appear raw in the source (which displays as an empty square in Opera and IE8). And nea

RE: ES4 draft: Object

2008-03-10 Thread Lars Hansen
Draft 2 of the spec for the Object class. Changelog near the beginning. --lars Title: The class "Object" The class Object NAME: "The class 'Object'" FILE: spec/library/Object.html CATEGORY: Pre-defined classes (E262-3 Chap

ES4 draft: Function

2008-03-10 Thread Lars Hansen
First draft of the spec for the Function class. Please comment. --lars Title: The class "Function" The class Function NAME: "The class 'Function'" FILE: spec/library/Function.html CATEGORY: Pre-defined classes SOURCES: