[FFmpeg-devel] [PATCH] avcodec/adpcm_argo: simplify and move duplicated logic into a function

2020-01-31 Thread Zane van Iperen
Signed-off-by: Zane van Iperen --- libavcodec/adpcm.c | 40 ++-- 1 file changed, 18 insertions(+), 22 deletions(-) diff --git a/libavcodec/adpcm.c b/libavcodec/adpcm.c index dad3da28d3..9a42353351 100644 --- a/libavcodec/adpcm.c +++ b/libavcodec/adpcm.c @@ -55

Re: [FFmpeg-devel] [PATCH 1/6] avformat/format: add av_demuxer_find_by_ext

2020-01-31 Thread Gyan Doshi
On 31-01-2020 10:41 pm, Andreas Rheinhardt wrote: Gyan Doshi: Allows selecting demuxer by extension which are more widely recognized by users. Conditional cast added since this function will usually be called after av_find_input_format, and so matches its return type. That's not a good point

[FFmpeg-devel] [PATCH 2/2] avformat: add demuxer for Simon & Schuster Interactive's VAG format

2020-01-31 Thread Zane van Iperen
Adds support for the custom VAG container used by some Simon & Schuster Interactive games such as Real War, and Real War: Rogue States. Signed-off-by: Zane van Iperen --- libavformat/Makefile | 1 + libavformat/allformats.c | 1 + libavformat/kvag.c | 149 ++

[FFmpeg-devel] [PATCH 0/2] Simon & Schuster Interactive VAG demuxer + decoder.

2020-01-31 Thread Zane van Iperen
Hi all, This patchset adds support for the VAG container and ADPCM variant used by some Simon & Schuster Interactive games such as 'Real War', and 'Real War: Rogue States'. It has been tested against VAG files from both games. Some things to note: * SSI's VAG has no relation to the existing PS2

[FFmpeg-devel] [PATCH 1/2] avcodec: add decoder for Simon & Schuster Interactive's ADPCM variant

2020-01-31 Thread Zane van Iperen
Adds support for the ADPCM variant used by some Simon & Schuster Interactive games such as Real War, and Real War: Rogue States. Signed-off-by: Zane van Iperen --- libavcodec/Makefile | 1 + libavcodec/adpcm.c | 10 ++ libavcodec/allcodecs.c | 1 + libavcodec/avcodec.h|

[FFmpeg-devel] [PATCH] avcodec/xvididct: Fix integer overflow in MULT()

2020-01-31 Thread Michael Niedermayer
Fixes: signed integer overflow: 23170 * 95058 cannot be represented in type 'int' Fixes: 20295/clusterfuzz-testcase-minimized-ffmpeg_AV_CODEC_ID_MJPEG_fuzzer-5800212870463488 Found-by: continuous fuzzing process https://github.com/google/oss-fuzz/tree/master/projects/ffmpeg Signed-off-by: Micha

Re: [FFmpeg-devel] [PATCH] avformat/protocols: check protocol name before foreach

2020-01-31 Thread Liu Steven
> 在 2020年1月31日,下午11:24,Nicolas George 写道: > > Liu Steven (12020-01-31): >> Just more safe than without check. > > This is a mistake, a common one: this is not safer, it is less: the > caller has the incorrect assumption that their pointer is not NULL, and > you are letting them keep it, and ev

[FFmpeg-devel] [PATCH] fftools/cmdutils: add no demuxer/muxer name specified message

2020-01-31 Thread Steven Liu
Signed-off-by: Steven Liu --- fftools/cmdutils.c | 15 +-- 1 file changed, 13 insertions(+), 2 deletions(-) diff --git a/fftools/cmdutils.c b/fftools/cmdutils.c index f0f2b4fde4..6e387ccb10 100644 --- a/fftools/cmdutils.c +++ b/fftools/cmdutils.c @@ -1854,8 +1854,14 @@ static void sh

Re: [FFmpeg-devel] [PATCH] avfilter/vf_geq: use per-thread AVExpr for expression evaluation

2020-01-31 Thread Marton Balint
On Thu, 30 Jan 2020, Michael Niedermayer wrote: On Wed, Jan 29, 2020 at 08:25:17PM +0100, Marton Balint wrote: There was no consensus about separating AVExprState from AVExpr so here is a minimal patch using the existing AVExpr to fix ticket #7528. Signed-off-by: Marton Balint --- doc/filt

Re: [FFmpeg-devel] [PATCH] avformat/hlsenc: fix hls_ts_options with mpegts

2020-01-31 Thread Marton Balint
On Fri, 31 Jan 2020, Steven Liu wrote: Marton Balint 于2020年1月31日周五 上午4:40写道: On Wed, 22 Jan 2020, Marton Balint wrote: > Was broken since cdbf8847ea97a985dfd55432e1384bb7fe5d2d3b. Ping, will apply soon. Thanks, Marton > > Signed-off-by: Marton Balint > --- > libavformat/hlsenc.c | 36

Re: [FFmpeg-devel] [PATCH 1/2] MAINTAINERS: Add patchwork maintainer

2020-01-31 Thread Michael Niedermayer
On Mon, Jan 27, 2020 at 09:54:21PM +0100, Michael Niedermayer wrote: > Signed-off-by: Michael Niedermayer > --- > MAINTAINERS | 1 + > 1 file changed, 1 insertion(+) will apply [...] -- Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB Complexity theory is the science of

Re: [FFmpeg-devel] [PATCH 2/2] avcodec/avdct: Clear IDCTDSPContext context

2020-01-31 Thread Michael Niedermayer
On Fri, Jan 31, 2020 at 12:47:57PM -0300, James Almer wrote: > On 1/28/2020 10:30 AM, Michael Niedermayer wrote: > > On Mon, Jan 27, 2020 at 11:49:49PM -0300, James Almer wrote: > >> On 1/27/2020 9:25 PM, Michael Niedermayer wrote: > >>> On Mon, Jan 27, 2020 at 06:09:28PM -0300, James Almer wrote:

Re: [FFmpeg-devel] [PATCH 1/6] avformat/format: add av_demuxer_find_by_ext

2020-01-31 Thread Andreas Rheinhardt
Gyan Doshi: > Allows selecting demuxer by extension which are more widely recognized > by users. > > Conditional cast added since this function will usually be called after > av_find_input_format, and so matches its return type. That's not a good point. av_demuxer_find_by_ext() already always ret

Re: [FFmpeg-devel] [PATCH v2] avfilter/scale: fix CID 1457833

2020-01-31 Thread Michael Niedermayer
On Fri, Jan 31, 2020 at 12:46:13PM +0530, Gyan Doshi wrote: > Remove expressions with constant results and > improve overflow checks. > --- > libavfilter/vf_scale.c | 6 ++ > 1 file changed, 2 insertions(+), 4 deletions(-) > > diff --git a/libavfilter/vf_scale.c b/libavfilter/vf_scale.c > ind

Re: [FFmpeg-devel] [PATCH 3/6] fftools/ffmpeg: search for demuxer by extension as well

2020-01-31 Thread Gyan Doshi
On 31-01-2020 11:17 pm, Andreas Rheinhardt wrote: Gyan Doshi: Identifies demuxer based on extension if short name search fails. --- fftools/ffmpeg_opt.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/fftools/ffmpeg_opt.c b/fftools/ffmpeg_opt.c index 12d44886ee..ecc7d8

Re: [FFmpeg-devel] [PATCH 3/6] fftools/ffmpeg: search for demuxer by extension as well

2020-01-31 Thread Andreas Rheinhardt
Gyan Doshi: > Identifies demuxer based on extension if short name search fails. > --- > fftools/ffmpeg_opt.c | 3 ++- > 1 file changed, 2 insertions(+), 1 deletion(-) > > diff --git a/fftools/ffmpeg_opt.c b/fftools/ffmpeg_opt.c > index 12d44886ee..ecc7d8f1c5 100644 > --- a/fftools/ffmpeg_opt.c >

Re: [FFmpeg-devel] [PATCH] dashenc: check pts to prevent division by zero error

2020-01-31 Thread Alfred E. Heggestad
On 31/01/2020 14:17, James Almer wrote: On 1/31/2020 10:08 AM, Jeyapal, Karthick wrote: On 1/30/20 3:28 PM, Alfred E. Heggestad wrote: this usecase will cause a division by zero trap: 1. dashenc has received one frame 2. os->max_pts and os->start_pts have same value 3. delta between max_pts

[FFmpeg-devel] [PATCH v3] lavc/qsv: adding DX11 support

2020-01-31 Thread Artem Galin
This enables DX11 support for QSV with higher priority than DX9. In case of multiple GPUs configuration, DX9 API does not allow to get access to QSV device in some cases - headless. Implementation based on DX11 resolves that restriction by enumerating list of available GPUs and finding device with

Re: [FFmpeg-devel] [PATCH 2/2] avcodec/avdct: Clear IDCTDSPContext context

2020-01-31 Thread James Almer
On 1/28/2020 10:30 AM, Michael Niedermayer wrote: > On Mon, Jan 27, 2020 at 11:49:49PM -0300, James Almer wrote: >> On 1/27/2020 9:25 PM, Michael Niedermayer wrote: >>> On Mon, Jan 27, 2020 at 06:09:28PM -0300, James Almer wrote: On 1/27/2020 5:54 PM, Michael Niedermayer wrote: > Fixes use

Re: [FFmpeg-devel] [PATCH] lavfi: add mbfequalizer filter.

2020-01-31 Thread Paul B Mahol
On 12/23/19, Nicolas George wrote: > TODO changelog and version bump > > Signed-off-by: Nicolas George > --- > doc/filters.texi | 48 +++ > libavfilter/Makefile | 1 + > libavfilter/af_mbfequalizer.c | 567 ++ > libavfilter/allfilters.c

Re: [FFmpeg-devel] [PATCH] lavfi: add mbfequalizer filter.

2020-01-31 Thread Paul B Mahol
On 12/23/19, Nicolas George wrote: > Thanks for the comment. > > James Almer (12019-12-23): >> > +frame_out = ff_get_audio_buffer(ctx->outputs[0], >> > frame->nb_samples); > >> Can't you use av_frame_make_writable() instead to simplify this? > > No, because it does not use ff_get_audio_buf

Re: [FFmpeg-devel] [PATCH] avformat/protocols: check protocol name before foreach

2020-01-31 Thread Nicolas George
Liu Steven (12020-01-31): > Just more safe than without check. This is a mistake, a common one: this is not safer, it is less: the caller has the incorrect assumption that their pointer is not NULL, and you are letting them keep it, and even in some extents validating it. > I think if it return -

[FFmpeg-devel] [PATCH 6/6] fftools/cmdutils: search for demuxer by extension as well

2020-01-31 Thread Gyan Doshi
Identifies demuxer based on extension if short name search fails. --- fftools/cmdutils.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/fftools/cmdutils.c b/fftools/cmdutils.c index f0f2b4fde4..855a78e15f 100644 --- a/fftools/cmdutils.c +++ b/fftools/cmdutils.c @@ -1854,9

[FFmpeg-devel] [PATCH 1/6] avformat/format: add av_demuxer_find_by_ext

2020-01-31 Thread Gyan Doshi
Allows selecting demuxer by extension which are more widely recognized by users. Conditional cast added since this function will usually be called after av_find_input_format, and so matches its return type. --- libavformat/avformat.h | 5 + libavformat/format.c | 15 +++ libavf

[FFmpeg-devel] [PATCH 5/6] fftools/ffplay: search for demuxer by extension as well

2020-01-31 Thread Gyan Doshi
Identifies demuxer based on extension if short name search fails. --- fftools/ffplay.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/fftools/ffplay.c b/fftools/ffplay.c index fee0619f7c..4b5f46949c 100644 --- a/fftools/ffplay.c +++ b/fftools/ffplay.c @@ -3477,8 +3477,8 @@

[FFmpeg-devel] [PATCH 4/6] fftools/ffprobe: search for demuxer by extension as well

2020-01-31 Thread Gyan Doshi
Identifies demuxer based on extension if short name search fails. --- fftools/ffprobe.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/fftools/ffprobe.c b/fftools/ffprobe.c index b619c1f34e..a2886ec976 100644 --- a/fftools/ffprobe.c +++ b/fftools/ffprobe.c @@ -3166,8 +3166

[FFmpeg-devel] [PATCH 3/6] fftools/ffmpeg: search for demuxer by extension as well

2020-01-31 Thread Gyan Doshi
Identifies demuxer based on extension if short name search fails. --- fftools/ffmpeg_opt.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/fftools/ffmpeg_opt.c b/fftools/ffmpeg_opt.c index 12d44886ee..ecc7d8f1c5 100644 --- a/fftools/ffmpeg_opt.c +++ b/fftools/ffmpeg_opt.c @@

[FFmpeg-devel] [PATCH 2/6] doc/APIchanges: add entry for av_demuxer_find_by_ext

2020-01-31 Thread Gyan Doshi
--- doc/APIchanges | 3 +++ 1 file changed, 3 insertions(+) diff --git a/doc/APIchanges b/doc/APIchanges index 2494a3901b..e3db90d5fd 100644 --- a/doc/APIchanges +++ b/doc/APIchanges @@ -15,6 +15,9 @@ libavutil: 2017-10-21 API changes, most recent first: +2020-01-31 - xx - lavf 5

Re: [FFmpeg-devel] [PATCH] dashenc: check pts to prevent division by zero error

2020-01-31 Thread James Almer
On 1/31/2020 10:08 AM, Jeyapal, Karthick wrote: > > On 1/30/20 3:28 PM, Alfred E. Heggestad wrote: >> this usecase will cause a division by zero trap: >> >> 1. dashenc has received one frame >> 2. os->max_pts and os->start_pts have same value >> 3. delta between max_pts and start_pts is 0 >> 4. av

Re: [FFmpeg-devel] [PATCH] dashenc: check pts to prevent division by zero error

2020-01-31 Thread Jeyapal, Karthick
On 1/30/20 3:28 PM, Alfred E. Heggestad wrote: > this usecase will cause a division by zero trap: > > 1. dashenc has received one frame > 2. os->max_pts and os->start_pts have same value > 3. delta between max_pts and start_pts is 0 > 4. av_rescale_q(0, x, y) returns 0 > 5. this value is used as d

Re: [FFmpeg-devel] [PATCH] lavc/dvdsubenc: accept palette from options

2020-01-31 Thread Michael Niedermayer
On Thu, Jan 30, 2020 at 07:40:53PM +0100, Michael Kuron wrote: > Is there anything else you need me to change before this can be > merged? If not, I am happy to split it into two patches if necessary. spliting the patch would certainly be a good thing if noone has any objections to the patch itsel

Re: [FFmpeg-devel] [PATCH] avformat/hlsenc: fix hls_ts_options with mpegts

2020-01-31 Thread Steven Liu
Marton Balint 于2020年1月31日周五 上午4:40写道: > > > > On Wed, 22 Jan 2020, Marton Balint wrote: > > > Was broken since cdbf8847ea97a985dfd55432e1384bb7fe5d2d3b. > > Ping, will apply soon. > > Thanks, > Marton > > > > > Signed-off-by: Marton Balint > > --- > > libavformat/hlsenc.c | 36 +--

Re: [FFmpeg-devel] [PATCH] avformat/protocols: check protocol name before foreach

2020-01-31 Thread Liu Steven
> 在 2020年1月31日,下午8:14,Liu Steven 写道: > > > >> 在 2020年1月31日,下午8:07,Nicolas George 写道: >> >> Liu Steven (12020-01-31): >>> for example: https://patchwork.ffmpeg.org/project/ffmpeg/list/?series=250 >> >> Yes, I saw it shortly afterwards. Seems misguided: same result for a >> protocol not foun

Re: [FFmpeg-devel] [PATCH] avformat/protocols: check protocol name before foreach

2020-01-31 Thread Liu Steven
> 在 2020年1月31日,下午8:07,Nicolas George 写道: > > Liu Steven (12020-01-31): >> for example: https://patchwork.ffmpeg.org/project/ffmpeg/list/?series=250 > > Yes, I saw it shortly afterwards. Seems misguided: same result for a > protocol not found (normal behavior, must be handled) and for a clumsy

Re: [FFmpeg-devel] [PATCH] avformat/protocols: check protocol name before foreach

2020-01-31 Thread Nicolas George
Liu Steven (12020-01-31): > for example: https://patchwork.ffmpeg.org/project/ffmpeg/list/?series=250 Yes, I saw it shortly afterwards. Seems misguided: same result for a protocol not found (normal behavior, must be handled) and for a clumsy programmer. I like it better when the core functions are

Re: [FFmpeg-devel] [PATCH] avformat/protocols: check protocol name before foreach

2020-01-31 Thread Liu Steven
> 在 2020年1月31日,下午7:13,Nicolas George 写道: > > Steven Liu (12020-01-31): >> Signed-off-by: Steven Liu >> --- >> libavformat/protocols.c | 2 ++ >> 1 file changed, 2 insertions(+) > > In what situation is it useful for the caller? for example: https://patchwork.ffmpeg.org/project/ffmpeg/list/?ser

Re: [FFmpeg-devel] [PATCH] avformat/protocols: check protocol name before foreach

2020-01-31 Thread Nicolas George
Steven Liu (12020-01-31): > Signed-off-by: Steven Liu > --- > libavformat/protocols.c | 2 ++ > 1 file changed, 2 insertions(+) In what situation is it useful for the caller? Regards, -- Nicolas George signature.asc Description: PGP signature __

[FFmpeg-devel] [PATCH] avfilter/vf_ssim: improve precision

2020-01-31 Thread Paul B Mahol
Use doubles for accumulating floats. Signed-off-by: Paul B Mahol --- libavfilter/ssim.h| 2 +- libavfilter/vf_ssim.c | 18 +-- libavfilter/x86/vf_ssim.asm | 36 ++ libavfilter/x86/vf_ssim_init.c| 2 +- tests/ref/

Re: [FFmpeg-devel] [PATCH v7 0/3] Fix mpeg1/2 stream copy

2020-01-31 Thread Gaullier Nicolas
>Envoyé : mercredi 15 janvier 2020 00:42 >À : ffmpeg-devel@ffmpeg.org >Objet : [PATCH v7 0/3] Fix mpeg1/2 stream copy > >Modified with Anton feedback: no public amendment, the code from >add_coded_side_data() is now duplicated from existing one in ffmpeg.c, but it >is rather small. > >Nicolas Gau