[FFmpeg-devel] [PATCH] Add atsc_a53 dependency to h264/hevc decoders

2020-10-05 Thread Chris Miceli
As per ticket #8901 there is a compilation issue where there is an undefined reference when compiled with a minimal set of filters. This commit remedies that by ensuring decoders which have SEI parsers import the relevent caption object and hence functionality. --- libavcodec/Makefile | 6 +++---

Re: [FFmpeg-devel] [PATCH] Document community process

2020-10-05 Thread Chris Miceli
Hi there, The vote.ffmpeg.org URL appears to be down, happy to help however I can but just wanted to let you know. Some recommendations for changes might be: - "arbitrate" instead of "arbitrage" - potentially rename Technical Committee to Technical Conflicts Committee to avoid the confusion

[FFmpeg-devel] autofate system

2020-10-05 Thread Chris Miceli
Hi all, I have written a small system called autofate ( https://github.com/cmiceli/autofate) which is designed to basically run fate on every commit in master, ideally capturing and then reporting broken builds. It's written in rust so that it can run on a wide variety of platforms (I am

Re: [FFmpeg-devel] [PATCH 8/8] RFC: editing HDR properties in H.265 metadata BSF

2020-10-05 Thread Kenny McClive
Hi, Was any additional progress made on this? Forgive me if I’m not finding it. Thanks, Kenny > On Aug 24, 2020, at 5:42 AM, Harry Mallon wrote: > > > > >> On 23 Aug 2020, at 23:33, Mark Thompson wrote: >> >> --- >> Setting HDR properties is a useful feature, but it's very unclear what

[FFmpeg-devel] [PATCH 2/4] avcodec/apedec: properly calculate and store absolute value

2020-10-05 Thread Paul B Mahol
Signed-off-by: Paul B Mahol --- libavcodec/apedec.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/libavcodec/apedec.c b/libavcodec/apedec.c index 273abe2490..aa4d8fa524 100644 --- a/libavcodec/apedec.c +++ b/libavcodec/apedec.c @@ -1311,7 +1311,7 @@ static void

[FFmpeg-devel] [PATCH 4/4] avcodec/apedec: use ff_clz() instead of while loop

2020-10-05 Thread Paul B Mahol
Signed-off-by: Paul B Mahol --- libavcodec/apedec.c | 10 +++--- 1 file changed, 3 insertions(+), 7 deletions(-) diff --git a/libavcodec/apedec.c b/libavcodec/apedec.c index 8fe7b5ee86..ea36247eb9 100644 --- a/libavcodec/apedec.c +++ b/libavcodec/apedec.c @@ -575,14 +575,10 @@ static inline

[FFmpeg-devel] [PATCH 1/4] avcodec/apedec: fix decoding insane files with recent versions

2020-10-05 Thread Paul B Mahol
Signed-off-by: Paul B Mahol --- libavcodec/apedec.c | 59 +++-- 1 file changed, 46 insertions(+), 13 deletions(-) diff --git a/libavcodec/apedec.c b/libavcodec/apedec.c index c76c0509df..273abe2490 100644 --- a/libavcodec/apedec.c +++

[FFmpeg-devel] [PATCH 3/4] avcodec/apedec: use proper macro and type for pivot variable

2020-10-05 Thread Paul B Mahol
Signed-off-by: Paul B Mahol --- libavcodec/apedec.c | 8 +++- 1 file changed, 3 insertions(+), 5 deletions(-) diff --git a/libavcodec/apedec.c b/libavcodec/apedec.c index aa4d8fa524..8fe7b5ee86 100644 --- a/libavcodec/apedec.c +++ b/libavcodec/apedec.c @@ -559,12 +559,10 @@ static inline

Re: [FFmpeg-devel] [PATCH 1/7] mpegvideo: use the AVVideoEncParams API for exporting QP tables

2020-10-05 Thread Michael Niedermayer
On Mon, Oct 05, 2020 at 10:40:59AM +0200, Anton Khirnov wrote: > Quoting Michael Niedermayer (2020-10-03 20:26:20) > > On Fri, Oct 02, 2020 at 08:03:25PM +0200, Anton Khirnov wrote: > > > Do it only when requested with the AV_CODEC_EXPORT_DATA_VIDEO_ENC_PARAMS > > > flag. > > > > > > Drop

Re: [FFmpeg-devel] [PATCH 1/3] avcodec/h2645_parse: Limit initial skipped_bytes_pos_size to nal size / 16

2020-10-05 Thread James Almer
On 10/5/2020 6:43 PM, Michael Niedermayer wrote: > On Mon, Oct 05, 2020 at 01:30:07AM -0300, James Almer wrote: >> On 10/4/2020 6:02 PM, James Almer wrote: >>> On 10/4/2020 5:57 PM, Michael Niedermayer wrote: On Sun, Oct 04, 2020 at 05:04:05PM -0300, James Almer wrote: > On 10/4/2020 4:41

Re: [FFmpeg-devel] [PATCH 4/7] lavfi/vf_spp: convert to the video_enc_params API

2020-10-05 Thread Michael Niedermayer
On Mon, Oct 05, 2020 at 10:26:24AM +0200, Anton Khirnov wrote: > Quoting Michael Niedermayer (2020-10-03 20:23:02) > > On Fri, Oct 02, 2020 at 08:03:28PM +0200, Anton Khirnov wrote: > > > --- > > > libavfilter/Makefile| 2 +- > > > libavfilter/vf_spp.c| 57

Re: [FFmpeg-devel] [PATCH 1/3] avcodec/h2645_parse: Limit initial skipped_bytes_pos_size to nal size / 16

2020-10-05 Thread Michael Niedermayer
On Mon, Oct 05, 2020 at 01:30:07AM -0300, James Almer wrote: > On 10/4/2020 6:02 PM, James Almer wrote: > > On 10/4/2020 5:57 PM, Michael Niedermayer wrote: > >> On Sun, Oct 04, 2020 at 05:04:05PM -0300, James Almer wrote: > >>> On 10/4/2020 4:41 PM, Michael Niedermayer wrote: > Fixes: OOM >

[FFmpeg-devel] [PATCH] Document community process

2020-10-05 Thread Jean-Baptiste Kempf
General Assembly + Main Elections --- doc/dev_community/community.md | 60 ++ 1 file changed, 60 insertions(+) create mode 100644 doc/dev_community/community.md diff --git a/doc/dev_community/community.md b/doc/dev_community/community.md new file mode 100644

Re: [FFmpeg-devel] [PATCH 2/3] tools/target_dec_fuzzer: Adjust threshold for opus

2020-10-05 Thread Michael Niedermayer
On Sun, Oct 04, 2020 at 05:09:28PM -0300, James Almer wrote: > On 10/4/2020 4:41 PM, Michael Niedermayer wrote: > > Fixes: Timeout (12sec -> 3sec) > > Fixes: > > 24549/clusterfuzz-testcase-minimized-ffmpeg_AV_CODEC_ID_LIBOPUS_fuzzer-6211170349088768 > > codec id, or decoder? The testcase used

Re: [FFmpeg-devel] [PATCH] avcodec/h264_slice: use av_buffer_replace() to simplify code

2020-10-05 Thread James Almer
On 10/5/2020 5:49 AM, Anton Khirnov wrote: > Quoting James Almer (2020-09-28 17:02:00) >> Based on eff289ce9f030f023e218ee7ce354d4f0e035b6d. >> >> Signed-off-by: James Almer >> --- >> libavcodec/h264_slice.c | 34 -- >> 1 file changed, 12 insertions(+), 22

Re: [FFmpeg-devel] [PATCH v4 0/9] avformat: wav-s337m support + new probe_stream option

2020-10-05 Thread Devin Heitmueller
On Mon, Oct 5, 2020 at 6:23 AM Nicolas Gaullier wrote: > dolby_e is a "professional" codec, it is not used for distribution and not > supported by end user chips, so the most common formats are : > - contribution: mpegts (or dvb for satt etc.) with s302m data -> s337m (this > could be

Re: [FFmpeg-devel] [PATCH 2/2] libavcodec/ac3tab: rename ff_ac3_sample_rate_tab to avpriv_ac3_sample_rate_tab so that it can be used in libavformat

2020-10-05 Thread James Almer
On 10/5/2020 7:48 AM, Nachiket Tarate wrote: > > > > From: ffmpeg-devel on behalf of Anton > Khirnov > Sent: Monday, October 5, 2020 1:50 PM > To: FFmpeg development discussions and patches > Subject: Re: [FFmpeg-devel] [PATCH 2/2] libavcodec/ac3tab: rename

Re: [FFmpeg-devel] [PATCH 2/2] libavcodec/ac3tab: rename ff_ac3_sample_rate_tab to avpriv_ac3_sample_rate_tab so that it can be used in libavformat

2020-10-05 Thread Nicolas George
Nachiket Tarate (12020-10-05): > What is your opinion about Anton Khirnov 's review > comments ? The only way forward is to merge the libraries. The split of shared objects brings all kinds of issues, including the problem of avpriv symbols, and no practical benefit. Regards, -- Nicolas

Re: [FFmpeg-devel] [PATCH 2/2] libavcodec/ac3tab: rename ff_ac3_sample_rate_tab to avpriv_ac3_sample_rate_tab so that it can be used in libavformat

2020-10-05 Thread Nachiket Tarate
From: ffmpeg-devel on behalf of Anton Khirnov Sent: Monday, October 5, 2020 1:50 PM To: FFmpeg development discussions and patches Subject: Re: [FFmpeg-devel] [PATCH 2/2] libavcodec/ac3tab: rename ff_ac3_sample_rate_tab to avpriv_ac3_sample_rate_tab so that

Re: [FFmpeg-devel] [PATCH v4 4/9] avformat/s337m: New ff_s337m_probe()

2020-10-05 Thread Nicolas Gaullier
>> Similar to ff_spdif_probe() with just an additional checking of the >> bit resolution of the container as it may be 16 or 24 for s337m. > >Sorry if I miss something: >Why is the new function part of s337m.c? There is a call to static s337m_get_offset_and_codec() which is in s337m.c. The muxer

Re: [FFmpeg-devel] [PATCH v4 0/9] avformat: wav-s337m support + new probe_stream option

2020-10-05 Thread Nicolas Gaullier
>> Because of the dependencies, I had to group all the patches in a serie, but >> they are 3 functional parts : >> * patch 1 is necessary to fix dolby_e pts that will be part of the >> test in patch 8 >> * patch 2,3,4,5,6,7,8 : s337m support in wav >> this is a rework of a precedent serie

Re: [FFmpeg-devel] [PATCH] avcodec/h264_slice: use av_buffer_replace() to simplify code

2020-10-05 Thread Anton Khirnov
Quoting James Almer (2020-09-28 17:02:00) > Based on eff289ce9f030f023e218ee7ce354d4f0e035b6d. > > Signed-off-by: James Almer > --- > libavcodec/h264_slice.c | 34 -- > 1 file changed, 12 insertions(+), 22 deletions(-) Looks good -- Anton Khirnov

Re: [FFmpeg-devel] [PATCH 1/7] mpegvideo: use the AVVideoEncParams API for exporting QP tables

2020-10-05 Thread Anton Khirnov
Quoting Michael Niedermayer (2020-10-03 20:26:20) > On Fri, Oct 02, 2020 at 08:03:25PM +0200, Anton Khirnov wrote: > > Do it only when requested with the AV_CODEC_EXPORT_DATA_VIDEO_ENC_PARAMS > > flag. > > > > Drop previous code using the long-deprecated AV_FRAME_DATA_QP_TABLE* > > API.

Re: [FFmpeg-devel] [PATCH v4 3/9] avformat/s337m: Consider container bit resolution

2020-10-05 Thread Tomas Härdin
lör 2020-10-03 klockan 00:23 +0200 skrev Nicolas Gaullier: > +if (container_word_bits && !(container_word_bits == 16 && word_bits == > 16) && !(container_word_bits == 24 && word_bits == 20) && > !(container_word_bits == 24 && word_bits == 24)) > +return AVERROR_INVALIDDATA; > That

Re: [FFmpeg-devel] [PATCH] avformat/mpegts: ensure seekback for small probesize

2020-10-05 Thread Marton Balint
On Sun, 4 Oct 2020, Andriy Gelman wrote: From: Andriy Gelman get_packet_size() may read upto PROBE_PACKET_MAX_BUF bytes, which may be larger than probesize. Signed-off-by: Andriy Gelman --- An alternative could be to make sure we don't read more than s->probesize bytes in

Re: [FFmpeg-devel] [PATCH 2/9] avformat/aviobuf: check if requested seekback buffer is already read

2020-10-05 Thread Marton Balint
On Sun, 4 Oct 2020, Andriy Gelman wrote: Hi Marton, On Tue, 29. Sep 23:10, Marton Balint wrote: Existing code did not check if the requested seekback buffer is already read entirely. In this case, nothing has to be done to guarantee seekback. Signed-off-by: Marton Balint ---

Re: [FFmpeg-devel] [PATCH 4/7] lavfi/vf_spp: convert to the video_enc_params API

2020-10-05 Thread Anton Khirnov
Quoting Michael Niedermayer (2020-10-03 20:23:02) > On Fri, Oct 02, 2020 at 08:03:28PM +0200, Anton Khirnov wrote: > > --- > > libavfilter/Makefile| 2 +- > > libavfilter/vf_spp.c| 57 - > > libavfilter/vf_spp.h| 3 +- > >

Re: [FFmpeg-devel] [PATCH 2/2] libavcodec/ac3tab: rename ff_ac3_sample_rate_tab to avpriv_ac3_sample_rate_tab so that it can be used in libavformat

2020-10-05 Thread Anton Khirnov
Quoting Nachiket Tarate (2020-10-04 16:35:09) > This will be used by HLS demuxer to parse EC3SpecificBox (dec3) during > SAMPLE-AES decryption. > > Signed-off-by: Nachiket Tarate Since the table is so small, it seems preferable to duplicate it in libavformat than add eat another private

Re: [FFmpeg-devel] [PATCH v2 3/3] avformat/mxfdec: Read Apple private Content Light Level from MXF

2020-10-05 Thread Tomas Härdin
tor 2020-10-01 klockan 22:13 +0200 skrev Michael Niedermayer: > On Thu, Oct 01, 2020 at 03:29:19PM +0100, Harry Mallon wrote: > > > On 30 Sep 2020, at 08:32, Michael Niedermayer > > > wrote: > > > > > > fails on big endian > > > > > > --- src/tests/ref/fate/mxf-probe-applehdr10