On Sat, May 30, 2015 at 1:53 PM, Karthik Nayak wrote:
> Create 'ref-filter.h', also add ref-filter to the Makefile.
> This completes movement of creation of 'ref-filter' from
> 'for-each-ref'.
It's important that the project can be built successfully and function
correctly at each stage of a patc
On Sat, May 30, 2015 at 1:53 PM, Karthik Nayak wrote:
> Rename some of the functions and make them publically available.
s/publically/publicly/
> This is a preparatory step for moving code from 'for-each-ref'
> to 'ref-filter' to make meaningful, targeted services available to
> other commands v
On Sat, May 30, 2015 at 1:53 PM, Karthik Nayak wrote:
> Intoduce 'ref_filter_cbdata' which will hold 'ref_filter'
s/Intoduce/Introduce/
> (Conditions to filter the refs on) and 'ref_array' (The array
s/Conditions/conditions/
s/The/the/
> of ref_array_items). Modify the code to use these new st
On Sat, May 30, 2015 at 1:53 PM, Karthik Nayak wrote:
> Extract two helper functions out of grab_single_ref(). Firstly,
> new_refinfo() which is used to allocate memory for a new refinfo
> structure and copy the objectname, refname and flag to it.
> Secondly, match_name_as_path() which when given
On Sat, May 30, 2015 at 7:29 AM, Patryk Obara wrote:
> On Thu, May 28, 2015 at 4:29 PM, Eric Sunshine
> wrote:
>> Did you consider the alternate approach of handling newline processing
>> immediately upon loading 'logfile' and 'template_file', rather than
>> delaying processing until this point?
On Tue, May 26, 2015 at 09:50:49PM +0100, John Lee wrote:
> Hi
>
> Does anybody have code to stage commits using a the visual
> diff/merge tools supported by git-difftool? Is there support in git
> itself somewhere, even?
>
> I'm looking for something functionally similar to git add -p
>
> Look
From: Quentin Neill
Complement existing --show-email option with fallback
configuration variable, with tests.
---
Documentation/git-blame.txt | 2 ++
builtin/blame.c | 10 +++-
t/t8002-blame.sh| 62 +
3 files changed, 73 in
On Fri, May 29, 2015 at 2:40 PM, Junio C Hamano wrote:
>
> Quentin Neill writes:
>
> > Thanks for the thorough review!
> > I have adjusted the commit messages and updated the documentation changes.
> > I'm in trying to add tests, I'll probably have some issues but will
> > post something that wor
On Sat, May 30, 2015 at 2:54 PM, Junio C Hamano wrote:
> Robert Dailey writes:
>
>> On Sat, May 30, 2015 at 12:04 PM, Junio C Hamano wrote:
>>> Robert Dailey writes:
>>>
In the meantime I'd like to ask, do we even need to add an option for
this? What if we just make `diff.submodule lo
Robert Dailey writes:
> On Sat, May 30, 2015 at 12:04 PM, Junio C Hamano wrote:
>> Robert Dailey writes:
>>
>>> In the meantime I'd like to ask, do we even need to add an option for
>>> this? What if we just make `diff.submodule log` not use
>>> --first-parent? This seems like a backward compat
On Sat, May 30, 2015 at 2:19 PM, Robert Dailey wrote:
> On Sat, May 30, 2015 at 12:04 PM, Junio C Hamano wrote:
>> Robert Dailey writes:
>>
>>> In the meantime I'd like to ask, do we even need to add an option for
>>> this? What if we just make `diff.submodule log` not use
>>> --first-parent? Th
On Sat, May 30, 2015 at 12:04 PM, Junio C Hamano wrote:
> Robert Dailey writes:
>
>> In the meantime I'd like to ask, do we even need to add an option for
>> this? What if we just make `diff.submodule log` not use
>> --first-parent? This seems like a backward compatible change in of
>> itself.
>
Quoting Thomas Braun :
Signed-off-by: Thomas Braun
---
contrib/completion/git-completion.bash | 48
+++---
1 file changed, 33 insertions(+), 15 deletions(-)
I don't see the benefits of this change. This patch adds more than
twice as many lines as it removes
Rename some of the functions and make them publically available.
This is a preparatory step for moving code from 'for-each-ref'
to 'ref-filter' to make meaningful, targeted services available to
other commands via public APIs.
Based-on-patch-by: Jeff King
Mentored-by: Christian Couder
Mentored-b
Create 'ref-filter.h', also add ref-filter to the Makefile.
This completes movement of creation of 'ref-filter' from
'for-each-ref'.
Mentored-by: Christian Couder
Mentored-by: Matthieu Moy
Signed-off-by: Karthik Nayak
---
Makefile | 1 +
builtin/for-each-ref.c | 41 +
Move most of the code from 'for-each-ref' to 'ref-filter' to make
it publicly available to other commands, this is to unify the code
of 'tag -l', 'branch -l' and 'for-each-ref' so that they can share
their implementations with each other.
Mentored-by: Christian Couder
Mentored-by: Matthieu Moy
S
Intoduce 'ref_filter_cbdata' which will hold 'ref_filter'
(Conditions to filter the refs on) and 'ref_array' (The array
of ref_array_items). Modify the code to use these new structures.
This is a preparatory patch to eventually move code from 'for-each-ref'
to 'ref-filter' and making it publically
Introduce and implement 'ref_filter_clear_data()' which will free
all allocated memory for 'ref_filter_cbdata' and its underlying array
of 'ref_array_item'.
Mentored-by: Christian Couder
Mentored-by: Matthieu Moy
Signed-off-by: Karthik Nayak
---
builtin/for-each-ref.c | 13 +
1 fil
Rename 'refinfo' to 'ref_array_item' as a preparatory step for introduction of
new structures in the forthcoming patch.
Re-order the fields in 'ref_array_item' so that refname can be
eventually converted to a FLEX_ARRAY.
Mentored-by: Christian Couder
Mentored-by: Matthieu Moy
Signed-off-by: Ka
In 'grab_single_ref()' remove the extra count variable 'cnt' and
use the variable 'grab_cnt' of structure 'grab_ref_cbdata' directly
instead.
Mentored-by: Christian Couder
Mentored-by: Matthieu Moy
Signed-off-by: Karthik Nayak
---
builtin/for-each-ref.c | 7 ++-
1 file changed, 2 insertion
Extract two helper functions out of grab_single_ref(). Firstly,
new_refinfo() which is used to allocate memory for a new refinfo
structure and copy the objectname, refname and flag to it.
Secondly, match_name_as_path() which when given an array of patterns
and the refname checks if the refname matc
Hello,
After the third iteration of this WIP/PATCH series ($gmane/270164). This
is a follow up.
Changes,
* Subdivided some patches.
* Spelling corrections.
* Small changes.
Thanks all for suggestions.
--
Regards,
Karthik
--
To unsubscribe from this list: send the line "unsu
Johannes Sixt writes:
> There you have it: Look the other way for a while, and people start
> using exotic stuff... ;)
Is it exotic to have random/srandom? Both are in POSIX and 4BSD;
admittedly rand/srand are written down in C89 and later, so they
might be more portable, but I recall the preva
Robert Dailey writes:
> In the meantime I'd like to ask, do we even need to add an option for
> this? What if we just make `diff.submodule log` not use
> --first-parent? This seems like a backward compatible change in of
> itself.
Why? People have relied on submodule-log not to include all the
Eric Sunshine writes:
> On Fri, May 29, 2015 at 4:17 PM, Junio C Hamano wrote:
>> By default, we should run clean-up after the editor we spawned gives
>> us the edited result. Not adding one more LF after the template
>> when it already ends with LF would not hurt, but an extra blank
>> after t
Signed-off-by: Thomas Braun
---
contrib/completion/git-completion.bash | 48 +++---
1 file changed, 33 insertions(+), 15 deletions(-)
diff --git a/contrib/completion/git-completion.bash
b/contrib/completion/git-completion.bash
index bfc74e9..f6e5bf6 100644
--- a/cont
Signed-off-by: Thomas Braun
---
contrib/completion/git-completion.bash | 48 +++---
1 file changed, 33 insertions(+), 15 deletions(-)
diff --git a/contrib/completion/git-completion.bash
b/contrib/completion/git-completion.bash
index bfc74e9..f6e5bf6 100644
--- a/cont
Signed-off-by: Thomas Braun
---
contrib/completion/git-completion.bash | 8
1 file changed, 8 insertions(+)
diff --git a/contrib/completion/git-completion.bash
b/contrib/completion/git-completion.bash
index f6e5bf6..486c61b 100644
--- a/contrib/completion/git-completion.bash
+++ b/cont
Ramkumar Ramachandra wrote:
> Junio C Hamano wrote:
> >
> > > contrib/completion/git-completion.bash | 5 +
> > > 1 file changed, 5 insertions(+)
> > >
> > > diff --git a/contrib/completion/git-completion.bash
> b/contrib/completion/git-completion.bash
> > > index bfc74e9..3c00acd 100644
> > >
2015-05-20 6:13 GMT+08:00 René Scharfe :
> It had never been used.
Confirmed. The unused "buf" should be removed.
>
> Signed-off-by: Rene Scharfe
> ---
> builtin/clean.c | 2 --
> 1 file changed, 2 deletions(-)
>
> diff --git a/builtin/clean.c b/builtin/clean.c
> index 98c103f..a9eb772 100644
>
@Eric, Junio
Thank you a lot for feedback - should I post new set of patches as new thread
with new cover letter, or reply to first mail in this thread?
On Thu, May 28, 2015 at 4:29 PM, Eric Sunshine wrote:
> Did you consider the alternate approach of handling newline processing
> immediately up
On Fri, May 29, 2015 at 09:18:11PM -0500, Robert Dailey wrote:
> So I am working on trying to setup my environment (VM through Virtual Box)
> to do some testing on this. You all have encouraged me to try the mailing
> list review model. So I won't give up yet.
I am not sure you need a VM or Linux
On Sat, May 30, 2015 at 3:29 PM, Paul Tan wrote:
> Hi,
> Okay, I'm trying this out in the next re-roll. I do agree that this
> patch series should not touch anything in t/ at all.
>
> One problem(?) is that putting builtins/pull.o in the BUILTIN_OBJS and
> leaving git-pull.sh in SCRIPT_SH in the M
Hi,
On Tue, May 19, 2015 at 3:21 AM, Junio C Hamano wrote:
> Paul Tan writes:
>
>> This series rewrites git-pull.sh into a C builtin, thus improving its
>> performance and portability. It is part of my GSoC project to rewrite
>> git-pull
>> and git-am into builtins[2].
>
> Earlier you were worr
34 matches
Mail list logo