[PATCH] completion: remove 'git column' from porcelain commands

2015-12-11 Thread SZEDER Gábor
'git column' is an internal helper, so it should not be offered on 'git ' along with porcelain commands. Signed-off-by: SZEDER Gábor --- contrib/completion/git-completion.bash | 1 + 1 file changed, 1 insertion(+) diff --git a/contrib/completion/git-completion.bash

[PATCHv2] Makefile: add missing phony target

2015-12-11 Thread Elia Pinto
Add some missing phony target to Makefile. Also put the .PHONY declaration immediately before the target declaration, where necessary, for a better readability and a uniform style. Signed-off-by: Elia Pinto Helped-by: Matthieu Moy --- This

[RFC] Case insensitive URL rewrite

2015-12-11 Thread Lars Schneider
Hi, the "url..insteadOf" git config is case sensitive. I understand that this makes sense on case sensitive file systems. However, URLs are mostly case insensitive: Consider this: git clone https://GIThub.com/GIT/GIT git clone https://github.com/git/git Both commands will clone the same

Re: [PATCHv2] Makefile: add missing phony target

2015-12-11 Thread Matthieu Moy
Elia Pinto writes: > This is the second version of this patch. > Added the corrections suggested by Matthieu Moy ($gmane/282221) Sorry, but my main concern was that the patch could not be reviewed in good conditions as-is, and I think it still cannot be. It's very hard

Re: [RFC] Case insensitive URL rewrite

2015-12-11 Thread Daniel Stenberg
On Fri, 11 Dec 2015, Lars Schneider wrote: the "url..insteadOf" git config is case sensitive. I understand that this makes sense on case sensitive file systems. However, URLs are mostly case insensitive: Minor detail here perhaps, but... I would object to URLs being "mostly case

Re: [PATCHv2] Makefile: add missing phony target

2015-12-11 Thread Elia Pinto
2015-12-11 15:40 GMT+01:00 Matthieu Moy : > Elia Pinto writes: > >> This is the second version of this patch. >> Added the corrections suggested by Matthieu Moy ($gmane/282221) > > Sorry, but my main concern was that the patch could not be

Re: [PATCHv2] Makefile: add missing phony target

2015-12-11 Thread Matthieu Moy
Elia Pinto writes: > 2015-12-11 15:40 GMT+01:00 Matthieu Moy : >> Elia Pinto writes: >> >>> This is the second version of this patch. >>> Added the corrections suggested by Matthieu Moy ($gmane/282221) >> >> Sorry,

sb/submodule-parallel-fetch, was: Re: What's cooking in git.git (Dec 2015, #03; Thu, 10)

2015-12-11 Thread Johannes Sixt
Am 11.12.2015 um 00:55 schrieb Stefan Beller: > On Thu, Dec 10, 2015 at 3:51 PM, Junio C Hamano wrote: >> Stefan Beller writes: >> * sb/submodule-parallel-fetch (2015-11-24) 17 commits ... >>> >>> I assume you plan on merging this after 2.7

Re: [PATCH 04/16] refs: add do_for_each_per_worktree_ref

2015-12-11 Thread Junio C Hamano
David Turner writes: > Alternate refs backends might still use files to store per-worktree > refs. So the files backend's ref-loading infrastructure should be > available to those backends, just for use on per-worktree refs. Add > do_for_each_per_worktree_ref, which

Re: sb/submodule-parallel-fetch, was: Re: What's cooking in git.git (Dec 2015, #03; Thu, 10)

2015-12-11 Thread Stefan Beller
On Fri, Dec 11, 2015 at 1:37 PM, Johannes Sixt wrote: > > Generally, I'm already quite satisfied with the state of the > infrastructure at the tip of the branch. > I was about the rework the patch series. > Nevertheless, I have a few niggles. If you don't mind I'll split your

[PATCH] completion: fix completing unstuck email alias arguments

2015-12-11 Thread SZEDER Gábor
Completing unstuck form of email aliases doesn't quite work: $ git send-email --to alice bob cecil $ git send-email --to a alice bob cecil While listing email aliases works as expected, the second case should just complete to 'alice', but it keeps offering all email aliases

Re: [PATCH/RFC 06/10] strbuf: introduce strbuf_split_str_without_term()

2015-12-11 Thread Junio C Hamano
Karthik Nayak writes: >>> diff --git a/ref-filter.c b/ref-filter.c >>> @@ -892,14 +892,11 @@ static void populate_value(struct ref_array_item *ref) >>> * TODO: Implement a function similar to >>> strbuf_split_str() >>> *

Re: sb/submodule-parallel-fetch,

2015-12-11 Thread Junio C Hamano
Stefan Beller writes: > On Fri, Dec 11, 2015 at 1:37 PM, Johannes Sixt wrote: >> >> Generally, I'm already quite satisfied with the state of the >> infrastructure at the tip of the branch. > > I was about the rework the patch series. OK. I think the very

Re: [PATCH 02/16] refs: add methods for misc ref operations

2015-12-11 Thread Junio C Hamano
David Turner writes: > struct ref_be { > struct ref_be *next; > const char *name; > ref_transaction_commit_fn *transaction_commit; > + > + pack_refs_fn *pack_refs; > + peel_ref_fn *peel_ref; > + create_symref_fn *create_symref; > + > +

Re: sb/submodule-parallel-fetch, was: Re: What's cooking in git.git (Dec 2015, #03; Thu, 10)

2015-12-11 Thread Johannes Sixt
Am 11.12.2015 um 23:52 schrieb Stefan Beller: If you don't mind I'll split your patch into chunks and squash these where appropriate I don't mind at all; please pick what you like. -- Hannes -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to

Re: [PATCH 02/16] refs: add methods for misc ref operations

2015-12-11 Thread Junio C Hamano
David Turner writes: > diff --git a/cache.h b/cache.h > index 51c35c3..707455a 100644 > --- a/cache.h > +++ b/cache.h > @@ -,6 +,13 @@ extern char *oid_to_hex(const struct object_id *oid); > /* same static buffer as s > extern int interpret_branch_name(const

Re: [PATCH 02/16] refs: add methods for misc ref operations

2015-12-11 Thread David Turner
On Fri, 2015-12-11 at 15:33 -0800, Junio C Hamano wrote: > David Turner writes: > > > diff --git a/cache.h b/cache.h > > index 51c35c3..707455a 100644 > > --- a/cache.h > > +++ b/cache.h > > @@ -,6 +,13 @@ extern char *oid_to_hex(const struct object_id > >

Re: [PATCH 04/16] refs: add do_for_each_per_worktree_ref

2015-12-11 Thread David Turner
On Fri, 2015-12-11 at 15:52 -0800, Junio C Hamano wrote: > David Turner writes: > > > Alternate refs backends might still use files to store per-worktree > > refs. So the files backend's ref-loading infrastructure should be > > available to those backends, just for use

Re: [PATCH/RFC 01/10] ref-filter: introduce a parsing function for each atom in valid_atom

2015-12-11 Thread Junio C Hamano
Karthik Nayak writes: >> This problem will go away if you introduce the 'valid_atom' field in >> the patch which actually needs it (as suggested above) rather than in >> this patch. > > Yup, agreed. > Thanks for your suggestions. In addition, most of the lines in this

Re: [PATCH/RFC 00/10] ref-filter: use parsing functions

2015-12-11 Thread Junio C Hamano
Karthik Nayak writes: > Karthik Nayak (10): > ref-filter: introduce a parsing function for each atom in valid_atom > ref-filter: introduce struct used_atom > ref-fitler: bump match_atom() name to the top > ref-filter: skip deref specifier in match_atom_name() >

Re: [PATCH 02/16] refs: add methods for misc ref operations

2015-12-11 Thread David Turner
On Fri, 2015-12-11 at 15:39 -0800, Junio C Hamano wrote: > David Turner writes: > > > struct ref_be { > > struct ref_be *next; > > const char *name; > > ref_transaction_commit_fn *transaction_commit; > > + > > + pack_refs_fn *pack_refs; > > +

Re: Why does send-pack call pack-objects for all remote refs?

2015-12-11 Thread Nasser Grainawi
> On Dec 9, 2015, at 9:19 PM, Jeff King wrote: > > On Tue, Dec 08, 2015 at 05:34:43PM +, Daniel Koverman wrote: > >> It is also good to know that 2000 remote refs is insane. The lower >> hanging fruit here sounds like trimming that to a reasonable >> number, so I'll try that

[L10N] Kickoff of translation for Git 2.7.0 round 1

2015-12-11 Thread Jiang Xin
Hi guys, Git v2.7.0-rc0 has been released, and it's time to start new round of git l10n. This time there are 66 updated messages need to be translated since last update: l10n: git.pot: v2.7.0 round 1 (66 new, 29 removed) Generate po/git.pot from v2.7.0-rc0 for git v2.7.0 l10n round 1.

Re: [PATCH 02/16] refs: add methods for misc ref operations

2015-12-11 Thread David Turner
On Fri, 2015-12-11 at 16:23 -0800, Junio C Hamano wrote: > David Turner writes: > > > The previous review was here: > > http://permalink.gmane.org/gmane.comp.version-control.git/279062 > > > > Michael wrote: > >> Hmmm, I thought our convention was to define typedefs for

Bug: git-p4 can skip changes when syncing large from multiple depot paths

2015-12-11 Thread James Farwell
Reproduction Steps: 1. Have a git repo cloned from a perforce repo using multiple depot paths (e.g. //depot/foo/ and //depot/bar/). 2. Add changes to the perforce repo in both depot paths. (e.g. 5 changes in each) 2. Do a "git p4 sync --changes_block_size n" where n is smaller than the number

Re: [PATCH 02/16] refs: add methods for misc ref operations

2015-12-11 Thread Junio C Hamano
David Turner writes: > The previous review was here: > http://permalink.gmane.org/gmane.comp.version-control.git/279062 > > Michael wrote: >> Hmmm, I thought our convention was to define typedefs for functions >> themselves, not for the pointer-to-function; e.g., >> >>

Re: [PATCH] completion: fix completing unstuck email alias arguments

2015-12-11 Thread Jacob Keller
On Fri, Dec 11, 2015 at 4:18 PM, SZEDER Gábor wrote: > Completing unstuck form of email aliases doesn't quite work: > > $ git send-email --to > alice bob cecil > $ git send-email --to a > alice bob cecil > Woops. Is it possible to add a test for this case?

Re: [PATCH 2/8] update-index: use enum for untracked cache options

2015-12-11 Thread Christian Couder
On Thu, Dec 10, 2015 at 7:46 PM, Junio C Hamano wrote: > Christian Couder writes: > +/* Untracked cache mode */ +enum uc_mode { + UNDEF_UC = -1, + NO_UC = 0, + UC, + FORCE_UC +}; + >>> >>> With

Re: [PATCH jk/prune-mtime] prune: close directory earlier during loose-object directory traversal

2015-12-11 Thread Junio C Hamano
Jeff King writes: > On Wed, Aug 12, 2015 at 07:43:01PM +0200, Johannes Sixt wrote: > >> 27e1e22d (prune: factor out loose-object directory traversal, 2014-10-16) >> introduced a new function for_each_loose_file_in_objdir() with a helper >> for_each_file_in_obj_subdir(). The latter

Re: [PATCH jk/prune-mtime] prune: close directory earlier during loose-object directory traversal

2015-12-11 Thread Jeff King
On Fri, Dec 11, 2015 at 11:37:54AM -0800, Junio C Hamano wrote: > Jeff King writes: > > > On Wed, Aug 12, 2015 at 07:43:01PM +0200, Johannes Sixt wrote: > > > >> 27e1e22d (prune: factor out loose-object directory traversal, 2014-10-16) > >> introduced a new function

Re: [PATCH] notes: allow merging from arbitrary references

2015-12-11 Thread Junio C Hamano
Jeff King writes: > On Tue, Nov 24, 2015 at 05:47:09PM -0500, Jeff King wrote: > >> On Fri, Nov 13, 2015 at 08:34:22AM -0800, Jacob Keller wrote: >> >> > --- >> > I do not remember what version this was since it has been an age ago >> > that I sent the previous code. This is

Re: [PATCH] git-gui: Remove ancient Cygwin compatibility code

2015-12-11 Thread Junio C Hamano
Adam Dinwoodie writes: > Remove special path handling for Cygwin in the git-gui Makefile. This > used to be necessary, but has been being patched out of the official > Cygwin distribution builds since Git v1.7.9, and should really be > patched out of the upstream code rather

[PATCH] rebase -i: remember merge options beyond continue actions

2015-12-11 Thread Ralf Thielow
From: Fabian Ruch If the user specifies a merge strategy or strategy options in "rebase --interactive", also use these in subsequent calls of "rebase --continue". In the implementation, the "do_merge" guard to check for a given merge strategy or strategy options is implied by

Re: [PATCH] notes: allow merging from arbitrary references

2015-12-11 Thread Jacob Keller
On Fri, Dec 11, 2015 at 11:47 AM, Junio C Hamano wrote: > I'll discard the topic for now, expecting the resurrection sometime > later. > Hi, Yes I fully intend to work this against master once I have some time again. It may be a few weeks as I am extra busy for the holidays,

Re: [PATCH] rebase -i: remember merge options beyond continue actions

2015-12-11 Thread Junio C Hamano
On Fri, Dec 11, 2015 at 11:54 AM, Ralf Thielow wrote: > From: Fabian Ruch > > If the user specifies a merge strategy or strategy options in > "rebase --interactive", also use these in subsequent calls of > "rebase --continue". > > In the implementation,

Re: What's cooking in git.git (Dec 2015, #03; Thu, 10)

2015-12-11 Thread Junio C Hamano
Stefan Beller writes: > On Thu, Dec 10, 2015 at 3:51 PM, Junio C Hamano wrote: >> Stefan Beller writes: >> * sb/submodule-parallel-fetch (2015-11-24) 17 commits ... >>> >>> I assume you plan on merging this after 2.7 settled

Re: What's cooking in git.git (Dec 2015, #03; Thu, 10)

2015-12-11 Thread Junio C Hamano
John Keeping writes: > On Thu, Dec 10, 2015 at 02:46:40PM -0800, Junio C Hamano wrote: >> * jk/send-email-ssl-errors (2015-11-24) 1 commit >> - send-email: enable SSL level 1 debug output >> >> Improve error reporting when SMTP TLS fails. >> >> Waiting for a reroll. >>

Re: [PATCH 2/8] update-index: use enum for untracked cache options

2015-12-11 Thread Junio C Hamano
Christian Couder writes: >> As you know I am bad at bikeshedding; the only suggestion in the >> above is to have common UC_ prefix ;-) Don't take what follow UC_ >> as my suggestion. > > I am bad at finding names too, so I think what you wrote is pretty good. > > I

Re: [PATCH] completion: remove 'git column' from porcelain commands

2015-12-11 Thread Junio C Hamano
SZEDER Gábor writes: > 'git column' is an internal helper, so it should not be offered on > 'git ' along with porcelain commands. > > Signed-off-by: SZEDER Gábor > --- I think this makes sense. Objections? > contrib/completion/git-completion.bash | 1 + >

Re: [RFC] Case insensitive URL rewrite

2015-12-11 Thread Jeff King
On Fri, Dec 11, 2015 at 10:26:41AM -0800, Junio C Hamano wrote: > Lars Schneider writes: > > > What do you think about a flag that makes these rewrites case insensitive? > > E.g. with the following config flag: > > > > [url ""] > > insteadOf = > > ignorecase

[PATCH v2] rebase -i: remember merge options beyond continue actions

2015-12-11 Thread Ralf Thielow
From: Fabian Ruch If the user explicitly specified a merge strategy or strategy options, continue to use that strategy/option after "rebase --continue". Add a test of the corrected behavior. If --merge is specified or implied by -s or -X, then "strategy and "strategy_opts"

Re: [RFC] Case insensitive URL rewrite

2015-12-11 Thread Junio C Hamano
Stefan Beller writes: > On Fri, Dec 11, 2015 at 10:26 AM, Junio C Hamano wrote: >> On the other hand, these two MUST be treated as different by >> default: >> >> git clone https://github.com/GIT/GIT (differences outside host part) >> git clone

Re: [PATCH] completion: remove 'git column' from porcelain commands

2015-12-11 Thread Duy Nguyen
On Fri, Dec 11, 2015 at 7:16 PM, Junio C Hamano wrote: > SZEDER Gábor writes: > >> 'git column' is an internal helper, so it should not be offered on >> 'git ' along with porcelain commands. >> >> Signed-off-by: SZEDER Gábor >> --- > > I

Re: [RFC] Case insensitive URL rewrite

2015-12-11 Thread Junio C Hamano
Lars Schneider writes: > What do you think about a flag that makes these rewrites case insensitive? > E.g. with the following config flag: > > [url ""] > insteadOf = > ignorecase = true I am with Daniel on this. It is perfectly fine to consider these two

Re: [RFC] Case insensitive URL rewrite

2015-12-11 Thread Stefan Beller
On Fri, Dec 11, 2015 at 10:26 AM, Junio C Hamano wrote: > On the other hand, these two MUST be treated as different by > default: > > git clone https://github.com/GIT/GIT (differences outside host part) > git clone g...@github.com:GIT/GIT (differences outside host

Re: [PATCH 1/8] update-index: add untracked cache notifications

2015-12-11 Thread Christian Couder
On Tue, Dec 8, 2015 at 8:03 PM, Junio C Hamano wrote: > Christian Couder writes: > >> Doing: >> >> cd /tmp >> git --git-dir=/git/somewhere/else/.git update-index --untracked-cache >> >> doesn't work how one would expect. It hardcodes "/tmp" as

Re: [PATCH 5/8] dir: add add_untracked_cache()

2015-12-11 Thread Christian Couder
On Wed, Dec 9, 2015 at 8:37 AM, Torsten Bögershausen wrote: > On 08.12.15 18:15, Christian Couder wrote: >> This new function will be used in a later patch. > May be > Factor out code into add_untracked_cache(), which will be used in the next > commit. Thanks for the suggestion.

[PATCH] gitk: sv.po: Update Swedish translation (311t)

2015-12-11 Thread Peter Krefting
(Attached gzipped to avoid character encoding issues) 0001-gitk-sv.po-Update-Swedish-translation-311t.patch.gz Description: application/gzip