Re: [GSoC] A late proposal: a modern send-email

2016-03-27 Thread Javier Domingo Cansino
> While Gmail provides SMTP access, it was (last I was told) > incompatible with two-factor auth; so I've encountered users > unable to send patches with their normal 2FA-enabled accounts. > > Maybe git hackers at Google have enough pull to lobby Gmail's > web interface to make it easier to send

Re: [GSoC] A late proposal: a modern send-email

2016-03-27 Thread Eric Wong
Junio C Hamano wrote: > 惠轶群 writes: > > - Build a simple email client (maybe a web components based web app or > > wxwidgets based GUI client, they are both cross-platform) which is > > easy to use for sending patch without disrupting the mailbox format. >

[PATCH] git-format-patch.txt: don't show -s as shorthand for multiple options

2016-03-27 Thread Eric Sunshine
git-format-patch recognizes -s as shorthand only for --signoff, however, its documentation shows -s as shorthand for both --signoff and --no-patch. Resolve this confusion by suppressing the bogus -s shorthand for --no-patch. While here, also avoid showing the --no-patch option in git-format-patch

git show -m with a parent number

2016-03-27 Thread Anatoly Borodin
Hi All, is there a good reason for `git show -m` to not accept the number of a parent of a merge commit? I can run `git show --first-parent COMMIT`, but need to write `git diff COMMIT^2 COMMIT` every time I want to diff with the second parent! `git cherry-pick -m 2 COMMIT` works, so why can't

Re: [PATCH v3] worktree: add: introduce --checkout option

2016-03-27 Thread Eric Sunshine
On Fri, Mar 25, 2016 at 11:25:37AM +, Ray Zhang wrote: > By adding this option which defaults to true, we can use the > corresponding --no-checkout to make some customizations before > the checkout, like sparse checkout, etc. > > Signed-off-by: Ray Zhang > --- > 1.

Re: [PATCH v10 2/3] t7507-commit-verbose: store output of grep in a file

2016-03-27 Thread Pranit Bauva
On Sun, Mar 27, 2016 at 10:57 PM, Eric Sunshine wrote: > On Sun, Mar 27, 2016 at 03:27:25PM +0200, SZEDER Gábor wrote: >> > > +! test -s out || >> > > +rm out && >> > >> > Why not just "rm -f out"? But, more importantly, why do you need to >> > remove the file at all? The

Re: [PATCH v2 5/5] branch -d: refuse deleting a branch which is currently checked out

2016-03-27 Thread Eric Sunshine
On Fri, Mar 25, 2016 at 2:28 PM, Kazuki Yamaguchi wrote: > When a branch is checked out by current working tree, deleting the > branch is forbidden. However when the branch is checked out only by > other working trees, deleting is allowed. > Use find_shared_symref() to check if the

Re: [PATCH v10 2/3] t7507-commit-verbose: store output of grep in a file

2016-03-27 Thread Eric Sunshine
On Sun, Mar 27, 2016 at 03:27:25PM +0200, SZEDER Gábor wrote: > > > +! test -s out || > > > +rm out && > > > > Why not just "rm -f out"? But, more importantly, why do you need to > > remove the file at all? The '>' redirection operator (used below) will > > overwrite the file, so no need to

Re: [PATCH v10 2/3] t7507-commit-verbose: store output of grep in a file

2016-03-27 Thread Eric Sunshine
[forwarding this to the list, as well, since I again didn't notice when replying that Pranit had accidentally dropped the mailing list as a recipient] On Sun, Mar 27, 2016 at 12:59 PM, Eric Sunshine wrote: > On Sun, Mar 27, 2016 at 5:05 AM, Pranit Bauva

Re: [PATCH v10 2/3] t7507-commit-verbose: store output of grep in a file

2016-03-27 Thread Eric Sunshine
[also forwarding this to the list since it's relevant to the ongoing discussion, and I hadn't noticed when replying that Pranit had (presumably) accidentally dropped the git list as a recipient] On Sun, Mar 27, 2016 at 3:10 AM, Eric Sunshine wrote: > On Sun, Mar 27, 2016

Re: [PATCH v10 2/3] t7507-commit-verbose: store output of grep in a file

2016-03-27 Thread Eric Sunshine
[forwarding this to the list since Pranit (presumably) accidentally replied only to me but it's relevant to the ongoing discussion] On Sun, Mar 27, 2016 at 1:42 AM, Pranit Bauva wrote: > On Sun, Mar 27, 2016 at 8:37 AM, Eric Sunshine > wrote: >>

Re: [PATCH v10 3/3] commit: add a commit.verbose config variable

2016-03-27 Thread Eric Sunshine
On Sun, Mar 27, 2016 at 7:59 AM, Pranit Bauva wrote: > On Sun, Mar 27, 2016 at 5:21 PM, SZEDER Gábor wrote: >>> +test_expect_success 'commit.verbose true and --no-verbose' ' >>> + git -c commit.verbose=true commit --amend --no-verbose && >>> + !

[PATCH v3 2/2] gitk: add an option to enable sorting the "Tags and heads" view by ref type

2016-03-27 Thread Michael Rappazzo
Signed-off-by: Michael Rappazzo --- gitk | 21 - 1 file changed, 16 insertions(+), 5 deletions(-) diff --git a/gitk b/gitk index 3686370..29ef36c 100755 --- a/gitk +++ b/gitk @@ -9944,7 +9944,7 @@ proc reflistfilter_change {n1 n2 op} { } proc

[PATCH v3 1/2] gitk: alter the ordering for the "Tags and heads" view

2016-03-27 Thread Michael Rappazzo
In the "Tags and heads" view, the list of refs is globally sorted. Because of this, the list of local refs (heads) can be interrupted by the list of remote refs. This change re-orders the view to be: local refs, remote refs tracked by local refs, remote refs, tags, and then other refs.

[PATCH v3 0/2] gitk: changes for the "Tags and heads" view

2016-03-27 Thread Michael Rappazzo
Changes since v2[1]: - Instead of getting the remote info for each local branch individually, grab it all at once and store the result - Instead of a command line option to enable the new sorting option, enable it with a preference which is stored in the config. v1 can be found here[2].

[PATCH v3 0/2] update all per-worktree HEADs when renaming a branch

2016-03-27 Thread Kazuki Yamaguchi
Changes from v2: - The flags REF_COMMON_DIR and RESOLVE_REF_COMMON_DIR are removed. - create_symref_common_dir() is removed and instead adds narrower purpose function, set_worktree_head_symref(). [1/2] Adds a new function set_worktree_head_symref(). This takes git_dir as the first argument, and

[PATCH v3 2/2] branch -m: update all per-worktree HEADs

2016-03-27 Thread Kazuki Yamaguchi
When renaming a branch, currently only the HEAD of current working tree is updated, but it must update HEADs of all working trees which point at the old branch. This is the current behavior, /path/to/wt's HEAD is not updated: % git worktree list /path/to 2c3c5f2 [master] /path/to/wt

[PATCH v3 1/2] refs: add a new function set_worktree_head_symref

2016-03-27 Thread Kazuki Yamaguchi
Add a new function set_worktree_head_symref, to update HEAD symref for the specified worktree. To update HEAD of a linked working tree, create_symref("worktrees/$work_tree/HEAD", "refs/heads/$branch", msg) could be used. However when it comes to updating HEAD of the main working tree, it is

Re: [PATCH v10 2/3] t7507-commit-verbose: store output of grep in a file

2016-03-27 Thread Pranit Bauva
On Sun, Mar 27, 2016 at 6:57 PM, SZEDER Gábor wrote: >> > +! test -s out || >> > +rm out && >> >> Why not just "rm -f out"? But, more importantly, why do you need to >> remove the file at all? The '>' redirection operator (used below) will >> overwrite the file, so no need to

Re: [PATCH v10 2/3] t7507-commit-verbose: store output of grep in a file

2016-03-27 Thread SZEDER Gábor
> > +! test -s out || > > +rm out && > > Why not just "rm -f out"? But, more importantly, why do you need to > remove the file at all? The '>' redirection operator (used below) will > overwrite the file, so no need to remove it beforehand. > > > +! grep '^diff --git' "$1" || > > +grep '^diff

Re: [PATCH v10 3/3] commit: add a commit.verbose config variable

2016-03-27 Thread Pranit Bauva
On Sun, Mar 27, 2016 at 5:37 PM, SZEDER Gábor wrote: > t/test-lib-functions.sh contains all our test helpers functions, that's > where you can look for a suitable helper, should it be necessary. Thanks. I will surely look into it. -- To unsubscribe from this list: send the line

Re: [PATCH v10 3/3] commit: add a commit.verbose config variable

2016-03-27 Thread SZEDER Gábor
Quoting Pranit Bauva : On Sun, Mar 27, 2016 at 5:21 PM, SZEDER Gábor wrote: +test_expect_success 'commit.verbose true and --no-verbose' ' + git -c commit.verbose=true commit --amend --no-verbose && + ! test -s out Please use the

Re: [PATCH v10 3/3] commit: add a commit.verbose config variable

2016-03-27 Thread Pranit Bauva
On Sun, Mar 27, 2016 at 5:21 PM, SZEDER Gábor wrote: >> +test_expect_success 'commit.verbose true and --no-verbose' ' >> + git -c commit.verbose=true commit --amend --no-verbose && >> + ! test -s out > > Please use the test_must_be_empty helper instead, because it has a

Re: [PATCH v10 3/3] commit: add a commit.verbose config variable

2016-03-27 Thread SZEDER Gábor
> +test_expect_success 'commit.verbose true and --no-verbose' ' > + git -c commit.verbose=true commit --amend --no-verbose && > + ! test -s out Please use the test_must_be_empty helper instead, because it has a nice, human-readable name and it complains with a helpful error message if

Re: [PATCH v10 3/3] commit: add a commit.verbose config variable

2016-03-27 Thread Pranit Bauva
On Sun, Mar 27, 2016 at 1:47 PM, Eric Sunshine wrote: > On Sun, Mar 27, 2016 at 3:00 AM, Pranit Bauva wrote: >> On Sun, Mar 27, 2016 at 9:04 AM, Eric Sunshine >> wrote: >>> On Sat, Mar 26, 2016 at 3:48 PM, Pranit Bauva

Re: [PATCH v10 3/3] commit: add a commit.verbose config variable

2016-03-27 Thread Eric Sunshine
On Sun, Mar 27, 2016 at 3:00 AM, Pranit Bauva wrote: > On Sun, Mar 27, 2016 at 9:04 AM, Eric Sunshine > wrote: >> On Sat, Mar 26, 2016 at 3:48 PM, Pranit Bauva wrote: >>> +test_expect_success 'commit.verbose true and

Re: [RFC/GSOC] Git Beginner | Warnings for potentially destructive commands

2016-03-27 Thread Jacob Keller
On Sat, Mar 26, 2016 at 8:12 AM, Matthieu Moy wrote: > Jacob Keller writes: > >> If possible, I would suggest aiming for generating the actual topology >> that the user is seeing, customized so that it gives relevenat >> information, rather

Re: [PATCH v2 0/5] branch: fix branch operations with multiple working trees

2016-03-27 Thread Kazuki Yamaguchi
On Fri, Mar 25, 2016 at 02:13:07PM -0700, Junio C Hamano wrote: > Kazuki Yamaguchi writes: > > > [1/5] > > Adds RESOLVE_REF_COMMON_DIR to resolve_ref_unsafe(). The second - fourth > > patch depend on this. At the same time, this allows us to remove > > reimplementation of

[PATCH v2a 3/3] gitk: Include commit title in branch dialog

2016-03-27 Thread Rogier Goossens
Hi, I made another branch dialog related change, included in this message. It applies on top of my other two patches. Rogier. --- 8< --- 8< -- Only the SHA1 was included. It's convenient to have the title mentioned as well. Signed-off-by: Rogier Goossens

Re: [PATCH v10 3/3] commit: add a commit.verbose config variable

2016-03-27 Thread Pranit Bauva
On Sun, Mar 27, 2016 at 9:04 AM, Eric Sunshine wrote: > On Sat, Mar 26, 2016 at 3:48 PM, Pranit Bauva wrote: >> Add commit.verbose configuration variable as a convenience for those >> who always prefer --verbose taking care of multiple levels of

Re: [PATCH v10 1/3] parse-options.c: make OPTION__COUNTUP understand "unspecified" values

2016-03-27 Thread Pranit Bauva
On Sun, Mar 27, 2016 at 8:15 AM, Eric Sunshine wrote: > On Sat, Mar 26, 2016 at 3:48 PM, Pranit Bauva wrote: >> parse-options.c: make OPTION__COUNTUP understand "unspecified" values > > A bit clearer: s/understand/respect/ > Also: s/__/_/ Sure.