Re: git merge banch w/ different submodule revision

2018-05-07 Thread Middelschulte, Leif
Hi, Am Freitag, den 04.05.2018, 07:43 -0700 schrieb Elijah Newren: > On Fri, May 4, 2018 at 3:18 AM, Heiko Voigt wrote: > > Hi, > > > > On Fri, May 04, 2018 at 08:29:32AM +, Middelschulte, Leif wrote: > > > Am Donnerstag, den 03.05.2018, 18:42 +0200 schrieb Heiko Voigt: >

Re: main url for linking to git source?

2018-05-07 Thread Konstantin Ryabitsev
On 05/07/18 07:38, Johannes Schindelin wrote: >> The git-scm.com site currently links to https://github.com/git/git for >> the (non-tarball) source code. Somebody raised the question[1] of >> whether it should point to kernel.org instead. >> >> Do people find one interface more or less pleasing

Re: [PATCH v4 5/7] builtin/grep.c: add '--column' option to 'git-grep(1)'

2018-05-07 Thread Junio C Hamano
Taylor Blau writes: > diff --git a/Documentation/git-grep.txt b/Documentation/git-grep.txt > index 18b494731f..5409a24399 100644 > --- a/Documentation/git-grep.txt > +++ b/Documentation/git-grep.txt > @@ -13,7 +13,7 @@ SYNOPSIS > [-v | --invert-match] [-h|-H]

Re: [PATCH 00/13] object store: alloc

2018-05-07 Thread Junio C Hamano
Stefan Beller writes: > This applies on top of sb/oid-object-info and is the logical continuum of > the series that it builds on; this brings the object store into more of > Gits code, removing global state, such that reasoning about the state of > the in-memory

Re: main url for linking to git source?

2018-05-07 Thread Junio C Hamano
Jeff King writes: > The git-scm.com site currently links to https://github.com/git/git for > the (non-tarball) source code. Somebody raised the question[1] of > whether it should point to kernel.org instead. Do people find one > interface more or less pleasing than the other? Do

[PATCH] t6050-replace: don't disable stdin for the whole test script

2018-05-07 Thread SZEDER Gábor
The test script 't6050-replace.sh' starts off with redirecting the whole test script's stdin from /dev/null. This redirection has been there since the test script was introduced in a3e8267225 (replace_object: add a test case, 2009-01-23), but the commit message doesn't explain why it was deemed

Re: [PATCH] tests: introduce test_unset_prereq, for debugging

2018-05-07 Thread SZEDER Gábor
> While working on the --convert-graft-file test, I missed that I was > relying on the GPG prereq, by using output of test cases that were only > run under that prereq. That GPG vs --convert-graft-file thing really does have a bit of a fallout, doesn't it? I'm at five patches and possibly

Re: main url for linking to git source?

2018-05-07 Thread Johannes Schindelin
Hi Peff, On Mon, 7 May 2018, Jeff King wrote: > The git-scm.com site currently links to https://github.com/git/git for > the (non-tarball) source code. Somebody raised the question[1] of > whether it should point to kernel.org instead. > > Do people find one interface more or less pleasing than

Re: [PATCH v3 1/1] completion: load completion file for external subcommand

2018-05-07 Thread SZEDER Gábor
On Sun, Apr 29, 2018 at 6:42 PM, Florian Gamböck wrote: > This way we can leverage bash-completion's dynamic loading for git > subcommands and make it easier for developers to distribute custom > completion scripts. The patch and the updated commit message both look good to me.

Re: [PATCH 10/28] t: skip pack tests if not using SHA-1

2018-05-07 Thread Martin Ågren
On 7 May 2018 at 01:17, brian m. carlson wrote: > These tests rely on creating packs with specially named objects which > are necessarily dependent on the hash used. Skip these tests if we're > not using SHA-1. > > Signed-off-by: brian m. carlson

Re: [PATCH 06/28] t0000: annotate with SHA1 prerequisite

2018-05-07 Thread Martin Ågren
On 7 May 2018 at 01:17, brian m. carlson wrote: > Since this is a core test that tests basic functionality, annotate the > assertions that have dependencies on SHA-1 with the appropriate > prerequisite. > > Signed-off-by: brian m. carlson

Re: [PATCH 01/28] t/test-lib: add an SHA1 prerequisite

2018-05-07 Thread Martin Ågren
On 7 May 2018 at 01:17, brian m. carlson wrote: > Add an SHA1 prerequisite to annotate both of these types of tests and > disable them when we're using a different hash. In the future, we can > create versions of these tests which handle both SHA-1 and NewHash.

Re: [PATCH 3/8] push tests: add more testing for forced tag pushing

2018-05-07 Thread Kaartic Sivaraam
Hi, On Monday 30 April 2018 01:50 AM, Ævar Arnfjörð Bjarmason wrote: > diff --git a/t/t5516-fetch-push.sh b/t/t5516-fetch-push.sh > index 15c8d5a734..c9a2011915 100755 > --- a/t/t5516-fetch-push.sh > +++ b/t/t5516-fetch-push.sh > @@ -981,7 +981,17 @@ test_expect_success 'push requires --force to

Re: [PATCH] refs: handle null-oid for pseudorefs

2018-05-07 Thread Martin Ågren
On 7 May 2018 at 09:39, Michael Haggerty wrote: > Thanks for the patch. This looks good to me. But it it seems that the > test coverage related to pseudorefs is still not great. Ideally, all of > the following combinations should be tested: > > Pre-update value |

Re: [PATCH 8/8] gpg-interface: handle alternative signature types

2018-05-07 Thread Jeff King
On Tue, Apr 17, 2018 at 12:12:12AM +, brian m. carlson wrote: > > That argues more strongly that we would regret unless we make the > > end-user configuration to at least the whole string (which later can > > be promoted to "a pattern that matches the whole string"), not just > > the part

Re: [PATCH v2 2/4] run-command: use BUG() to report bugs, not die()

2018-05-07 Thread Jeff King
On Wed, May 02, 2018 at 11:38:31AM +0200, Johannes Schindelin wrote: > The slightly misleading name die_bug() of the function intended to > report a bug is actually called always, and only reports a bug if the > passed-in parameter `err` is non-zero. > > It uses die_errno() to report the bug, to

Re: [PATCH v2 0/4] Finish the conversion from die("BUG: ...") to BUG()

2018-05-07 Thread Jeff King
On Wed, May 02, 2018 at 11:38:13AM +0200, Johannes Schindelin wrote: > The BUG() macro was introduced in this patch series: > https://public-inbox.org/git/20170513032414.mfrwabt4hovuj...@sigill.intra.peff.net > > The second patch in that series converted one caller from die("BUG: ") > to use the

Re: [PATCH v2 02/18] Add a new builtin: branch-diff

2018-05-07 Thread Jeff King
On Sat, May 05, 2018 at 11:57:26PM +0200, Johannes Schindelin wrote: > > It feels really petty complaining about the name, but I just want to > > raise the point, since it will never be easier to change than right now. > > I do hear you. Especially since I hate `git cherry` every single time

Re: [PATCH v2 02/18] Add a new builtin: branch-diff

2018-05-07 Thread Jeff King
On Sun, May 06, 2018 at 10:04:31PM -0400, Johannes Schindelin wrote: > > Let's, please, not fall into the trap of polluting git-branch with > > utterly unrelated functionality, as has happened a few times with > > other Git commands. Let's especially not do so merely for the sake of > >

Re: [PATCH v2 13/18] color: provide inverted colors, too

2018-05-07 Thread Jeff King
On Mon, May 07, 2018 at 10:35:53AM +0900, Junio C Hamano wrote: > > So really, I guess all I am arguing for is having GIT_COLOR_INV (or > > REVERSE) as a constant, and then teaching the code to combine it with > > the existing "new" color. It's perfectly OK to have: > > > > \x1b[7m\x1b[36m > >

Re: [PATCH] refs: handle null-oid for pseudorefs

2018-05-07 Thread Michael Haggerty
On 05/06/2018 03:35 PM, Martin Ågren wrote: > According to the documentation on `git update-ref`, it is possible to > "specify 40 '0' or an empty string as to make sure that the > ref you are creating does not exist." But in the code for pseudorefs, we > do not implement this. If we fail to read

Re: [PATCH v2 13/18] color: provide inverted colors, too

2018-05-07 Thread Jeff King
On Sun, May 06, 2018 at 09:20:46PM -0400, Johannes Schindelin wrote: > > Heh, of course you knew that already, as I just noticed your patch is > > using the reverse attribute internally (I had thought at first glance > > you were just specifying the background independently). > > > > So really,

Offre de prêts

2018-05-07 Thread LACASSIN
Bonjour Vous aviez besoin de prêts d'argent entre particuliers pour faire face aux difficultés financières pour enfin sortir de l'impasse que provoquent les banques, par le rejet de vos dossiers de demande de crédits ? Je suis un un citoyen français à la retraite en mesure de vous faire un prêt

main url for linking to git source?

2018-05-07 Thread Jeff King
The git-scm.com site currently links to https://github.com/git/git for the (non-tarball) source code. Somebody raised the question[1] of whether it should point to kernel.org instead. Do people find one interface more or less pleasing than the other? Do we want to prefer kernel.org as more

<    1   2