On 5/6/2016 10:26 AM, Junio C Hamano wrote:
> Li Peng writes:
>
>> Fix duplicate words of "output" in comment.
>>
>> Signed-off-by: Li Peng
>> ---
>> t/t-basic.sh | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/t/t-basic.sh b/t/t-basic.sh
>> index 79b9074.
lowing commands like
./t1502-rev-parse-parseopt.sh --run=1-2
to stop at the test case 2 without any further modification of the test
state area.
Signed-off-by: Ilya Bobyr
---
On 7/13/2015 2:55 PM, Junio C Hamano wrote:
> ilya.bo...@gmail.com writes:
>
>> Junio, thank you very mu
From: Ilya Bobyr
A line in the input to "rev-parse --parseopt" describes an option by
listing a short and/or long name, optional flags [*=?!], argument hint, and
then whitespace and help string.
We did not allow any of the [*=?!] characters in the argument hints. The
following
From: Ilya Bobyr
It is not very likely that any of the "*=?!" Characters would be useful
in the argument short or long names. On the other hand, there are
already argument hints that contain the "=" sign. It used to be
impossible to include any of the "*=?!" signs
//www.mail-archive.com/git@vger.kernel.org/msg48463.html
I've replied to those messages. There are two comments from Junio that did not
result in changed. All the others have been addressed I hope.
Ilya Bobyr (3):
test-lib: Document short options in t/README
test-lib: tests skipped by GIT_SKIP_TEST
Most arguments that could be provided to a test have short forms.
Unless documented, the only way to learn them is to read the code.
Signed-off-by: Ilya Bobyr
---
Changed to use AsciiDoc format.
t/README |4
1 files changed, 4 insertions(+), 0 deletions(-)
diff --git a/t/README b/t
Allow better control of the set of tests that will be executed for a
single test suite. Mostly useful while debugging or developing as it
allows to focus on a specific test.
Signed-off-by: Ilya Bobyr
---
A number of minor changes according to the review comments.
t/README | 81
We used to show "(missing )" next to tests skipped because they are
specified in GIT_SKIP_TESTS. Use "(GIT_SKIP_TESTS)" instead.
Plus tests that check basic GIT_SKIP_TESTS functions.
Signed-off-by: Ilya Bobyr
---
No changes.
t/t
On 4/23/2014 12:51 PM, Eric Sunshine wrote:
> On Tue, Apr 22, 2014 at 4:19 AM, Ilya Bobyr wrote:
>> Allow better control of the set of tests that will be executed for a
>> single test suite. Mostly useful while debugging or developing as it
>> allows to focus on a specific t
On 4/23/2014 11:40 AM, Junio C Hamano wrote:
> Ilya Bobyr writes:
>
>> @@ -187,10 +192,70 @@ and either can match the "t[0-9]{4}" part to skip the
>> whole
>> test, or t[0-9]{4} followed by ".$number" to say which
>> particular test to skip.
On 4/23/2014 11:24 AM, Junio C Hamano wrote:
> Ilya Bobyr writes:
>> Most arguments that could be provided to a test have short forms.
>> Unless documented, the only way to learn them is to read the code.
>>
>> Signed-off-by: Ilya Bobyr
>> ---
>> t/README
On 4/22/2014 9:31 AM, Felipe Contreras wrote:
> Stephen Leake wrote:
>> Felipe Contreras writes:
>>
>>> Ilya Bobyr wrote:
>>>> On 4/21/2014 2:17 PM, Felipe Contreras wrote:
>>>>> Ilya Bobyr wrote:
>>>>>
>>>>>
We used to show "(missing )" next to tests skipped because they are
specified in GIT_SKIP_TESTS. Use "(GIT_SKIP_TESTS)" instead.
Plus tests that check basic GIT_SKIP_TESTS functions.
Signed-off-by: Ilya Bobyr
---
t/t
Most arguments that could be provided to a test have short forms.
Unless documented, the only way to learn them is to read the code.
Signed-off-by: Ilya Bobyr
---
t/README |8
1 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/t/README b/t/README
index caeeb9d..6b93aca
Allow better control of the set of tests that will be executed for a
single test suite. Mostly useful while debugging or developing as it
allows to focus on a specific test.
Signed-off-by: Ilya Bobyr
---
t/README | 73 +++-
t/t-basic.sh | 356
27
Maybe it would be better to support 'v' suffix as a flag to indicate what
a test needs to be run in verbose mode:
./t-basic.sh --run=1-4,27v
Ilya Bobyr (3):
test-lib: Document short options in t/README
test-lib: tests skipped by GIT_SKIP_TESTS say so
test-lib:
On 4/21/2014 11:45 PM, Felipe Contreras wrote:
> [...]
This is how it is suggested by t/README and how it is done in the other
test suites.
I can not see how your case is different, but I might be missing something.
>>> Let's take a cursoy look at `git grep -l "'EOF'" t`.
>>>
>>> [..
On 4/21/2014 1:49 PM, Felipe Contreras wrote:
> Ilya Bobyr wrote:
>> On 4/20/2014 7:23 PM, Felipe Contreras wrote:
>>> This hook is invoked whenever a branch is updated, either when a branch
>>> is created or updated with 'git branch', or when it's reba
On 4/20/2014 7:23 PM, Felipe Contreras wrote:
> [...]
>
> diff --git a/branch.c b/branch.c
> index 660097b..c2058d1 100644
> --- a/branch.c
> +++ b/branch.c
> @@ -4,6 +4,7 @@
> #include "refs.h"
> #include "remote.h"
> #include "commit.h"
> +#include "run-command.h"
>
> struct tracking {
>
On 4/21/2014 3:24 PM, Felipe Contreras wrote:
> Ilya Bobyr wrote:
>> On Mon, Apr 21, 2014 at 2:35 PM, Felipe Contreras <
>> felipe.contre...@gmail.com> wrote:
>>> Ilya Bobyr wrote:
>>>> test_expect_success 'setup' "
>>>>
On 4/21/2014 2:17 PM, Felipe Contreras wrote:
> Ilya Bobyr wrote:
>
>> Also, most have names that start with either "pre-" or "post-".
>> It seems reasonable for both "pre-update-branch" and
>> "post-update-branch" to exist.
> I
On 4/21/2014 2:15 PM, Felipe Contreras wrote:
> Ilya Bobyr wrote:
>> On 4/20/2014 7:23 PM, Felipe Contreras wrote:
>>> [...]
>>>
>>> diff --git a/t/t5408-update-branch-hook.sh b/t/t5408-update-branch-hook.sh
>>> new file mode 100755
>>> inde
On 4/20/2014 7:23 PM, Felipe Contreras wrote:
> [...]
>
> diff --git a/t/t5408-update-branch-hook.sh b/t/t5408-update-branch-hook.sh
> new file mode 100755
> index 000..d921c0e
> --- /dev/null
> +++ b/t/t5408-update-branch-hook.sh
> @@ -0,0 +1,39 @@
> +#!/bin/sh
> +
> +test_description='Test th
On 4/21/2014 1:49 PM, Felipe Contreras wrote:
> Ilya Bobyr wrote:
>> On 4/20/2014 7:23 PM, Felipe Contreras wrote:
>>> This hook is invoked whenever a branch is updated, either when a branch
>>> is created or updated with 'git branch', or when it's reba
On 4/20/2014 7:23 PM, Felipe Contreras wrote:
> This hook is invoked whenever a branch is updated, either when a branch
> is created or updated with 'git branch', or when it's rebased with 'git
> rebase'. It receives two parameters; the name of the branch, and the
> SHA-1 of the latest commit, addi
On 3/27/2014 8:36 PM, Eric Sunshine wrote:
> On Thu, Mar 27, 2014 at 6:32 AM, Ilya Bobyr wrote:
>> Allow better control of the set of tests that will be executed for a
>> single test suite. Mostly useful while debugging or developing as it
>> allows to focus on a specific t
Most arguments that could be provided to a test have short forms.
Unless documented, the only way to learn them is to read the code.
Signed-off-by: Ilya Bobyr
---
Minor changes according to comments in
http://www.mail-archive.com/git@vger.kernel.org/msg46423.html
Ramsay Jones
and
Allow better control of the set of tests that will be executed for a
single test suite. Mostly useful while debugging or developing as it
allows to focus on a specific test.
Signed-off-by: Ilya Bobyr
---
No changes from the previous version.
t/README | 65 ++-
t/t
We used to show "(missing )" next to tests skipped because they are
specified in GIT_SKIP_TESTS. Use "(GIT_SKIP_TESTS)" instead.
Plus tests that check basic GIT_SKIP_TESTS functions.
Signed-off-by: Ilya Bobyr
---
No changes from the previous version.
t/t
This is an update verson of the patches I've posted here:
[RFC/PATCH] Better control of the tests run by a test suite
http://www.mail-archive.com/git@vger.kernel.org/msg46419.html
Chanes are only in the first patch, according to
http://www.mail-archive.com/git@vger.kernel.org/msg4642
On 3/24/2014 9:58 PM, Junio C Hamano wrote:
> Jeff King writes:
>
>> On Mon, Mar 24, 2014 at 01:49:44AM -0700, Ilya Bobyr wrote:
>>
>>> Here are some examples of how functionality added by the patch
>>> could be used. In order to run setup tests and then only
On 3/25/2014 10:23 AM, Junio C Hamano wrote:
> Ilya Bobyr writes:
>
>> On 3/24/2014 4:39 AM, Ramsay Jones wrote:
>>> On 24/03/14 08:49, Ilya Bobyr wrote:
>>> [...]
>>>> [...]
>>>>
>>>> ---valgrind=::
>>>> +-v,--val
On 3/24/2014 4:39 AM, Ramsay Jones wrote:
> On 24/03/14 08:49, Ilya Bobyr wrote:
>> Most arguments that could be provided to a test have short forms.
>> Unless documented the only way to learn then is to read the code.
>>
>> Signed-off-by: Ilya Bobyr
>> ---
>
Allow better control of the set of tests that will be executed for a
single test suite. Mostly useful while debugging or developing as it
allows to focus on a specific test.
Signed-off-by: Ilya Bobyr
---
t/README | 65 ++-
t/t-basic.sh | 233
Hello,
This is a second attempt on a functionality I proposed in
[PATCH 2/2] test-lib: GIT_TEST_ONLY to run only specific tests
http://www.mail-archive.com/git%40vger.kernel.org/msg44828.html
except that the implementation is quite different now.
I hope that I have accounted for the com
Most arguments that could be provided to a test have short forms.
Unless documented the only way to learn then is to read the code.
Signed-off-by: Ilya Bobyr
---
t/README | 10 +-
1 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/t/README b/t/README
index caeeb9d..ccb5989
We used to show "(missing )" next to tests skipped because they are
specified in GIT_SKIP_TESTS. Use "(GIT_SKIP_TESTS)" instead.
Plus tests that check basic GIT_SKIP_TESTS functions.
Signed-off-by: Ilya Bobyr
---
t/t
Built-in commands can specify names for option arguments when usage text
is generated for a command. sh based commands should be able to do the
same.
Option argument name hint is any text that comes after [*=?!] after the
argument name up to the first whitespace.
Signed-off-by: Ilya Bobyr
On 3/20/2014 4:19 PM, Ilya Bobyr wrote:
> On 3/20/2014 11:38 AM, Junio C Hamano wrote:
>> Ilya Bobyr writes:
>>
>>> [...]
>>>
>>> -* SP+ help LF
>>> +*? SP+ help LF
>>>
>>> ``::
>>>
On 3/20/2014 1:18 PM, Eric Sunshine wrote:
On Thu, Mar 20, 2014 at 4:44 AM, Ilya Bobyr wrote:
Built-in commands can specify names for option arguments when usage text
is generated for a command. sh based commands should be able to do the
same.
Option argument name hint is any text that comes
On 3/20/2014 11:38 AM, Junio C Hamano wrote:
Ilya Bobyr writes:
Built-in commands can specify names for option arguments when usage text
is generated for a command. sh based commands should be able to do the
same.
Option argument name hint is any text that comes after [*=?!] after the
whitespace. It is unlikely that an underscore would be useful in the
hint text.
Signed-off-by: Ilya Bobyr
---
Changed according to the last comments. Added "Usage text" paragraph in the
documentation and updated variable names.
Documentation/git-rev-parse.
On 3/19/2014 11:46 AM, Junio C Hamano wrote:
Ilya Bobyr writes:
I can not find this particular patch in the latest "What's cooking" email.
Is there something I can do?
IIRC, I think I was waiting for the version with a new "Usage text"
section to the documentati
On 3/12/2014 9:59 AM, Junio C Hamano wrote:
Ilya Bobyr writes:
I though that an example just to describe `argh' while useful would
look a bit disproportional, compared to the amount of text on
--parseopt.
But now that I've added a "Usage text" section to looks quite in p
On 3/11/2014 12:10 PM, Junio C Hamano wrote:
Junio C Hamano writes:
Documentation on the whole argument parsing is quite short, so, I
though, adding an example just to show how usage is generated would
look like I am trying to make this feature look important than it is
:)
You already are by
whitespace. It is unlikely that an underscore would be useful in the
hint text.
Signed-off-by: Ilya Bobyr
---
Documentation/git-rev-parse.txt | 11 +--
builtin/rev-parse.c | 17 -
t/t1502-rev-parse-parseopt.sh | 20
3 files changed
On 3/4/2014 11:22 AM, Junio C Hamano wrote:
Ilya Bobyr writes:
Built-in commands can specify names for option arguments, that are shown
when usage text is generated for the command. sh based commands should
be able to do the same.
Option argument name hint is any text that comes after
On 3/9/2014 12:54 PM, Carlos Pereira wrote:
On 03/09/2014 07:46 AM, Torsten Bögershausen wrote:
After creating a local repository with these two branches, and a
server repository with git init --bare, and pushing the two branches:
> > git remote add originfoo@bar:~/path/test.git
> git push o
On 3/4/2014 10:15 AM, Junio C Hamano wrote:
From: Ilya Bobyr
Date: Thu, 27 Feb 2014 22:51:37 -0800
We already replace old SHA with the clipboard content for the mouse
paste event. It seems reasonable to do the same when pasting from
keyboard.
Signed-off-by: Ilya Bobyr
---
* Paul? I do
On 3/4/2014 12:29 AM, Junio C Hamano wrote:
Ilya Bobyr writes:
While it could be done, it looks less obvious than this:
GIT_TEST_ONLY='1 4' ./t0001-init.sh
If you are thinking about affecting only one test,
Yes, that is the use case: when I am developing a specific feature
On 3/3/2014 4:08 PM, Junio C Hamano wrote:
Ilya Bobyr writes:
It might be that we are looking at different use cases, as you are
talking about whole test suits.
I do not think so.
Good :)
I am trying to understand the use cases. And make sure we are talking
about the same ones.
I am not
On 3/3/2014 3:18 PM, Eric Sunshine wrote:
On Mon, Mar 3, 2014 at 6:12 PM, Ilya Bobyr wrote:
On 3/3/2014 2:59 PM, Eric Sunshine wrote:
On Mon, Mar 3, 2014 at 5:24 AM, Ilya Bobyr wrote:
We used to show "(missing )" next to tests skipped because they are
specified in GIT_SKIP_T
On 3/3/2014 3:26 PM, Junio C Hamano wrote:
Eric Sunshine writes:
On Mon, Mar 3, 2014 at 5:24 AM, Ilya Bobyr wrote:
This is a counterpart to GIT_SKIP_TESTS. Mostly useful when debugging.
To be grammatically similar to GIT_SKIP_TESTS, perhaps name it GIT_RUN_TESTS?
I actually do not like
On 3/3/2014 3:03 PM, Eric Sunshine wrote:
On Mon, Mar 3, 2014 at 5:24 AM, Ilya Bobyr wrote:
This is a counterpart to GIT_SKIP_TESTS. Mostly useful when debugging.
To be grammatically similar to GIT_SKIP_TESTS, perhaps name it GIT_RUN_TESTS?
There is actually an upside in the fact that the
On 3/3/2014 2:59 PM, Eric Sunshine wrote:
On Mon, Mar 3, 2014 at 5:24 AM, Ilya Bobyr wrote:
We used to show "(missing )" next to tests skipped because they are
specified in GIT_SKIP_TESTS. Use "(matched by GIT_SKIP_TESTS)" instead.
Bikeshedding: That's pretty
On 3/3/2014 7:11 AM, Philip Oakley wrote:
From: "Ilya Bobyr"
We used to show "(missing )" next to tests skipped because they are
specified in GIT_SKIP_TESTS. Use "(matched by GIT_SKIP_TESTS)" instead.
The message below forgets the "by".
I'll f
are replaced with
whitespace. It is unlikely that an underscore would be useful in the
hint text.
Signed-off-by: Ilya Bobyr
---
Documentation/git-rev-parse.txt | 11 +--
builtin/rev-parse.c | 17 -
t/t1502-rev-parse-parseopt.sh | 20
This is a counterpart to GIT_SKIP_TESTS. Mostly useful when debugging.
---
t/README | 15 +++
t/test-lib.sh |8
2 files changed, 23 insertions(+), 0 deletions(-)
diff --git a/t/README b/t/README
index caeeb9d..f939987 100644
--- a/t/README
+++ b/t/README
@@ -187,6
We used to show "(missing )" next to tests skipped because they are
specified in GIT_SKIP_TESTS. Use "(matched by GIT_SKIP_TESTS)" instead.
---
t/test-lib.sh | 13 -
1 files changed, 8 insertions(+), 5 deletions(-)
diff --git a/t/test-lib.sh b/t/test-lib.sh
index 1531c24..89a405b 1
We already replace old SHA with the clipboard content for the mouse
paste event. It seems reasonable to do the same when pasting from
keyboard.
Signed-off-by: Ilya Bobyr
---
gitk-git/gitk |1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/gitk-git/gitk b/gitk-git/gitk
We already replace old SHA with the clipboard content for the mouse
paste event. It seems reasonable to do the same when pasting from
keyboard.
Signed-off-by: Ilya Bobyr
---
gitk-git/gitk |1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/gitk-git/gitk b/gitk-git/gitk
61 matches
Mail list logo