[PATCH v5 2/2] t7102: add 'reset -' tests

2015-03-13 Thread Sudhanshu Shekhar
Add following test cases: 1) Confirm error message when git reset is used with no previous branch 2) Confirm git reset - works like git reset @{-1} 3) Confirm - is always treated as a commit unless the -- file option is specified 4) Confirm git reset - works normally even when a file named @{-1}

[PATCH v5 1/2] reset: enable '-' short-hand for previous branch

2015-03-13 Thread Sudhanshu Shekhar
git reset '-' will reset to the previous branch. To reset a file named - use either git reset ./- or git reset -- -. Change error message to treat single - as an ambigous revision or path rather than a bad flag. Helped-by: Junio C Hamano gits...@pobox.com Helped-by: Eric Sunshine

Re: [PATCH] git-completion: add stashes for gitk

2015-03-13 Thread Sveinung Kvilhaugsvik
Thank you for the review. I now understand that the commit message should have provided way more context about my use case. I used Bazaar almost exclusively until about a year ago. Git's ability to put stuff in the index without committing and the power of git rebase covers many of the use cases

Re: [PATCH v5 1/2] reset: enable '-' short-hand for previous branch

2015-03-13 Thread Eric Sunshine
On Fri, Mar 13, 2015 at 2:18 PM, Sudhanshu Shekhar sudshekha...@gmail.com wrote: git reset '-' will reset to the previous branch. To reset a file named - use either git reset ./- or git reset -- -. Change error message to treat single - as an ambigous revision or path rather than a bad flag.

Kedves: Webmail Előfizető

2015-03-13 Thread Web-mail Security Team
-- Kedves: Webmail Előfizető Felhívjuk figyelmét, hogy az e-mail fiók meghaladta tárolókapacitás. Ön nem tud küldeni és fogadni e-maileket és a e-mail fiókja törlésre kerül a szerverünkről. A probléma elkerülése érdekében, Kattintson ide frissítse a számla. http://mailupgafsd.jigsy.com/

Re: [PATCH/GSoC/RFC] fetch: git fetch --deepen

2015-03-13 Thread Eric Sunshine
On Fri, Mar 13, 2015 at 9:04 AM, Dongcan Jiang dongcan.ji...@gmail.com wrote: This patch is just for discusstion. An option --deepen is added to 'git fetch'. When it comes to '--deepen', git should fetch N more commits ahead the local shallow commit, where N is indicated by '--depth=N'. [1]

Re: [PATCH v5 2/2] t7102: add 'reset -' tests

2015-03-13 Thread Eric Sunshine
On Fri, Mar 13, 2015 at 2:18 PM, Sudhanshu Shekhar sudshekha...@gmail.com wrote: Add following test cases: 1) Confirm error message when git reset is used with no previous branch 2) Confirm git reset - works like git reset @{-1} 3) Confirm - is always treated as a commit unless the -- file

Re: [PATCH v2] userdiff: funcname and word patterns for sh

2015-03-13 Thread Junio C Hamano
Adrien Schildknecht adrien+...@schischi.me writes: Add regexp based on the Shell Command Language specifications. Because of the lax syntax of sh, some corner cases may not be handled properly. Signed-off-by: Adrien Schildknecht adrien+...@schischi.me --- Those of you who helped in the

Re: [PATCH] git-completion: add stashes for gitk

2015-03-13 Thread Junio C Hamano
Sveinung Kvilhaugsvik sveinun...@users.sourceforge.net writes: A bigger question is why this change is made to gitk completion. If this completion were useful for gitk, wouoldn't it be equally useful for git log? I must admit that I didn't know that git log could display the content of a

Re: [PATCH/GSoC/RFC] fetch: git fetch --deepen

2015-03-13 Thread Junio C Hamano
Dongcan Jiang dongcan.ji...@gmail.com writes: This patch is just for discusstion. An option --deepen is added to 'git fetch'. When it comes to '--deepen', git should fetch N more commits ahead the local shallow commit, where N is indicated by '--depth=N'. [1] e.g. (upstream)

[PATCH v2 07/10] diff: convert struct combine_diff_path to object_id

2015-03-13 Thread brian m. carlson
Also, convert a constant to GIT_SHA1_HEXSZ. Signed-off-by: brian m. carlson sand...@crustytoothpaste.net --- combine-diff.c | 56 diff-lib.c | 10 +- diff.h | 5 +++-- tree-diff.c| 10 +- 4 files changed,

[PATCH v2 04/10] archive.c: convert to use struct object_id

2015-03-13 Thread brian m. carlson
Signed-off-by: brian m. carlson sand...@crustytoothpaste.net --- archive.c | 22 +++--- 1 file changed, 11 insertions(+), 11 deletions(-) diff --git a/archive.c b/archive.c index 96057ed..d37c41d 100644 --- a/archive.c +++ b/archive.c @@ -101,7 +101,7 @@ static void

[PATCH v2 03/10] bisect.c: convert leaf functions to use struct object_id

2015-03-13 Thread brian m. carlson
Convert some constants to GIT_SHA1_HEXSZ. Signed-off-by: brian m. carlson sand...@crustytoothpaste.net --- bisect.c | 40 1 file changed, 20 insertions(+), 20 deletions(-) diff --git a/bisect.c b/bisect.c index 8c6d843..10f5e57 100644 --- a/bisect.c +++

[PATCH v2 10/10] apply: convert threeway_stage to object_id

2015-03-13 Thread brian m. carlson
Signed-off-by: brian m. carlson sand...@crustytoothpaste.net --- builtin/apply.c | 14 +++--- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git a/builtin/apply.c b/builtin/apply.c index 65b97ee..c2c8f39 100644 --- a/builtin/apply.c +++ b/builtin/apply.c @@ -208,7 +208,7 @@

[PATCH v2 02/10] Define utility functions for object IDs.

2015-03-13 Thread brian m. carlson
There are several utility functions (hashcmp and friends) that are used for comparing object IDs (SHA-1 values). Using these functions, which take pointers to unsigned char, with struct object_id requires tiresome access to the sha1 member, which bloats code and violates the desired

[PATCH v2 09/10] patch-id: convert to use struct object_id

2015-03-13 Thread brian m. carlson
Convert some magic numbers to the new GIT_SHA1 constants. Signed-off-by: brian m. carlson sand...@crustytoothpaste.net --- builtin/patch-id.c | 34 +- 1 file changed, 17 insertions(+), 17 deletions(-) diff --git a/builtin/patch-id.c b/builtin/patch-id.c index

Re: [PATCH v2 00/10] Use a structure for object IDs.

2015-03-13 Thread brian m. carlson
On Wed, Mar 11, 2015 at 01:35:06PM -0700, Junio C Hamano wrote: Michael Haggerty mhag...@alum.mit.edu writes: 4. We continue to support working with SHA-1s declared to be (unsigned char *) in some performance-critical code, even as we migrate most other code to using SHA-1s embedded within a

[PATCH v2 00/10] Use a structure for object IDs.

2015-03-13 Thread brian m. carlson
This is a patch series to convert some of the relevant uses of unsigned char [20] to struct object_id. The goal of this series to improve type-checking in the codebase and to make it easier to move to a different hash function if the project decides to do that. There should be no functional

[PATCH v2 01/10] Define a structure for object IDs.

2015-03-13 Thread brian m. carlson
Many places throughout the code use unsigned char [20] to store object IDs (SHA-1 values). This leads to lots of hardcoded numbers throughout the codebase. It also leads to confusion about the purposes of a buffer. Introduce a structure for object IDs. This allows us to obtain the benefits of

[PATCH v2 08/10] commit: convert parts to struct object_id

2015-03-13 Thread brian m. carlson
Convert struct commit_graft and necessary local parts of commit.c. Also, convert several constants based on the hex length of an SHA-1 to use GIT_SHA1_HEXSZ, and move several magic constants into variables for readability. Signed-off-by: brian m. carlson sand...@crustytoothpaste.net --- commit.c

[PATCH v2 06/10] bulk-checkin.c: convert to use struct object_id

2015-03-13 Thread brian m. carlson
Signed-off-by: brian m. carlson sand...@crustytoothpaste.net --- bulk-checkin.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/bulk-checkin.c b/bulk-checkin.c index 0c4b8a7..c80e503 100644 --- a/bulk-checkin.c +++ b/bulk-checkin.c @@ -24,7 +24,7 @@ static struct

[PATCH v2 05/10] zip: use GIT_SHA1_HEXSZ for trailers

2015-03-13 Thread brian m. carlson
Signed-off-by: brian m. carlson sand...@crustytoothpaste.net --- archive-zip.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/archive-zip.c b/archive-zip.c index 4bde019..b669e50 100644 --- a/archive-zip.c +++ b/archive-zip.c @@ -427,12 +427,12 @@ static void

Re: [PATCH 6/7] t5541: move run_with_cmdline_limit to test-lib.sh

2015-03-13 Thread Eric Sunshine
On Fri, Mar 13, 2015 at 12:53 AM, Jeff King p...@peff.net wrote: We use this to test http pushing with a restricted commandline. Other scripts (like t5551, which does http fetching) will want to use it, too. Signed-off-by: Jeff King p...@peff.net --- As we discussed a while ago, this is the

Is it possible get the tag name of working copy in Git?

2015-03-13 Thread chen chang
I want to use make file auto generate the revision number of working copy from the tag name in git. So as questioned in subject, I have tried to use 'git describe', it works well in most case, and the output is good match my requirement. Problem is: when there are multiple tags on same one commit,

Re: [Documentation] Submitting Patches

2015-03-13 Thread Junio C Hamano
Cody Taylor cody.tay...@maternityneighborhood.com writes: Anyway, this brings up the point that `git send-email` should at least get a mention in the Documentation/SubmittingPatches file. Likely the best place for this is a paragraph after `git format-patch` is mentioned in section 4 (Sending

[Documentation] Submitting Patches

2015-03-13 Thread Cody Taylor
Apologies for the poorly formatted e-mail. I realized after I sent the message that the `git send-mail` command was an option. I was trying to use python to modify the e-mail before sending it, and the three different From fields got mumbled. Anyway, this brings up the point that `git send-email`

Re: [PATCH v2] git prompt: Use toplevel to find untracked files.

2015-03-13 Thread Junio C Hamano
Cody A Taylor cody.tay...@maternityneighborhood.com writes: From c861d5cb401110ce7d86b76c1eaa8e89e80f484e Mon Sep 17 00:00:00 2001 From: Cody A Taylor codemiste...@yahoo.com Date: Thu, 12 Mar 2015 20:36:44 -0400 Subject: [PATCH] git prompt: Use toplevel to find untracked files. All of the

Re: [PATCH v3 1/4] git-credential-store: support multiple credential files

2015-03-13 Thread Jeff King
On Wed, Mar 11, 2015 at 02:49:10PM +0800, Paul Tan wrote: Previously, git-credential-store only supported storing credentials in a single file: ~/.git-credentials. In order to support the XDG base directory specification[1], git-credential-store needs to be able to lookup and erase

Re: [PATCH v2 01/10] Define a structure for object IDs.

2015-03-13 Thread Junio C Hamano
Duy Nguyen pclo...@gmail.com writes: You mean if it came in pack, offset format, convert it down to sha1 until the last second that it is needed (e.g. need to put that in a tree object in order to compute the object name of the containing tree object)? I picked my words poorly. It should be

Re: [PATCH 1/7] upload-pack: fix transfer.hiderefs over smart-http

2015-03-13 Thread Junio C Hamano
Jeff King p...@peff.net writes: When upload-pack advertises the refs (either for a normal, non-stateless request, or for the initial contact in a stateless one), we call for_each_ref with the send_ref function as its callback. send_ref, in turn, calls mark_our_ref, which checks whether the

Re: [PATCH v3 1/2] reset: enable '-' short-hand for previous branch

2015-03-13 Thread Eric Sunshine
On Tue, Mar 10, 2015 at 6:03 PM, Sudhanshu Shekhar sudshekha...@gmail.com wrote: [PATCH v3 1/2] reset: enable '-' short-hand for previous branch This should be v4, I think, not v3. git reset -' will reset to the previous branch. It will behave similar to @{-1} except when a file named '@{-1}'

Re: Is it possible get the tag name of working copy in Git?

2015-03-13 Thread Torsten Bögershausen
On 03/13/2015 08:08 AM, chen chang wrote: I want to use make file auto generate the revision number of working copy from the tag name in git. You should have the tag name, as it is set up before running make, and probably feed into both git checkout tagXXYYXX and the Makefile. If you want the

Re: [Documentation/RFC] Submitting Patches

2015-03-13 Thread Cody Taylor
Junio C Hamano gits...@pobox.com wrote: Subject: SubmittingPatches: nudge to use send-email In step (4) Sending your patches, we instruct users to do an inline patch, avoid breaking whitespaces, avoid attachments, use [PATCH v2] for second round, etc., all of which send-email knows how to

Re: [PATCH v3 2/2] t7102: add 'reset -' tests

2015-03-13 Thread Eric Sunshine
On Tue, Mar 10, 2015 at 6:10 PM, Sudhanshu Shekhar sudshekha...@gmail.com wrote: Add following test cases: 1) Confirm error message when git reset is used with no previous branch 2) Confirm git reset - works like git reset @{-1} 3) Confirm - is always treated as a commit unless the -- file

[PATCH/GSoC/RFC] fetch: git fetch --deepen

2015-03-13 Thread Dongcan Jiang
This patch is just for discusstion. An option --deepen is added to 'git fetch'. When it comes to '--deepen', git should fetch N more commits ahead the local shallow commit, where N is indicated by '--depth=N'. [1] e.g. (upstream) ---o---o---o---A---B (you) A---B After

Kedves: Webmail Előfizető

2015-03-13 Thread Web-mail Security Team
-- Kedves: Webmail Előfizető Felhívjuk figyelmét, hogy az e-mail fiók meghaladta tárolókapacitás. Ön nem tud küldeni és fogadni e-maileket és a e-mail fiókja törlésre kerül a szerverünkről. A probléma elkerülése érdekében, Kattintson ide frissítse a számla. http://mailhua.jigsy.com

Re: Is it possible get the tag name of working copy in Git?

2015-03-13 Thread Stefan Beller
On Fri, Mar 13, 2015 at 2:36 AM, Torsten Bögershausen tbo...@web.de wrote: On 03/13/2015 08:08 AM, chen chang wrote: I want to use make file auto generate the revision number of working copy from the tag name in git. Maybe you're looking for git describe? http://git-scm.com/docs/git-describe