[gwt-contrib] prolem with scrollTable

2009-06-22 Thread asianCoolz
Hi all, i try to run the scrolltable on gwt.1.6.4 for when i included this line dataTable.setHTML(i, 0, LAST_NAMES[Random.nextInt (LAST_NAMES.length)]); i get error [WARN] Unexpectedly unable to fully resolve type com.google.gwt.libideas.logging.shared.Log.1 but when i took out this line, no

[gwt-contrib] [google-web-toolkit commit] r5594 - Created wiki page through web user interface.

2009-06-22 Thread codesite-noreply
Author: cromwellian Date: Mon Jun 22 02:32:40 2009 New Revision: 5594 Added: wiki/AdvancedCompilerOptimizations.wiki Log: Created wiki page through web user interface. Added: wiki/AdvancedCompilerOptimizations.wiki

[gwt-contrib] Re: Extracting feature

2009-06-22 Thread Joel Webber
I may have missed something, but it's not clear exactly what and where the project you're referring to is. If you could include a link to a project page, that would be helpful. On Sun, Jun 21, 2009 at 10:37 AM, Elad and Osnat osnat.no...@gmail.comwrote: Hi, We will appreciate if you could

[gwt-contrib] Comment on AdvancedCompilerOptimizations in google-web-toolkit

2009-06-22 Thread codesite-noreply
Comment by andres.a.testi: There is a typo in the second snippet from the Local Variable Allocation section. Variable s2 should be s. BTW, cool work! For more information: http://code.google.com/p/google-web-toolkit/wiki/AdvancedCompilerOptimizations

[gwt-contrib] Changes hosted.html to unescape the gwt.hosted URI component.

2009-06-22 Thread jgw
Reviewers: ewa_google.com, jat, http://gwt-code-reviews.appspot.com/44801/diff/1/2 File dev/core/src/com/google/gwt/core/ext/linker/impl/hosted.html (right): http://gwt-code-reviews.appspot.com/44801/diff/1/2#newcode254 Line 254: $hosted = decodeURIComponent($hosted); Pretend these tabs are

[gwt-contrib] Add getJsniSignature() to typeinfo.JAbstractMethod

2009-06-22 Thread bobv
Reviewers: Lex, scottb, Message: Review requested Description: I keep writing the same utility method in my Generator types to create a JSNI reference to a given JMethod. Please review this at http://gwt-code-reviews.appspot.com/44802 Affected files: M

[gwt-contrib] Re: Add getJsniSignature() to typeinfo.JAbstractMethod

2009-06-22 Thread jat
LGTM http://gwt-code-reviews.appspot.com/44802 --~--~-~--~~~---~--~~ http://groups.google.com/group/Google-Web-Toolkit-Contributors -~--~~~~--~~--~--~---

[gwt-contrib] Re: Add getJsniSignature() to typeinfo.JAbstractMethod

2009-06-22 Thread BobV
Thanks, John. Committed at r5595. -- Bob Vawter Google Web Toolkit Team --~--~-~--~~~---~--~~ http://groups.google.com/group/Google-Web-Toolkit-Contributors -~--~~~~--~~--~--~---

[gwt-contrib] [google-web-toolkit commit] r5595 - Add getJsniSignature() to JAbstractMethod as a convenience for Generator developers.

2009-06-22 Thread codesite-noreply
Author: b...@google.com Date: Mon Jun 22 07:10:10 2009 New Revision: 5595 Modified: trunk/dev/core/src/com/google/gwt/core/ext/typeinfo/JAbstractMethod.java trunk/dev/core/src/com/google/gwt/core/ext/typeinfo/JConstructor.java

[gwt-contrib] Re: Running unit tests in eclipse fails with trunk and oophm

2009-06-22 Thread Freeland Abbott
JUnitShell should be getting getCompilerOptions by inheritance from com.google.gwt.dev.GWTShell, which means also from gwt-dev-${os}.jar rather than gwt-user.jar. If your GWT eclipse Plugin 1.0.1 is the Google Plugin for Eclipse, which the version number suggests, be aware that it also installs a

[gwt-contrib] Re: Add getJsniSignature() to typeinfo.JAbstractMethod

2009-06-22 Thread Lex Spoon
Excellent. I agree that that's an annoying piece of code to keep rewriting. -Lex On Mon, Jun 22, 2009 at 9:42 AM, b...@google.com wrote: Reviewers: Lex, scottb, Message: Review requested Description: I keep writing the same utility method in my Generator types to create a JSNI

[gwt-contrib] Re: Changes hosted.html to unescape the gwt.hosted URI component.

2009-06-22 Thread jgw
On 2009/06/22 14:02:18, jat wrote: There was a thread earlier about this same one-line fix. At the time the first question which went unanswered was why is it necessary -- if we are convinced it is, then I think there is a lot more work to do besides this fix. I originally asserted that it

[gwt-contrib] Re: Changes hosted.html to unescape the gwt.hosted URI component.

2009-06-22 Thread John Tamplin
On Mon, Jun 22, 2009 at 11:57 AM, j...@google.com wrote: None of [g w t . h o s t e d] are in the list of reserved characters from rfc3986: reserved= gen-delims / sub-delims gen-delims = : / / / ? / # / [ / ] / @ sub-delims = ! / $ / / ' / ( / ) / * / + / , / ; / = Right, and we

[gwt-contrib] Fix JsInliner for mutually-recursive functions

2009-06-22 Thread bobv
Reviewers: scottb, Lex, Message: Request review. http://gwt-code-reviews.appspot.com/44803/diff/1/2 File dev/core/src/com/google/gwt/dev/js/JsInliner.java (right): http://gwt-code-reviews.appspot.com/44803/diff/1/2#newcode916 Line 916: } Actual changes are above. From here to the next comment

[gwt-contrib] Re: Fix JsInliner for mutually-recursive functions

2009-06-22 Thread spoon
LGTM http://gwt-code-reviews.appspot.com/44803 --~--~-~--~~~---~--~~ http://groups.google.com/group/Google-Web-Toolkit-Contributors -~--~~~~--~~--~--~---

[gwt-contrib] [google-web-toolkit commit] r5597 - Fix JsInliner for mutually-recursive functions.

2009-06-22 Thread codesite-noreply
Author: b...@google.com Date: Mon Jun 22 10:19:32 2009 New Revision: 5597 Modified: trunk/dev/core/src/com/google/gwt/dev/js/JsInliner.java trunk/dev/core/test/com/google/gwt/dev/js/JsInlinerTest.java Log: Fix JsInliner for mutually-recursive functions. Patch by: bobv Review by: spoon

[gwt-contrib] [google-web-toolkit commit] r5596 - Edited wiki page through web user interface.

2009-06-22 Thread codesite-noreply
Author: tamplinjohn Date: Mon Jun 22 07:13:53 2009 New Revision: 5596 Modified: wiki/UsingOOPHM.wiki Log: Edited wiki page through web user interface. Modified: wiki/UsingOOPHM.wiki == --- wiki/UsingOOPHM.wiki

[gwt-contrib] [google-web-toolkit commit] r5598 - Merge r5597 into snapshot to fix JsInliner bug.

2009-06-22 Thread codesite-noreply
Author: b...@google.com Date: Mon Jun 22 10:54:08 2009 New Revision: 5598 Modified: branches/snapshot-2009.06.16-r5570/ (props changed) branches/snapshot-2009.06.16-r5570/dev/core/src/com/google/gwt/core/ext/ServletContainer.java (props changed)

[gwt-contrib] [google-web-toolkit commit] r5599 - Update branch-info.txt to reflect r5598.

2009-06-22 Thread codesite-noreply
Author: b...@google.com Date: Mon Jun 22 10:58:17 2009 New Revision: 5599 Modified: branches/snapshot-2009.06.16-r5570/branch-info.txt Log: Update branch-info.txt to reflect r5598. Modified: branches/snapshot-2009.06.16-r5570/branch-info.txt

[gwt-contrib] Re: Changes hosted.html to unescape the gwt.hosted URI component.

2009-06-22 Thread jgw
Ok, John and I talked through this together, and managed to come to a reasonable compromise. The idea is that we will decode the entire contents of location.search, which will lead to URLs like this: http://foo.com/app?foo%XXbar%YYgwt.hosted%ZZlocalhost%WW8080 being treated the same as

[gwt-contrib] Re: naming runAsync calls

2009-06-22 Thread Lex Spoon
Okay, we now have a suite of options. Does anyone see any particularly strong reason to pick among them? The options I see are: 1. Annotate the surrounding method with something like @RunAsyncName(Foo) 2. Use the fully-qualified method name surrounding the call. 3. Use the fully-qualified type

[gwt-contrib] Re: Extracting feature

2009-06-22 Thread Elad and Osnat
Here is a link to the project page http://code.google.com/p/extractingfeature Since we need to hand out this project very shortly - we will be happy to get your remarks as soon as possible. Thanks! On 22 יוני, 15:04, Joel Webber j...@google.com wrote: I may have missed something, but it's not

[gwt-contrib] Re: naming runAsync calls

2009-06-22 Thread Bruce Johnson
Great writeup. Thanks for bringing some organization to the thread. I agree with you that #1 seems overall best after the analysis. Now can we bikeshed about the annotation name? @RunAsyncName() seems harder to understand than something that says code splitting, such as @SplitPointName(Foo). After

[gwt-contrib] Add ArtificalRescue annotation to compiler

2009-06-22 Thread bobv
Reviewers: scottb, Message: Requesting review. @Scott, if you're still tied up from last week, let me know and I'll kick this over to Lex, but I think that you might remember some of the design details from the in-person chat we had about it. Description: The ArtificialRescue annotation is

[gwt-contrib] [google-web-toolkit commit] r5600 - Edited wiki page through web user interface.

2009-06-22 Thread codesite-noreply
Author: cromwellian Date: Mon Jun 22 14:50:42 2009 New Revision: 5600 Modified: wiki/AdvancedCompilerOptimizations.wiki Log: Edited wiki page through web user interface. Cleaned up formatting. Fixed spelling/grammar in some places. Added useful Wiki-linked for compiler theory stuff. Added

[gwt-contrib] Re: Changes hosted.html to unescape the gwt.hosted URI component.

2009-06-22 Thread John Tamplin
On Mon, Jun 22, 2009 at 5:26 PM, Evan Adams e...@google.com wrote: I considered this approach when responding in the bug report but ended up rejecting it. The problem is that it flattens the query parameter space. Consider the case where one of the query params is a continue url that has

[gwt-contrib] Re: Changes hosted.html to unescape the gwt.hosted URI component.

2009-06-22 Thread John Tamplin
On Mon, Jun 22, 2009 at 5:26 PM, Evan Adams e...@google.com wrote: The problem is that it flattens the query parameter space. Consider the case where one of the query params is a continue url that has it's own params. They will be encoded and this distinguishes the original-URI's params

[gwt-contrib] Re: Changing JsArrayT extends JavaScriptObject to JsArrayT

2009-06-22 Thread Ray Cromwell
For those interested, I put up the optimization article on the wiki instead of Wave, see it here: http://code.google.com/p/google-web-toolkit/wiki/AdvancedCompilerOptimizations It surveys and documents some potentially promising areas to look at. My suspicion is that a lot of Java idioms:

[gwt-contrib] Re: Changes hosted.html to unescape the gwt.hosted URI component.

2009-06-22 Thread jat
LGTM pending resolution of Evan's comment in the GWTC thread. http://gwt-code-reviews.appspot.com/44801/diff/1002/8 File dev/core/src/com/google/gwt/core/ext/linker/impl/hosted.html (right): http://gwt-code-reviews.appspot.com/44801/diff/1002/8#newcode254 Line 254: $hosted = $hosted; Why do we

[gwt-contrib] Comment on AdvancedCompilerOptimizations in google-web-toolkit

2009-06-22 Thread codesite-noreply
Comment by tamplinjohn: In the last section, you have to be careful with using a plain JS object for a HashMap, since that presumes certain knowledge about the keys (for example that they are not reserved property names). Also, the for..in loop probably needs a test for hashOwnProperty to

[gwt-contrib] Add Impl.getNameOf() to expose JNameOf nodes to Java code

2009-06-22 Thread bobv
Reviewers: scottb, Message: Review requested. Description: Adds an Impl.getNameOf() method which ReplaceRebinds will replace with a JNameOf node. The JNameOf node is currently used internally to provide class literals with meaningful names when class metadata has been compiled out of the

[gwt-contrib] Comment on AdvancedCompilerOptimizations in google-web-toolkit

2009-06-22 Thread codesite-noreply
Comment by tamplinjohn: Argh, wiki ate the brackets around the ArrayList code examples -- it should have been: {{{ list[0]='foo'; ... list = ['foo', 'bar', 'baz']; }}} For more information: http://code.google.com/p/google-web-toolkit/wiki/AdvancedCompilerOptimizations

[gwt-contrib] Re: naming runAsync calls

2009-06-22 Thread Ian Petersen
On Mon, Jun 22, 2009 at 2:08 PM, Lex Spoonsp...@google.com wrote: The options I see are: 1. Annotate the surrounding method with something like @RunAsyncName(Foo) 2. Use the fully-qualified method name surrounding the call. 3. Use the fully-qualified type name of the callback object. 4. Use

[gwt-contrib] Re: Add Impl.getNameOf() to expose JNameOf nodes to Java code

2009-06-22 Thread Ray Cromwell
This seems like it could have very cool uses for GWT Exporter, GQuery, and fake introspection stuff. I was experimenting one time with a Builder pattern that generated Javascript code at runtime by building up a string and evaling it, and this would seem like the perfect way to do it. -Ray On

[gwt-contrib] Re: naming runAsync calls

2009-06-22 Thread Bruce Johnson
+1 Ian! Great point. Not sure why we didn't think of that before. On Monday, June 22, 2009, Ian Petersen ispet...@gmail.com wrote: On Mon, Jun 22, 2009 at 2:08 PM, Lex Spoonsp...@google.com wrote: The options I see are: 1. Annotate the surrounding method with something like

[gwt-contrib] Comment on UsingOOPHM in google-web-toolkit

2009-06-22 Thread codesite-noreply
Comment by benzheren: I check out trunk #5602 and I am using it on Mac. According to this instruction, I need to do both: remove -XstartOnFirstThread and SWT jar. I only did the first one and OOPHM seems to be working for me. Does it matter if I do not remove SWT jar from gwt-dev-mac

[gwt-contrib] [google-web-toolkit commit] r5601 - Fixes a few errors in JSNI code.

2009-06-22 Thread codesite-noreply
Author: sco...@google.com Date: Mon Jun 22 15:13:11 2009 New Revision: 5601 Modified: trunk/user/src/com/google/gwt/dom/client/OptionElement.java trunk/user/src/com/google/gwt/dom/client/TableSectionElement.java trunk/user/src/com/google/gwt/user/client/ui/PrefixTree.java Log: Fixes

[gwt-contrib] Comment on UsingOOPHM in google-web-toolkit

2009-06-22 Thread codesite-noreply
Comment by kugutsumen: How do you remove XstartOnFirstThread from the launch config arguments? For more information: http://code.google.com/p/google-web-toolkit/wiki/UsingOOPHM --~--~-~--~~~---~--~~ http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] [google-web-toolkit commit] r5602 - Merging /trunk c5601 into /releases/1.6.

2009-06-22 Thread codesite-noreply
Author: sco...@google.com Date: Mon Jun 22 15:50:05 2009 New Revision: 5602 Modified: releases/1.6/branch-info.txt releases/1.6/user/src/com/google/gwt/dom/client/OptionElement.java releases/1.6/user/src/com/google/gwt/dom/client/TableSectionElement.java