[gwt-contrib] Fix JsDuplicateFunctionRemover to handle non-empty ctor/seed funcs

2010-03-09 Thread cromwellian
Reviewers: Lex, scottb, Description: Scott's new ctor patch violates some assumptions of the old duplicate remover. This new one uses a more general purpose mechanism for avoiding removal where it's not warranted, the algorithm, as Scott invented it: Any JsNameRef JsName that is *not* the immedi

[gwt-contrib] Re: Changes for crawling:

2010-03-09 Thread amitmanjhi
On 2010/03/09 18:27:31, kathrin wrote: Continuing the code review here. The only remaining issue I have is with the 3 constructors in CrawlableHyperlink that don't do anything. Do you need to override all 3? Also, while you are at it, perhaps you can deprecate/refactor/cleanup some of the constr

[gwt-contrib] Re: Fix escaping

2010-03-09 Thread amitmanjhi
On 2010/03/09 02:56:39, jat wrote: LGTM Thanks. Commited http://code.google.com/p/google-web-toolkit/source/detail?r=7688 http://gwt-code-reviews.appspot.com/163801 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

Re: [gwt-contrib] [google-web-toolkit] r7690 committed - Gflow framework with some local CFG-based optimizations....

2010-03-09 Thread Bruce Johnson
very exciting! nice work. On Tue, Mar 9, 2010 at 7:20 PM, Scott Blum wrote: > w00t! That's a lot of work that just landed! > > -- > http://groups.google.com/group/Google-Web-Toolkit-Contributors > -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: First request factory call with params

2010-03-09 Thread rjrjr
Code review, please http://gwt-code-reviews.appspot.com/168801 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] First request factory call with params

2010-03-09 Thread rjrjr
Reviewers: amitmanjhi, Description: Pick an employee from the select, and see his expenses. Please review this at http://gwt-code-reviews.appspot.com/168801 Affected files: bikeshed/.classpath bikeshed/src/com/google/gwt/requestfactory/shared/Slot.java bikeshed/src/com/google/gwt/sample/

[gwt-contrib] Test upload for soft permutations

2010-03-09 Thread scottb
(Just adding myself as a reviewer.) http://gwt-code-reviews.appspot.com/160801 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

Re: [gwt-contrib] [google-web-toolkit] r7690 committed - Gflow framework with some local CFG-based optimizations....

2010-03-09 Thread Scott Blum
w00t! That's a lot of work that just landed! -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

Re: [gwt-contrib] RFC : Soft permutations for the GWT compiler

2010-03-09 Thread BobV
On Tue, Mar 9, 2010 at 4:26 PM, Bruce Johnson wrote: > Thanks for the explanation. Would be really useful to add to the design doc > with enough formatting to make it easy to understand. It just seems like a > very powerful feature that could interact in very hard-to-understand ways > with various

[gwt-contrib] [google-web-toolkit] r7689 committed - Get rid of the jars in bikeshed/war/WEB_INF/lib, and fix style of Stor...

2010-03-09 Thread codesite-noreply
Revision: 7689 Author: rj...@google.com Date: Tue Mar 9 10:30:26 2010 Log: Get rid of the jars in bikeshed/war/WEB_INF/lib, and fix style of Storage Desk review by amitmanjhi No rietvled review due to upload script problemsb Review by: amitman...@google.com http://code.google.com/p/google-web

[gwt-contrib] Re: Testing new GWT RPC implementation (aka deRPC)

2010-03-09 Thread Eric B. Ridge
On Jul 24 2009, 10:22 pm, BobV wrote: > The deRPC code went into trunk a week or so ago, and no initial fires > have been reported.  I'd like to get folks on GWTC to give it a > shakedown. > I'm mainly looking for the following kinds of feedback: >   - If it doesn't work, please tell me how it

Re: [gwt-contrib] RFC : Soft permutations for the GWT compiler

2010-03-09 Thread Bruce Johnson
Thanks for the explanation. Would be really useful to add to the design doc with enough formatting to make it easy to understand. It just seems like a very powerful feature that could interact in very hard-to-understand ways with various build systems, IDEs, etc. So it would need a lot of vetting.

Re: [gwt-contrib] RFC : Soft permutations for the GWT compiler

2010-03-09 Thread John Tamplin
On Tue, Mar 9, 2010 at 3:31 PM, BobV wrote: > - The runtimeLocale property is defined and collapsed by a > ModuleDefMutator which also defines additional rebind rules based on > the defined locale values. >- One or more ModuleDefMutators are installed by a class="Foo" /> which are called be

Re: [gwt-contrib] RFC : Soft permutations for the GWT compiler

2010-03-09 Thread Bruce Johnson
Since amounts to an API change (and sounds pretty weird from a distance), please update the (nice) design doc and get unanimous consent from the SDK team (after getting contributor feedback from the group here). On Tue, Mar 9, 2010 at 3:31 PM, BobV wrote: > Here's what John and I worked out ove

[gwt-contrib] [google-web-toolkit] r7688 committed - Fix the escaping of a String used in one of test methods of JsonpReque...

2010-03-09 Thread codesite-noreply
Revision: 7688 Author: amitman...@google.com Date: Tue Mar 9 09:29:14 2010 Log: Fix the escaping of a String used in one of test methods of JsonpRequestTest Patch by: amitmanjhi Review by: jat http://code.google.com/p/google-web-toolkit/source/detail?r=7688 Modified: /trunk/user/test/com/g

Re: [gwt-contrib] RFC : Soft permutations for the GWT compiler

2010-03-09 Thread BobV
Here's what John and I worked out over IM to get the existing runtime locales support migrated to soft permutations: - The existing locale property continues to work as it currently does. - The runtime.locales configuration property is eliminated in favor of a runtimeLocale deferred-binding pr

[gwt-contrib] Re: Give a better error message when RunAsyncCode.runAsyncCode is passed something

2010-03-09 Thread scottb
I should have mentioned.. one of the important reasons to do the error checking early (and on the JDT AST rather than the GWT AST) is that at some point we want to share all user-error validation code with the Google Eclipse Plugin, and it'd be good if that migration is as painless as possible. h

[gwt-contrib] Re: Give a better error message when RunAsyncCode.runAsyncCode is passed something

2010-03-09 Thread scottb
Mostly LGTM, and a definitely improvement. That being said, there's an inconsistency between this and the the existing error reporting architecture. The general paradigm is that all potential user-errors are caught by the time GenerateJavaAST finishes. These lines in JavaToJavaScriptCompiler are

[gwt-contrib] Changes for crawling:

2010-03-09 Thread kprobst
Reviewers: amitmanjhi, Description: Changes for crawling: - CrawlableHyperlink - client-side changes to Showcase sample Review at http://gwt-code-reviews.appspot.com/161801 Please review this at http://gwt-code-reviews.appspot.com/165801 Affected files: M samples/showcase/src/com/google/gwt

[gwt-contrib] Re: supporting java.io.InputStream/Reader in GWT's JRE

2010-03-09 Thread Eric B. Ridge
On Mar 9, 11:29 am, Andi Mullaraj wrote: > > Also, my coworkers and I are wondering if GWT is single.? > > I am not an English native (so I might have read smth you didn't mean :)), > but this is very funny. I love her too. You read it correctly! eric -- http://groups.google.com/group/Google-W

Re: [gwt-contrib] RFC : Soft permutations for the GWT compiler

2010-03-09 Thread BobV
> Essentially what soft permutations do, for number/date/time formatting > rules, currency details, and the default currency for a locale. > They are implemented by doing a switch on the runtime locale to select among > implementations that inherit from a given deferred-bound locale.  The > selecte

Re: [gwt-contrib] RFC : Soft permutations for the GWT compiler

2010-03-09 Thread John Tamplin
On Tue, Mar 9, 2010 at 12:04 PM, BobV wrote: > What does runtime locales do, exactly? Essentially what soft permutations do, for number/date/time formatting rules, currency details, and the default currency for a locale. They are implemented by doing a switch on the runtime locale to select am

Re: [gwt-contrib] RFC : Soft permutations for the GWT compiler

2010-03-09 Thread BobV
What does runtime locales do, exactly? -- Bob Vawter Google Web Toolkit Team -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: Fix for KeyPressEvent.getCharCode and overall key events improvements

2010-03-09 Thread jgw
On 2010/03/03 16:47:02, jlabanca wrote: LGTM. http://gwt-code-reviews.appspot.com/154812 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

Re: [gwt-contrib] RFC : Soft permutations for the GWT compiler

2010-03-09 Thread John Tamplin
On Tue, Mar 9, 2010 at 11:29 AM, BobV wrote: > > As a more complicated example, an internal app has different translations > > for Latin-American Spanish from the rest of the Spanish translations, so > > they have es and es_419 as deferred binding properties. Then they > inherit > > CldrLocales,

Re: [gwt-contrib] Re: supporting java.io.InputStream/Reader in GWT's JRE

2010-03-09 Thread Bruce Johnson
On Tue, Mar 9, 2010 at 11:29 AM, Andi Mullaraj wrote: > > Also, my coworkers and I are wondering if GWT is single.? > > I am not an English native (so I might have read smth you didn't mean :)), > but this is very funny. I love her too. > ha ha -- i'm totally stealing that joke. -- http://group

Re: [gwt-contrib] RFC : Soft permutations for the GWT compiler

2010-03-09 Thread BobV
> As a more complicated example, an internal app has different translations > for Latin-American Spanish from the rest of the Spanish translations, so > they have es and es_419 as deferred binding properties.  Then they inherit > CldrLocales, and automatically get the right set of runtime locales i

Re: [gwt-contrib] Re: supporting java.io.InputStream/Reader in GWT's JRE

2010-03-09 Thread Andi Mullaraj
> Also, my coworkers and I are wondering if GWT is single.? I am not an English native (so I might have read smth you didn't mean :)), but this is very funny. I love her too. Andi On Tue, Mar 9, 2010 at 11:24 AM, Eric B. Ridge wrote: > Hi Ray. Thanks for the pointer. That was exactly what I

[gwt-contrib] Re: supporting java.io.InputStream/Reader in GWT's JRE

2010-03-09 Thread Eric B. Ridge
Hi Ray. Thanks for the pointer. That was exactly what I needed. Took about 20 minutes of "work" to get InputStream and Reader working in GWT. Also, my coworkers and I are wondering if GWT is single. eric On Mar 8, 5:18 pm, Ray Cromwell wrote: > Look at the user/super/com/google/gwt/emul sourc

[gwt-contrib] Re: Changes for crawling:

2010-03-09 Thread kprobst
http://gwt-code-reviews.appspot.com/161801/diff/1/3 File samples/showcase/war/Showcase.html (right): http://gwt-code-reviews.appspot.com/161801/diff/1/3#newcode4 Line 4:

[gwt-contrib] Changes for crawling:

2010-03-09 Thread kprobst
Reviewers: amtimanjhi_google.com, Description: Changes for crawling: - CrawlableHyperlink - client-side changes to Showcase sample Review at http://gwt-code-reviews.appspot.com/161801 Please review this at http://gwt-code-reviews.appspot.com/163802 Affected files: M samples/showcase/src/com

Re: [gwt-contrib] 3 PopupPanel related bugs

2010-03-09 Thread Joel Webber
Thanks, George. I'll put these on our schedule to look at as soon as we can. On Fri, Mar 5, 2010 at 9:41 AM, ggeorg wrote: > Hi, > > please have a look at: > > - http://code.google.com/p/google-web-toolkit/issues/detail?id=4720&can=4 > - http://code.google.com/p/google-web-toolkit/issues/detail

[gwt-contrib] Re: Remove caching of style sheets in IE6 (cache may be invalid when there are multiple modules)

2010-03-09 Thread jgw
On 2010/03/08 19:43:13, Dan Rice wrote: I added a new patch that caches the lengths but not the actual style sheet contents. In the worst case, if the lengths are wrong we will just append in a suboptimal way, but not lose any data. Benchmarking shows that the performance difference is mi

[gwt-contrib] Issue 4586: DOMImpl.g/setInnerText() use unnecessarily expensive node manipulation

2010-03-09 Thread jgw
LGTM http://gwt-code-reviews.appspot.com/160805 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors