[PHP-DEV] [patch] __string() method

2003-09-02 Thread Jon Parise
Attached is a fairly simple (and rough) patch that adds support for a "special" __string() object method to ZE2. I wrote it for fun, but I thought there might be general interest in the idea, so I'm posting it here. The idea is inspired by Python's __str__ method [1]. Here's how it works in prac

[PHP-DEV] [PATCH] Disable the Zend memory cache

2003-09-02 Thread Vesselin Atanasov
Hello. The memory cache code in zend_alloc.c has serious problems with memory fragmentation. When a big script is run which allocates both lots of small objects and a few big objects, the memory cache grows until the allowed limits (11 buckets x 256 blocks each) keeping all of the cached memory occ

Re: [PHP-DEV] [patch] __string() method

2003-09-02 Thread Marcus Börger
27;m posting it JP> here. The idea is inspired by Python's __str__ method [1]. First why not name it toString() since for now we have consensus on sudlyCaps. But i didn't bother with names yet when i made this patch: http://marcus-boerger.de/php/ext/ze2/ze2-iterators-20030902.diff.t

[PHP-DEV] A note about the Zend low level memory manager in zend_mm.c

2003-09-02 Thread Vesselin Atanasov
Hello. The current low-level memory management code in zend_mm.c places the free blocks as first on the bucket. This increases the fragmentation of newly allocated free blocks. I think it is a good idea to place the freed or newly allocated blocks as last on the bucket. Thus when a new block is all

Re: [PHP-DEV] [PATCH] Disable the Zend memory cache

2003-09-02 Thread Zeev Suraski
At 12:46 02/09/2003, Vesselin Atanasov wrote: Hello. The memory cache code in zend_alloc.c has serious problems with memory fragmentation. When a big script is run which allocates both lots of small objects and a few big objects, the memory cache grows until the allowed limits (11 buckets x 256 bl

Re: [PHP-DEV] [patch] __string() method

2003-09-02 Thread Jon Parise
idea, so I'm posting it > JP> here. The idea is inspired by Python's __str__ method [1]. > > First why not name it toString() since for now we have consensus on sudlyCaps. > But i didn't bother with names yet when i made this patch: > http://marcus-boerger.de/php/e

Re: [PHP-DEV] [patch] __string() method

2003-09-02 Thread Jon Parise
On Tue, Sep 02, 2003 at 11:45:29AM -0400, Jon Parise wrote: > I chose '__string' to follow the existing convention for "special" > method names (e.g. __construct, __clone, __call). Also, I suspect > that many developers are already using toString() methods in their > classes, and I'm not sure we

Re: [PHP-DEV] [patch] __string() method

2003-09-02 Thread Marcus Börger
; But i didn't bother with names yet when i made this patch: >> http://marcus-boerger.de/php/ext/ze2/ze2-iterators-20030902.diff.txt > I chose '__string' to follow the existing convention for "special" > method names (e.g. __construct, __clone, __call). Also, I suspe

[PHP-DEV] heap corruption in php 4.3.[23]--any info?

2003-09-02 Thread moregan
Our development web server has Apache children segfaulting every so often--both Apache 1.3.27 and 1.3.28, and both PHP 4.3.2 and 4.3.3--and thus far we've been unable to make it happen on demand. It appears to be a heap corruption problem and there's a good chance that the corruption happens in a

Re: [PHP-DEV] A note about the Zend low level memory manager in zend_mm.c

2003-09-02 Thread Andi Gutmans
Hi, First of all I'm happy someone is taking a closer look at the memory manager. I am aware that it needs some fine tuning. The first thing I'd like you to try is to change the following line in zend_alloc.c zend_mm_startup(&AG(mm_heap), 256*1024); to zend_mm_startup(&AG(mm_heap), 32*1024); //

Re: [PHP-DEV] [PATCH] Disable the Zend memory cache

2003-09-02 Thread Andi Gutmans
Let's hold on this patch until we finish benchmarking. We might just "do the right thing" automagically. I prefer the user not to have to be smart about such internals. Andi At 12:46 PM 9/2/2003 +0300, Vesselin Atanasov wrote: Hello. The memory cache code in zend_alloc.c has serious problems wi

Re: [PHP-DEV] A note about the Zend low level memory manager in zend_mm.c

2003-09-02 Thread Marcus Börger
Hello Andi, Tuesday, September 2, 2003, 10:49:01 PM, you wrote: [...] > I didn't change this in the CVS yet because libXML2 2.5.9 (or was it > 2.5.8?) has a bug (memory corruption) which indirectly would cause a crash. > Best is if you upgrade to 2.5.10 and then changing this value shouldn't >

Re: [PHP-DEV] Proposed Function: urlencode_array

2003-09-02 Thread Moriyoshi Koizumi
I find this useful, but the name is a bit confusing because the function works differently than a combo of urlencode() / rawurlencode() and array_map(). One of my picks is build_query_string() (this doesn't conform to the naming convention though.) Moriyoshi "Sara Golemon" <[EMAIL PROTECTED]>

Re: [PHP-DEV] A note about the Zend low level memory manager inzend_mm.c

2003-09-02 Thread Vesselin Atanasov
Hello. >The first thing I'd like you to try is to change the following line in >zend_alloc.c >zend_mm_startup(&AG(mm_heap), 256*1024); >to >zend_mm_startup(&AG(mm_heap), 32*1024); // You can also try 16 > >I didn't change this in the CVS yet because libXML2 2.5.9 (or was it >2.5.8?) has a

Re: [PHP-DEV] Proposed Function: urlencode_array

2003-09-02 Thread Sara Golemon
Since Wez has been talking about an http_request() function (which inspired the underlying php_url_encode_hash() function), using a name like http_query_string() (or similar) might suffice for both naming conventions and suitability. -Sara > I find this useful, but the name is a bit confusing bec

Re: [PHP-DEV] implicit public peroperties

2003-09-02 Thread Marcus Börger
Hello Zeev, Friday, August 29, 2003, 10:15:57 AM, you wrote: > Fixed! Yes you fixed it for implicit properties and i fixed it for internal properties. Now we still have to fix it for user space default properties and static properties. And for static properties we should disallow overriding the