Re: [PHP-DEV] raw post data

2003-11-20 Thread Hartmut Holzgraefe
Andi Gutmans wrote: Any chance we can make the necessary changes to support an upload progress bar? I came accross this web site but I'm not quite sure if always populating RAW_POST_DATA is enough. http://www.raditha.com/php/progress.php RAW_POST_DATA won't help at all here as PHP user code execu

Re: [PHP-DEV] raw post data

2003-11-20 Thread Chris Shiflett
--- Rasmus Lerdorf <[EMAIL PROTECTED]> wrote: > As for always populating the raw post data. See the aptly named > always_populate_raw_post_data php.ini setting. I am probably mistaken, but doesn't this ini setting only work when the content type is not application/x-www-form-urlencoded? Chris -

Re: [PHP-DEV] E_STRICT

2003-11-20 Thread Derek Ford
Alan Knowles wrote: How about removing the depreciated functions completely, and providing a userside implementation of them.. include_once 'depreciated.php'; That works for functions at least.. , pass-by-ref is a bit more complex.. At least it gets the mess out of the C code, and it provides

Re: [PHP-DEV] E_STRICT

2003-11-20 Thread Alan Knowles
How about removing the depreciated functions completely, and providing a userside implementation of them.. include_once 'depreciated.php'; That works for functions at least.. , pass-by-ref is a bit more complex.. At least it gets the mess out of the C code, and it provides a simple answer to a

Re: [PHP-DEV] Using do_alloca() instead of emalloc()

2003-11-20 Thread Timm Friebe
On Thu, 2003-11-20 at 10:48, Andi Gutmans wrote: > Hey, > > I've been taking a look at the __autoload problem. During that time I saw > that lots of places in the code (especially reflection API) use > zend_str_tolower_dup(). [...] Here's a patch for zend_reflection_api.c which uses do_alloca /

Re: [PHP-DEV] windows build with libxml and iconv

2003-11-20 Thread Frank M. Kromann
Hi Rob, I'm using iconv 1.9.1 and I get problems with _libiconv_version it does'nt seam to be in the lib file. If I remove this from the exports I can build and link php4dllts.lib and php_xls.dll without problems but not php_iconv.dll. I'll try to resolve this. I also move the @echo off to the

Re: [PHP-DEV] __autoload() lowercase

2003-11-20 Thread Timm Friebe
On Tue, 2003-11-18 at 23:01, Andi Gutmans wrote: > Yeah, this is something we need to tackle. i think we're going to have to > keep the pretty case version but it's going to be a slight hit in performance. > Remember if anyone has posted a patch for this in the past? I did: http://zend.com/lists/

Re: [PHP-DEV] E_STRICT

2003-11-20 Thread Derek Ford
Derek Ford wrote: Andi Gutmans wrote: That's OK with me. At 04:42 PM 11/19/2003 -0600, Derek Ford wrote: Derek Ford wrote: Andi Gutmans wrote: At 11:53 AM 11/19/2003 -0500, George Schlossnagle wrote: I agree with --disable-deprecated, it seems to be the best option. Do you think it would be

Re: [PHP-DEV] [PATCH] sapi apache2 uninitialized content-length value

2003-11-20 Thread Doru Petrescu
you missed the point. it is probably zero like it is now, the point was to put the right value there, not some garbage. and of course I DO NEED THAT VALUE at some point in time, and I see no use of having garbage or a wrong value there. also what stroke me is that all other sapi modules were prope

Re: [PHP-DEV] [PATCH] sapi apache2 uninitialized content-length value

2003-11-20 Thread Uwe Schindler
all other sapi modules do it in the same way... At 15:31 20.11.2003, Ilia Alshanetsky wrote: Why not simply do SG(request_info).content_length = 0; ? Ilia -- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php - Uwe Schindler [EMAIL PROTEC

Re: [PHP-DEV] [PATCH] sapi apache2 uninitialized content-length value

2003-11-20 Thread Ilia Alshanetsky
Why not simply do SG(request_info).content_length = 0; ? Ilia -- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php

Re: [PHP-DEV] validate_file() and strip_file()

2003-11-20 Thread Ilia Alshanetsky
On November 20, 2003 02:22 am, Andi Gutmans wrote:> > Andi > > P.S.-If you think php_strip_whitespace() is misleading then see if you can > find a better name. I think php_strip() is just too short and will be > confused with strip() (which doesn't exist but still...) > Looks much better now. Pleas

Re: [PHP-DEV] __autoload() lowercase

2003-11-20 Thread Derick Rethans
On Wed, 19 Nov 2003, Andi Gutmans wrote: > Yes, this is definitely a problem. Today, when possible, we lowercase the > class at compile-time so that we save time during execution. Supporting > this will lead to a small slow down. > I tend to agree that __autoload() should support this but I'm not

[PHP-DEV] windows build with libxml and iconv

2003-11-20 Thread Rob Richards
Can someone with a clean windows build test the changes for the libxml/iconv linking. I believe it is working, but have so many copies of libxml/libxslt on my system I cant be 100% sure that it is. A few things. It currently is exporting all libxml symbols. It looks like there may be about 200K di

[PHP-DEV] libpcre 4.4 released

2003-11-20 Thread Sebastian Bergmann
Maybe update the bundled libpcre to 4.4? -- Sebastian Bergmann http://sebastian-bergmann.de/ http://phpOpenTracker.de/ Das Buch zu PHP 5: http://professionelle-softwareentwicklung-mit-php5.de/ -- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: ht

[PHP-DEV] [PATCH] sapi apache2 uninitialized content-length value

2003-11-20 Thread Doru Petrescu
Hi, While playing with the upload progress meter I noticed that apache2 sapi implementation does not initialize the content-length sapi variable. Apache 1.3 sapi does! and so does ALL OTHER interfaces. A quick grep into the sources will reveal that only apache2handler and apache2filter does

[PHP-DEV] [PATCH] upload-progress-tracking

2003-11-20 Thread Doru Petrescu
Hi, This is a patch that implements a hooking mechanism into the rfc1867_post_handler() function that process post content of type multipart/form-data, for example when uploading files. This

RE: [PHP-DEV] E_STRICT

2003-11-20 Thread Ford, Mike [LSS]
On 19 November 2003 20:34, Steph wrote: > > Not to branch the discussion, but again: if we never plan on > > removing functions, why go to the trouble of deprecating them? > > Deprecation implies it will be removed. > > > > .. and as Andi said earlier, removal without loud and clear warning >

Re: [PHP-DEV] [PATCH] substr() returns false

2003-11-20 Thread Morten Poulsen
On Wed, 2003-11-19 at 19:30, Andi Gutmans wrote: > Isn't it a mistake to give a start position at the end or beyond the > string? You could easily argue, that beyond the end is an error, but I agree with the way Perl allows the start to be at the end. I think of it as with (pseudo-) C: char str

[PHP-DEV] Using do_alloca() instead of emalloc()

2003-11-20 Thread Andi Gutmans
Hey, I've been taking a look at the __autoload problem. During that time I saw that lots of places in the code (especially reflection API) use zend_str_tolower_dup(). In most of these cases it would be much more efficient to use do_alloca()/free_alloca() because that usually uses alloca() which

Re: [PHP-DEV] E_STRICT

2003-11-20 Thread Derek Ford
Andi Gutmans wrote: That's OK with me. At 04:42 PM 11/19/2003 -0600, Derek Ford wrote: Derek Ford wrote: Andi Gutmans wrote: At 11:53 AM 11/19/2003 -0500, George Schlossnagle wrote: I agree with --disable-deprecated, it seems to be the best option. Do you think it would be relevant to have a

Re: [PHP-DEV] E_STRICT

2003-11-20 Thread Andi Gutmans
At 09:24 AM 11/20/2003 +0200, Jani Taskinen wrote: On Thu, 20 Nov 2003, Michael Walter wrote: >No - NEWS contains way more than that. What I was talking about was a >file the exclusively contains removed/changed functionality - you might >not want to skim over the entire NEWS file if solely intere

Re: [PHP-DEV] E_STRICT

2003-11-20 Thread Jani Taskinen
On Thu, 20 Nov 2003, Michael Walter wrote: >No - NEWS contains way more than that. What I was talking about was a >file the exclusively contains removed/changed functionality - you might >not want to skim over the entire NEWS file if solely interested in BC >breaking changes (see Wez' post - no

Re: [PHP-DEV] allow_call_time_pass_reference

2003-11-20 Thread Andi Gutmans
I think it should stay the way it is (except for the bug). It should print a warning when people use it and the default allow_call_time_pass_reference directive is off. Andi At 07:52 AM 11/20/2003 +0100, Sebastian Bergmann wrote: I am wondering what should happen to the allow_call_time_p

Re: [PHP-DEV] validate_file() and strip_file()

2003-11-20 Thread Andi Gutmans
Looks much better now. Please make sure you test it well because it's quite sensitive APIs you are using. About the return value, I think it should return the error message or true on success. Then people could use === to check what they got (I prefer that over Markus' idea). Then again I'm not