Re: [PHP-DEV] Re: When, When, When???

2014-09-16 Thread Anatol Belski
Hi Jorge, On Mon, September 15, 2014 22:25, Jorge F. Hernandez wrote: > Stephen asked me to check in your list, but I don't see anything new, so > does anybody have any idea? Signature > > > > On 9/15/2014 3:32 PM, Stephen Zarkos wrote: > >> Hi, >> >> >> >>> -Original Message- >>> From: Jo

Re: [PHP-DEV] Re: [PHP-CVS] com php-src: fix signed/unsigned mismatch: Zend/zend_execute.c

2014-09-16 Thread Anatol Belski
Hi Nikita, On Mon, September 15, 2014 22:36, Nikita Popov wrote: > On Mon, Sep 15, 2014 at 2:47 PM, Anatol Belski > wrote: > > > > On Mon, September 15, 2014 13:38, Anatol Belski wrote: > >> On Mon, September 15, 2014 13:13, Nikita Popov wrote: >> >> >>> On Mon, Sep 15, 2014

Re: [PHP-DEV] [VOTE][RFC] Integer Semantics

2014-09-16 Thread Dmitry Stogov
Hi Andrea, Shifts by negative number may make sense. (N << -1) => (N >> 1) At least receiving "false" from shift is not very pleasant. In the patch you use SIZEOF_LONG. It probably should be changed to SIZEOF_ZEND_LONG. Thanks. Dmitry. On Mon, Sep 15, 2014 at 8:31 PM, Andrea Faulds wrote: >

Re: [PHP-DEV] [VOTE][RFC] Integer Semantics

2014-09-16 Thread Andrea Faulds
On 16 Sep 2014, at 10:16, Dmitry Stogov wrote: > Shifts by negative number may make sense. (N << -1) => (N >> 1) > At least receiving "false" from shift is not very pleasant. The problem is that changing from the current behaviour (undefined in C, but typically a shift by (PHP_INT_MAX - $bits)

Re: [PHP-DEV] Re: [PHP-CVS] com php-src: fix signed/unsigned mismatch: Zend/zend_execute.c

2014-09-16 Thread Nikita Popov
On Tue, Sep 16, 2014 at 9:43 AM, Anatol Belski wrote: > Hi Nikita, > > > Are you sure about this? I can set memory_limit to -1, which is then cast > > to size_t, resulting in a limit > ZEND_LONG_MAX. > > > > > > I tried the following in a 32bit VM with -dmemory_limit=-1 and got a > > segfault: >

Re: [PHP-DEV] [VOTE][RFC] Integer Semantics

2014-09-16 Thread Dmitry Stogov
you already made silent break for N << 64 and N >> 64, but it may be explained as more consistent behaviour. I don't see a big difference with negative shifts. The real thing that I don't like - is a "boolean" result. Warning is not a big problem. Thanks. Dmitry. On Tue, Sep 16, 2014 at 1:23 P

Re: [PHP-DEV] [VOTE][RFC] Integer Semantics

2014-09-16 Thread Chris Wright
On 16 September 2014 11:05, Dmitry Stogov wrote: > you already made silent break for N << 64 and N >> 64, but it may be > explained as more consistent behaviour. > I don't see a big difference with negative shifts. > > The real thing that I don't like - is a "boolean" result. Warning is not a > bi

Re: [PHP-DEV] Re: [PHP-CVS] com php-src: fix signed/unsigned mismatch: Zend/zend_execute.c

2014-09-16 Thread Anatol Belski
On Tue, September 16, 2014 12:03, Nikita Popov wrote: > On Tue, Sep 16, 2014 at 9:43 AM, Anatol Belski > wrote: > > > > Hi Nikita, > > > >> Are you sure about this? I can set memory_limit to -1, which is then >> cast to size_t, resulting in a limit > ZEND_LONG_MAX. >> >> >> I

Re: [PHP-DEV] [VOTE][RFC] Integer Semantics

2014-09-16 Thread Andrea Faulds
On 16 Sep 2014, at 11:19, Chris Wright wrote: > On 16 September 2014 11:05, Dmitry Stogov wrote: >> you already made silent break for N << 64 and N >> 64, but it may be >> explained as more consistent behaviour. >> I don't see a big difference with negative shifts. >> >> The real thing that I

[PHP-DEV] DOMDocument::load* return values

2014-09-16 Thread Chris Wright
All The return value of the DOMDocument::load* family of methods currently varies depending on whether it was invoked statically or as an instance method - when invoked on an instance it returns bool, and when invoked statically it returns the implicitly created instance or FALSE on error. Invokin

Re: [PHP-DEV] Re: When, When, When???

2014-09-16 Thread Jorge F. Hernandez
I am running PHP 5.6.0 x64 on my Windows Server 2008 R2 with Apache 2.4 x64, I just tried to put a "memory_limit" higher than 3584M and I got a white screen when trying to access phpinfo() to check, I also tested uploading a 6GB file (after changing memory_limit back to 3.5G - x86 maximum) and

Re: [PHP-DEV] Re: When, When, When???

2014-09-16 Thread Andrea Faulds
On 16 Sep 2014, at 14:40, Jorge F. Hernandez wrote: > I am running PHP 5.6.0 x64 on my Windows Server 2008 R2 with Apache 2.4 x64, > I just tried to put a "memory_limit" higher than 3584M and I got a white > screen when trying to access phpinfo() to check, I also tested uploading a > 6GB file

Re: [PHP-DEV] Re: When, When, When???

2014-09-16 Thread Jorge F. Hernandez
Where can I get the master branch? I just went to http://windows.php.net/downloads/snaps/master/ and all I saw was x86. Thanks, Signature On 9/16/2014 9:46 AM, Andrea Faulds wrote: On 16 Sep 2014, at 14:40, Jorge F. Hernandez wrote: I am running PHP 5.6.0 x64 on my Windows Server 2008 R2

Re: [PHP-DEV] Re: When, When, When???

2014-09-16 Thread Christoph Becker
Jorge F. Hernandez wrote: > I am running PHP 5.6.0 x64 on my Windows Server 2008 R2 with Apache 2.4 > x64, I just tried to put a "memory_limit" higher than 3584M and I got a > white screen when trying to access phpinfo() to check, I also tested > uploading a 6GB file (after changing memory_limit b

[PHP-DEV] Re: [VOTE] Removing Multiple Default Clauses in Switch Statements

2014-09-16 Thread Levi Morrison
On Fri, Sep 5, 2014 at 2:29 PM, Levi Morrison wrote: > Dear list, > > I have opened voting on this RFC: > https://wiki.php.net/rfc/switch.default.multiple#vote > > The RFC is very short so I will not summarize it here. > > Voting will remain open for 10 days and will close on Monday, > September t

Re: [PHP-DEV] Re: [VOTE] Removing Multiple Default Clauses in Switch Statements

2014-09-16 Thread Andrea Faulds
On 16 Sep 2014, at 15:13, Levi Morrison wrote: > The vote passed unambiguously in favor of the RFC, 28 votes to none. > Thanks to everyone who participated. Since it passed, are you going to merge into master soon? Also, you should probably amend the master branch of the spec in turn. -- Andr

[PHP-DEV] Renaming type-hints to something else?

2014-09-16 Thread Levi Morrison
Dear list, I've always been bothered by the fact that we call type declarations 'hints', as if they aren't enforced. They have always been enforced and we don't have an option to turn them off. I'm wondering if we want to move away from that name to something else. I have two RFCs already that de

Re: [PHP-DEV] Re: When, When, When???

2014-09-16 Thread Anatol Belski
Hi, On Tue, September 16, 2014 15:54, Christoph Becker wrote: > Jorge F. Hernandez wrote: > > >> I am running PHP 5.6.0 x64 on my Windows Server 2008 R2 with Apache 2.4 >> x64, I just tried to put a "memory_limit" higher than 3584M and I got >> a white screen when trying to access phpinfo() to ch

Re: [PHP-DEV] Renaming type-hints to something else?

2014-09-16 Thread Andrea Faulds
Hi! Here are my thoughts. The general concept should be called Optional Type Declarations, to replace “Type Hinting". They are type declarations, and they are optional. Thus the name. For the things themselves, they’re just Type Declarations, to replace “Type Hints". So, for example: “I am a

Re: [PHP-DEV] Renaming type-hints to something else?

2014-09-16 Thread Levi Morrison
On Tue, Sep 16, 2014 at 9:16 AM, Andrea Faulds wrote: > Hi! > > Here are my thoughts. > > The general concept should be called Optional Type Declarations, to replace > “Type Hinting". They are type declarations, and they are optional. Thus the > name. For the things themselves, they’re just Type

Re: [PHP-DEV] Renaming type-hints to something else?

2014-09-16 Thread Andrea Faulds
On 16 Sep 2014, at 16:24, Levi Morrison wrote: > On Tue, Sep 16, 2014 at 9:16 AM, Andrea Faulds wrote: >> >> The general concept should be called Optional Type Declarations, to replace >> “Type Hinting". They are type declarations, and they are optional. Thus the >> name. For the things them

Re: [PHP-DEV] Re: When, When, When???

2014-09-16 Thread Jorge F. Hernandez
On 9/16/2014 11:14 AM, Anatol Belski wrote: Hi, On Tue, September 16, 2014 15:54, Christoph Becker wrote: Jorge F. Hernandez wrote: I am running PHP 5.6.0 x64 on my Windows Server 2008 R2 with Apache 2.4 x64, I just tried to put a "memory_limit" higher than 3584M and I got a white screen w

Re: [PHP-DEV] Re: [VOTE] Removing Multiple Default Clauses in Switch Statements

2014-09-16 Thread Levi Morrison
On Tue, Sep 16, 2014 at 9:09 AM, Andrea Faulds wrote: > > On 16 Sep 2014, at 15:13, Levi Morrison wrote: > >> The vote passed unambiguously in favor of the RFC, 28 votes to none. >> Thanks to everyone who participated. > > Since it passed, are you going to merge into master soon? As I don't have

Re: [PHP-DEV] Re: When, When, When???

2014-09-16 Thread Jorge F. Hernandez
On 9/16/2014 11:14 AM, Anatol Belski wrote: Hi, On Tue, September 16, 2014 15:54, Christoph Becker wrote: Jorge F. Hernandez wrote: I am running PHP 5.6.0 x64 on my Windows Server 2008 R2 with Apache 2.4 x64, I just tried to put a "memory_limit" higher than 3584M and I got a white screen w

Re: [PHP-DEV] Re: When, When, When???

2014-09-16 Thread Leigh
On 16 September 2014 16:14, Anatol Belski wrote: > I made a build from the current revision > http://windows.php.net/downloads/snaps/ostc/master-f469dc74/ so anyone > curious can easy snuffle :) It contains all the currently ported exts + > debug symbols, no PGO. Please catch up later with windows

Re: [PHP-DEV] Re: When, When, When???

2014-09-16 Thread christopher jones
On 9/16/14, 9:11 AM, Jorge F. Hernandez wrote: On 9/16/2014 11:14 AM, Anatol Belski wrote: I made a build from the current revision http://windows.php.net/downloads/snaps/ostc/master-f469dc74/ so anyone curious can easy snuffle :) It contains all the currently ported exts + debug symbols, n

Re: [PHP-DEV] Re: When, When, When???

2014-09-16 Thread Anatol Belski
Hi Jorge, On Tue, September 16, 2014 18:11, Jorge F. Hernandez wrote: > On 9/16/2014 11:14 AM, Anatol Belski wrote: > >> Hi, >> >> >> On Tue, September 16, 2014 15:54, Christoph Becker wrote: >> >>> Jorge F. Hernandez wrote: >>> >>> >>> I am running PHP 5.6.0 x64 on my Windows Server 2008 R2

Re: [PHP-DEV] Re: When, When, When???

2014-09-16 Thread Leigh
On 16 September 2014 17:25, Leigh wrote: > > What's the difference between the build you put up, and the builds in > http://windows.php.net/downloads/snaps/master/ ? Since I am home now and can test. I'll answer my own question - builds in snaps/master are still 32 bit builds. -- PHP Internals

Re: [PHP-DEV] Re: When, When, When???

2014-09-16 Thread Anatol Belski
On Tue, September 16, 2014 18:25, Leigh wrote: > On 16 September 2014 16:14, Anatol Belski wrote: > >> I made a build from the current revision >> http://windows.php.net/downloads/snaps/ostc/master-f469dc74/ so anyone >> curious can easy snuffle :) It contains all the currently ported exts + >> de

Re: [PHP-DEV] [RFC] Implicit isset() in Shorthand Ternary Operator

2014-09-16 Thread Andrea Faulds
On 10 Sep 2014, at 10:31, Pierre Joye wrote: > On Tue, Sep 9, 2014 at 12:58 AM, Adam Harvey wrote: >> On 8 September 2014 07:56, Christoph Becker wrote: >> +1 on ?? — there's precedent for it, and it means we don't have to >> explain why the shorthand form of an operator behaves differently to

Re: [PHP-DEV] [RFC] Implicit isset() in Shorthand Ternary Operator

2014-09-16 Thread Adam Harvey
On 16 September 2014 11:34, Andrea Faulds wrote: > By popular demand, I’ve changed the RFC to instead propose a ?? operator, > after Nikita Popov generously donated a working ?? patch. In doing so, the > RFC is renamed “Null Coalesce Operator”. > > Please read it: https://wiki.php.net/rfc/isset_

Re: [PHP-DEV] [RFC] Implicit isset() in Shorthand Ternary Operator

2014-09-16 Thread Andrea Faulds
On 16 Sep 2014, at 19:38, Adam Harvey wrote: > On 16 September 2014 11:34, Andrea Faulds wrote: >> By popular demand, I’ve changed the RFC to instead propose a ?? operator, >> after Nikita Popov generously donated a working ?? patch. In doing so, the >> RFC is renamed “Null Coalesce Operator”

Re: [PHP-DEV] [RFC] Implicit isset() in Shorthand Ternary Operator

2014-09-16 Thread Shashank Kumar
This will be a nice addition. Kudos to you! Is there an issue targeting next minor for this? (assuming there is one) ​

Re: [PHP-DEV] [RFC] Implicit isset() in Shorthand Ternary Operator

2014-09-16 Thread Andrea Faulds
On 16 Sep 2014, at 19:55, Shashank Kumar wrote: > This will be a nice addition. Kudos to you! Really, you should thank Nikita, not me. He wrote the patch. ^^ > Is there an issue targeting next minor for this? (assuming there is one) Well, the patch is written for master. It could be back port

AW: [PHP-DEV] Renaming type-hints to something else?

2014-09-16 Thread Robert Stoll
> -Ursprüngliche Nachricht- > Von: Andrea Faulds [mailto:a...@ajf.me] > Gesendet: Dienstag, 16. September 2014 17:26 > An: Levi Morrison > Cc: internals > Betreff: Re: [PHP-DEV] Renaming type-hints to something else? > > > On 16 Sep 2014, at 16:24, Levi Morrison wrote: > > > On Tue, Se

Re: [PHP-DEV] [RFC] Implicit isset() in Shorthand Ternary Operator

2014-09-16 Thread Shashank Kumar
> Really, you should thank Nikita, not me. He wrote the patch. ^^ ​He gets my bag of thanks for many things. > Well, the patch is written for master. It could be back ported, but I don’t know how. > Also, even if there is a 5.7, it sounds like it will consist purely of bug fixes and E_DEPRECATED w

Re: [PHP-DEV] [RFC] Implicit isset() in Shorthand Ternary Operator

2014-09-16 Thread Thomas Bley
Andrea Faulds wrote on 16.09.2014 20:34: > > On 10 Sep 2014, at 10:31, Pierre Joye wrote: > >> On Tue, Sep 9, 2014 at 12:58 AM, Adam Harvey wrote: >>> On 8 September 2014 07:56, Christoph Becker wrote: >>> +1 on ?? — there's precedent for it, and it means we don't have to >>> explain why the

Re: [PHP-DEV] [RFC] Implicit isset() in Shorthand Ternary Operator

2014-09-16 Thread Andrea Faulds
On 16 Sep 2014, at 20:28, Thomas Bley wrote: > What are the pros and cons of a new operator vs. a new function? For example, > MySQL has a coalesce() function: > http://dev.mysql.com/doc/refman/5.6/en/comparison-operators.html#function_coalesce A function is useless as it wouldn’t stop you get

Re: [PHP-DEV] [RFC] Implicit isset() in Shorthand Ternary Operator

2014-09-16 Thread Thomas Bley
Sorry, I mean to implement coalesce() as a token like isset() ? Regards, Thomas Andrea Faulds wrote on 16.09.2014 21:30: > > On 16 Sep 2014, at 20:28, Thomas Bley wrote: > >> What are the pros and cons of a new operator vs. a new function? For example, >> MySQL has a coalesce() function: >>

Re: [PHP-DEV] [RFC] Implicit isset() in Shorthand Ternary Operator

2014-09-16 Thread Christoph Becker
Andrea Faulds wrote: > On 16 Sep 2014, at 19:38, Adam Harvey wrote: > >> On 16 September 2014 11:34, Andrea Faulds wrote: >>> By popular demand, I’ve changed the RFC to instead propose a ?? operator, >>> after Nikita Popov generously donated a working ?? patch. In doing so, the >>> RFC is ren

Re: [PHP-DEV] [RFC] Implicit isset() in Shorthand Ternary Operator

2014-09-16 Thread Kingsquare.nl - Robin Speekenbrink
2014-09-16 22:00 GMT+02:00 Christoph Becker : > Andrea Faulds wrote: > >> On 16 Sep 2014, at 19:38, Adam Harvey wrote: >> >>> On 16 September 2014 11:34, Andrea Faulds wrote: By popular demand, I’ve changed the RFC to instead propose a ?? operator, after Nikita Popov generously donated

Re: [PHP-DEV] [RFC] Implicit isset() in Shorthand Ternary Operator

2014-09-16 Thread Andrea Faulds
On 16 Sep 2014, at 21:46, Kingsquare.nl - Robin Speekenbrink wrote: > As a userland point of view on this: will this have a shorthand? No. > i.e. > what will happen if i leave out the second part? > > ie. > $var = $_GET['test'] ?? ; > > would that be the same as > $var = @$_GET['test’]; No

Re: [PHP-DEV] Renaming type-hints to something else?

2014-09-16 Thread Stas Malyshev
Hi! > The general concept should be called Optional Type Declarations, to > replace “Type Hinting". They are type declarations, and they are > optional. Thus the name. For the things themselves, they’re just Type > Declarations, to replace “Type Hints". So, for example: I'd just call it type decl