[jQuery] Re: new Plugin every: jQuery-oriented setTimeout and setInterval

2007-08-17 Thread Blair Mitchelmore
te: > On Aug 16, 6:40 pm, Blair Mitchelmore <[EMAIL PROTECTED]> > wrote: > > >http://jquery.offput.ca/js/jquery.timers.js > > I am seeing this: > > You don't have permission to access /js/jquery.timers.js on this > server. > > Additionally, a 404 Not F

[jQuery] Re: new Plugin every: jQuery-oriented setTimeout and setInterval

2007-08-16 Thread Blair Mitchelmore
> oliver > > On Aug 13, 3:09 pm, Blair Mitchelmore <[EMAIL PROTECTED]> > wrote: > > > So I actually wrote this plugin almost six months ago, but a few weeks > > ago I fleshed it out for use at work. The main external change was a > > change in the order of th

[jQuery] Re: Updated Plugin: jQuery Timers. jQuery-oriented setTimeout/setInterval

2007-08-15 Thread Blair Mitchelmore
The point of WTFPL is exactly that: the user can do *whatever* the fuck they want with it. Anything. That includes taking it and shamelessly saying they developed it whole cloth or selling it to unsuspecting users who could get it for free with no strings attached if they knew better. It also mean

[jQuery] Re: Updated Plugin: jQuery Timers. jQuery-oriented setTimeout/setInterval

2007-08-15 Thread Blair Mitchelmore
I should've changed the url in this e-mail. The actual page for the plugin is <http://jquery.offput.ca/timers> but I redirect the 'every' subdirectory to 'timers' -blair On Aug 15, 1:00 pm, Blair Mitchelmore <[EMAIL PROTECTED]> wrote: > I released this a

[jQuery] Updated Plugin: jQuery Timers. jQuery-oriented setTimeout/setInterval

2007-08-15 Thread Blair Mitchelmore
I released this a couple days ago but as was discussed on a previous thread there were some method naming issues and I also wanted to add a feature that another setInterval wrapper had. Lucky I did, because I discove

[jQuery] Re: new Plugin every: jQuery-oriented setTimeout and setInterval

2007-08-14 Thread Blair Mitchelmore
gt; > $(...).oneTime(); > $(...).everyTime(); > $(...).stopTime(); > > Cheers, > -js > > P.S. I approved your account so there shouldn't be a delay anymore. > > On 8/14/07, Blair Mitchelmore <[EMAIL PROTECTED]> wrote: > > > > > Maybe it's ju

[jQuery] Re: new Plugin every: jQuery-oriented setTimeout and setInterval

2007-08-14 Thread Blair Mitchelmore
ty and simplicity of jQuery. Though perhaps an importing system could be used. jQuery.import("timer"); jQuery(...).stop(); // stops timer events not animations But this is all a discussion better suited for the dev list. -blair On Aug 14, 9:52 am, Stephan Beal <[EMAIL PROTECTED]>

[jQuery] Re: "scollovers" animation

2007-08-14 Thread Blair Mitchelmore
lds). (Nested forms are also necessary if working in ASP.NET and avoiding the postback system for one reason or another). The second is a simple and elegant way of hiding things you wanted to be shown for javascript behaviour, or vice versa. Anyways, enough standards ranting. -blair On Aug

[jQuery] Re: new Plugin every: jQuery-oriented setTimeout and setInterval

2007-08-14 Thread Blair Mitchelmore
d names but for now (as you'll see from the source) it's quite easy for you to do this on your own for now. -blair On Aug 13, 6:09 pm, Blair Mitchelmore <[EMAIL PROTECTED]> wrote: > So I actually wrote this plugin almost six months ago, but a few weeks > ago I fleshed it out f

[jQuery] Re: "scollovers" animation

2007-08-14 Thread Blair Mitchelmore
s Hartl <[EMAIL PROTECTED]> wrote: > Blair Mitchelmore wrote: > > I have no idea why a fieldset is being used but I do know that it let > > me define both a width as well as display:inline so that's probably > > the reason the script uses it. > > There is a C

[jQuery] new Plugin every: jQuery-oriented setTimeout and setInterval

2007-08-14 Thread Blair Mitchelmore
So I actually wrote this plugin almost six months ago, but a few weeks ago I fleshed it out for use at work. The main external change was a change in the order of the arguments to simplify the code. And the main internal change was moving the structure of the timer tracking code to more closely mi

[jQuery] Re: "scollovers" animation

2007-08-13 Thread Blair Mitchelmore
tl <[EMAIL PROTECTED]> wrote: > Blair Mitchelmore wrote: > > Here's my (40 line) proof of concept. It's not as foolproof as the > > original especially regarding the positioning of the resultant element > > (the original took a link and changed it to an em in a

[jQuery] Re: "scollovers" animation

2007-08-13 Thread Blair Mitchelmore
> btw: the example doesn't work in Safari 2.0.3 > > On 11 Aug 2007, at 06:21, Blair Mitchelmore wrote: > > > > > (I'm not sure if this is a double post, I tried to post earlier...) > > > Here's my (40 line) proof of concept. It's not as foolproof a

[jQuery] Re: "scollovers" animation

2007-08-11 Thread Blair Mitchelmore
(I'm not sure if this is a double post, I tried to post earlier...) Here's my (40 line) proof of concept. It's not as foolproof as the original especially regarding the positioning of the resultant element (the original took a link and changed it to an em in a span in a span in a span in a fields

[jQuery] Re: "scollovers" animation

2007-08-11 Thread Blair Mitchelmore
Ask and ye shall receive. http://jquery.offput.ca/js/jquery.scrollover.js It's not probably not a foolproof as the other one, I left out any options that could have been specified, and I could probably make the nudging work a bit better but this is good enough for a bit of hacking. It's also not

[jQuery] Query String Object

2007-08-10 Thread Blair Mitchelmore
So recently, I needed a quick easy way to both access query string parameters as an object and to output that object as a query string. I found a meta-plugin that Joern had written a while back for parsing into an object and I decided to expand on that. The two key features I added were a 'set' me

[jQuery] Re: outerHTML and Firefox does not work

2007-04-09 Thread Blair Mitchelmore
outerHTML is an IE only property that only a few other browsers support. However, Mozilla's JavaScript implementation rocks so try this code I found on : var _emptyTags = { "IMG": true, "BR":true, "INPUT": true, "META": true, "

[jQuery] Re: xpath question

2007-04-05 Thread Blair Mitchelmore
I heard John talking about adding in the "/modules/module[1]" syntax on the list a little while ago for jQuery 1.1.3 but that might have been pushed back to 1.2 -blair [EMAIL PROTECTED] wrote: Ok, after re-reading http://docs.jquery.com/DOM/Traversing/Selectors I figured out that I should b