D16832: fix empty runner list after switching to new locale

2018-12-01 Thread Nick Shaforostoff
shaforostoff added inline comments. INLINE COMMENTS > davidedmundson wrote in runnermanager.cpp:274 > what does deadRunners have to do with this? if deadRunners is empty then there is no sense rerunning this method, and it even could cause endless recursion REPOSITORY R308 KRunner REVISION

Re: Review Request 127896: make dbus optional on osx: kauth

2016-05-20 Thread Nick Shaforostoff
on linux, tests on linux still pass. Thanks, Nick Shaforostoff ___ Kde-frameworks-devel mailing list Kde-frameworks-devel@kde.org https://mail.kde.org/mailman/listinfo/kde-frameworks-devel

Re: Review Request 127896: make dbus optional on osx: kauth

2016-05-12 Thread Nick Shaforostoff
might use. > IOW, I don't think a distribution system that aims to provide the best > possible context for the applications it carries can get around using DBus. > > But this is probably not the best place for an in-depth discussion around > underlying principles; that should p

Re: Review Request 127896: make dbus optional on osx: kauth

2016-05-12 Thread Nick Shaforostoff
> > > Was this a redundant statement? yes, it was redundant. - Nick --- This is an automatically generated e-mail. To reply, visit: https://git.reviewboard.kde.org/r/127896/#review95403 -

Re: Review Request 127896: make dbus optional on osx: kauth

2016-05-12 Thread Nick Shaforostoff
d any IPC? that would just pollute his/her system with redundant stuff. how many gtk-based apps require dbus to run on windows and osx? - Nick --- This is an automatically generated e-mail. To reply, visit: https://git.reviewboa

Re: Review Request 127896: make dbus optional on osx: kauth

2016-05-11 Thread Nick Shaforostoff
on linux, tests on linux still pass. Thanks, Nick Shaforostoff ___ Kde-frameworks-devel mailing list Kde-frameworks-devel@kde.org https://mail.kde.org/mailman/listinfo/kde-frameworks-devel

Review Request 127896: make dbus optional on osx: kauth

2016-05-11 Thread Nick Shaforostoff
://git.reviewboard.kde.org/r/127896/diff/ Testing --- compiles fine on osx, compiles fine on linux, tests on linux still pass. Thanks, Nick Shaforostoff ___ Kde-frameworks-devel mailing list Kde-frameworks-devel@kde.org https://mail.kde.org/mailman

dbus-less frameworks on osx

2016-05-10 Thread Nick Shaforostoff
hi all! I'm investigating possibility of getting some kde apps to build on osx with vanilla Qt without dbus. would you accept patches that make that possible? for example, i have just built kauth without dbus and i can prepare a review request with a (nice) patch for this

Re: Review Request 127666: kconfig and kurlrequester friendship: store local paths in string-typed item without file:// prefix

2016-04-30 Thread Nick Shaforostoff
:// prefix Thanks, Nick Shaforostoff ___ Kde-frameworks-devel mailing list Kde-frameworks-devel@kde.org https://mail.kde.org/mailman/listinfo/kde-frameworks-devel

Re: Review Request 127632: Prioritize correct extension per theme

2016-04-22 Thread Nick Shaforostoff
. we can adopt this change now, mention this somewhere in docs (print a qWarning saying that the checking order has changed?), and introduce X-KDE-Extensions later (which would only require a slght adjustment of iconPathByName() method). - Nick Shaforostoff On April 11, 2016, 11:17 p.m., Aleix

Review Request 127666: kconfig and kurlrequester friendship: store local paths in string-typed item without file:// prefix

2016-04-17 Thread Nick Shaforostoff
it appropriately Diffs - src/core/kcoreconfigskeleton.cpp 293387b Diff: https://git.reviewboard.kde.org/r/127666/diff/ Testing --- ktorrent now displays local paths in settings dialog without file:// prefix Thanks, Nick Shaforostoff

Re: Review Request 127236: Leverage QDir to know what's in a KIconThemeDir

2016-03-14 Thread Nick Shaforostoff
lt;< "1" << > QFileInfo(actionIconsDir).lastModified(); > QVERIFY(QFile::copy(QStringLiteral(":/test-22x22.png"), > newIconPath)); > +qDebug() << "2" << > QFileInfo(actionIconsDir).lastMod

Re: Review Request 127236: Leverage QDir to know what's in a KIconThemeDir

2016-03-14 Thread Nick Shaforostoff
lt;< "1" << > QFileInfo(actionIconsDir).lastModified(); > QVERIFY(QFile::copy(QStringLiteral(":/test-22x22.png"), > newIconPath)); > +qDebug() << "2" << > QFileInfo(actionIconsDir).lastMod

Re: Review Request 127215: simplify code, reduce pointer dereferences

2016-03-02 Thread Nick Shaforostoff
marked as submitted. Review request for KDE Frameworks. Changes --- Submitted with commit b9c8b1fadcbb742e6129b77f28336c223a18b424 by Nick Shaforostoff to branch master. Repository: kservice Description --- Changes are mostly related to containers/iterators, but there are also few

Re: Review Request 127236: Leverage QDir to know what's in a KIconThemeDir

2016-03-01 Thread Nick Shaforostoff
lt;< "1" << > QFileInfo(actionIconsDir).lastModified(); > QVERIFY(QFile::copy(QStringLiteral(":/test-22x22.png"), > newIconPath)); > +qDebug() << "2" << > QFileInfo(actionIconsDir).lastMod

Re: Review Request 127236: Leverage QDir to know what's in a KIconThemeDir

2016-03-01 Thread Nick Shaforostoff
> On March 1, 2016, 4:37 p.m., Aleix Pol Gonzalez wrote: > > Eh... I just realized it's not 100% correct. We have a test > > (testUnknownIconNotCached) that fails, unsure how I didn't see it yesterday. > > > > The problem with this one is that we are not reacting when icons are > > introduced

Re: Review Request 127215: simplify code, reduce pointer dereferences

2016-03-01 Thread Nick Shaforostoff
rgument to 'const KSycocaDictStringList&'? - Nick --- This is an automatically generated e-mail. To reply, visit: https://git.reviewboard.kde.org/r/127215/#review92874 --- On F

Re: Review Request 127215: simplify code, reduce pointer dereferences

2016-03-01 Thread Nick Shaforostoff
(var == constant) > > more readable than the other way around. > > ("is this car green?", not "is green the color of this car?"). In any > > case that's how it is everywhere in KF5 AFAIK. > > Nick Shaforostoff wrote: > i have changed

Re: Review Request 127236: Leverage QDir to know what's in a KIconThemeDir

2016-03-01 Thread Nick Shaforostoff
--- This is an automatically generated e-mail. To reply, visit: https://git.reviewboard.kde.org/r/127236/#review92967 --- Ship it! great finding, thanks for you work! - Nick

Re: Review Request 127215: simplify code, reduce pointer dereferences

2016-03-01 Thread Nick Shaforostoff
Shaforostoff On Feb. 29, 2016, 12:27 p.m., Nick Shaforostoff wrote: > > --- > This is an automatically generated e-mail. To reply, visit: > https://git.reviewboard.kde.

Re: Review Request 127215: simplify code, reduce pointer dereferences

2016-02-29 Thread Nick Shaforostoff
- This is an automatically generated e-mail. To reply, visit: https://git.reviewboard.kde.org/r/127215/#review92899 --- On Feb. 29, 2016, 12:27 p.m., Nick Shaforostoff wrote: > >

Re: Review Request 127215: simplify code, reduce pointer dereferences

2016-02-29 Thread Nick Shaforostoff
src/sycoca/ksycocafactory.cpp e410581 > src/sycoca/ksycocautils_p.h 8db26b0 > > Diff: https://git.reviewboard.kde.org/r/127215/diff/ > > > Testing > --- > > all tests pass, except kmimeassociationstest (fakeApplicationService is > NULL), but it fails also without my c

Re: Review Request 127215: simplify code, reduce pointer dereferences

2016-02-29 Thread Nick Shaforostoff
de.org/r/127215/diff/ Testing --- all tests pass, except kmimeassociationstest (fakeApplicationService is NULL), but it fails also without my changes Thanks, Nick Shaforostoff ___ Kde-frameworks-devel mailing list Kde-frameworks-devel@kde.org

Review Request 127215: simplify code, reduce pointer dereferences

2016-02-28 Thread Nick Shaforostoff
https://git.reviewboard.kde.org/r/127215/diff/ Testing --- all tests pass, except kmimeassociationstest (fakeApplicationService is NULL), but it fails also without my changes Thanks, Nick Shaforostoff ___ Kde-frameworks-devel mailing list Kde-frameworks

Re: QString -> QStringLiteral conversions might make applications crash on exit

2016-02-26 Thread Nick Shaforostoff
> a) Everyone who makes QString -> QStringLiteral replacements should be > extremely careful (which is very difficult, since it is not always > obvious if passing a QString to a function will result in the string > being stored in a global static object). Automated tools like clazy > should then

Re: Review Request 126774: Fix many warnings presented by clazy

2016-02-20 Thread Nick Shaforostoff
ant to reduce number of [re]allocs then change it to one big assignment: info += ... + ... + ... + ...; and make sure QT_USE_STRINGBUILDER is defined - Nick Shaforostoff On Feb. 20, 2016, 8:41

Re: Review Request 126392: Fix some Clazy warnings in kcoreaddons

2015-12-24 Thread Nick Shaforostoff
use a string is appended to the existing one, i suggest to use QLatin1String here (there is an overload taking QLatin1String as an argument) - Nick Shaforostoff On Dec. 24, 2015, 11:58 a.m., Andrey Cygankov wrote: > > --- > Thi

Re: Review Request 126348: Make it possible to provide the metadata in json

2015-12-14 Thread Nick Shaforostoff
tps://git.reviewboard.kde.org/r/126348/#comment61260> something more meaningful? - Nick Shaforostoff On Dec. 14, 2015, 5:11 p.m., Aleix Pol Gonzalez wrote: > > --- > This is an automatically generated e-mail. To reply,

Re: Review Request 126350: Fixed all Clazy level 1 and level 2 warnings

2015-12-14 Thread Nick Shaforostoff
> On Dec. 14, 2015, 7:10 p.m., Sergio Martins wrote: > > src/klocalizedstring.cpp, line 389 > > > > > > this will break the build with MSVC, it doesn't support QStringLiteral > > with multi-line literals. > >

Re: Review Request 126329: kio: Do not use QStringLiteral with multi strings

2015-12-12 Thread Nick Shaforostoff
for QRegExp. for the rest i suggest using #ifdef Q_OS_WIN #define U QLatin1String #else #define U QStringLiteral #endif or smth like that. - Nick Shaforostoff On Dec. 12, 2015, 11:08 p.m., Patrick Spendrin wrote

Re: Review Request 126327: sonnet: Do not use QStringLiteral with multi strings

2015-12-12 Thread Nick Shaforostoff
suggest just using QLatin1String everywhere - Nick Shaforostoff On Dec. 12, 2015, 10:54 p.m., Patrick Spendrin wrote: > > --- > This is an automatically generated e-mail. To reply, visit: > https://git.reviewboard.kde.

Re: Review Request 126328: kwallet: Do not use QStringLiteral with multi strings

2015-12-12 Thread Nick Shaforostoff
#else #define U QStringLiteral #endif - Nick Shaforostoff On Dec. 12, 2015, 10:59 p.m., Patrick Spendrin wrote: > > --- > This is an automatically generated e-mail. To reply, visit: > https://git.reviewboard.kde.

Re: Review Request 126140: [kfilemetadata] avoid utf16->utf8->utf16 conversions reading taglib metadata

2015-11-24 Thread Nick Shaforostoff
On Nov. 23, 2015, 9:01 p.m., Nick Shaforostoff wrote: > > --- > This is an automatically generated e-mail. To reply, visit: > https://git.reviewboard.kde.org/r/126140/ > -

Re: Review Request 126140: [kfilemetadata] avoid utf16->utf8->utf16 conversions reading taglib metadata

2015-11-24 Thread Nick Shaforostoff
marked as submitted. Review request for KDE Frameworks, Juan Palacios, Pino Toscano, and Vishesh Handa. Changes --- Submitted with commit 4655943a49acfa181d31a00c5aef1bf10dcba2bf by Nick Shaforostoff to branch master. Repository: kfilemetadata Description --- also this patch

Review Request 126140: [kfilemetadata] avoid utf16->utf8->utf16 conversions reading taglib metadata

2015-11-22 Thread Nick Shaforostoff
. José, Cátulo) in the tags. also i did test this toCWString-based conversion on windows and it worked fine. should work on osx as well Thanks, Nick Shaforostoff ___ Kde-frameworks-devel mailing list Kde-frameworks-devel@kde.org https://mail.kde.org

Re: Review Request 125951: [calendar] Move the plugins handling to a separate class

2015-11-09 Thread Nick Shaforostoff
tRef() instead of left() and % instead of + three lines below (or make sure + is the same as % by adding define -DQT_USE_QSTRINGBUILDER) - Nick Shaforostoff On Nov. 9, 2015, 7:56 p.m., Martin Klapetek wrote: > > --- > This is an

Re: Review Request 126002: Fix KArchive for behavior change in Qt 5.6

2015-11-09 Thread Nick Shaforostoff
g/r/126002/#comment60472> why can't we just use QFile::decodeName(const char * localFileName) overload? - Nick Shaforostoff On Nov. 9, 2015, 7:54 a.m., David Faure wrote: > > --- > This is an automatically generated e

Re: Review Request 126002: Fix KArchive for behavior change in Qt 5.6

2015-11-09 Thread Nick Shaforostoff
> On Nov. 9, 2015, 10:42 a.m., Nick Shaforostoff wrote: > > src/ktar.cpp, line 293 > > <https://git.reviewboard.kde.org/r/126002/diff/1/?file=415780#file415780line293> > > > > why can't we just use QFile::decodeName(const char * localFileName) > >

Re: Review Request 125971: k7zip: fix memleaks, lower memory usage

2015-11-07 Thread Nick Shaforostoff
marked as submitted. Review request for KDE Frameworks, David Faure and Laurent Montel. Changes --- Submitted with commit 5e00ad1f31a6cb436f3d17896de82e1691acfefa by Nick Shaforostoff to branch master. Repository: karchive Description --- i couldn't find the place where

Re[2]: Failure while executing KTar::open while using KCompressionDevice as the device

2015-11-07 Thread Nick Shaforostoff
> Aleix suggested QBuffer, but archives can be *huge*, so this might > eat all available memory. This is the reason why KTar uses a temp file > for the compressed-tar case. qbuffer may be used for decompressing archives that are e.g. less than 50% of free ram if an archive is larger then

Re: Review Request 125969: kinit: fix Coverity issues + small optimization

2015-11-06 Thread Nick Shaforostoff
marked as submitted. Review request for KDE Frameworks and Alex Merry. Changes --- Submitted with commit 04e64f8ec47476530157cefc434776f4aa93a27f by Nick Shaforostoff to branch master. Repository: kinit Description --- this patch fixes two coverity issues ranked 'outstanding

Re: Review Request 125969: kinit: fix Coverity issues + small optimization

2015-11-06 Thread Nick Shaforostoff
://git.reviewboard.kde.org/r/125969/diff/ Testing --- compiles fine Thanks, Nick Shaforostoff ___ Kde-frameworks-devel mailing list Kde-frameworks-devel@kde.org https://mail.kde.org/mailman/listinfo/kde-frameworks-devel

Re: Review Request 125815: Provide an alternative when khelpcenter is not available

2015-11-06 Thread Nick Shaforostoff
to use QStringLiteral - Nick Shaforostoff On Nov. 6, 2015, 4:48 p.m., Aleix Pol Gonzalez wrote: > > --- > This is an automatically generated e-mail. To reply, visit: > https://git.reviewboar

Re: Review Request 125969: kinit: fix Coverity issues + small optimization

2015-11-05 Thread Nick Shaforostoff
atically generated e-mail. To reply, visit: https://git.reviewboard.kde.org/r/125969/#review88068 --- On Nov. 5, 2015, 10:16 p.m., Nick Shaforostoff wrote: > > --- > This is a

Review Request 125971: k7zip: fix memleaks, lower memory usage

2015-11-05 Thread Nick Shaforostoff
it was not used anywhere after Diffs - src/k7zip.cpp 321620a Diff: https://git.reviewboard.kde.org/r/125971/diff/ Testing --- compiles fine Thanks, Nick Shaforostoff ___ Kde-frameworks-devel mailing list Kde-frameworks-devel@kde.org https

Review Request 125969: kinit: fix Coverity issues + small optimization

2015-11-05 Thread Nick Shaforostoff
optimization by eliminating redundant mallocs done by QByteArray ctor Diffs - src/kdeinit/kinit.cpp 9e775b6 Diff: https://git.reviewboard.kde.org/r/125969/diff/ Testing --- compiles fine Thanks, Nick Shaforostoff ___ Kde-frameworks

Re: Review Request 123131: Port kio_man away from kdelibs4support

2015-03-25 Thread Nick Shaforostoff
On March 25, 2015, 9:54 p.m., Lukáš Tinkl wrote: man/kio_man.cpp, line 242 https://git.reviewboard.kde.org/r/123131/diff/1/?file=356605#file356605line242 Not correct, this returns only user configured list of languages, whereas it previously returned the full list. please see

Re[2]: [ki18n] src: small qstring optimizations

2015-01-25 Thread Nick Shaforostoff
On Wednesday 21 January 2015 21:32:07 Nick Shaforostoff wrote: +static const QString SUBSTITUTE_ME=QStringLiteral(%1); I'm not sure that adding global static (non-POD) objects in libraries is a good idea. We've had many problems with that in the past (see below for details

Re[2]: [ki18n] src: small qstring optimizations

2015-01-25 Thread Nick Shaforostoff
Because otherwise, it is a very bad thing to do. There is *no* reason to ever do: QString(%1).arg(foo); There are no overloads of QString::number having fieldWidth argument. ___ Kde-frameworks-devel mailing list Kde-frameworks-devel@kde.org