D5912: minimize dialog resizes/moves

2017-05-25 Thread Marco Martin
mart added a comment. In https://phabricator.kde.org/D5912#111657, @davidedmundson wrote: > but: we're still doing a resize whislt we have the old window management min/max hints set from the previous item, so it'll still have an extra resize, just at a kwin level not here.

D5912: minimize dialog resizes/moves

2017-05-25 Thread Marco Martin
This revision was automatically updated to reflect the committed changes. Closed by commit R242:32e67a591edb: minimize dialog resizes/moves (authored by mart). CHANGED PRIOR TO COMMIT https://phabricator.kde.org/D5912?vs=14809=14834#toc REPOSITORY R242 Plasma Framework (Library) CHANGES

D5912: minimize dialog resizes/moves

2017-05-24 Thread David Edmundson
davidedmundson accepted this revision. This revision is now accepted and ready to land. REPOSITORY R242 Plasma Framework (Library) BRANCH arcpatch-D5912 REVISION DETAIL https://phabricator.kde.org/D5912 To: mart, #plasma, hein, davidedmundson Cc: broulik, davidedmundson, plasma-devel,

D5912: minimize dialog resizes/moves

2017-05-24 Thread David Edmundson
davidedmundson added a comment. Offtopic, but in future can you adjust the summary when rewriting a patch rather than leaving a comment, it's easier to read. Phab still keeps the history if we need it. So this is for fixing when we have a mainItem whose size is bigger/smaller than its

D5912: minimize dialog resizes/moves

2017-05-24 Thread Kai Uwe Broulik
broulik added inline comments. INLINE COMMENTS > dialog.cpp:487 > +} > +Q_ASSERT(mainItem); > +Q_ASSERT(mainItemLayout); Those asserts are redundant now REPOSITORY R242 Plasma Framework (Library) REVISION DETAIL https://phabricator.kde.org/D5912 To: mart, #plasma, hein,

D5912: minimize dialog resizes/moves

2017-05-24 Thread Marco Martin
mart added inline comments. INLINE COMMENTS > davidedmundson wrote in tooltipdialog.cpp:45 > Calling set flags explicitly and set type explicitly is conflicting. now just uses settype, tested on x11, still works and tooltip windows still has _NET_WM_WINDOW_TYPE_TOOLTIP settype is needed in

D5912: minimize dialog resizes/moves

2017-05-24 Thread Marco Martin
mart updated this revision to Diff 14809. mart added a comment. - use settype, not setflags REPOSITORY R242 Plasma Framework (Library) CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D5912?vs=14690=14809 BRANCH arcpatch-D5912 REVISION DETAIL https://phabricator.kde.org/D5912

D5912: minimize dialog resizes/moves

2017-05-24 Thread David Edmundson
davidedmundson requested changes to this revision. davidedmundson added inline comments. This revision now requires changes to proceed. INLINE COMMENTS > tooltipdialog.cpp:45 > setLocation(Plasma::Types::Floating); > +setType(Dialog::WindowType::Tooltip); > Calling set flags

D5912: minimize dialog resizes/moves

2017-05-24 Thread Eike Hein
hein accepted this revision. This revision is now accepted and ready to land. REPOSITORY R242 Plasma Framework (Library) BRANCH phab/dialogresize REVISION DETAIL https://phabricator.kde.org/D5912 To: mart, #plasma, hein Cc: davidedmundson, plasma-devel, #frameworks, ZrenBot, spstarr,

D5912: minimize dialog resizes/moves

2017-05-24 Thread Marco Martin
mart added a comment. ping? REPOSITORY R242 Plasma Framework (Library) REVISION DETAIL https://phabricator.kde.org/D5912 To: mart, #plasma Cc: davidedmundson, plasma-devel, #frameworks, ZrenBot, spstarr, progwolff, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, mart,

D5912: minimize dialog resizes/moves

2017-05-19 Thread Marco Martin
mart added a comment. now tooltips are animated again REPOSITORY R242 Plasma Framework (Library) REVISION DETAIL https://phabricator.kde.org/D5912 To: mart, #plasma Cc: davidedmundson, plasma-devel, #frameworks, ZrenBot, spstarr, progwolff, lesliezhai, ali-mohamed, jensreuterberg,

D5912: minimize dialog resizes/moves

2017-05-19 Thread Marco Martin
mart updated this revision to Diff 14690. mart added a comment. - make the tooltips actual tooltips REPOSITORY R242 Plasma Framework (Library) CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D5912?vs=14688=14690 BRANCH phab/dialogresize REVISION DETAIL

D5912: minimize dialog resizes/moves

2017-05-19 Thread Marco Martin
mart added a comment. removed that extra complexity block/unblock that didn't seem to buy anything. comparing before/after, all the normal tooltips, exept taskmanager consistyently passed from two resizes to one. perhaps will be possible to fix the taskmanager case by tweaking up how

D5912: minimize dialog resizes/moves

2017-05-19 Thread Marco Martin
mart updated this revision to Diff 14688. mart added a comment. - remove updategeometryblocked REPOSITORY R242 Plasma Framework (Library) CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D5912?vs=14674=14688 BRANCH phab/dialogresize REVISION DETAIL

D5912: minimize dialog resizes/moves

2017-05-18 Thread Marco Martin
mart added inline comments. INLINE COMMENTS > davidedmundson wrote in dialog.cpp:864 > I don't understand your description of the problem. > > this call both that resizes and moves. > but if the item hasn't changed yet, it shouldn't actually resize anything. > > you're implying it does. Why?

D5912: minimize dialog resizes/moves

2017-05-18 Thread David Edmundson
davidedmundson added inline comments. INLINE COMMENTS > dialog.cpp:864 > if (d->mainItem) { > d->syncToMainItemSize(); > } I don't understand your description of the problem. this call both that resizes and moves. but if the item hasn't changed yet, it shouldn't

D5912: minimize dialog resizes/moves

2017-05-18 Thread Marco Martin
mart created this revision. Restricted Application added projects: Plasma, Frameworks. Restricted Application added subscribers: Frameworks, plasma-devel. REVISION SUMMARY take into account size hints also when adjusting with synctomainitemsize which sometimes has to be executed right before