Re: (subset) [PATCH v2 0/3] RISC-V: Fix a few kexec_file_load(2) failures

2023-08-09 Thread Palmer Dabbelt
riscv64-kdump.html > > [...] Applied, thanks! [1/3] riscv/kexec: handle R_RISCV_CALL_PLT relocation type https://git.kernel.org/palmer/c/d0b4f95a5103 [3/3] riscv/kexec: load initrd high in available memory https://git.kernel.org/palmer/c/49af7a2cd5f6 Best reg

Re: [RESEND PATCH -fixes 1/2] riscv: Export va_kernel_pa_offset in vmcoreinfo

2023-08-03 Thread Palmer Dabbelt
d2b7f [2/2] Documentation: kdump: Add va_kernel_pa_offset for RISCV64 https://git.kernel.org/palmer/c/640c503d7dbd Best regards, -- Palmer Dabbelt ___ kexec mailing list kexec@lists.infradead.org http://lists.infradead.org/mailman/listinfo/kexec

Re: [PATCH v2 2/3] riscv/purgatory: do not link with string.o and its dependencies

2023-08-03 Thread Palmer Dabbelt
breaks my builds. I tried fixing the first one with something like From 41c5a952f77e53bf4201296abff0132725aa19e6 Mon Sep 17 00:00:00 2001 From: Palmer Dabbelt Date: Wed, 2 Aug 2023 20:22:33 -0700 Subject: [PATCH] RISC-V: Include io from timex Without this I get som

Re: [PATCH v6 4/4] risc/purgatory: Add linker script

2023-05-01 Thread Palmer Dabbelt
y_start -z nodefaultlib Acked-by: Palmer Dabbelt ___ kexec mailing list kexec@lists.infradead.org http://lists.infradead.org/mailman/listinfo/kexec

Re: [PATCH 1/2] RISC-V: kexec: Fix memory leak of fdt buffer

2022-12-05 Thread Palmer Dabbelt
palmer/c/96df59b1ae23 [2/2] RISC-V: kexec: Fix memory leak of elf header buffer https://git.kernel.org/palmer/c/cbc32023ddbd These are on for-next. They'd probably be fine fixes candidates had I gotten to them in time, but it's pretty late and a leak during kexec doesn't seem like a show-stopper

Re: [PATCH V5 0/2] Support VMCOREINFO export for RISCV64

2022-12-02 Thread Palmer Dabbelt
mp: describe VMCOREINFO export for RISCV64 https://git.kernel.org/palmer/c/c5b4216929eb Best regards, -- Palmer Dabbelt ___ kexec mailing list kexec@lists.infradead.org http://lists.infradead.org/mailman/listinfo/kexec

Re: [PATCH V6 0/6] RISC-V fixups to work with crash tool

2022-08-11 Thread Palmer Dabbelt
On Thu, 11 Aug 2022 00:41:44 PDT (-0700), xianting.t...@linux.alibaba.com wrote: I ever sent the patch 1 in the link: https://patchwork.kernel.org/project/linux-riscv/patch/20220708073150.352830-3-xianting.t...@linux.alibaba.com/ And patch 2,3 in the link:

Re: [PATCH] RISC-V: Prepare dropping week attribute from arch_kexec_apply_relocations[_add]

2022-05-31 Thread Palmer Dabbelt
On Mon, 30 May 2022 22:58:03 PDT (-0700), u.kleine-koe...@pengutronix.de wrote: On Mon, May 30, 2022 at 04:11:27PM -0700, Palmer Dabbelt wrote: On Mon, 30 May 2022 12:41:33 PDT (-0700), u.kleine-koe...@pengutronix.de wrote: > Hello, > > On Mon, May 30, 2022 at 11:58:16AM -0700, Palme

Re: [PATCH] RISC-V: Prepare dropping week attribute from arch_kexec_apply_relocations[_add]

2022-05-30 Thread Palmer Dabbelt
On Mon, 30 May 2022 12:41:33 PDT (-0700), u.kleine-koe...@pengutronix.de wrote: Hello, On Mon, May 30, 2022 at 11:58:16AM -0700, Palmer Dabbelt wrote: On Mon, 30 May 2022 00:42:02 PDT (-0700), u.kleine-koe...@pengutronix.de wrote: > Without this change arch/riscv/kernel/elf_kexec.c fa

Re: [PATCH] RISC-V: Prepare dropping week attribute from arch_kexec_apply_relocations[_add]

2022-05-30 Thread Palmer Dabbelt
On Mon, 30 May 2022 00:42:02 PDT (-0700), u.kleine-koe...@pengutronix.de wrote: Without this change arch/riscv/kernel/elf_kexec.c fails to compile once commit 233c1e6c319c ("kexec_file: drop weak attribute from arch_kexec_apply_relocations[_add]") is also contained in the tree. This currently

Re: [PATCH v3 -next 1/6] kexec_file: Fix kexec_file.c build error for riscv platform

2022-05-20 Thread Palmer Dabbelt
On Fri, 08 Apr 2022 03:09:09 PDT (-0700), lizheng...@huawei.com wrote: From: Liao Chang When CONFIG_KEXEC_FILE is set for riscv platform, the compilation of kernel/kexec_file.c generate build error: kernel/kexec_file.c: In function 'crash_prepare_elf64_headers':

Re: [PATCH v3 -next 0/6] riscv: kexec: add kexec_file_load() support

2022-05-20 Thread Palmer Dabbelt
On Fri, 08 Apr 2022 03:09:08 PDT (-0700), lizheng...@huawei.com wrote: This patchset implement kexec_file_load() support on riscv, Most of the code is based on the kexec-tool-patch repo developed by Nick Kossifids. This patch series enables us to load the riscv vmlinux by specifying its file

Re: [PATCH v2 -next 0/6] riscv: kexec: add kexec_file_load() support

2022-03-31 Thread Palmer Dabbelt
On Wed, 30 Mar 2022 01:16:55 PDT (-0700), lizheng...@huawei.com wrote: This patchset implement kexec_file_load() support on riscv, Most of the code is based on the kexec-tool-patch repo developed by Nick Kossifids. This patch series enables us to load the riscv vmlinux by specifying its file

Re: [PATCH v2 2/5] riscv: mm: init: use IS_ENABLED(CONFIG_KEXEC_CORE) instead of #ifdef

2022-01-11 Thread Palmer Dabbelt
/* CONFIG_KEXEC_CORE */ void __init paging_init(void) { @@ -819,9 +819,7 @@ void __init misc_mem_init(void) arch_numa_init(); sparse_init(); zone_sizes_init(); -#ifdef CONFIG_KEXEC_CORE reserve_crashkernel(); -#endif memblock_dump_all(); } Acked-by: Palmer

Re: [PATCH v4 06/10] riscv: Remove non-standard linux, elfcorehdr handling

2021-07-20 Thread Palmer Dabbelt
reserved_mem *rmem) -{ - elfcorehdr_addr = rmem->base; - elfcorehdr_size = rmem->size; - return 0; -} - -RESERVEDMEM_OF_DECLARE(elfcorehdr, "linux,elfcorehdr", elfcore_hdr_setup); -#endif - void __init paging_init(void) { setup_bootmem(); Reviewed

Re: [PATCH v3 1/5] RISC-V: Add EM_RISCV to kexec UAPI header

2021-04-22 Thread Palmer Dabbelt
On Mon, 05 Apr 2021 01:57:08 PDT (-0700), m...@ics.forth.gr wrote: Add RISC-V to the list of supported kexec architecturs, we need to add the definition early-on so that later patches can use it. EM_RISCV is 243 as per ELF psABI specification here:

Re: [PATCH 09/13] Move bp_type_idx to kernel/event/hw_breakpoint.c

2015-11-08 Thread Palmer Dabbelt
On Wed, 04 Nov 2015 04:21:51 PST (-0800), pet...@infradead.org wrote: > On Wed, Nov 04, 2015 at 12:41:06PM +0100, Peter Zijlstra wrote: >> On Tue, Nov 03, 2015 at 11:46:30AM -0800, Palmer Dabbelt wrote: >> > This has a "#ifdef CONFIG_*" that used to be exposed to us

[PATCH 13/13] Re-enable and clean up "check_config()" in headers_check.pl

2015-11-03 Thread Palmer Dabbelt
-by: Palmer Dabbelt <pal...@dabbelt.com> Reviewed-by: Andrew Waterman <water...@eecs.berkeley.edu> Reviewed-by: Albert Ou <a...@eecs.berkeley.edu> --- scripts/headers_check.pl | 19 +-- 1 file changed, 17 insertions(+), 2 deletions(-) diff --git a/scripts/headers_

[PATCH 10/13] Move USE_WCACHING to drivers/block/pktcdvd.c

2015-11-03 Thread Palmer Dabbelt
I don't think this was ever intended to be exposed to userspace, but it did require an "#ifdef CONFIG_*". Since the name is kind of generic and was only used in one place, I've moved the definition to the one user. Signed-off-by: Palmer Dabbelt <pal...@dabbelt.com> Reviewed-by:

[PATCH 11/13] Always define MAX_RAW_MINORS as 2**20 in userspace

2015-11-03 Thread Palmer Dabbelt
warning about a split config string here, but I've left that alone. Signed-off-by: Palmer Dabbelt <pal...@dabbelt.com> Reviewed-by: Andrew Waterman <water...@eecs.berkeley.edu> Reviewed-by: Albert Ou <a...@eecs.berkeley.edu> --- drivers/char/raw.c | 7 --- include/uapi/lin

[PATCH 08/13] Move MAX_SHARED_LIBS to fs/binfmt_flat.c

2015-11-03 Thread Palmer Dabbelt
I'm not sure what this is, but it doesn't feel like something that should be exposed to userspace here. I'm assuming this file was exposed for the structure in it, which doesn't depend on MAX_SHARED_LIBS. Signed-off-by: Palmer Dabbelt <pal...@dabbelt.com> Reviewed-by: Andrew Waterman

[PATCH 06/13] Move ep_take_care_of_epollwakeup() to fs/eventpoll.c

2015-11-03 Thread Palmer Dabbelt
This doesn't make any sense to expose to userspace, so it's been moved to the one user. This was introduced by commit 95f19f658ce1 ("epoll: drop EPOLLWAKEUP if PM_SLEEP is disabled"). Signed-off-by: Palmer Dabbelt <pal...@dabbelt.com> Reviewed-by: Andrew Waterman <water..

[PATCH v4] Remove #ifdef CONFIG_* from all userspace headers

2015-11-03 Thread Palmer Dabbelt
I think this is good to go. There are two acks, but I wasn't sure if I was supposed to collect them in the patches or not. Arnd Bergman acked #1 and #7. Changes since v3 (<1442271047-4908-1-git-send-email-pal...@dabbelt.com>) * #4 is very different: rather than defining a canonical value for

[PATCH 03/13] Move COMPAT_ATM_ADDPARTY to net/atm/svc.c

2015-11-03 Thread Palmer Dabbelt
This used to be behind an #ifdef COMPAT_COMPAT, so most of userspace wouldn't have seen the definition before. Unfortunately this header file became visible to userspace, so the definition has instead been moved to net/atm/svc.c (the only user). Signed-off-by: Palmer Dabbelt <pal...@dabbelt.

[PATCH 07/13] Make FB_BACKLIGHT_{LEVELS,MAX} always visible

2015-11-03 Thread Palmer Dabbelt
Nothing else in the kernel defines this, and this header is visible to userspace. Rather than hiding it in an #ifdef, I think it's sane to just make this visible to userspace. Signed-off-by: Palmer Dabbelt <pal...@dabbelt.com> Reviewed-by: Andrew Waterman <water...@eecs.berkeley.edu&

Re: [PATCH 03/13] Move COMPAT_ATM_ADDPARTY to net/atm/svc.c

2015-09-17 Thread Palmer Dabbelt
On Thu, 17 Sep 2015 02:57:12 PDT (-0700), dhowe...@redhat.com wrote: > Palmer Dabbelt <pal...@dabbelt.com> wrote: > >> +#ifdef CONFIG_COMPAT >> +/* It actually takes struct sockaddr_atmsvc, not struct atm_iobuf */ >> +#define COMPAT_ATM_ADDPARTY _IOW

Re: [PATCH 09/13] Move bp_type_idx to kernel/event/hw_breakpoint.c

2015-09-16 Thread Palmer Dabbelt
On Tue, 15 Sep 2015 01:06:07 PDT (-0700), pet...@infradead.org wrote: > On Mon, Sep 14, 2015 at 03:50:43PM -0700, Palmer Dabbelt wrote: >> This has a "#ifdef CONFIG_*" that used to be exposed to userspace. >> >> The names in here are so generic that I don't think it'

Re: [PATCH 09/13] Move bp_type_idx to kernel/event/hw_breakpoint.c

2015-09-16 Thread Palmer Dabbelt
On Tue, 15 Sep 2015 12:39:10 PDT (-0700), pet...@infradead.org wrote: > On Tue, Sep 15, 2015 at 11:40:11AM -0700, Palmer Dabbelt wrote: >> On Tue, 15 Sep 2015 01:06:07 PDT (-0700), pet...@infradead.org wrote: >> > On Mon, Sep 14, 2015 at 03:50:43PM -0700, Palmer Dabbelt wro

Re: [PATCH 11/13] Always define MAX_RAW_MINORS as 65535 in userspace

2015-09-16 Thread Palmer Dabbelt
On Tue, 15 Sep 2015 13:42:47 PDT (-0700), h...@zytor.com wrote: > On 09/14/2015 03:50 PM, Palmer Dabbelt wrote: >> While I don't think this was ever meant to be exposed to userspace, if >> anyone is using it then this will at least provide a correct (if >>

[PATCH 10/13] Move USE_WCACHING to drivers/block/pktcdvd.c

2015-09-14 Thread Palmer Dabbelt
I don't think this was ever intended to be exposed to userspace, but it did require an "#ifdef CONFIG_*". Since the name is kind of generic and was only used in one place, I've moved the definition to the one user. Signed-off-by: Palmer Dabbelt <pal...@dabbelt.com> Reviewed-by:

[PATCH 12/13] Remove AT_VECTOR_SIZE_ARCH on x86

2015-09-14 Thread Palmer Dabbelt
of to do is to just remove the definition. Signed-off-by: Palmer Dabbelt <pal...@dabbelt.com> Reviewed-by: Andrew Waterman <water...@eecs.berkeley.edu> Reviewed-by: Albert Ou <a...@eecs.berkeley.edu> --- arch/x86/include/uapi/asm/auxvec.h | 7 --- 1 file changed, 7 deletions(-)

[PATCH 09/13] Move bp_type_idx to kernel/event/hw_breakpoint.c

2015-09-14 Thread Palmer Dabbelt
This has a "#ifdef CONFIG_*" that used to be exposed to userspace. The names in here are so generic that I don't think it's a good idea to expose them to userspace (or even the rest of the kernel). Since there's only one kernel user, it's been moved to that file. Signed-off-by: Palm

[PATCH 01/13] Remove #ifdef CONFIG_64BIT from all asm-generic/fcntl.h

2015-09-14 Thread Palmer Dabbelt
in with F_SETLK64 was being defined (there's some more in glibc, but that's a whole different story... :)) is the result of CONFIG_64BIT showing up in this user-visible header. confirms this isn't sane, so I replaced it with a __BITS_PER_LONG check. Signed-off-by: Palmer Dabbelt <pal...@dabbelt.com> Re

[PATCH 13/13] Re-enable and clean up "check_config()" in headers_check.pl

2015-09-14 Thread Palmer Dabbelt
-by: Palmer Dabbelt <pal...@dabbelt.com> Reviewed-by: Andrew Waterman <water...@eecs.berkeley.edu> Reviewed-by: Albert Ou <a...@eecs.berkeley.edu> --- scripts/headers_check.pl | 19 +-- 1 file changed, 17 insertions(+), 2 deletions(-) diff --git a/scripts/headers_

[PATCH 11/13] Always define MAX_RAW_MINORS as 65535 in userspace

2015-09-14 Thread Palmer Dabbelt
warning about a split config string here, but I've left that alone. Signed-off-by: Palmer Dabbelt <pal...@dabbelt.com> Reviewed-by: Andrew Waterman <water...@eecs.berkeley.edu> Reviewed-by: Albert Ou <a...@eecs.berkeley.edu> --- drivers/char/raw.c | 7 --- include/uapi/lin

[PATCH v3] Remove #ifdef CONFIG_* from all userspace headers

2015-09-14 Thread Palmer Dabbelt
This patch set used to be called "[PATCH] Remove #ifdef CONFIG_64BIT from all asm-generic/fcntl.h". This is version 3 of the patch set. I think things are kind of cleaning up, but there's still some questions I have: * #4 might be dangerous, but I think this is the best way to do it because

[PATCH 05/13] Split FDPIC "struct elf_prstatus" to "struct elf_fdpic_prstatus"

2015-09-14 Thread Palmer Dabbelt
he existing struct definitions in this file have the brace a line afterwards, so I'm going to leave this alone. Signed-off-by: Palmer Dabbelt <pal...@dabbelt.com> Reviewed-by: Andrew Waterman <water...@eecs.berkeley.edu> Reviewed-by: Albert Ou <a...@eecs.berkeley.edu> --- fs/binf

[PATCH 07/13] Make FB_BACKLIGHT_{LEVELS,MAX} always visible

2015-09-14 Thread Palmer Dabbelt
Nothing else in the kernel defines this, and this header is visible to userspace. Rather than hiding it in an #ifdef, I think it's sane to just make this visible to userspace. Signed-off-by: Palmer Dabbelt <pal...@dabbelt.com> Reviewed-by: Andrew Waterman <water...@eecs.berkeley.edu&

[PATCH 03/13] Move COMPAT_ATM_ADDPARTY to net/atm/svc.c

2015-09-14 Thread Palmer Dabbelt
This used to be behind an #ifdef COMPAT_COMPAT, so most of userspace wouldn't have seen the definition before. Unfortunately this header file became visible to userspace, so the definition has instead been moved to net/atm/svc.c (the only user). Signed-off-by: Palmer Dabbelt <pal...@dabbelt.

[PATCH 04/13] Always expose MAP_UNINITIALIZED to userspace

2015-09-14 Thread Palmer Dabbelt
also applies to the xtensa version of this definition, whic is the same as the generic one. Signed-off-by: Palmer Dabbelt <pal...@dabbelt.com> Reviewed-by: Andrew Waterman <water...@eecs.berkeley.edu> Reviewed-by: Albert Ou <a...@eecs.berkeley.edu> --- arch/xtensa/include/uapi

[PATCH 06/13] Move ep_take_care_of_epollwakeup() to fs/eventpoll.c

2015-09-14 Thread Palmer Dabbelt
This doesn't make any sense to expose to userspace, so it's been moved to the one user. This was introduced by commit 95f19f658ce1 ("epoll: drop EPOLLWAKEUP if PM_SLEEP is disabled"). Signed-off-by: Palmer Dabbelt <pal...@dabbelt.com> Reviewed-by: Andrew Waterman <water..

[PATCH 02/13] Use sys_ni.c instead of #ifdef to disable fork on CONFIG_NOMMU

2015-09-14 Thread Palmer Dabbelt
CONFIG_* in a user-visible header. Signed-off-by: Palmer Dabbelt <pal...@dabbelt.com> Reviewed-by: Andrew Waterman <water...@eecs.berkeley.edu> Reviewed-by: Albert Ou <a...@eecs.berkeley.edu> --- include/uapi/asm-generic/unistd.h | 4 kernel/sys_ni.c | 1 +

[PATCH 08/13] Move MAX_SHARED_LIBS to fs/binfmt_flat.c

2015-09-14 Thread Palmer Dabbelt
I'm not sure what this is, but it doesn't feel like something that should be exposed to userspace here. I'm assuming this file was exposed for the structure in it, which doesn't depend on MAX_SHARED_LIBS. Signed-off-by: Palmer Dabbelt <pal...@dabbelt.com> Reviewed-by: Andrew Waterman

Re: [PATCH 04/13] Always expose MAP_UNINITIALIZED to userspace

2015-09-14 Thread Palmer Dabbelt
On Mon, 14 Sep 2015 17:23:58 PDT (-0700), kir...@shutemov.name wrote: > On Mon, Sep 14, 2015 at 03:50:38PM -0700, Palmer Dabbelt wrote: >> This used to be hidden behind CONFIG_MMAP_ALLOW_UNINITIALIZED, so >> userspace wouldn't actually ever see it be non-zero. While I could >