[Kicad-developers] [PATCH]v2 Fix memory leaks with improper wxBaseConfig* usage (model ownership and ownership-transfer with std::unique_ptr)

2016-06-28 Thread Michael Steinberg
Hello, I removed the "auto" usage, added @todo's and tried to comply with the coding style. If there's anything noncompliant left I'd appreciate a pointer! Michael === modified file 'bitmap2component/bitmap2cmp_gui.cpp' --- bitmap2component/bitmap2cmp_gui.cpp 2016-06-08 06:32:01 + +++

Re: [Kicad-developers] [PATCH] Fix memory leaks with improper wxBaseConfig* usage (model ownership and ownership-transfer with std::unique_ptr)

2016-06-28 Thread Wayne Stambaugh
On 6/28/2016 3:30 PM, Michael Steinberg wrote: >> Potential for errors aside, I think auto makes the code less readable >> and yes code readability matters. In this case, I have to go look up >> the return value of GetNewConfig() because I don't know what an auto >> type is. I do know what a

Re: [Kicad-developers] 3D-Viewer - Request for merge evaluation

2016-06-28 Thread Mário Luzeiro
Thanks Wayne, Give me some time to work on that list and I will let you know when it is ready for another evaluation pass. Mario Luzeiro From: Wayne Stambaugh [stambau...@gmail.com] Sent: 28 June 2016 20:33 To: Mário Luzeiro;

Re: [Kicad-developers] [PATCH] Fix memory leaks with improper wxBaseConfig* usage (model ownership and ownership-transfer with std::unique_ptr)

2016-06-28 Thread Wayne Stambaugh
On 6/28/2016 3:55 PM, Simon Richter wrote: > Hi, > > On 28.06.2016 21:30, Michael Steinberg wrote: > >> Now I only need to know how I should go about your concerns. Maybe using >> something along the lines of >> >> using WX_CONFIG_PTR = std::unique_ptr< wxConfigBase >; > > No, that isn't

Re: [Kicad-developers] [PATCH] Fix memory leaks with improper wxBaseConfig* usage (model ownership and ownership-transfer with std::unique_ptr)

2016-06-28 Thread Simon Richter
Hi, On 28.06.2016 21:30, Michael Steinberg wrote: > Now I only need to know how I should go about your concerns. Maybe using > something along the lines of > > using WX_CONFIG_PTR = std::unique_ptr< wxConfigBase >; No, that isn't readable either, because it doesn't communicate the

Re: [Kicad-developers] 3D-Viewer - Request for merge evaluation

2016-06-28 Thread Wayne Stambaugh
I forgot to mention most of you copyright date are 2015. Any files modified in 2016 needs to be corrected. On 6/28/2016 2:52 PM, Mário Luzeiro wrote: > Hi Wayne, > > From the email below, I took your advice about the camel case and underscores > naming and updated my branch, > renaming

Re: [Kicad-developers] 3D-Viewer - Request for merge evaluation

2016-06-28 Thread Wayne Stambaugh
I haven't looked at all of your latest commits but I saw quite a few coding policy issues in your code. Source file maximum line length is 100 characters with an exception for long strings (although I prefer that they be broken into smaller strings). I saw a lot of line wrapping in your code.

Re: [Kicad-developers] [PATCH] Fix memory leaks with improper wxBaseConfig* usage (model ownership and ownership-transfer with std::unique_ptr)

2016-06-28 Thread Michael Steinberg
Potential for errors aside, I think auto makes the code less readable and yes code readability matters. In this case, I have to go look up the return value of GetNewConfig() because I don't know what an auto type is. I do know what a wxConfigBase* type is. I'll just warn everyone now that I am

Re: [Kicad-developers] [PATCH] Fix memory leaks with improper wxBaseConfig* usage (model ownership and ownership-transfer with std::unique_ptr)

2016-06-28 Thread Wayne Stambaugh
On 6/27/2016 6:20 PM, Simon Richter wrote: > On 27.06.2016 23:47, Michael Steinberg wrote: > >> === modified file 'bitmap2component/bitmap2cmp_gui.cpp' >> --- bitmap2component/bitmap2cmp_gui.cpp 2016-06-08 06:32:01 + >> +++ bitmap2component/bitmap2cmp_gui.cpp 2016-06-27 19:02:56

Re: [Kicad-developers] 3D-Viewer - Request for merge evaluation

2016-06-28 Thread Mário Luzeiro
Hi Wayne, >From the email below, I took your advice about the camel case and underscores >naming and updated my branch, renaming variables and some function names, to apply to that policy. https://code.launchpad.net/~mrluzeiro/kicad/kicad_new3d-viewer I didn't received any more reports related

Re: [Kicad-developers] replace_boost_function_boost_bind.patch: Replace boost::function and boost::bind with their std:: counterparts

2016-06-28 Thread Wayne Stambaugh
On 6/28/2016 12:07 PM, Michael Steinberg wrote: > > Am 28.06.2016 um 17:52 schrieb Wayne Stambaugh: >> Orson, >> >> Since this mostly effects the new tool framework, I'll defer to your >> judgement as to whether or not to commit this patch. I don't have a >> strong opinion one way or the other

Re: [Kicad-developers] replace_boost_function_boost_bind.patch: Replace boost::function and boost::bind with their std:: counterparts

2016-06-28 Thread jp charras
Le 28/06/2016 à 18:07, Michael Steinberg a écrit : > > Am 28.06.2016 um 17:52 schrieb Wayne Stambaugh: >> Orson, >> >> Since this mostly effects the new tool framework, I'll defer to your >> judgement as to whether or not to commit this patch. I don't have a >> strong opinion one way or the

Re: [Kicad-developers] replace_boost_function_boost_bind.patch: Replace boost::function and boost::bind with their std:: counterparts

2016-06-28 Thread Michael Steinberg
Am 28.06.2016 um 17:52 schrieb Wayne Stambaugh: Orson, Since this mostly effects the new tool framework, I'll defer to your judgement as to whether or not to commit this patch. I don't have a strong opinion one way or the other since we will not be able to completely eliminate boost until C++

Re: [Kicad-developers] [PATCH 11/16] Clarify ownership semantics

2016-06-28 Thread Wayne Stambaugh
Simon, I'm going to hold off on this patch until after we meet at CERN. It will be much easier for me to explain to you in person rather than writing a thesis how SCH_SCREEN does and should behave. Once you have all of the pertinent information, you might be able to come up with and improved

Re: [Kicad-developers] replace_boost_function_boost_bind.patch: Replace boost::function and boost::bind with their std:: counterparts

2016-06-28 Thread Wayne Stambaugh
Orson, Since this mostly effects the new tool framework, I'll defer to your judgement as to whether or not to commit this patch. I don't have a strong opinion one way or the other since we will not be able to completely eliminate boost until C++ supports context switching. Thanks, Wayne On

[Kicad-developers] replace_boost_function_boost_bind.patch: Replace boost::function and boost::bind with their std:: counterparts

2016-06-28 Thread Michael Steinberg
=== modified file 'common/gal/opengl/opengl_gal.cpp' --- common/gal/opengl/opengl_gal.cpp 2016-06-13 14:43:33 + +++ common/gal/opengl/opengl_gal.cpp 2016-06-28 13:23:01 + @@ -39,7 +39,8 @@ #endif /* __WXDEBUG__ */ #include -#include +#include +using namespace std::placeholders;

Re: [Kicad-developers] [PATCH 1/5] Clarify ERC: we're iterating netlist items, not nets

2016-06-28 Thread Wayne Stambaugh
Patches 1-3/5 committed in the product branch r6952 along with some minor housing keeping that I did. FYI: is already included in fctsys.h->wx/wx.h->wx/defs.h so I removed it. Thanks, Wayne On 6/27/2016 3:35 PM, Simon Richter wrote: > > This renames the "net", "lastNet" and "nextNet"