Re: [libav-devel] [PATCH 1/1] lavf: force single-threaded decoding in avformat_find_stream_info

2012-01-19 Thread Andrey Utkin
Thanks a lot. Fixes my issue. -- Andrey Utkin ___ libav-devel mailing list libav-devel@libav.org https://lists.libav.org/mailman/listinfo/libav-devel

[libav-devel] [PATCH] gif: Some KR cosmetics and other cleanups for better readability.

2012-01-19 Thread Aneesh Dogra
--- libavcodec/gif.c | 31 ++- 1 files changed, 18 insertions(+), 13 deletions(-) diff --git a/libavcodec/gif.c b/libavcodec/gif.c index c7e7bcd..1c32971 100644 --- a/libavcodec/gif.c +++ b/libavcodec/gif.c @@ -71,10 +71,10 @@ static int

Re: [libav-devel] [PATCH] gif: Some KR cosmetics and other cleanups for better readability.

2012-01-19 Thread Diego Biurrun
On Thu, Jan 19, 2012 at 07:40:12PM +0530, Aneesh Dogra wrote: --- a/libavcodec/gif.c +++ b/libavcodec/gif.c @@ -71,10 +71,10 @@ static int gif_image_write_header(AVCodecContext *avctx, /* the global palette */ -for(i=0;i256;i++) { +for(i = 0; i 256; i++) { for (

Re: [libav-devel] [PATCH 2/2] avplay: add support for using a user-specified decoder name.

2012-01-19 Thread Justin Ruggles
On 01/19/2012 02:40 AM, Anton Khirnov wrote: On Wed, 18 Jan 2012 17:19:43 -0500, Justin Ruggles justin.rugg...@gmail.com wrote: Allows for choosing an alternate decoder when available. --- avplay.c | 35 ++- 1 files changed, 30 insertions(+), 5

Re: [libav-devel] [PATCH 1/2] avformat: Use AVCodecContext.codec for displaying the codec name

2012-01-19 Thread Justin Ruggles
On 01/19/2012 02:28 AM, Anton Khirnov wrote: On Wed, 18 Jan 2012 17:19:42 -0500, Justin Ruggles justin.rugg...@gmail.com wrote: --- libavcodec/utils.c |4 +++- 1 files changed, 3 insertions(+), 1 deletions(-) diff --git a/libavcodec/utils.c b/libavcodec/utils.c index

[libav-devel] [PATCH] swscale: KR formatting cosmetics for Blackfin code

2012-01-19 Thread Diego Biurrun
Also prettyprint some comments in Assembly code. --- libswscale/bfin/internal_bfin.S | 12 +++--- libswscale/bfin/swscale_bfin.c | 48 +++- libswscale/bfin/yuv2rgb_bfin.c | 91 --- 3 files changed, 78 insertions(+), 73 deletions(-) diff

Re: [libav-devel] [PATCH] cosmetics: Rename ffsink to avsink.

2012-01-19 Thread Diego Biurrun
On Thu, Jan 19, 2012 at 08:41:48AM +0100, Anton Khirnov wrote: On Wed, 18 Jan 2012 23:18:39 +0100, Diego Biurrun di...@biurrun.de wrote: --- avconv.c |6 +++--- avplay.c |6 +++--- cmdutils.c | 20 ++-- cmdutils.h |4 ++-- ffmpeg.c |6 +++---

[libav-devel] [PATCH] Drop unnecessary prefix from *sink* variable and struct names.

2012-01-19 Thread Diego Biurrun
--- avconv.c |6 +++--- avplay.c |6 +++--- cmdutils.c | 20 ++-- cmdutils.h |4 ++-- ffmpeg.c |6 +++--- 5 files changed, 21 insertions(+), 21 deletions(-) diff --git a/avconv.c b/avconv.c index 9861faf..172417b 100644 --- a/avconv.c +++ b/avconv.c @@

Re: [libav-devel] [PATCH 2/2] avplay: add support for using a user-specified decoder name.

2012-01-19 Thread Anton Khirnov
On Thu, 19 Jan 2012 09:56:04 -0500, Justin Ruggles justin.rugg...@gmail.com wrote: On 01/19/2012 02:40 AM, Anton Khirnov wrote: On Wed, 18 Jan 2012 17:19:43 -0500, Justin Ruggles justin.rugg...@gmail.com wrote: Allows for choosing an alternate decoder when available. ---

[libav-devel] [PATCH 0/8] bethsoftvid fixes

2012-01-19 Thread Justin Ruggles
Justin Ruggles (8): bethsoftvid: pass palette in side data instead of in a separate packet. bethsoftvid: fix read_packet() return codes. bethsoftvid: set packet key frame flag for audio and I-frame video packets. bethsoftvid: Set current pts before adding the frame duration

[libav-devel] [PATCH 1/8] bethsoftvid: pass palette in side data instead of in a separate packet.

2012-01-19 Thread Justin Ruggles
This also fixes the FATE test if frame data is not initialized in get_buffer(). --- avconv.c |2 +- libavcodec/bethsoftvideo.c | 14 +++--- libavformat/bethsoftvid.c | 35 +-- 3 files changed, 41 insertions(+), 10 deletions(-)

[libav-devel] [PATCH 3/8] bethsoftvid: set packet key frame flag for audio and I-frame video packets.

2012-01-19 Thread Justin Ruggles
Fixes avconv video stream copy or bethsoft video, which was skipping all video frames unless the copyinkf option was used. --- libavformat/bethsoftvid.c |3 +++ 1 files changed, 3 insertions(+), 0 deletions(-) diff --git a/libavformat/bethsoftvid.c b/libavformat/bethsoftvid.c index

[libav-devel] [PATCH 2/8] bethsoftvid: fix read_packet() return codes.

2012-01-19 Thread Justin Ruggles
Use proper AVERROR codes, and return 0 for no error. --- libavformat/bethsoftvid.c | 31 ++- 1 files changed, 22 insertions(+), 9 deletions(-) diff --git a/libavformat/bethsoftvid.c b/libavformat/bethsoftvid.c index a949c4d..4208050 100644 ---

[libav-devel] [PATCH 5/8] bethsoftvid: set pts and duration for audio packets.

2012-01-19 Thread Justin Ruggles
Also, use the sample rate as the time base. --- libavformat/bethsoftvid.c | 11 --- 1 files changed, 8 insertions(+), 3 deletions(-) diff --git a/libavformat/bethsoftvid.c b/libavformat/bethsoftvid.c index 204960b..6a73f62 100644 --- a/libavformat/bethsoftvid.c +++

[libav-devel] [PATCH 7/8] bethsoftvid: synchronize video timestamps with audio sample rate

2012-01-19 Thread Justin Ruggles
According to unofficial documentation, the video rate is locked to the audio sample rate. This results in proper synchronization of audio and video timestamps. --- libavformat/bethsoftvid.c |8 ++- tests/ref/fate/bethsoft-vid | 139 ++- 2 files

[libav-devel] [PATCH 6/8] bethsoftvid: add audio stream only after getting the first audio packet

2012-01-19 Thread Justin Ruggles
This avoids initializing a stream with dummy values or when the file does not contain audio. --- libavformat/bethsoftvid.c | 39 +++ 1 files changed, 23 insertions(+), 16 deletions(-) diff --git a/libavformat/bethsoftvid.c b/libavformat/bethsoftvid.c index

[libav-devel] [PATCH 8/8] FATE: set frame rate for bethsoft-vid test

2012-01-19 Thread Justin Ruggles
Bethsoft video is VFR, but in this case using the average frame rate generates nearly correct timestamps. Unfortunately there is nothing in the bitstream to indicate average FPS, so we must set it manually. --- tests/fate/video.mak|2 +- tests/ref/fate/bethsoft-vid | 140

[libav-devel] [PATCH 1/2] lavc: use av_freep() for freeing extended_data

2012-01-19 Thread Justin Ruggles
From: Michael Niedermayer michae...@gmx.at This is safer Signed-off-by: Michael Niedermayer michae...@gmx.at Signed-off-by: Justin Ruggles justin.rugg...@gmail.com --- libavcodec/utils.c |8 1 files changed, 4 insertions(+), 4 deletions(-) diff --git a/libavcodec/utils.c

[libav-devel] [PATCH 2/2] lavc: Check CODEC_CAP_VARIABLE_FRAME_SIZE !frame

2012-01-19 Thread Justin Ruggles
From: Michael Niedermayer michae...@gmx.at This combination is quite odd and almost certainly a bug if it happens. Signed-off-by: Michael Niedermayer michae...@gmx.at Signed-off-by: Justin Ruggles justin.rugg...@gmail.com --- libavcodec/utils.c |2 ++ 1 files changed, 2 insertions(+), 0

Re: [libav-devel] [PATCH 1/2] lavc: use av_freep() for freeing extended_data

2012-01-19 Thread Måns Rullgård
Justin Ruggles justin.rugg...@gmail.com writes: From: Michael Niedermayer michae...@gmx.at This is safer Signed-off-by: Michael Niedermayer michae...@gmx.at Signed-off-by: Justin Ruggles justin.rugg...@gmail.com --- libavcodec/utils.c |8 1 files changed, 4 insertions(+), 4

[libav-devel] [PATCH] dsputil: SIMD for bswap_buf

2012-01-19 Thread Christophe Gisquet
Hi, Note: - I have tried SSE4 (and pextrd for the remaining cases) with a testcase on fewer elements (eg mpc7), but that was not faster - Unrolling SSSE3 only up to 4 is slower - Unrolling up to 16 doesn't change things I'm not sure it's worth writing a MMX2 version. Maybe building several

Re: [libav-devel] [PATCH 1/2] lavc: use av_freep() for freeing extended_data

2012-01-19 Thread Justin Ruggles
On 01/19/2012 03:55 PM, Måns Rullgård wrote: Justin Ruggles justin.rugg...@gmail.com writes: From: Michael Niedermayer michae...@gmx.at This is safer Signed-off-by: Michael Niedermayer michae...@gmx.at Signed-off-by: Justin Ruggles justin.rugg...@gmail.com --- libavcodec/utils.c |

[libav-devel] [PATCH] XWD encoder and decoder

2012-01-19 Thread Paul B Mahol
--- Changelog |1 + doc/general.texi |2 + libavcodec/Makefile|2 + libavcodec/allcodecs.c |1 + libavcodec/avcodec.h |1 + libavcodec/version.h |2 +- libavcodec/xwddec.c| 220 libavcodec/xwdenc.c

Re: [libav-devel] [PATCH] XWD encoder and decoder

2012-01-19 Thread Justin Ruggles
On 01/19/2012 04:22 PM, Paul B Mahol wrote: +#if HAVE_BIGENDIAN +p-data[1][i * 4] = 0xFF; +p-data[1][i * 4 + 1] = bytestream_get_be16(buf) 8; +p-data[1][i * 4 + 2] = bytestream_get_be16(buf) 8; +p-data[1][i * 4 + 3] =

Re: [libav-devel] [PATCH] dsputil: SIMD for bswap_buf

2012-01-19 Thread Jason Garrett-Glaser
On Thu, Jan 19, 2012 at 1:05 PM, Christophe Gisquet christophe.gisq...@gmail.com wrote: Hi, Note: - I have tried SSE4 (and pextrd for the remaining cases) with a testcase on fewer elements (eg mpc7), but that was not faster - Unrolling SSSE3 only up to 4 is slower - Unrolling up to 16

Re: [libav-devel] [PATCH 2/2] lavc: Check CODEC_CAP_VARIABLE_FRAME_SIZE !frame

2012-01-19 Thread Luca Barbato
On 19/01/12 12:14, Justin Ruggles wrote: This combination is quite odd and almost certainly a bug if it happens. Why it would happen? lu -- Luca Barbato Gentoo/linux http://dev.gentoo.org/~lu_zero ___ libav-devel mailing list

Re: [libav-devel] [PATCH 2/2] lavc: Check CODEC_CAP_VARIABLE_FRAME_SIZE !frame

2012-01-19 Thread Måns Rullgård
Luca Barbato lu_z...@gentoo.org writes: On 19/01/12 12:14, Justin Ruggles wrote: This combination is quite odd and almost certainly a bug if it happens. Why it would happen? Blah blah blah mplayer blah blah. Probably. -- Måns Rullgård m...@mansr.com

Re: [libav-devel] [PATCH 2/2] lavc: Check CODEC_CAP_VARIABLE_FRAME_SIZE !frame

2012-01-19 Thread Justin Ruggles
On 01/19/2012 04:55 PM, Luca Barbato wrote: On 19/01/12 12:14, Justin Ruggles wrote: This combination is quite odd and almost certainly a bug if it happens. Why it would happen? Only if an encoder has both CODEC_CAP_VARIABLE_FRAME_SIZE and CODEC_CAP_DELAY set and doesn't use encode2(). We

Re: [libav-devel] [PATCH] dsputil: SIMD for bswap_buf

2012-01-19 Thread Loren Merritt
On Thu, 19 Jan 2012, Christophe Gisquet wrote: +%if %1 == 0 +%define MOVR mova +%else +%define MOVR movu +%endif If you passed u/a instead of 1/0, you wouldn't need to define MOVR. --Loren Merritt ___ libav-devel mailing list

Re: [libav-devel] [PATCH 2/2] lavc: Check CODEC_CAP_VARIABLE_FRAME_SIZE !frame

2012-01-19 Thread Luca Barbato
On 19/01/12 15:21, Justin Ruggles wrote: Only if an encoder has both CODEC_CAP_VARIABLE_FRAME_SIZE and CODEC_CAP_DELAY set and doesn't use encode2(). We don't have any such encoders, and any new audio encoders should use encode2(). The problem would be that nb_samples could be zero at that

Re: [libav-devel] [PATCH] XWD encoder and decoder

2012-01-19 Thread Anton Khirnov
On Thu, 19 Jan 2012 21:22:12 +, Paul B Mahol one...@gmail.com wrote: --- Changelog |1 + doc/general.texi |2 + libavcodec/Makefile|2 + libavcodec/allcodecs.c |1 + libavcodec/avcodec.h |1 + libavcodec/version.h |2 +-

Re: [libav-devel] [PATCH 1/8] bethsoftvid: pass palette in side data instead of in a separate packet.

2012-01-19 Thread Anton Khirnov
On Thu, 19 Jan 2012 15:01:16 -0500, Justin Ruggles justin.rugg...@gmail.com wrote: This also fixes the FATE test if frame data is not initialized in get_buffer(). --- Looks good. -- Anton Khirnov ___ libav-devel mailing list libav-devel@libav.org

Re: [libav-devel] [PATCH 2/8] bethsoftvid: fix read_packet() return codes.

2012-01-19 Thread Anton Khirnov
On Thu, 19 Jan 2012 15:01:17 -0500, Justin Ruggles justin.rugg...@gmail.com wrote: Use proper AVERROR codes, and return 0 for no error. --- Ok. -- Anton Khirnov ___ libav-devel mailing list libav-devel@libav.org

Re: [libav-devel] [PATCH 3/8] bethsoftvid: set packet key frame flag for audio and I-frame video packets.

2012-01-19 Thread Anton Khirnov
On Thu, 19 Jan 2012 15:01:18 -0500, Justin Ruggles justin.rugg...@gmail.com wrote: Fixes avconv video stream copy or bethsoft video, which was skipping all video frames unless the copyinkf option was used. --- Ok. -- Anton Khirnov ___ libav-devel

Re: [libav-devel] [PATCH 4/8] bethsoftvid: Set current pts before adding the frame duration

2012-01-19 Thread Anton Khirnov
On Thu, 19 Jan 2012 15:01:19 -0500, Justin Ruggles justin.rugg...@gmail.com wrote: Fixes both video and audio timestamp starting points. --- libavformat/bethsoftvid.c |6 -- 1 files changed, 4 insertions(+), 2 deletions(-) OK. -- Anton Khirnov

Re: [libav-devel] [PATCH 5/8] bethsoftvid: set pts and duration for audio packets.

2012-01-19 Thread Anton Khirnov
On Thu, 19 Jan 2012 15:01:20 -0500, Justin Ruggles justin.rugg...@gmail.com wrote: Also, use the sample rate as the time base. --- libavformat/bethsoftvid.c | 11 --- 1 files changed, 8 insertions(+), 3 deletions(-) diff --git a/libavformat/bethsoftvid.c

Re: [libav-devel] [PATCH 6/8] bethsoftvid: add audio stream only after getting the first audio packet

2012-01-19 Thread Anton Khirnov
On Thu, 19 Jan 2012 15:01:21 -0500, Justin Ruggles justin.rugg...@gmail.com wrote: This avoids initializing a stream with dummy values or when the file does not contain audio. --- LGTM. -- Anton Khirnov ___ libav-devel mailing list

Re: [libav-devel] [PATCH 8/8] FATE: set frame rate for bethsoft-vid test

2012-01-19 Thread Anton Khirnov
On Thu, 19 Jan 2012 15:01:23 -0500, Justin Ruggles justin.rugg...@gmail.com wrote: Bethsoft video is VFR, but in this case using the average frame rate generates nearly correct timestamps. Unfortunately there is nothing in the bitstream to indicate average FPS, so we must set it manually.

Re: [libav-devel] [PATCH 1/2] avformat: Use AVCodecContext.codec for displaying the codec name

2012-01-19 Thread Anton Khirnov
On Thu, 19 Jan 2012 10:01:53 -0500, Justin Ruggles justin.rugg...@gmail.com wrote: On 01/19/2012 02:28 AM, Anton Khirnov wrote: On Wed, 18 Jan 2012 17:19:42 -0500, Justin Ruggles justin.rugg...@gmail.com wrote: --- libavcodec/utils.c |4 +++- 1 files changed, 3

Re: [libav-devel] [PATCH] Drop unnecessary prefix from *sink* variable and struct names.

2012-01-19 Thread Anton Khirnov
On Thu, 19 Jan 2012 16:18:34 +0100, Diego Biurrun di...@biurrun.de wrote: --- avconv.c |6 +++--- avplay.c |6 +++--- cmdutils.c | 20 ++-- cmdutils.h |4 ++-- ffmpeg.c |6 +++--- 5 files changed, 21 insertions(+), 21 deletions(-) Ok. -- Anton

Re: [libav-devel] [PATCH 1/1] lavf: force single-threaded decoding in avformat_find_stream_info

2012-01-19 Thread Anton Khirnov
On Wed, 18 Jan 2012 22:46:12 +0100, Janne Grunau janne-li...@jannau.net wrote: On 2012-01-18 21:38:18 +0100, Anton Khirnov wrote: On Wed, 18 Jan 2012 20:52:28 +0100, Janne Grunau janne-li...@jannau.net wrote: The H.264 decoder needs SPS and PPS for initialization during

Re: [libav-devel] [PATCH] doc: Mention that '-vf' is an alias for '-filter:v' in avplay documentation.

2012-01-19 Thread Anton Khirnov
On Wed, 18 Jan 2012 23:50:02 +0100, Diego Biurrun di...@biurrun.de wrote: --- doc/avplay.texi |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/doc/avplay.texi b/doc/avplay.texi index 8fc3308..a597bef 100644 --- a/doc/avplay.texi +++ b/doc/avplay.texi @@ -61,7